AWT applications fail with java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper

Bug #1788250 reported by James Cowgill on 2018-08-21
136
This bug affects 19 people
Affects Status Importance Assigned to Milestone
JOSM
Unknown
Critical
openjdk-10 (Debian)
Fix Released
Unknown
openjdk-8 (Ubuntu)
Undecided
Unassigned
openjdk-lts (Ubuntu)
Critical
Unassigned

Bug Description

After recently upgrading to 10.0.2+13-1ubuntu0.18.04.1 in bionic, all AWT applications have started failing with this exception: (using jedit as an example, but it happens for lots of apps):

 ~  jedit
18:12:48 [main] [error] main: Exception in thread "main"
18:12:48 [main] [error] main: java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
18:12:48 [main] [error] main: at java.desktop/java.awt.Toolkit.newAWTError(Toolkit.java:472)
18:12:48 [main] [error] main: at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:488)
18:12:48 [main] [error] main: at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:183)
18:12:48 [main] [error] main: at java.base/java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:177)
18:12:48 [main] [error] main: at java.base/java.util.HashMap$KeySpliterator.forEachRemaining(HashMap.java:1608)
18:12:48 [main] [error] main: at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484)
18:12:48 [main] [error] main: at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
18:12:48 [main] [error] main: at java.base/java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150)
18:12:48 [main] [error] main: at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173)
18:12:48 [main] [error] main: at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
18:12:48 [main] [error] main: at java.base/java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:497)
18:12:48 [main] [error] main: at java.desktop/java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:532)
18:12:48 [main] [error] main: at java.desktop/java.awt.Toolkit.getDefaultToolkit(Toolkit.java:613)
18:12:48 [main] [error] main: at java.desktop/java.awt.EventQueue.invokeAndWait(EventQueue.java:1342)
18:12:48 [main] [error] main: at java.desktop/javax.swing.SwingUtilities.invokeAndWait(SwingUtilities.java:1480)
18:12:48 [main] [error] main: at org.gjt.sp.jedit.GUIUtilities.showSplashScreen(GUIUtilities.java:1957)
18:12:48 [main] [error] main: at org.gjt.sp.jedit.jEdit.main(jEdit.java:389)
18:12:48 [main] [error] main: Caused by: java.lang.ClassNotFoundException: org.GNOME.Accessibility.AtkWrapper
18:12:48 [main] [error] main: at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
18:12:48 [main] [error] main: at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
18:12:48 [main] [error] main: at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
18:12:48 [main] [error] main: at java.base/java.lang.Class.forName0(Native Method)
18:12:48 [main] [error] main: at java.base/java.lang.Class.forName(Class.java:374)
18:12:48 [main] [error] main: at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:485)
18:12:48 [main] [error] main: ... 15 more

Downgrading to 10.0.1+10-3ubuntu1 fixes the bug.

Work Around
-----------
Comment out line with 'assistive_technologies=org.GNOME.Accessibility.AtkWrapper'
in /etc/java-11-openjdk/accessibility.properties

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-lts (Ubuntu):
status: New → Confirmed
James Cowgill (jcowgill) on 2018-08-21
description: updated
Don-vip (vincent-privat) on 2018-08-21
Changed in josm:
importance: Unknown → Critical
Don-vip (vincent-privat) wrote :

It seems this regression has been introduced through https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=900912

fbyoung (fbyoung) wrote :

Also breaks freeplane

fbyoung (fbyoung) wrote :

Workaround from Freeplane bug-tracker
https://sourceforge.net/p/freeplane/bugs/2605/

Comment out line with 'assistive_technologies=org.GNOME.Accessibility.AtkWrapper'
in
/etc/java-11-openjdk/accessibility.properties

Damiön la Bagh (kat-amsterdam) wrote :

The workaround to comment out the accessibility.properties does not work on Ubuntu 18.04.1 using the Unity desktop

Damiön la Bagh (kat-amsterdam) wrote :

Switching to the Official Oracle Java 8 Package was the workaround that worked for me.

sudo add-apt-repository ppa:webupd8team/java
sudo apt update
sudo apt install oracle-java8-installer

This bug caused downtime. Hopefully it will be given high priority to fix.

Norbert (nrbrtx) on 2018-08-26
tags: added: bionic
John Little (john-b-little) wrote :

Google found the workaround in #4 from 2015, and it has worked for me, running SQL Workbench/J.

Changed in gpsprune (Ubuntu):
status: New → Confirmed
tags: added: rls-bb-incoming
description: updated
Tiago Stürmer Daitx (tdaitx) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug is being tracked and a fix has been proposed to the openjdk-lts package.

The package fix comments out
'assistive_technologies=org.GNOME.Accessibility.AtkWrapper'
in /etc/java-11-openjdk/accessibility.properties as well as moves libatk-wrapper-java-jni to Recommends.

A new package release with the fix is expected soon.

Sebastien Bacher (seb128) wrote :

the bug is in openjdk-lts and going to be fixed there, closing the java-atk-wrapper item since there is nothing to do for this one

Changed in java-atk-wrapper (Ubuntu):
status: New → Invalid
Mirzet Kadic (caracal-enl) wrote :

jMeter fails to start with the error message: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper

Steve Langasek (vorlon) on 2018-09-12
no longer affects: 389-console (Ubuntu)
no longer affects: aladin (Ubuntu)
no longer affects: alter-sequence-alignment (Ubuntu)
no longer affects: arduino (Ubuntu)
no longer affects: drmips (Ubuntu)
no longer affects: emboss (Ubuntu)
no longer affects: freeplane (Ubuntu)
no longer affects: geotranz (Ubuntu)
no longer affects: gpsprune (Ubuntu)
no longer affects: jakarta-jmeter (Ubuntu)
no longer affects: jaligner (Ubuntu)
no longer affects: jaxe (Ubuntu)
no longer affects: jedit (Ubuntu)
no longer affects: jftp (Ubuntu)
no longer affects: jhdf (Ubuntu)
no longer affects: jmol (Ubuntu)
no longer affects: jxplorer (Ubuntu)
no longer affects: logisim (Ubuntu)
no longer affects: neobio (Ubuntu)
no longer affects: plantuml (Ubuntu)
no longer affects: opticalraytracer (Ubuntu)
no longer affects: proalign (Ubuntu)
no longer affects: runescape (Ubuntu)
no longer affects: spread-phy (Ubuntu)
Steve Langasek (vorlon) on 2018-09-12
no longer affects: starjava-topcat (Ubuntu)
no longer affects: sunflow (Ubuntu)
no longer affects: thepeg (Ubuntu)
no longer affects: treeview (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openjdk-8 (Ubuntu):
status: New → Confirmed
Download full text (5.6 KiB)

@Steve Langasek (vorlon)
Could you please fix the bug?

I have spent long time adding all affected software to the bug list.

Your actions are not friendly. I do not appreciate them.

Why is it too difficult to roll-out simple one-liner patch as package to
the 18.04 LTS? Is it Ubuntu LTS or damn buggy ArchLinux?

On Wed, Sep 12, 2018 at 10:47 PM, Steve Langasek <
<email address hidden>> wrote:

> ** No longer affects: 389-console (Ubuntu)
>
> ** No longer affects: aladin (Ubuntu)
>
> ** No longer affects: alter-sequence-alignment (Ubuntu)
>
> ** No longer affects: arduino (Ubuntu)
>
> ** No longer affects: drmips (Ubuntu)
>
> ** No longer affects: emboss (Ubuntu)
>
> ** No longer affects: freeplane (Ubuntu)
>
> ** No longer affects: geotranz (Ubuntu)
>
> ** No longer affects: gpsprune (Ubuntu)
>
> ** No longer affects: jakarta-jmeter (Ubuntu)
>
> ** No longer affects: jaligner (Ubuntu)
>
> ** No longer affects: jaxe (Ubuntu)
>
> ** No longer affects: jedit (Ubuntu)
>
> ** No longer affects: jftp (Ubuntu)
>
> ** No longer affects: jhdf (Ubuntu)
>
> ** No longer affects: jmol (Ubuntu)
>
> ** No longer affects: jxplorer (Ubuntu)
>
> ** No longer affects: logisim (Ubuntu)
>
> ** No longer affects: neobio (Ubuntu)
>
> ** No longer affects: plantuml (Ubuntu)
>
> ** No longer affects: opticalraytracer (Ubuntu)
>
> ** No longer affects: proalign (Ubuntu)
>
> ** No longer affects: runescape (Ubuntu)
>
> ** No longer affects: spread-phy (Ubuntu)
>
> ** No longer affects: starjava-topcat (Ubuntu)
>
> ** No longer affects: sunflow (Ubuntu)
>
> ** No longer affects: thepeg (Ubuntu)
>
> ** No longer affects: treeview (Ubuntu)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1788250
>
> Title:
> AWT applications fail with java.awt.AWTError: Assistive Technology
> not found: org.GNOME.Accessibility.AtkWrapper
>
> Status in jEdit:
> New
> Status in JOSM:
> Unknown
> Status in java-atk-wrapper package in Ubuntu:
> Invalid
> Status in openjdk-8 package in Ubuntu:
> Confirmed
> Status in openjdk-lts package in Ubuntu:
> Confirmed
>
> Bug description:
> After recently upgrading to 10.0.2+13-1ubuntu0.18.04.1 in bionic, all
> AWT applications have started failing with this exception: (using
> jedit as an example, but it happens for lots of apps):
>
> ~  jedit
> 18:12:48 [main] [error] main: Exception in thread "main"
> 18:12:48 [main] [error] main: java.awt.AWTError: Assistive Technology
> not found: org.GNOME.Accessibility.AtkWrapper
> 18:12:48 [main] [error] main: at java.desktop/java.awt.Toolkit.
> newAWTError(Toolkit.java:472)
> 18:12:48 [main] [error] main: at java.desktop/java.awt.Toolkit.
> fallbackToLoadClassForAT(Toolkit.java:488)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:183)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> ReferencePipeline$2$1.accept(ReferencePipeline.java:177)
> 18:12:48 [main] [error] main: at java.base/java.util.HashMap$
> KeySpliterator.forEachRemaining(HashMap.java:1608)
> 18:12:48 [main] [error] main: at java.bas...

Read more...

Norbert (nrbrtx) wrote :
Download full text (4.9 KiB)

@Steve Langasek (vorlon)

Could you please fix the bug?

I have spent long time adding all affected software to the bug list.

Your actions are not friendly. I do not appreciate them.

Why is it too difficult to roll-out simple one-liner patch as package to
the 18.04 LTS? Is it Ubuntu LTS or damn buggy ArchLinux?

All these applications (389-console aladin alter-sequence-alignment arduino
drmips emboss freeplane geotranz gpsprune jakarta-jmeter jaligner jaxe
jedit jftp jhdf jmol jxplorer logisim neobio plantuml opticalraytracer
proalign runescape spread-phy starjava-topcat sunflow thepeg treeview ) are
affected by the bug and nobody cares about the problem...

On Wed, Sep 12, 2018 at 10:53 PM, Launchpad Bug Tracker <
<email address hidden>> wrote:

> Status changed to 'Confirmed' because the bug affects multiple users.
>
> ** Changed in: openjdk-8 (Ubuntu)
> Status: New => Confirmed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1788267).
> https://bugs.launchpad.net/bugs/1788250
>
> Title:
> AWT applications fail with java.awt.AWTError: Assistive Technology
> not found: org.GNOME.Accessibility.AtkWrapper
>
> Status in jEdit:
> New
> Status in JOSM:
> Unknown
> Status in java-atk-wrapper package in Ubuntu:
> Invalid
> Status in openjdk-8 package in Ubuntu:
> Confirmed
> Status in openjdk-lts package in Ubuntu:
> Confirmed
>
> Bug description:
> After recently upgrading to 10.0.2+13-1ubuntu0.18.04.1 in bionic, all
> AWT applications have started failing with this exception: (using
> jedit as an example, but it happens for lots of apps):
>
> ~  jedit
> 18:12:48 [main] [error] main: Exception in thread "main"
> 18:12:48 [main] [error] main: java.awt.AWTError: Assistive Technology
> not found: org.GNOME.Accessibility.AtkWrapper
> 18:12:48 [main] [error] main: at java.desktop/java.awt.Toolkit.
> newAWTError(Toolkit.java:472)
> 18:12:48 [main] [error] main: at java.desktop/java.awt.Toolkit.
> fallbackToLoadClassForAT(Toolkit.java:488)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:183)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> ReferencePipeline$2$1.accept(ReferencePipeline.java:177)
> 18:12:48 [main] [error] main: at java.base/java.util.HashMap$
> KeySpliterator.forEachRemaining(HashMap.java:1608)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> AbstractPipeline.copyInto(AbstractPipeline.java:484)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> AbstractPipeline.evaluate(AbstractPipeline.java:234)
> 18:12:48 [main] [error] main: at java.base/java.util.stream.
> ReferencePipeline.forEach(ReferencePipeline.java:497)
> 18:12:48 [...

Read more...

Norbert (nrbrtx) wrote :

Moreover we have 1074 views of related Q&A on AskUbuntu ( https://askubuntu.com/q/1067569/66509 ).

How long it will be going on?

Steve Langasek (vorlon) wrote :

On Wed, Sep 12, 2018 at 08:21:52PM -0000, Norbert wrote:
> I have spent long time adding all affected software to the bug list.

That is not a correct use of 'affects' in Launchpad. This bogs down the UI
and makes it difficult to interact with this bug.

> Why is it too difficult to roll-out simple one-liner patch as package to
> the 18.04 LTS? Is it Ubuntu LTS or damn buggy ArchLinux?

The Java package undergoes extensive testing as part of an SRU process, and
this is not the only change pending for openjdk-lts. The straightforward
workaround in the meantime is to make the same change as described in https://bugs.launchpad.net/ubuntu/+source/openjdk-lts/+bug/1788250/comments/8
locally in your own config file.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openjdk-lts - 10.0.2+13-1ubuntu0.18.04.2

---------------
openjdk-lts (10.0.2+13-1ubuntu0.18.04.2) bionic-security; urgency=medium

  * debian/rules: by default leave atk disabled, move accessibility bridge to
    recommends. LP: #1788250. LP: #1788267.
  * debian/control.in, debian/control: move accessibility bridge to
    recommends.

 -- Tiago Stürmer Daitx <email address hidden> Fri, 24 Aug 2018 17:36:24 +0000

Changed in openjdk-lts (Ubuntu):
status: Confirmed → Fix Released
tags: removed: rls-bb-incoming
Mathew Hodson (mhodson) on 2018-09-16
Changed in openjdk-lts (Ubuntu):
importance: Undecided → Critical
Mathew Hodson (mhodson) on 2018-09-16
no longer affects: java-atk-wrapper (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Mathew Hodson (mhodson) on 2018-09-16
affects: jedit → ubuntu
no longer affects: ubuntu
Changed in openjdk-10 (Debian):
status: Unknown → Confirmed
Changed in openjdk-10 (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.