openarena crashes by changing sound quality

Bug #120568 reported by Sancho on 2007-06-15
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
openarena (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openarena

When I change the sound quality from hight to another one, openarena(the standard version as ubuntu pakage) simply closes and go out without saying anything. I have an Inspiron 6400(Dell)

same problem.

- ubuntu feisty package
- standard AC'97 sound chipset

Martin Doucha (next-ghost) wrote :

Could you run openarena from terminal and post here the output?

Sancho (sashb) wrote :
Download full text (7.3 KiB)

[: 30: ==: unexpected operator
ioQ3 1.33+oa linux-i386 Feb 5 2007
----- FS_Startup -----
Current search path:
/home/sanja/.openarena/baseoa/tig_out.pk3 (30 files)
/home/sanja/.openarena/baseoa/mrcq3t3.pk3 (25 files)
/home/sanja/.openarena/baseoa/meatpak.pk3 (174 files)
/home/sanja/.openarena/baseoa/map-saiko_tourney1.pk3 (29 files)
/home/sanja/.openarena/baseoa/map-charon3dm3.pk3 (56 files)
/home/sanja/.openarena/baseoa/keenq3dm1.pk3 (170 files)
/home/sanja/.openarena/baseoa/htourney1.pk3 (9 files)
/home/sanja/.openarena/baseoa/catq3tourney01.pk3 (7 files)
/home/sanja/.openarena/baseoa/agony.pk3 (22 files)
/home/sanja/.openarena/baseoa
/usr/share/games/openarena/baseoa/pak6-misc.pk3 (96 files)
/usr/share/games/openarena/baseoa/pak5-TA.pk3 (7 files)
/usr/share/games/openarena/baseoa/pak4-textures.pk3 (932 files)
/usr/share/games/openarena/baseoa/pak2-players.pk3 (187 files)
/usr/share/games/openarena/baseoa/pak1-maps.pk3 (25 files)
/usr/share/games/openarena/baseoa/pak0.pk3 (748 files)
/usr/share/games/openarena/baseoa
/usr/lib/games/openarena/baseoa

----------------------
2517 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----

------- Input Initialization -------
Joystick is not active.
------------------------------------
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
Initializing OpenGL display
...setting mode 6: 1024 768
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: Mesa DRI Intel(R) 945GM 20061017 x86/MMX/SSE2
Initializing OpenGL extensions
...GL_S3_s3tc not found
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...ignoring GL_EXT_texture_filter_anisotropic

GL_VENDOR: Tungsten Graphics, Inc
GL_RENDERER: Mesa DRI Intel(R) 945GM 20061017 x86/MMX/SSE2
GL_VERSION: 1.3 Mesa 6.5.2
GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_fragment_program GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_cull_vertex GL_EXT_compiled_vertex_array GL_EXT_convolution GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_histogram GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine G...

Read more...

Jeff Anderson (jander99) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in openarena (Ubuntu):
status: New → Incomplete
Download full text (7.1 KiB)

Hi, I have this bug in Karmic.
Crash when changing quality, and no sound.
Openarena crash when exiting.

francois@franfran:~$ openarena
ioq3+oa 1.35 linux-x86_64 May 3 2009
----- FS_Startup -----
Current search path:
/home/francois/.openarena/baseoa
/usr/share/games/openarena/baseoa/pak6-misc.pk3 (229 files)
/usr/share/games/openarena/baseoa/pak5-TA.pk3 (139 files)
/usr/share/games/openarena/baseoa/pak4-textures.pk3 (1753 files)
/usr/share/games/openarena/baseoa/pak2-players.pk3 (669 files)
/usr/share/games/openarena/baseoa/pak2-players-mature.pk3 (231 files)
/usr/share/games/openarena/baseoa/pak1-maps.pk3 (100 files)
/usr/share/games/openarena/baseoa/pak0.pk3 (1042 files)
/usr/share/games/openarena/baseoa

----------------------
4163 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
SDL using driver "x11"
Initializing OpenGL display
Estimated display aspect: 1.250
...setting mode 8: 1280 1024
Using 8/8/8 Color bits, 24 depth, 0 stencil display.
Available modes: '1920x1080 640x512 1280x1024 320x240 400x300 416x312 512x384 576x432 640x480 800x600 832x624 896x672 1024x768 1152x864 1280x960 800x512 720x450 840x525 960x600 680x384 960x540'
GL_RENDERER: GeForce 7600 GS/PCI/SSE2
Initializing OpenGL extensions
...ignoring GL_EXT_texture_compression_s3tc
...ignoring GL_S3_s3tc
...using GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...ignoring GL_EXT_texture_filter_anisotropic

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce 7600 GS/PCI/SSE2
GL_VERSION: 2.1.2 NVIDIA 185.18.36
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_framebuffer_object GL_ARB_imaging GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_ATI_draw_buffers GL_ATI_texture_float GL_ATI_texture_mirror_once GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_depth_bounds_test GL_EXT_direct_state_access GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arra...

Read more...

Changed in openarena (Ubuntu):
status: Incomplete → New

Hi,
I haven't this bug now in karmic, because I have disabled OpenAl in the sound menu. It doesn't make Openarena crash.
But with OpenAl actived, sound is very bad, there are "bzzzz".
Thanks

dradis (sluthouser) wrote :

Ubuntu 9.10: I have that "buzz" too. After turning off OpenAl the game worked for a while. After some time I had no sound and when I tried to exit the game computer freezes.
motherboard asus m2n8-vmx

Roshan George (roshan-george) wrote :

On Karmic with a 9400 GT OpenArena freezes but stays in front so I don't get my desktop back without changing to a VT and killing it.

komputes (komputes) wrote :

@Roshan George

I can confirm this since I have also seen this behavior. After killing openarena in a VT and coming back to screen 7 (Xorg), the screen resolution is on a low resolution. In this case I either need to restart X (need to re-activate ctrl-alt-backspace first for this to work).

I have tested openarena 0.8.1-5 in Lucid Alpha, and besides some brightness issues, quiting and changing sound quality or video resolution does not make the program crash any longer.

However changing sound quality does change the quality, then bring you back to the main game menu. Would be nice to see direct feedback instead of going back to the main menu.

Please test openarena 0.8.1-5 with your hardware and comment in this bug if you still have this issue. Thank you.

I removed PulseAudio with

$ sudo aptitude purge pulseaudio

To get it to work..

Changed in openarena (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers