OpenAFS fails to build on trusty kernel 3.12 [openafs-modules-dkms 1.6.5.1-1: openafs kernel module failed to build]

Bug #1246675 reported by Anders Kaseorg
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
openafs (Ubuntu)
Fix Released
High
Luke Faraone

Bug Description

OpenAFS doesn’t build with CONFIG_UIDGID_STRICT_TYPE_CHECKS=y (required by CONFIG_USER_NS). Patches don’t appear to exist upstream yet. That’s awkward.

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: openafs-modules-dkms 1.6.5.1-1
ProcVersionSignature: Ubuntu 3.12.0-1.3-generic 3.12.0-rc7
Uname: Linux 3.12.0-1-generic x86_64
ApportVersion: 2.12.6-0ubuntu1
Architecture: amd64
DKMSKernelVersion: 3.12.0-1-generic
Date: Thu Oct 31 06:51:55 2013
DuplicateSignature: dkms:openafs-modules-dkms:1.6.5.1-1:/var/lib/dkms/openafs/1.6.5.1/build/src/afs/LINUX/osi_machdep.h:160:17: error: incompatible types when assigning to type ‘kuid_t’ from type ‘uid_t’
InstallationDate: Installed on 2010-12-05 (1061 days ago)
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
MarkForUpload: True
PackageArchitecture: all
PackageVersion: 1.6.5.1-1
SourcePackage: openafs
Title: openafs-modules-dkms 1.6.5.1-1: openafs kernel module failed to build
UpgradeStatus: Upgraded to trusty on 2013-10-31 (0 days ago)

Revision history for this message
Anders Kaseorg (andersk) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Anders Kaseorg (andersk) wrote :

I submitted a patch upstream for review: http://gerrit.openafs.org/10386

Revision history for this message
Anders Kaseorg (andersk) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openafs (Ubuntu):
status: New → Confirmed
Luke Faraone (lfaraone)
Changed in openafs (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
assignee: nobody → Luke Faraone (lfaraone)
Luke Faraone (lfaraone)
Changed in openafs (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openafs - 1.6.5.1-1ubuntu1

---------------
openafs (1.6.5.1-1ubuntu1) trusty; urgency=low

  * Include patches by Anders Kaseorg to fix FTBFS on trusty's kernel.
    (LP: #1246675)
 -- Luke Faraone <email address hidden> Mon, 25 Nov 2013 11:02:43 -0500

Changed in openafs (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Pali (pali) wrote :

This problem is also on Ubuntu LTS Precise with Kernel Enablement Stack.

Revision history for this message
Luke Faraone (lfaraone) wrote :

Pali: Precise's HWE kernel is currently Saucy's kernel. The FTBFS with Saucy was recorded in bug 1222376 and is fixed in Saucy.

The tracking bug for the Stable Release Update we've prepared for Precise is bug 1206387.

This bug will become relevant once the trusty kernel is backported via the HWE stack, but that shouldn't happen until much later in the cycle.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers