open-vm-tools 11.0.0 released

Bug #1844834 reported by Oliver Kurth on 2019-09-20
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
open-vm-tools (Debian)
Fix Released
Unknown
open-vm-tools (Ubuntu)
Medium
Christian Ehrhardt 
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

[Impact]

 * In the past a lack of updated open-vm-tools versions was found fatal
   and therefore we agreed to regularly backport those to the latest LTS.
   This is backporting the recent version 11.0 to B/D/E releases.

[Test Case]

 * Test open-vm-tools done by VMWare QA Team as agreed for these
   backports.

[Regression Potential]

 * This has the usual regression potential of a new version upgrade and
   therefore is higher than a usual SRU. But as agreed int he past to
   support new (virtual) hardware open-vm-tools shall regularly be
   backported. I suggest keeping it somewhat longer in proposed than usual
   just to be on the safe side.

[Other Info]

 * Open-vm-tools does regular backports up to the latest stable release
   Per agreement with VMWare they are doing a QA check on it once it is in
   -proposed

---

We have released open-vm-tools 11.0.0, see https://github.com/vmware/open-vm-tools/releases/tag/stable-11.0.0 .

Also filed at Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=940853

Related branches

tags: added: upgrade-software-version
Changed in open-vm-tools (Debian):
status: Unknown → New

Thanks Oliver for the ping.
Bernd already has that prepared in Debian/experimental.
For Ubuntu I'll have a look after 20.04 opened its development cycle.

tags: added: server-next
Changed in open-vm-tools (Ubuntu):
assignee: nobody → Christian Ehrhardt  (paelzer)
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in open-vm-tools (Ubuntu):
status: New → Confirmed
vmware-gos-Yuhua (yhzou) wrote :

Do you have plan to rebase OVT 11.0.0 to ubuntu 19.10 ?
It will be valuable to get 11.0.0 into 19.10.

Thanks
Yuhua Zou

> Do you have plan to rebase OVT 11.0.0 to ubuntu 19.10 ?
> It will be valuable to get 11.0.0 into 19.10.

Hi Yuhua,
no - as I have stated multiple times in advance in other
places/calls/emails - 11.0 came out after 19.10 feature freeze and is
too much of a risk.
The plan for a long time already was to have OVT >=11 in Ubuntu 20.04.

Changed in open-vm-tools (Debian):
status: New → Fix Released
tags: added: needs-debian-merge

The changes for 1847157 are in 11.0 which were our only Delta due to the Eoan feature freeze.
We can sync 11.0 from Debian now that Focal is open, doing so now ...

Changed in open-vm-tools (Ubuntu):
status: Confirmed → Triaged
status: Triaged → In Progress

This bug was fixed in the package open-vm-tools - 2:11.0.1-2

---------------
open-vm-tools (2:11.0.1-2) unstable; urgency=medium

  * [76c600f] Fix segfault for fs devices without /
    See https://github.com/vmware/open-vm-tools/issues/378 for details.
    Thanks to Mo Zhou (Closes: #942692)

 -- Bernd Zeimetz <email address hidden> Tue, 22 Oct 2019 15:48:48 +0200

open-vm-tools (2:11.0.1-1) unstable; urgency=medium

  * [bb36e10] Update upstream source from tag 'upstream/11.0.1'
    Update to upstream version '11.0.1'
    with Debian dir 60c0d512096774b9a2a7cc9e4e94556b2893ae8a

 -- Bernd Zeimetz <email address hidden> Tue, 22 Oct 2019 09:40:50 +0200

open-vm-tools (2:11.0.0-2) unstable; urgency=medium

  * [4cfe383] Update Vcs-Git/Browser to point to salsa.
  * [bc253ad] Remove .travis.yml, add debian/.gitlab-ci.yml
  * [c92ca3a] Add add_patch.sh script to add patches from upstream.
  * [1d9b491] Add patch to remove deprecated inline functions
  * [3e2e307] Rename lintian-override file properly

 -- Bernd Zeimetz <email address hidden> Tue, 15 Oct 2019 23:25:24 +0200

open-vm-tools (2:11.0.0-1) unstable; urgency=medium

  [ goldstar611 ]
  * [c138871] Ensure VGAuthService starts after AppArmor
    https://gitlab.com/apparmor/apparmor/issues/13

  [ Bernd Zeimetz ]
  * [28ef841] New upstream version 11.0.0~0
  * [f78ed2d] New upstream version 11.0.0
    Closes: #940853
  * [19efc80] Revert "Revert "Removing libdumbnet-dev.""
    This reverts commit 31177fab964d92687501ab81774440a9b8d09e39.
  * [bc14a8b] snapshot changelog
  * [1c5e9ea] Dropping patches that were picked from upstream

 -- Bernd Zeimetz <email address hidden> Mon, 30 Sep 2019 14:37:27 +0200

Changed in open-vm-tools (Ubuntu):
status: In Progress → Fix Released

To be clear, only in proposed now - but migration takes a while so I wanted to update the bug with the sync info.

FYI - Released in Focal, reviews on the MPs for B+D+E start to come in.

Changed in open-vm-tools (Ubuntu Eoan):
status: New → Triaged
Changed in open-vm-tools (Ubuntu Disco):
status: New → Triaged
Changed in open-vm-tools (Ubuntu Bionic):
status: New → Triaged
description: updated

B/D/E review complete, uploaded to -unapproved for the SRU Team to take a look and accept it into -proposed of these releases.

I'd like to answer a ping bdmurry sent me (thanks that might explain why it waits to long in the queue!):
[22:19] <bdmurray> cpaelzer: Where did "we agreed to regularly backport those to the latest LTS." from bug 1844834

First of all that is the practice for quite a while (almost two years now), see:
- https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1741390
- https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1784638
- https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1813944
- https://bugs.launchpad.net/ubuntu/+source/open-vm-tools/+bug/1822204

The request back then came from the community and the decision back then was between VMWare and Ubuntu. VMWare QA Team since then does the qualification of these uploads as we (I) don't have a matrix of Host versions for that around.
^^ that is the "agreement" I mentioned

I agree that I sometimes fail to find it listed in [1] where I would expected this (and you might have looked there as well). The reason is that so far we always concluded that this qualifies for #2 and #3 of [2].
Maybe I should add an entry to [1] that just says so? That might help SRU members to identify this case as what it is. What do you think @bdmurray should I do that or do you want a wider re-discussion?

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Documentation_for_Special_Cases
[2]: https://wiki.ubuntu.com/StableReleaseUpdates#Other_safe_cases

Hello Oliver, or anyone else affected,

Accepted open-vm-tools into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:11.0.1-2ubuntu0.19.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in open-vm-tools (Ubuntu Eoan):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-eoan
Changed in open-vm-tools (Ubuntu Disco):
status: Triaged → Fix Committed
tags: added: verification-needed-disco
Timo Aaltonen (tjaalton) wrote :

Hello Oliver, or anyone else affected,

Accepted open-vm-tools into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:11.0.1-2ubuntu0.19.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Timo Aaltonen (tjaalton) wrote :

Hello Oliver, or anyone else affected,

Accepted open-vm-tools into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:11.0.1-2ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in open-vm-tools (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed-bionic

I haven't found an issue in my minimal testing, but more important I have pinged VMWare (via mail) to do the usual full verification on these builds before we mark it verified.

vmware-gos-Yuhua (yhzou) wrote :

I am working on it. Thanks

vmware-gos-Yuhua (yhzou) wrote :

 It works well when do sanity check for open-vm-tools 11.0.1 with repo “-proposed“

 Check items:
   1. install / uninstall open-vm-tools, check service
   2. reboot VM after install / uninstall, check open-vm-tools/ VGAuth service
   3. check ip address and OS fullName after install open-vm-tools.

 in following VMs:
   1. ubuntu-19.10-desktop-amd64
   2. ubuntu-19.10-server-amd64
   3. ubuntu-19.10-live-server-amd64

   4. ubuntu-19.04-server-amd64

   5. ubuntu-18.04.3-desktop-amd64

Thanks

tags: added: verification-done verification-done-bionic verification-done-disco verification-done-eoan
removed: verification-needed verification-needed-bionic verification-needed-disco verification-needed-eoan
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package open-vm-tools - 2:11.0.1-2ubuntu0.19.10.1

---------------
open-vm-tools (2:11.0.1-2ubuntu0.19.10.1) eoan; urgency=medium

  * Update to latest release v11 (LP: #1844834)

 -- Christian Ehrhardt <email address hidden> Wed, 30 Oct 2019 09:58:25 +0100

Changed in open-vm-tools (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for open-vm-tools has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

FYI this went into crash reports for ID 1603513cf3aef02631bc0136e990c10f5c891c50
I analyzed and filed [1], for now please do NOT release it to Bionic and Disco yet.
After we have discussed (and maybe fixed) upstream there might be a new spin on this.

I don't think we have to fully roll back the Eoan version yet wit han extra upload.
Just keep it at the low phasing it is (or set phasing back to 0% if that is possible?). Once we know more we can make better decisions then how to continue.

[1]: https://github.com/vmware/open-vm-tools/issues/390

tags: added: block-proposed-bionic block-proposed-disco
vmware-gos-Yuhua (yhzou) wrote :

 > https://github.com/vmware/open-vm-tools/issues/390

For above issue, maybe it caused by the failure to exec command "/usr/bin/lsb_release". So I do the following testing in ubuntu-19.04-live-server:

1) apt-get update
2) rm -rf /usr/bin/lsb_release
3) install open-vm-tools with command "apt-get install open-vm-tools"
4) check services: vmtoolsd service VGAuth service are both running
5) reboot VM and check services again: vmtoolsd service VGAuth service are both running
6) uninstall open-vm-tools with command "apt-get purge open-vm-tools"

For step 4) and 5), the services are running but not crash

Hi Yuhua,
ack - that was about the same testing I did.
As I said on that GH issue I can't reproduce my own, but the crashes keep coming in and the fix seems rather clear.
So I hope that the developers agree, code something up and we can make it part of our 11.0 uploads here before pushing it further to the users.

Now that the issue is resolved by upstream lets open a bug for proper tracking.
=> bug 1855686

This bug here (the base update to v11) is already verified and ok.
So IMHO once the new fix hits the SRU queue we only need to verify the "extra issue on top" in bug 1855686.
Never the less I'll mention this bug here in the new changelog as for Bionic/Disco-updates pocket this never happened.

FYI - this is in B/C/D-unapproved queues now
The E upload covers just this fix, B/D uploads (being not yet released to -updates before) cover the former bump to v11 in their changes file as well.

Once in proposed we can verify bug 1855686 on them and then release to -updates.

Hello Oliver, or anyone else affected,

Accepted open-vm-tools into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:11.0.1-2ubuntu0.19.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-disco
removed: verification-done verification-done-disco
tags: added: verification-needed-bionic
removed: verification-done-bionic
Robie Basak (racb) wrote :

Hello Oliver, or anyone else affected,

Accepted open-vm-tools into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/open-vm-tools/2:11.0.1-2ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

As forecast this is the "re-appearance" of the SRU for 11.0 this time with the fix for bug 1855686.
The general v11 behavior on this was already verified and hasn't changed in the recent add to the upload. Therefore we need no full evaluation "again" on this.
To be on the safe side I did at least some basic checks and it still behaved as usual.

Marking verified (again).

tags: added: verification-done verification-done-bionic verification-done-disco
removed: block-proposed-bionic block-proposed-disco verification-needed verification-needed-bionic verification-needed-disco

Note: Also removed block proposed on this as we entered a new phase with this new uploads.

Oliver Kurth (okurth-1) wrote :

Thank you. I notified the team to test this.

vmware-gos-Yuhua (yhzou) wrote :

It works well when do sanity check for 11.0.1-2ubuntu0.18.04.2 and 11.0.1-2ubuntu0.19.04.2

Check items:
 1. install / uninstall open-vm-tools, check open-vm-tools/VGAuth service
 2. reboot VM after install / uninstall open-vm-tools and then check open-vm-tools/ VGAuth service
 3. check ip address, guestId, OS fullName after install open-vm-tools.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.