open-iscsi: reconnecting to targets fails with kernel >2.6.32 due to sysfs changes (open-iscsi pkg version out of date with kernel)

Bug #677333 reported by Jim Paris on 2010-11-19
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
open-iscsi (Debian)
Fix Released
Unknown
open-iscsi (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: open-iscsi

Open-iscsi needs this patch
  http://git.kernel.org/?p=linux/kernel/git/mnc/open-iscsi.git;a=commitdiff;h=f0b670c016c85c882bb0583eaef8ea2f7147d4af
for kernels after 2.6.32 to work correctly, particularly when connecting to iSCSI targets that don't use authentication.

(See also http://bugs.debian.org/603990. This is the same bug, but more important for Ubuntu because it's using a >2.6.32 kernel).

Related branches

CVE References

Changed in open-iscsi (Debian):
status: Unknown → New
Changed in open-iscsi (Debian):
status: New → Fix Released
Cinquero (cinquero) wrote :

See also here: https://bugzilla.kernel.org/show_bug.cgi?id=26992

Please upgrade the open-iscsi Version in Maverick to 2.0-872 which is hidden at http://kernel.org/pub/linux/kernel/people/mnc/open-iscsi/releases/open-iscsi-2.0-872.tar.gz.

Changed in open-iscsi (Ubuntu):
status: New → Confirmed
summary: open-iscsi: reconnecting to targets fails with kernel >2.6.32 due to
- sysfs changes
+ sysfs changes (open-iscsi pkg version out of date with kernel)
Cinquero (cinquero) wrote :

There should be a kernel dependency for open-iscsi* packages which limits the maximum kernel version for which the package source has patches available...

Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package open-iscsi - 2.0.873-3ubuntu1

---------------
open-iscsi (2.0.873-3ubuntu1) quantal; urgency=low

  * Merge from Debian. Remaining changes: (LP: #961114, LP: #677333)
    - Add upstart job iscsi-network-interface
    - Migrate from /var/run and /lib/init/rw to /run, from /var/lock to
      /run/lock.
  * Turn open-iscsi-utils into a transitional package

open-iscsi (2.0.873-3) unstable; urgency=low

  * [4939401] Fix build to install udeb stuff only on supported architectures

open-iscsi (2.0.873-2) unstable; urgency=low

  * [0019fa9] Restrict architecture for the udeb package as its dependency,
    scsi-modules, is not available on all the architecture paltforms

open-iscsi (2.0.873-1) unstable; urgency=low

  * [53943f2] Load iscsi_ibft module to allow target session over iBFT.
    Thanks to JOORIS Emmanuel (Closes: #672122)
  * [ca41744] Delete old obsolete patches
  * [01a54bf] Drop old manpages already available upstream
  * [caf884c] ship upstream manpages for iscsi-iname and iscsistart
  * [a983848] Imported Upstream version 2.0.873

open-iscsi (2.0.872+git0.6676a1cf-2) unstable; urgency=low

  * Upload to unstable
  * [cb80472] Fix default iscsid path in config file.
    Thanks to Michal Suchanek (Closes: #650221)

open-iscsi (2.0.872+git0.6676a1cf-1) experimental; urgency=low

  [ Ritesh Raj Sarraf ]
  * New Upstream git snapshot (Closes: #645752)
  * [ce26f7c] Imported Upstream version 2.0.872+git0.6676a1cf
  * [9ad08d7] also include iscsitart in the udeb
  * [bc79ad2] refresh patch debian/patches/spelling-error-fixes.patch
  * [0286328] refresh patch 004_make-iscsistart-a-dynamic-binary.patch
  * [360a509] Drop patches:
    + iscsi-dont-build-with-ssl.patch and
    + disable-isns-security.patch
  * [350db4d] rename and reorder patches
  * [794fa4f] Package-Type is now an understood feild by dpkg
  * [593f187] Add hardened build flags.
    Thanks to Moritz Muehlenhoff (Closes: #659662)
  * [cf4c6c3] Kill iscsid processes properly, on stop.
    Thanks to Gwendal Grignou (Closes: #665966)
  * [f1a9d2f] linitan fixes for spelling errors and manpage hyphen errors
  * [a8560c8] add and fix lsb headers for init files

  [ Colin Watson ]
  * [156b745] open-iscsi: add a udeb (Closes: #635161)

open-iscsi (2.0.872-2) unstable; urgency=low

  * Upload to unstable

open-iscsi (2.0.872-1) experimental; urgency=low

  * New Upstream Release
  * [cccd5a9] Use udevadm to check for existense of udev.
    Thanks to Marco d'Itri (Closes: #622209)
  * [ddb81e4] Drop patches, merged upstream
  * [25aa1d9] disable security and slp support
  * [89b2a6a] Add patch to disable ssl.
    Thanks to Mike Christie
  * [d70e88a] Refresh patch
  * [b501aec] delete debian/patches/disable-isns.patch
  * [2cc67f7] spelling-error and hyphentation fixes
  * [b886116] Bump Standards Version to 3.9.2
  * [405ecfd] add autotools-dev to build-dep to ensure we have no stale
    configure scripts

open-iscsi (2.0.871.3-6) unstable; urgency=low

  * [87c440c] fix gcc 4.6 build failure (Closes: #625152)

open-iscsi (2.0.871.3-5) unstable; urgency=low

  * Last upload was incorrect. Really upload to unstable

open-iscsi (2.0.871.3-4) unstable...

Read more...

Changed in open-iscsi (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.