oneconf-query crashed with AttributeError in /usr/bin/oneconf-query: 'GNUTranslations' object has no attribute 'ugettext'

Bug #1103192 reported by Guenillon on 2013-01-22
108
This bug affects 24 people
Affects Status Importance Assigned to Milestone
oneconf (Ubuntu)
Medium
Barry Warsaw

Bug Description

Version 13.04

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: oneconf 0.3.2
ProcVersionSignature: Ubuntu 3.8.0-0.4-generic 3.8.0-rc3
Uname: Linux 3.8.0-0-generic i686
ApportVersion: 2.8-0ubuntu2
Architecture: i386
Date: Tue Jan 22 22:41:18 2013
ExecutablePath: /usr/share/oneconf/oneconf-query
InstallationDate: Installed on 2012-07-14 (191 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120627)
InterpreterPath: /usr/bin/python3.3
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python3.3 /usr/bin/oneconf-query --async-update
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/oneconf-query', '--async-update']
SourcePackage: oneconf
Title: oneconf-query crashed with AttributeError in /usr/bin/oneconf-query: 'GNUTranslations' object has no attribute 'ugettext'
Traceback:
 Traceback (most recent call last):
   File "/usr/bin/oneconf-query", line 30, in <module>
     _ = gettext.translation('oneconf').ugettext
 AttributeError: 'GNUTranslations' object has no attribute 'ugettext'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Guenillon (guenillon) wrote :
tags: removed: need-duplicate-check
Changed in oneconf (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in oneconf (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1103192

tags: added: iso-testing
information type: Private → Public
Changed in oneconf (Ubuntu):
assignee: nobody → Barry Warsaw (barry)
Barry Warsaw (barry) on 2013-01-23
Changed in oneconf (Ubuntu):
status: Confirmed → In Progress
Coya DeBrojara (coyadebrojara) wrote :

The program crashed immediately after upgrading to the latest version (0.3.2)
The difference with the above:

ProcVersionSignature: Ubuntu 3.8.0-1.5-generic 3.8.0-rc4
Uname: Linux 3.8.0-1-generic x86_64
...
Architecture: amd64
...

(Program ulegl awarii bezpośrednio po aktualizacji do nowszej wersji (0.3.2).

Barry Warsaw (barry) wrote :

Hopefully I've fixed this now. I'm not completely able to test it locally, but I switched it to use the more recommended Python 3 API for installing gettext application-wide. Please test it 0.3.3.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oneconf - 0.3.3

---------------
oneconf (0.3.3) raring; urgency=low

  * d/tests/unittests: Remove -x debugging artifact and run the nose tests
    under -q instead of -vv to inhibit stderr output. (LP: #1102875)
  * oneconf-query: Use gettext.install() to install the _() function.
    (LP: #1103192)
 -- Barry Warsaw <email address hidden> Wed, 23 Jan 2013 18:30:05 -0500

Changed in oneconf (Ubuntu):
status: In Progress → Fix Released
Alex Liang (chinabiue) wrote :

okOK

hongwen luo (lhw828) wrote :

经常出现这个情况

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers