Screen keyboard shows, even though it's turned off in accessibility settings

Bug #938302 reported by Jimmy Merrild Krag on 2012-02-22
70
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Onboard
Undecided
Unassigned
onboard (Ubuntu)
Undecided
Unassigned

Bug Description

I accidentally ran onboard from the dash. Now it shows every time I have to unlock my screen. How do I turn it off?

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: onboard 0.96.1-0ubuntu0.1
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic x86_64
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Wed Feb 22 01:17:09 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: onboard
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jimmy Merrild Krag (beruic) wrote :
Jimmy Merrild Krag (beruic) wrote :

I got it turned off in the Onboard Settings, under Desktop integration. But shouldn't this be unnecessary when the screen keyboard is turned off in the accessibility settings?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in onboard (Ubuntu):
status: New → Confirmed
marmuta (marmuta) wrote :

Yes, this is a known quirk. Onboard in Ubuntu is set up to enable screen saver integration by default. This happens on first start and has to be turned off manually in preferences.

We just recently talked about this again. What we could do from Onboard's side is to refuse to start in g-s-s when either Onboard wasn't already running in the user session or the on-screen keyboard is turned off in accessibility settings.

I'm not sure yet if this isn't something that should be solved outside of Onboard though. perhaps by disabling/enabling the relevant g-s-s gsettings keys when toggling the osk in accessibility settings.

Francesco Fumanti (frafu) wrote :

Enabling Onboard in the Universal Access panel also starts at-spi2. However, Onboard does not require at-spi2, unless its the auto-show feature is used. So let's assume now that a user does not want to use at-spi2 and therefore starts Onboard manually. Checking for the on-screen keyboard setting in the Universal Access panel would report incorrect information.

marmuta (marmuta) wrote :

True, "Typing assistant" toggles toolkit-accessibility too, so no checking for this switch? I guess this would collide with onboard being fully functional as an independent application too.

If we stay independent of the switch, the external solution, i.e. patching gnome-settings-daemon to toggle embedded-keyboard-enabled, isn't useful either.

So what's left is looking for a running instance of Onboard. If there is none, onboard shuts down early when xembedding. The exception being in unity-greeter to keep onboard in the login screen. We'd need to test for unreliable RUNNING_UNDER_GDM, meaning this bug would be fixed except when running off the live-cd.

Francesco Fumanti (frafu) wrote :

An alternative might be to consider the unlock screen as the exception instead of the display manager. Thus, Onboard would only check for a running instance when it gets started under the unlock screen. Is there a way for Onboard to check whether it has been started for the unlock screen?

About the RUNNING_UNDER_GDM: Does this not mean that Onboard will depend on specific display managers to even start up? Since the problem is about the unlock screen, we might perhaps try to avoid as much as possible relying on other things.

marmuta (marmuta) wrote :

> An alternative might be to consider the unlock screen as the exception instead of the display manager.
That's safer, yes. We can probably check if the parent process is gnome-screensaver. If this fails in the future, the worst that can happen is that this bug reappears. I try this.

> About the RUNNING_UNDER_GDM: Does this not mean that Onboard will depend on specific display managers to even start up?
RUNNING_FROM_GDM would suggest that, but last time I checked it's usage wasn't restricted to GDM.

marmuta (marmuta) wrote :

The fix from #8 seems to work. I've pushed it to trunk.

Changed in onboard (Ubuntu):
status: Confirmed → Fix Committed
marmuta (marmuta) on 2012-04-20
Changed in onboard:
status: New → Fix Committed
Changed in onboard (Ubuntu):
status: Fix Committed → Confirmed

experiencing the same problem in 12.04

DavidW617 (davidw617) wrote :

I needed to run gsettings set org.gnome.desktop.screensaver embedded-keyboard-enabled false to make the onscreen keyboard stop showing up even after I turned it off. I am running 12.04.

Francesco Fumanti (frafu) wrote :

You can find Onboard 0.97.1, that contains the fix to this problem in our Stable PPA for oneiric, precise and quantal:
https://launchpad.net/~onboard/+archive/stable

Changed in onboard:
status: Fix Committed → Fix Released
Beowulf (s-highlander) wrote :

I confirm that this bug affects me, too.

Francesco Fumanti (frafu) wrote :

@Beowulf

Do you mean that the problem still occurs on your system with version 0.97.1 of the stable PPA?

Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package onboard - 0.97.1-0ubuntu1

---------------
onboard (0.97.1-0ubuntu1) quantal; urgency=low

  * Request for sponsorship: New bugfix release available (LP: #999185)
  * debian/control:
    - add moustetweaks (>= 3.3.90) to recommends
    - update standards-version 3.9.3
    - remove wnck dependency from depends
  * debian/patches: remove fix_encoding_mismatch.patch and update series
  * Improve auto-show:
    - unhide for combo boxes (helps in qtoctave) and date editors
    - add focused attribute to debug output
    - fix iconifying by title bar button
    - fix bad repositioning the very first time onboard pops up
    - fix non-critical backtraces for auto-show
    - fix keyboard not being hidden on startup in Metacity
  * Detect running environment to better care for its specificities
    - fix and make also window type hints environment specific
  * Add command line option to override automatic environment detection
  * Fix Onboard not being shown in taskbar (LP: #990486)
  * Prevent zombie process when launching preferences (LP: #936332)
  * Only appear in gnome-screen-saver if onboard was running (LP: #938302)
  * Don't check for running Onboard if "Typing Assistant" is on (LP: #938302)
  * Fix potential encoding mismatches in exception handlers (LP #958385)
  * Fix idle transparency kicking in while typing into firefox awesomebar
  * Change spelling of the unity property to ONSCREEN_KEYBOARD
  * Properly set up WM_CLASS to be above dash (LP: 915250, LP: #931331)
  * Switch window property to type XA_CARDINAL for compiz
  * Release all keys before quitting Onboard (LP #978430)
  * Simplify opacity transitions to fix some transparency glitches
  * Stop blocking the unity launcher icon for some seconds after each click
  * Skip transition delays on screens without compositing
  * Suppress python error messages when stdin or stderr are lost
  * Fix glitches when toggling force-to-top mode or decoration
  * Don't flash the icon palette in lightdm
  * Don't create the icon palette when embedding
  * Improve robustness of showing/hiding the icon palette on startup
  * Keep keyboard and icon palette above unity-2d dash
  * Don't get resized by compiz grid plugin
  * Try to honor rotating screens in gnome-shell
  * Use deiconify for metacity when minimized by titlebar
  * Remove wnck dependency as gtk3's window-state-event reports iconification
  * Don't save window position for maximized or iconified windows
  * Stop endless loop of auto-showing and hiding hiding onboard in dash
  * Fix visibility of active modifier keys in scanning mode
  * Make sure to remove the maximize button on recreating the keyboard window
  * Don't try to hide keyboard when turning on force-to-top while iconified
  * Switch all translated strings to unicode (LP: #933030)
  * Improve robustness against errors in translations (LP: 968044)
  * Import translations from the Ubuntu Translators team as of 6th May 2012
  * Fix geometries not being saved when exiting from the very first launch
  * Briefly present the keyboard when unhiding
  * Add middle click in hover click mode; requires mousetweaks >= 3.3.90
  * Make improvements in Onboard's...

Read more...

Changed in onboard (Ubuntu):
status: Confirmed → Fix Released
Beowulf (s-highlander) wrote :

I confirm that the bug has been fixed in 0.97.1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions