UIFe: Onboard (on-screen keyboard) does not use Ubuntu interface font or colours

Bug #768583 reported by Paul Sladen on 2011-04-21
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Wishlist
Unassigned
Onboard
Undecided
Unassigned
onboard (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: onboard

The default on-screen keyboard (used for a11y and tablets) in Ubuntu does not use the Ubuntu interface font or theme colours.

  http://people.ubuntu.com/~alanbell/unityvirtualbox.png
  http://www.theopensourcerer.com/2011/04/21/ubuntu-natty-in-virtualbox-with-unity/

Think that's everything covered:

  1. +1 from A11y/Charlie/Penelope as it improves the contrast and colours (comment #4 and comment #8)
  2. +1 from Jim/Ubuntu Docs as there is no Onboard documentation/screenshots (comment #7)
  3. +1 from Ivanka/Ayatana/Design/ (IRC logs in comment #3)

Related branches

Paul Sladen (sladen) on 2011-04-21
summary: - Onboard (on-screen keyboard) does not use Ubuntu interface font or
+ UIFe: Onboard (on-screen keyboard) does not use Ubuntu interface font or
colours
Changed in onboard (Ubuntu):
milestone: none → ubuntu-11.04
Changed in ayatana-design:
milestone: none → release
Changed in onboard (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Changed in ayatana-design:
status: New → Fix Committed
importance: Undecided → Wishlist
Changed in onboard:
status: New → Confirmed
Alan Bell (alanbell) wrote :

discussion in accessibility IRC channel with Ivanka from the design team
http://irclogs.ubuntu.com/2011/04/07/%23ubuntu-accessibility.html#t09:23

Paul Sladen (sladen) wrote :

Ooops, seems I ended up duplicating the original bug from two weeks ago! (Guess the right people just didn't get subscribed!).

Signed off by Ivanka two weeks ago:

  http://irclogs.ubuntu.com/2011/04/07/%23ubuntu-accessibility.html#t09:38
  <ivanka> AlanBell: makes a lot of sense but to warn you, UI exceptions are getting harder and harder.
  <ivanka> AlanBell: that won't stop me trying though as this does look much much better.

description: updated
Charlie Kravetz (charlie-tca) wrote :

The contrasts and letters used in this scheme do make the Onboard Keyboard easier to see. From a visual impairment view, this should make Onboard more useful to the Ubuntu community. As a user who can not always distinguish letters and numbers due to the design, this is a step in the right direction. The contrasts on the keys themselves make the most used keys easier to see.

Alan Bell (alanbell) wrote :

The colours are tones of the correct aubergine and orange colours with #dd4814 as the keycap border colour. The highest contrast keys are the main keys followed by the number keys. Boldest colours are on shift and space as they don't need contrast. Image was checked with a variety of visually impaired users in #ubuntu-accessibility and gnome #a11y channels.

Jim Campbell (jwcampbell) wrote :

At the moment we don't have any documentation about Onboard (we have some about Orca, but those docs need a bit of updating) so this proposed merge is fine by the Ubuntu Docs team.

Penelope Stowe (pendulum) wrote :

I love anything that makes a accessibility program look more like it belongs within Ubuntu.

As well, the colours and contrast are much improved from the previous colours for onBoard.

Paul Sladen (sladen) wrote :

Jim: per your reply about the /lack/ of documentation, I've filed bug #768602 ('Does not contain any a11y/tablet computer documentation about Onboard, the default on-screen keyboard') while we're at it!

description: updated
tags: added: a11y
Francesco Fumanti (frafu) wrote :

In reply to comment #1 and the references to Caribou (It is a bit of topic, but since people of the a11y team are watching this thread, I think it is worth mentioning it):

Onboard does not need at-spi in order to work; but I think Caribou depends on it. I don't know whether at-spi2 solves the problems of at-spi (for example, opening /usr/bin in nautilus takes very long; under some circumstances there was something like a lock (I don't remember the details from the top of my head),...), but I think for a simple onscreen keyboard like onboard, not depending on at-spi is a good thing.

In fact, I wonder whether we should not consider two categories of onscreen keyboard users:

- Those that can control the pointer that only requires a simple onscreen keyboard like onboard.

- Those that access the computer with switches and that probably need a more sophisticated onscreen keyboard like gok (or I suppose Caribou, once it is completed), that is able to grab elements of the active application and duplicate them in the gok interface to make them accessible to the user.

Alan Bell (alanbell) wrote :

@Francesco, yes, totally valid points. I will be looking at Caribou and there are known bugs with on screen keyboards and both unity and gnome shell, however, this specific bug is about getting onboard which is already in Natty to look like it belongs, what we do for Oneiric is up for discussion and I would encourage you to participate in the relevant sessions at UDS in a few weeks.

marmuta (marmuta) on 2011-04-27
Changed in onboard:
status: Confirmed → In Progress
Changed in onboard (Ubuntu):
milestone: ubuntu-11.04 → natty-updates
marmuta (marmuta) wrote :

Onboard main has support for themes now. There is an Ambiance theme included based on Alan Bells design. The system wide default theme can be specified in a new configuration file onboard-defaults.conf (see sample file in the project root).
Have a look and let me know if you want to see any changes.

Changed in onboard:
status: In Progress → Fix Committed
Francesco Fumanti (frafu) wrote :

Onboard 0.95.0 has been released and it contains among others the changes that marmuta announced in comment 11 of this thread.

Remark:
Onboard uses distutils-extra and version 2.26 currently shipping with natty has a bug that breaks the building of the debian package of Onboard. The distutils-extra bug is fixed in version 2.28 that is currently shipping in oneiric. Thus, unless the fixed version of distutils-extra is backported to natty, onboard cannot be built on a current standard natty installation.

Charlie Kravetz (charlie-tca) wrote :

The normal procedure to get the fix into the previous versions of Ubuntu is:
Please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in onboard:
status: Fix Committed → Fix Released
Changed in onboard:
status: Fix Released → Fix Committed
Francesco Fumanti (frafu) wrote :
Francesco Fumanti (frafu) wrote :

You can find the new version of Onboard that among others includes this bug fix in my PPA for Ubuntu Natty:
https://launchpad.net/~frafu/+archive/ppa

I am writing this here in case you might want to try the new release.

Changed in onboard (Ubuntu):
status: Triaged → Fix Released
Changed in onboard:
status: Fix Committed → Fix Released
Changed in ayatana-design:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers