Comment 8 for bug 1612367

Pat McGowan (pat-mcgowan) wrote :

The log does show that on the first call the playback started and then paused within less than a few tenths of a second but did not stop for 6 seconds. The second call did not pause for 5 seconds and then immediately stopped. Presumably the status went to stopped when the call was answered.

[II 2016-08-31 06:31:04.883664] [player_implementation.cpp:193@operator()] Emiting playback_status_changed signal: PlaybackStatus::playing
[II 2016-08-31 06:31:05.032598] [player_implementation.cpp:193@operator()] Emiting playback_status_changed signal: PlaybackStatus::paused
[II 2016-08-31 06:31:05.038372] [player_implementation.cpp:193@operator()] Emiting playback_status_changed signal: PlaybackStatus::paused
[II 2016-08-31 06:31:05.059649] [player_implementation.cpp:193@operator()] Emiting playback_status_changed signal: PlaybackStatus::paused
[II 2016-08-31 06:31:11.386511] [player_implementation.cpp:193@operator()] Emiting playback_status_changed signal: PlaybackStatus::paused
[II 2016-08-31 06:31:11.398468] [player_implementation.cpp:193@operator()] Emiting playback_status_changed signal: PlaybackStatus::stopped

Does this indicate there are multiple threads running that should not? Many of the log messages are repeated in seemingly random ways. For example the second call reported this three times in a few 100ths, whereas normally its once. I see the same in my logs.

[II 2016-08-31 06:46:24.320900] [engine.cpp:442@play] Engine: playing uri: file:///home/phablet/.local/share/ubuntu-system-settings/Music/Auld%20Lang%20Syne.ogg
[II 2016-08-31 06:46:24.341765] [engine.cpp:442@play] Engine: playing uri: file:///home/phablet/.local/share/ubuntu-system-settings/Music/Auld%20Lang%20Syne.ogg
[II 2016-08-31 06:46:24.356592] [engine.cpp:442@play] Engine: playing uri: file:///home/phablet/.local/share/ubuntu-system-settings/Music/Auld%20Lang%20Syne.ogg