ofono-scripts must be ported to python3

Bug #1283571 reported by Dimitri John Ledkov on 2014-02-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ofono (Ubuntu)
High
Martin Pitt

Bug Description

ofono-scripts must be ported to python3

Related branches

Changed in ofono (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Dimitri John Ledkov (xnox) wrote :

or be removed from the ubuntu-touch seed, which i have now proposed.

Martin Pitt (pitti) on 2014-02-25
Changed in ofono (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

For the record, I did the porting and tested most of the scripts. I sent the patches to <email address hidden>, unfortunately there is no proper bug tracker for ofono ATM.

Tony Espy (awe) wrote :

I'd prefer if these scripts weren't removed as default, as they're very useful for debugging ofono problems and I quite frequently ask people to use them when diagnosing telephony issues. Also, if we get the cycles they could also be valuable for ofono specific bug reporting.

Is there a mandate to remove all such tools from our images?

Tony Espy (awe) wrote :

Sorry that comment should've landed in the merge proposal.

Martin's Python 3 changes have been fully reviewed, tested, and merged into our github repository:

https://github.com/rilmodem/ofono

I will work on putting together a merge proposal to land this in the archive version of ofono.

On 26 February 2014 19:48, Tony Espy <email address hidden> wrote:
> Sorry that comment should've landed in the merge proposal.
>
> Martin's Python 3 changes have been fully reviewed, tested, and merged
> into our github repository:
>
> https://github.com/rilmodem/ofono
>
> I will work on putting together a merge proposal to land this in the
> archive version of ofono.
>

Excellent. Thanks a lot to you and Martin. Please reference this bug
report in the merge-proposal / landing to notify all interested
parties.

--
Regards,

Dimitri.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ofono - 1.12+bzr6856-0ubuntu1

---------------
ofono (1.12+bzr6856-0ubuntu1) trusty; urgency=low

  [ Tony Espy ]
  * unit: fix fail-to-build on powerpc
    The previously released version enabled -Wall,
    which triggered build failures due to unused
    functions on powerpc. This is due to the fact
    that the unit tests only run on LITTLE_ENDIAN
    systems via an ifdef, which leaves unused functions
    and data. This change exends the ifdef to cover
    the unused functions and test data.
  * idmap: use UL for bitshift literals (LP: #1271284)
    This change fixes a failing unit test on ppc64le
    due to the undefined behavior when the left bitshift
    operator is given a value that excedes the size of
    the value being shifted.
  * gril, rilmodem/sim, unit: fix SIM IO crash (LP: #1268743)
    - cleanup gril_reply_parse_sim_io() to add malformed parcel
      check and fix memory leak.
    - add check for null hex_response in ril_file_io_cb(), as
      the emulator can return such responses.
    - add additional unit tests to cover crash scenarios.
  * ril, src: enable message-waiting-interface
    - register message_waiting atom in ril plugin
    - register message_waiting atom in ril plugin
    - fix sms_mwi_dcs_decode bug which prevented incoming message
      waiting indications from being set.
  * rilmodem/voicecall: fix call-decline bug (LP: #1260988)
    Send a RIL_REQUEST_HANGUP_WAITING_OR_BACKGROUND instead of
    was used correctly for displaying operator name, however
    some modems failed to handle roaming correctly for MVNOs.
    This fix is transparent to modems that do the right thing.
  * gril/gril.c, plugins/ril.c: API changes for OEMS
    This change introduces a socket-path to the g_ril_new()
    function, and also adds a new disconnect function.
  * gril/grilunsol.c: add support for v5 signal strength message
  * debian/control: adjust ofono-scripts dependencies for Python 3
  * test/rilmodem: add copyright/license headers

  [ Martin Pitt ]
  * test: convert tests scripts to Python 3 (LP: #1283571)
 -- Ricardo Salveti de Araujo <email address hidden> Fri, 28 Feb 2014 17:50:54 -0300

Changed in ofono (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) wrote :
Changed in ofono (Ubuntu):
status: Fix Released → Fix Committed
Changed in ofono (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers