Karmic: please do NOT synchronize following packages

Bug #387943 reported by David MENTRÉ
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ocaml (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ocaml

Hello,

Could you stop importing in Karmic the source packages listed in the attached document? It is to avoid starting transition to OCaml 3.11.1 in Karmic.

Context: https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2009-June/008704.html

Sincerely yours,
david

Revision history for this message
David MENTRÉ (dmentre) wrote :
Revision history for this message
Iain Lane (laney) wrote :

I'm interested in why you feel this cannot be done for Karmic. There is still a fairly long time[0] before the first major freeze (FeatureFreeze), and blacklisting a whole swathe of packages from being synced seems a rather heavyweight solution. Is there no realistic chance that this will be done in sid in time?

[0] https://wiki.ubuntu.com/KarmicReleaseSchedule

Revision history for this message
David MENTRÉ (dmentre) wrote : Re: [Bug 387943] Re: Karmic: please do NOT synchronize following packages

Hello Iain,

On Tue, Jun 16, 2009 at 16:48, Iain Lane<email address hidden> wrote:
> I'm interested in why you feel this cannot be done for Karmic.

I'm not saying it cannot be done but *I* cannot commit to do it over
this time period. As I am the only one, as far as I know, to care
about this I don't want to commit to things that I cannot provide.

Of course, I would be very glad to have OCaml 3.11.1 in Karmic and I
will help any people that would like to do it.

I plan to follow that transition in Debian and maybe provide those
packages through other means (PPA?).

I admit this decision is a pretty conservative one and I am open to
any discussion about it.

Yours,
d.

Revision history for this message
Iain Lane (laney) wrote : Re: [Bug 387943] Re: Karmic: please do NOT synchronize following packages

Hi,

Thanks for caring for this set of packages.

On 16 Jun 2009, at 16:05, David MENTRÉ wrote:

> ...
> I'm not saying it cannot be done but *I* cannot commit to do it over
> this time period. As I am the only one, as far as I know, to care
> about this I don't want to commit to things that I cannot provide.
>
> Of course, I would be very glad to have OCaml 3.11.1 in Karmic and I
> will help any people that would like to do it.
>
> I plan to follow that transition in Debian and maybe provide those
> packages through other means (PPA?).

Does the Debian team have any estimate of how long the transition is
likely to take? Once you have this time estimate, it might be worth
discussing with the motu-release team members whether they feel it's a
good idea or not to proceed.

I strongly suspect that if you put out a call for volunteers on the
mailing list and provided regular status updates then you'd be
surprised about how quickly things manage to get done on our side.
It's been my experience in the past that people are quite willing to
step up and get such tasks done.

Regards,
Iain
This message has been checked for viruses but the contents of an attachment
may still contain software viruses, which could damage your computer system:
you are advised to perform your own checks. Email communications with the
University of Nottingham may be monitored as permitted by UK legislation.

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Hi David,

Does Debian have a time table they are looking at to transition to 3.11.1? Looking at the comparison between unstable and Karmic [1], only a handful of packages seem to have Ubuntu local changes. OCaml Task Force transition page doesn't seem to mention a time frame. [2] As Iain notes above, we're still fairly far out from Karmic's release.

Thanks for all your work on this!

 - Andrew

[1] https://bentobako.org/ubuntu-ocaml-status/raw/compare-unstable-karmic.html
[2] http://wiki.debian.org/Teams/OCamlTaskForce/OCamlTransitions

Revision history for this message
David MENTRÉ (dmentre) wrote : Re: [Bug 387943] Re: Karmic: please do NOT synchronize following packages

On Tue, Jun 16, 2009 at 17:28, Iain Lane<email address hidden> wrote:
> Does the Debian team have any estimate of how long the transition is
> likely to take?

Last transition took 1.5 months but it was a bigger one than this:
  http://lists.debian.org/debian-ocaml-maint/2009/06/msg00105.html

> Once you have this time estimate, it might be worth
> discussing with the motu-release team members whether they feel it's a
> good idea or not to proceed.

Where do you "discuss with the motu-release team members"? On
ubuntu-motu@ mailing list?

> I strongly suspect that if you put out a call for volunteers on the
> mailing list and provided regular status updates then you'd be
> surprised about how quickly things manage to get done on our side.
> It's been my experience in the past that people are quite willing to
> step up and get such tasks done.

I think that is more or less what I have in mind:
* block for now Karmic and follow the transition in Debian unstable;
* once the transition is done in Unstable, decide if all packages
should be imported & rebuilt in Karmic or not.

My main issue with the transition is that there is now way to
backtrack if things go wrong. Once ocaml 3.11.1 source package is
imported in karmic, *all* other packages should be rebuilt and they
should build successfully or dropped. There are about 246 binary
packages to track.

Yours,
d.

Revision history for this message
David MENTRÉ (dmentre) wrote : Re: [Bug 387943] Re: Karmic: please do NOT synchronize following packages

Hello Andrew,

Andrew Starr-Bochicchio <email address hidden> writes:

> Does Debian have a time table they are looking at to transition to
> 3.11.1?

Sorry, no precise time table except that it took 1.5 months for the last
transition.

> Looking at the comparison between unstable and Karmic [1], only
> a handful of packages seem to have Ubuntu local changes.

Yes, Ubuntu specific changes are limited to 3 packages:
   1. graphviz: g/graphviz/graphviz_2.20.2-3ubuntu3.patch
   2. lablgtk2: l/lablgtk2/lablgtk2_2.12.0-2ubuntu1.patch
   3. ocaml-bjack: o/ocaml-bjack/ocaml-bjack_0.1.2-1ubuntu1.patch

Source: http://bentobako.org/ubuntu-ocaml-status/raw/ubuntu-patches.html

Sincerely yours,
d.
--
GPG/PGP key: A3AD7A2A -- <email address hidden>
 5996 CC46 4612 9CA4 3562 D7AC 6C67 9E96 A3AD 7A2A

Revision history for this message
Colin Watson (cjwatson) wrote :

A blacklist is easy to install and easy to remove; a transition somewhat less so - so I've no objection to blacklisting these for the time being, and have done so. If you want this undone following discussion, just let us know.

Changed in ocaml (Ubuntu):
status: New → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :

FWIW the current sync blacklist is here: http://people.ubuntu.com/~ubuntu-archive/sync-blacklist.txt

Revision history for this message
David MENTRÉ (dmentre) wrote : Re: [Bug 387943] Re: Karmic: please do NOT synchronize following packages

Hello Colin,

Thank you for the sync-blacklist. I have read your remark regarding
the ability to change that in a near future.

On Tue, Jun 16, 2009 at 18:29, Colin Watson<email address hidden> wrote:
> FWIW the current sync blacklist is here: http://people.ubuntu.com
> /~ubuntu-archive/sync-blacklist.txt

That's useful, thanks.

Yours,
d.

Revision history for this message
Steve Kowalik (stevenk) wrote :

Surely unilaterally blocking updates to a large number of source packages is just going to make other transitions harder? For example, the librpm4.4 -> librpm0 is now blocked by this.

Revision history for this message
David MENTRÉ (dmentre) wrote :

Hello Steve,

2009/7/20 Steve Kowalik <email address hidden>:
> Surely unilaterally blocking updates to a large number of source
> packages is just going to make other transitions harder? For example,
> the librpm4.4 -> librpm0 is now blocked by this.

This blocking was discussed on ubuntu-devel-discuss@. Should I have
warned on other mailing list?

Which ocaml package is blocking librpm transition?

Sincerely yours,
david

Revision history for this message
David MENTRÉ (dmentre) wrote :

Hello,

Please cancel all sync-blacklist for ocaml related packages to allow transition to 3.11.1 in Karmic.

Bug re-opened following Laney suggestion on #ubuntu-motu.

Yours,
d?

Changed in ocaml (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Steve Kowalik (stevenk) wrote :

Since we are now past Debian Import Freeze, you will need to file sync requests to have the packages updated in Karmic. If they have no Ubuntu changes just listing the packages is fine, but we will require a list.

Revision history for this message
David MENTRÉ (dmentre) wrote :

Hello Steve,

2009/7/23 Steve Kowalik <email address hidden>:
> Since we are now past Debian Import Freeze, you will need to file sync
> requests to have the packages updated in Karmic.

I already, filed such a sync request for the first round of the transition:
  https://bugs.launchpad.net/ubuntu/+source/ocaml/+bug/402710

I also provided the complete list of packages to synchronize, to
rebuild or to manually check for Ubuntu changes:
  https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2009-July/009088.html

I need to have the first round finished before fulfilling the sync
requests for the other rounds.

It is Iain Lane that suggested to remove the sync-blacklist on OCaml
packages (on both IRC #ubuntu-motu and
https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2009-July/009084.html).
Andrea Gasparini on LP bug #402710 had the same opinion. I followed
their advices. I don't know much more than that. More specifically, I
don't know if the sync-blacklist.txt blocks a sync request or not.

Scott Kitterman approved the whole transition:
  https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2009-July/009093.html

Sincerely yours,
david

Revision history for this message
Steve Kowalik (stevenk) wrote :

I have unblacklisted the packages.

Changed in ocaml (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
David MENTRÉ (dmentre) wrote :

2009/7/24 Steve Kowalik <email address hidden>:
> I have unblacklisted the packages.

Many thanks Steve!

Yours,
d.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers