Ubuntu

No file transfers possible with cell phones, regression since oneiric alpha

Reported by Felix on 2011-10-22
586
This bug affects 129 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
James M. Leddy
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned
obexd (Ubuntu)
High
Mathieu Trudel-Lapierre
Oneiric
High
Mathieu Trudel-Lapierre
Precise
High
Mathieu Trudel-Lapierre
obex-data-server (Ubuntu)
Undecided
Unassigned
Oneiric
High
Unassigned
Precise
Undecided
Unassigned

Bug Description

Since i upgraded to oneiric (alpha3) my laptop isn't able to send/receive files from mycell phone anymore. Deleting the cellphone and pairing it again doesn't help.

In addition my cellphone won't find my laptop (laptop's bluetooth is set to "visible"). So pairing only works when initiated by the laptop.

Please let me know which debug information you need.

(I am not the only one: http://ubuntuforums.org/showthread.php?t=1861725 )

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-bluetooth 3.2.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-13.21-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Sat Oct 22 16:00:42 2011
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
SourcePackage: gnome-bluetooth
UpgradeStatus: Upgraded to oneiric on 2011-09-29 (23 days ago)

Related branches

Felix (apoapo) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Mads Juul (madsjuulanimation) wrote :

When trying to browse I get this message

Felix (apoapo) wrote :

From time to time the phone gets "mounted" so that it is listed in the directory list of nautilus. While trying to access it this error occurs:

DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)

My bluetooth can't send anything to my cellphone anymore since upgrading to oneiric... :(

karel tucek (kareltucek) wrote :

exactly the same problem on Xubuntu, so I guess that the problem is not in gnome-bluetooth package

Felix (apoapo) wrote :

I guess it is the obex service itself because it also happens with other managers as confirmed from post before.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in obex-data-server (Ubuntu):
status: New → Confirmed
tags: added: i386
Pedro Villavicencio (pedro) wrote :

Thanks for the report, could you please attach your /var/log/messages to the report after reproduced the issue? Thanks.

Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Felix (apoapo) wrote :

Syslog reads:

Oct 25 21:35:44 laptop-a obex-data-server: sdp_extract_seqtype: Unexpected end of packet

My /var/log/messages is empty and stays empty.

 when browse file is selected from bluetooth menu device name appears in the side bar of file manager but on selecting it a dialog box appears with error
" DBus error org.freedesktop.DBus.Error.ServiceUnknown: The name :1.128 was not provided by any .service files. please select another viewer and try again." appears . Although send file and Internet connection over blue-tooth is working but receive file and browser file is not working.

was able to receive file from other devices by activating 'Receive files over bluethooth ' in personal file sharing pref.
but still not able to browse files over bluetooth . i suppose problem is with the file manager.

Same problem here, I posted in another bug report too...

This is what is giving me while pairing my mobile phone:
Oct 28 09:23:26 simone-ThinkPad-T400 bluetoothd[1266]: Discovery session 0x22902cd8 with :1.121 activated
Oct 28 09:23:34 simone-ThinkPad-T400 bluetoothd[1266]: Stopping discovery
Oct 28 09:23:47 simone-ThinkPad-T400 bluetoothd[1266]: input-headset driver probe failed for device 00:1C:35:AA:A7:5F

And this is what happen when I try to browse:
Oct 28 10:24:40 simone-ThinkPad-T400 obex-data-server: sdp_extract_seqtype: Unexpected end of packet

This bug is terribly similar to the GVFS related bug I had once I tried to upgrade my libimobiledevice on my 10.04 Lucid installation. At the time, I upgraded an iPhone OS and wasn't unable to connect anymore. Found a fix for the library, but it required to upgrade also GVFS. After I did, I got exactly that problem and that error. Seems a "reincarnated" bug...

Ubuntu 11.10 32 bits
Lenovo T400 laptop
Kernel 3.0.12

And I am able to send/receive files manually too, just the browse function doesn't work.

I have the same problem on ubuntu 11.10

 I can transfer files but browse does not work.

Lucazade (lucazade) wrote :

I'm able only to send files from pc to phone but I can't browse files on the mobile device

Rafael P. (rafael-p) wrote :

I cannot send, receive files or browse files. The "browse" button in the window appearing from the "Browse files on device..." line in the applet menu (notification area) makes the applet crash.

Terminal displays:

(bluetooth-applet:3767): GLib-GObject-WARNING **: invalid uninstantiatable type `(null)' in cast to `BluetoothChooser'

(bluetooth-applet:3767): GLib-GObject-WARNING **: instance of invalid non-instantiatable type `(null)'
Segmentation fault

I also report a graphical bug on the device list in the appearing window (see attached screenshot)

Very naughty buggy applet ...

Changed in gnome-bluetooth (Ubuntu):
status: Incomplete → Confirmed

Hello Guys, are you going to do something about this ? Need any help with it ? Is pretty much embarassing... For me personally, I cannot mount my phone or any other devices over Bluetooth, so even Gammu is not working (to backup phone data), and have to resort back to 1920s USB cable connection.

Downloaded daily build of 12.04 LTS today and much to my disappointment I can see that the bug is still there, rendering Bluetooth almost totally useless. Tried to report the bug but ubuntu-bug failed with an error message... oh well...

Forgot to mention: the interface of Bluetooth is totally useless, after mounting the device the list is about 2 pixels high, rendering impossibile to pick the device for browsing (both in 11.10 and 12.04...).

teodor_kasap (erol-erten) wrote :

Hi all,
Simone's comments are true.
Furthermore the devices can pair but cannot exchange files (send-receive), and the browsing files does not work either.

Peco (peco) wrote :

Hi,
Same issue here.
Fresh install of Ubuntu 11.10
Dongle Belkin Components B8T017 Bluetooth+EDR 2.1

Phone and Headset don't work anymore.
Dec 2 20:28:06 xx bluetoothd[11729]: Adapter /org/bluez/11729/hci0 has been enabled
Dec 2 20:28:31 xx bluetoothd[11729]: Permission denied (13)
Dec 2 20:28:31 xx bluetoothd[11729]: Unable to get service record: Permission denied (13)
Dec 2 20:28:33 xx bluetoothd[11729]: Permission denied (13)

Felix (apoapo) wrote :

Does anyone know if there is a upstream bug already reported? Is this actually upstream?

I wonder how this can't be noticed. I expect every Ubuntu user to fail with bluetooth file transfers right now. This must have some echo?

Peco (peco) wrote :

IMHO, the bluetooth is a general issue from Ubuntu (11.10+).
Issues sending files, issues paring Headsets, mouses and keyboards, issues installing different stacks and applications (bluez, blueman, etc) and now a big mess when you want to look for a solution or a workaround.
Again, IMHO, Bluetooth is not a bug with a "medium importance", at this point is critical due that it affects the overall look&feel of Ubuntu.

Atcold (atcold) wrote :

I do quote Peco. IMHO this is a definitely critical problem of the OS. It is so critical, for me, that I am back to Windows!

Felix (apoapo) wrote :

I totally agree. I cannot convince anyone about the ubuntu feeling when they realize they won't be able to use their bluetooth. It is a standard, nothing new, just a must-have for every device.

It is definitly critical. Maybe Ubuntu should start adding a "why did you uninstall ubuntu?" survey.. Bluetooth will be at least 2 times in there from what i know, plus Atcold ;)

Rafael P. (rafael-p) wrote :

plus me...

kanhiya (kanhiya78) wrote :

On the top of bug status , it is written that it is of medium priority, I am saying that people who use bluetooth in daily task like headset, Dial up Networking , file transfer etc.

When they are not able to even use it, why they will use Ubuntu?

I was having no problem with Bluetooth before Ubuntu 11.10, Canonical is saying that we are getting better with every release, I am wondering that even devices like Bluetooth and wireless are not working or causing problems , how they are getting better?

They should change the code if something is causing problems, but if one thing is running well than there is no need to update or change the code. :)

Ubuntu should do a survey , why do u like Windows and why don't like Ubuntu & Vice versa.

Only on the basis of virus free and looks , they will not be able to compete with Windows.

Most of people believe in stability and peace of mind, which is not here :),

Also, Ubuntu should release one distro update a year, so that it can be tested well and or release only LTS.

A patch is being provided by Community member, check out this link

https://bugs.launchpad.net/bugs/872044/+attachment/2623321/+files/obexd.diff

Atcold (atcold) wrote :

Ok, is there any instruction about how to run this patch?
Do I simply run "patch -b -p0 obexd.diff"? It does not seem to work...

Tuomas Lähteenmäki (lahtis) wrote :

i have same OBEX error messages in my upgraded 10.04 LTS distro.

But when im a tested this 10.04 LIVE CD and not installed any packages and updates.
There are not this OBEX errors and im get files (images) my phones. Why this live distro working ????
my phones are Nokia 2720a-2.

When im tested this 11.10 LIVE CD im get this same OBEX error messages.

Atcold (atcold) wrote :

Because what causes this error is an update present in the 10.10 Ubuntu version...

Atcold (atcold) wrote :

Actually, it should be related with the kernel version. Anyway, they've updated it right now; let's see if it has been fixed!

Changed in gnome-bluetooth (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Medium → High
Sebastien Bacher (seb128) wrote :

Hey everybody, sorry that this bug got "ignored" for a while, there is just too much traffic on launchpad and it's hard to read everything coming, the bug is targetted for precise, set to high and assigned to the desktop team so it should be on track

the issue from comment #19 has been fixed today thanks to Mathieu:

gnome-bluetooth (3.2.1-1ubuntu2) precise; urgency=low

  * debian/patches/fix_browse_devices_selector.patch: use gtk_pack_start()
    rather than gtk_container_add() to add the bluetooth chooser widget,
    as it's already done elsewhere, to make sure it's visible. (LP: #829703)

The bug seems to mix several issues. Browsing a bluetooth device over gvfs,nautilus is known to be broken (upstream said they would drop the feature this cycle if not fixed in a blog post recently)

The issue this bug is tracking is "can't receive files from a phone", if you have other issues please open another bug (check before if that one is not reported already though)

Did somebody try to boot a 11.04 kernel on 11.10 and see if that solve the issue?

Atcold (atcold) wrote :

I know someone did the opposite: he just update the 11.04 kernel to the 11.10 and the BT started to do not work properly.

Felix (apoapo) wrote :

With kernel:

Linux laptop-a 3.0.0-15-generic #24-Ubuntu SMP Mon Dec 12 15:23:55 UTC 2011 x86_64 x86_64 x86_64 GNU/Linu

I am ableto transfer a file from my phone to the pc again. Further tests not done yet.

Atcold (atcold) wrote :

To update the kernel do I have to simply select "Pre-released updates" from the Repositories menu of Synaptic, and hence select the linux-image-3.0.0-15-generic package and thus clicking on Apply?
Thanks

Changed in oem-priority:
status: New → Confirmed
importance: Undecided → Critical
Changed in oem-priority:
assignee: nobody → Pedro Villavicencio (pvillavi)
newbe (theodor-zoller) wrote :

hello everybody,

I still have this Probleme, too. I can't send or recive any data from or to my smartphone.
In an forum I've found, that in hcid.conf the device-class should be set to 0x100100. On my system it is set to 0xa40100. For more Information see my Post hier:
http://forum.ubuntuusers.de/topic/keine-bluetoothverbindung-moeglich/

Hope You're able to fix thsi soon.

newbe

Ara Pulido (apulido) on 2012-01-04
Changed in gnome-bluetooth (Ubuntu Oneiric):
status: New → Confirmed
Changed in obex-data-server (Ubuntu Oneiric):
status: New → Confirmed
Changed in gnome-bluetooth (Ubuntu Oneiric):
importance: Undecided → High
Changed in obex-data-server (Ubuntu Oneiric):
importance: Undecided → High

I really should have claimed this some time ago already, so I'll go ahead and change the assignee to me instead of Canonical Desktop team.

Changed in gnome-bluetooth (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in gnome-bluetooth (Ubuntu Oneiric):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

Changing the gnome-bluetooth target to obexd: to me, things look really rather fine with gnome-bluetooth; no change needed locally to fix any of the issues (except for the browse dialog which is too small, fixed elsewhere). *However*, I can simply update obexd to the latest upstream version to make sending and receiving files largely work.

The patch provided by "phcoder" in bug 872044 looks like it might work, but I wish it didn't just mean adding a delay. Regardless, it will need testing now.

affects: gnome-bluetooth (Ubuntu Oneiric) → obexd (Ubuntu Oneiric)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package obexd - 0.43-0ubuntu1

---------------
obexd (0.43-0ubuntu1) precise; urgency=low

  * New upstream release. (LP: #879923)
  * debian/control: drop libopenobex1 from Build-Depends, it's no longer needed
    and replaced by gobex (in source).
 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 05 Jan 2012 17:33:25 -0500

Changed in obexd (Ubuntu Precise):
status: Confirmed → Fix Released
Jane Atkinson (irihapeti) wrote :

I can pair my phone, send and receive files, but still can't browse it.

If I try using Blueman, I get the following error message.

---
Could not display "obex://[(BT_address)]/".

Error: DBus error org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Please select another viewer and try again.
---

Is this part of the same bug, or should I open a new one?

Ubuntu version is precise alpha1, 3.2.0-8-generic #14-Ubuntu SMP Fri Jan 6 01:55:11 UTC 2012 i686 i686 i386 GNU/Linux

Albert Pool (albertpool) wrote :

I also can't receive files from another laptop, running Linux Mint 11. I'm using Mint 12. Not yet tried it the other way round.

Both laptops have 03f0:171d Hewlett-Packard Bluetooth 2.0 Interface [Broadcom BCM2045] and run 64-bit Linux.

James M. Leddy (jm-leddy) wrote :

Hi Albert, would you please provide your system log as well as the error you get from the application? Is it the same error that Jane gets?

Could not display "obex://[(BT_address)]/".

Please, I do think we have enough information and all that's needed is for the work to be done to integrate patches and test this properly. The bug can be reproduced sufficiently reliably at this point.

For bluetooth browsing, please file a separate bug. It tends to be handled by sufficiently different applications -- please file it under "gvfs", or better: use "ubuntu-bug gvfs" to report the bug.

James M. Leddy (jm-leddy) wrote :

Okay, sorry about that, I had only given a cursory glance at the bug before posting.

Changed in oem-priority:
assignee: Pedro Villavicencio (pvillavi) → Ursula Junque (ursinha)
bwanamarko (bwanamarko) wrote :

I also had the same issues: My rooted Android HTC Inc phone (rom: CM7 s-off) would not pair from phone initially, it would timeout ( in about 2 seconds) and with an error, but if I entered any pin fast enough it could pair. Also I could pair manually with hcitool or bluez-simple-agent; (2) pairing from linuxbox work only twice, but usually would spin indefinately, although my phone was "discoverable" sometimes hcitool would not find my phone, but restarting bluetooth (from unity or cli) always fixed this; (3) once paired I could not send or recieve files, (4) the browse files on device does not let me select any devices and the box of devices is still squashed flat.

The fix in bug #872044 comments #14 #22 #35 #36 check personal file sharing (gnome-user-share) worked for me. I had to use the dash to find it. Then suddenly the set up new device worked (although I had just paired and removed it manually with hcitool, which is the only other time the gnome-bluetooth wizard worked, so...), and now I can successfully send and receive files.

The updates have not fixed the squashed box in browse files or browsing. If personal file sharing for bluetooth is required, then this should automatically be enabled during setup of a new bluetooth device, or at least the user should be notified and a link to this setting should be in the bluetooth section of system settings (a unity problem), and also in that the browse device feature is not working.

I will look for a separate bug for browsing files on my phone. Thanks.

Tim Chen (ctf) on 2012-01-17
tags: added: lab-taipei
Ara Pulido (apulido) on 2012-01-17
tags: added: rls-mgr-p-tracking

There is already a bug opened for *Browse* problem only:
https://bugs.launchpad.net/ubuntu/+source/gvfs/+bug/899858

Please I kindly ask everyone to click on "This bug affects me" over that one, so that it can be confirmed and moved.

Mathieu Trudel-Lapierre: can you use that bug for the fix instead of opening a new one ?

Correct, browsing should be covered by that bug report (bug 899858).

For any other transfer issues, there appears to be a workaround which seems to work properly in general for more people:

sudo hciconfig hci0 sspmode 0

This does work on my end to allow file transfer to reach other devices. It was also needed for auth to succeed prior to getting to test OBEXFTP.

There's a kernel patch being discussed (or nearing inclusion) that should fix this, but in the meantime that hciconfig command does appear to work for nearly everyone.

Ruokoton (uborealis) wrote :

sudo hciconfig hci0 sspmode 0 isn't solution for me as it's (the sspmode) not supported by my Bluetooth chip.
I can pair the devices but all file transfers will fail regardless of direction. The connection will just timeout.

The Bluetooth HW is 0a5c:201e Broadcom Corp. IBM Integrated Bluetooth IV on a IBM Thinkpad X41.

Tested with Samsung Galaxy S (Android 2.3.7), ZTE Blade (Android 2.2), Huawei Ideos X5 (Android 2.2) and Nokia N82 (S60) - similar results for all.

I suspect this is HW specific as file transfer to / from desktop computer with external Bluetooth dongle (ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)) works ok with the same phones.

Mar 6 00:31:52 X41 bluetoothd[21676]: Stopping discovery
Mar 6 00:32:32 X41 bluetoothd[21676]: 98:F5:37:8B:DF:AA: error updating services: Connection timed out (110)
Mar 6 00:32:32 X41 kernel: [91110.846866] hci_link_tx_to: hci0 link tx timeout
Mar 6 00:32:32 X41 kernel: [91110.846874] hci_link_tx_to: hci0 killing stalled connection 98:F5:37:8B:DF:AA
Mar 6 00:32:32 X41 bluetoothd[21676]: 98:F5:37:8B:DF:AA: error updating services: Software caused connection abort (103)

That's typical log output for failed file transfer attempt.

I can do further tests if instructed.

Martin Pitt (pitti) on 2012-03-07
tags: added: rls-p-tracking
removed: rls-mgr-p-tracking
tags: added: rls-mgr-p-tracking
removed: rls-p-tracking
Changed in oem-priority:
assignee: Ursula Junque (ursinha) → James M. Leddy (jm-leddy)
Anthony Wong (anthonywong) wrote :

Should have been fixed in Precise by bug 872044.

James M. Leddy (jm-leddy) wrote :

Hi Anthony, is this bug fixed? What about the obex-data-server component of this bug?

Anthony Wong (anthonywong) wrote :

Hi James, I'm not sure about obex-data-server, for the file transfer problem, it is actually fixed in the linux kernel itself in bug 872044. And in my testing, both transfer from cellphone (android) to Ubuntu and Ubuntu to cellphone work.

Changed in oem-priority:
status: Confirmed → Fix Released

Indeed, this turns up not being an issue in obexd or obex-data-server but in the linux kernel, see bug 872044. I'll mark this bug as a duplicate of it now.

Tulasi (murtulasi) wrote :

I have oneiric32 and paired with Nokia N9. Pairing goes ok. But i cannot browse the N9 file system from oneiric using bluetooth. How to get this fixed ?

tester@yantram:~$ uname -a
Linux yantram 3.0.0-17-generic-pae #30-Ubuntu SMP Thu Mar 8 17:53:35 UTC 2012 i686 i686 i386 GNU/Linux
tester@yantram:~$

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers