Cannot receive or send files via bluetooth

Bug #822141 reported by Christian Niederreiter on 2011-08-07
92
This bug affects 19 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned

Bug Description

If I send a file from my phone to my computer as I always did successfully using 10.04, my phone says "not sent" and the file does not arrive on my computer. If I want to send a file from Nautilus, as I used to do successfully, now I get the message "permission denied 13" in nautilus. So neither receiving nor sending works any more. I tested both Oneiric and Natty, both are affected. Unfortunately, I am not able to execute sudo hcidump -XYt > $HOME/hci.log because hcidump is missing.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: bluez 4.96-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
Architecture: amd64
CasperVersion: 1.275
Date: Sun Aug 7 02:43:40 2011
InterestingModules: rfcomm bnep btusb bluetooth
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
MachineType: SAMSUNG ELECTRONICS CO., LTD. 90X3A
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
SourcePackage: bluez
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/20/2011
dmi.bios.vendor: Phoenix Technologies Ltd.
dmi.bios.version: 05HL
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 90X3A
dmi.board.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.board.version: FAB1
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: SAMSUNG ELECTRONICS CO., LTD.
dmi.chassis.version: 0.1
dmi.modalias: dmi:bvnPhoenixTechnologiesLtd.:bvr05HL:bd05/20/2011:svnSAMSUNGELECTRONICSCO.,LTD.:pn90X3A:pvr0.1:rvnSAMSUNGELECTRONICSCO.,LTD.:rn90X3A:rvrFAB1:cvnSAMSUNGELECTRONICSCO.,LTD.:ct9:cvr0.1:
dmi.product.name: 90X3A
dmi.product.version: 0.1
dmi.sys.vendor: SAMSUNG ELECTRONICS CO., LTD.
hciconfig:
 hci0: Type: BR/EDR Bus: USB
  BD Address: 88:53:2E:04:2F:26 ACL MTU: 310:10 SCO MTU: 64:8
  UP RUNNING PSCAN ISCAN INQUIRY
  RX bytes:5094 acl:18 sco:0 events:110 errors:0
  TX bytes:1418 acl:20 sco:0 commands:52 errors:0

Christian Niederreiter (cndg) wrote :
VladimirCZ (vlabla) wrote :

I have similar problem in 11.10 Alpha 3 64-bit. When I choose to browse files on a paired device (via a bluetooth indicator menu) the CPU becomes heavily loaded and no Nautilus window is opened. The same operation can be done on the same notebook with 11.04 64-bit without any problem.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
atarixle (atarixle) wrote :

I got the same problem still in the Ubuntu Final(!).

I can:
-pair my Nokia 6230 with my Ubuntu Laptop
-I can mount the Nokia into Nautilus
-Send files from Ubuntu to the Nokia

I cannot:
-send files directly from the Nokia to Ubuntu (because Ubuntu is invisible to the Nokia, althru Ubuntu is visible for my iPod touch)
-Browse files from the Nokia in Nautilus (even if it's mounted, it breaks up when clicking onto my Phone in the sidebar, and it disconnects and unmounts suddenly)

Justin (justin-wzy) wrote :

Same here.. the error msg says "Unable to find service record"

FelipeAF (felipealexandref) wrote :

i have the same problem with permission denied (13)

atarixle: Interesting that you can mount the device and send files, that already fails for me.

I also don’t get “permission denied”, but “Connection refused (111)”. Is this a different bug?

I attached a hcidump log from the session. It contains an “Authentication failed” error, that might be the problem?

There are several bluetooth bug reports. None of them seems to receive much attention. For me, this is rather critical, as it breaks syncing PIM data with my phone. (But probably everybody thinks his/her bugs are critical). So if there is anything I can do to help in triaging this bug, I’d be happy to do so.

Rafael Peñates (androxvanxo) wrote :

same problem, i can send from pc to phone but cannot from the phone to pc

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers