obconf segfaults with the --tab option when changing pager options

Bug #1272834 reported by Lyn Perrine on 2014-01-26
234
This bug affects 43 people
Affects Status Importance Assigned to Milestone
obconf (Debian)
Fix Released
Unknown
obconf (Ubuntu)
Medium
Unassigned

Bug Description

version
Distributor ID: Ubuntu
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
Codename: trusty

obconf version
obconf:
  Installed: 1:2.0.4+git20130908-2
  Candidate: 1:2.0.4+git20130908-2
  Version table:
 *** 1:2.0.4+git20130908-2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status
3. I expected this to open a tab on obconf and be able to launch the program

4. The obconf segfaults when opening obconf and am not able to get to the GUI if I try to open a specific tab

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: obconf 1:2.0.4+git20130908-2
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Uname: Linux 3.12.0-7-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.13.1-0ubuntu2
Architecture: amd64
CurrentDesktop: LXDE
Date: Sat Jan 25 21:36:25 2014
ExecutablePath: /usr/bin/obconf
InstallationDate: Installed on 2014-01-02 (24 days ago)
InstallationMedia: Lubuntu 14.04 "Trusty Tahr" - Alpha amd64 (20140101)
ProcCmdline: obconf --tab 6
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis: Skipped: missing required field "Disassembly"
Signal: 11
SourcePackage: obconf
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Lyn Perrine (walterorlin) wrote :

This crash has the same stack trace characteristics as bug #1218221. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 __GI_____strtol_l_internal (nptr=0x0, endptr=endptr@entry=0x0, base=base@entry=10, group=group@entry=0, loc=0x7f82bf9a9060 <_nl_global_locale>) at ../stdlib/strtol_l.c:298
 __GI_strtol (nptr=<optimized out>, endptr=endptr@entry=0x0, base=base@entry=10) at ../stdlib/strtol.c:108
 atoi (__nptr=<optimized out>) at /usr/include/stdlib.h:280
 parse_args (argv=0x7fff5741dc28, argc=3) at src/main.c:135
 main (argc=3, argv=0x7fff5741dc28) at src/main.c:214

Changed in obconf (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

Note starting this with a tab other than 6 in the command line will also have cause a segmentation fault on the command line.

information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in obconf (Ubuntu):
status: New → Confirmed
tags: added: utopic
Lyn Perrine (walterorlin) wrote :

Workaround to people trying to launch obconf to a tab thorugh desktop pager is you can add new desktops in LXDE by middle clicking on the desktop. and selecting add new desktop or removing the last desktop. You can also launch obconf from the menu in LXDE.

tags: added: bugpattern-needed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1272834

tags: added: iso-testing

i should add, too, that the typical way a user confronts this bug is
by right clicking on the desktop pager and selecting the option from
the context menu to change the pager preferences. this results in no
apparent effect, but ultimately, this is what's happening underneath.

Changed in obconf (Debian):
status: Unknown → New
Walter Lapchynski (wxl) on 2014-10-14
summary: - obconf segfaults with the --tab option
+ obconf segfaults with the --tab option when changing pager options
Julien Lavergne (gilir) wrote :

I can't reproduce on my x86_64 system. Is anyone can reproduce it on an 15.04 ISO ?

Lyn Perrine (walterorlin) wrote :

I can reproduce in a vm and on a system upgraded to 15.04. both from launching `obconf --tab 3` and from the desktop pager. 

jgratero (jgratero) wrote :

I can confirm this is still present in Lubuntu 14.10 (fresh install). X86 system...

On a related subject, is also still present a bug that I've been observing in Openbox desktop pager for quite a while (I've searched for a report on it, but so far either I'm looking in the wrong way, or no one has reported it): If say, I open a program in Desktop 2, It appears (as per desktop pager) in Desktop 1, even though the program is actually open in desktop 1...

tags: added: vivid
Steven Chan (schan2) wrote :

I am running Lubuntu 14.10 on an amd64 machine and have experienced the problem.

I have found the source of the problem and have just submitted a fix as a Pull Request at https://github.com/danakj/obconf/pull/5. See the PR comments for more details.

Surprisingly, I cannot find a report of the error at the upstream issue tracker, https://bugzilla.icculus.org/buglist.cgi?quicksearch=obconf.

Walter Lapchynski (wxl) wrote :

Steven, utterly fantastic work! Would you mind creating a proper Github issue to go with that? I'd also suggest filing a report on the upstream and leaving a comment on the debbug. Don't forget to link us here. Thanks!

Changed in obconf (Ubuntu):
status: Confirmed → Triaged
Changed in obconf (Ubuntu):
status: Triaged → In Progress
Changed in obconf (Debian):
status: New → Fix Released
Changed in obconf (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.