openbox configuration manager crashed with SIGSEGV in __GI_____strtol_l_internal()

Bug #1218221 reported by Simon THOBY on 2013-08-29
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
obconf (Ubuntu)
Medium
Unassigned

Bug Description

Additionnal data :
$ lsb_release -rd
Description: Ubuntu Saucy Salamander (development branch)
Release: 13.10
version of obconf:
$ apt-cache policy obconf
obconf:
  Installed: 1:2.0.4-0ubuntu1
  Candidate: 1:2.0.4-0ubuntu1
  Version table:
 *** 1:2.0.4-0ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ saucy/universe i386 Packages
        100 /var/lib/dpkg/status

I was trying to change the positions of the icons on LXPanel (the software used for the task bar in LXDE) when OpenBox crashed.
Apport opened and ensure me to complete the bug report. None windows were closed but the system became very slow and I had to restart my computer !

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: obconf 1:2.0.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-4.9-generic 3.11.0-rc7
Uname: Linux 3.11.0-4-generic i686
ApportVersion: 2.12.1-0ubuntu2
Architecture: i386
Date: Thu Aug 29 09:26:37 2013
ExecutablePath: /usr/bin/obconf
InstallationDate: Installed on 2013-08-05 (23 days ago)
InstallationMedia: Lubuntu 13.10 "Saucy Salamander" - Alpha i386 (20130804)
MarkForUpload: True
ProcCmdline: obconf --tab 6
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb6c5ad2c <__GI_____strtol_l_internal+92>: movzbl (%edx),%eax
 PC (0xb6c5ad2c) ok
 source "(%edx)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: obconf
StacktraceTop:
 __GI_____strtol_l_internal (nptr=nptr@entry=0x0, endptr=endptr@entry=0x0, base=base@entry=10, group=group@entry=0, loc=0xb6dd58c0 <_nl_global_locale>) at strtol_l.c:298
 __GI_strtol (nptr=0x0, endptr=0x0, base=10) at strtol.c:109
 main ()
Title: obconf crashed with SIGSEGV in __GI_____strtol_l_internal()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo uucp

information type: Private → Public

StacktraceTop:
 __GI_____strtol_l_internal (nptr=nptr@entry=0x0, endptr=endptr@entry=0x0, base=base@entry=10, group=group@entry=0, loc=0xb6dd58c0 <_nl_global_locale>) at strtol_l.c:298
 __GI_strtol (nptr=0x0, endptr=endptr@entry=0x0, base=base@entry=10) at strtol.c:109
 atoi (__nptr=<optimized out>) at /usr/include/stdlib.h:280
 parse_args (argv=0xbf81a7a4, argc=3) at src/main.c:135
 main (argc=3, argv=0xbf81a7a4) at src/main.c:213

Changed in obconf (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in obconf (Ubuntu):
status: New → Confirmed
Changed in obconf (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package obconf - 1:2.0.4+git20130908-1

---------------
obconf (1:2.0.4+git20130908-1) experimental; urgency=low

  * Merge upstream version 2.0.4+git20130908: (LP: #1218221)
    + use gtk3 for now. (LP: #1059543)
    + refresh debian/patches/update_desktop.patch. (LP: #1179969)
  * Use xz compress for sources and binaries.
  * Upload to experimental.

 -- Mateusz Łukasik <email address hidden> Tue, 29 Oct 2013 16:39:08 +0100

Changed in obconf (Ubuntu):
status: In Progress → Fix Released
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers