GPU fan always at 100%, can not change the thermal settings

Bug #946178 reported by Le Gluon Du Net on 2012-03-04
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
High
Alberto Milone

Bug Description

Hello,

since "Precise Pangolin" upgrade, my GeForce 8800 GT fan is always at 100%, it's very noisy!!!

On Oneiric I put this lines in xorg.conf:

Option "Coolbits" "4"

to enable thermal settings and control the fan.
It works great until I upgraded to 12.04:

at Xorg start, fan is at maximum speed. If I go to nvidia sttings to change the fan speed, my change are not kept when I click on "Apply":

http://youtu.be/zuU1QNgUt6E

If I try to change the fan speed in command line:

# nvidia-settings -a [gpu:0]/GPUFanControlState=1

  Attribute 'GPUFanControlState' (tipingouin-home:0[gpu:0]) assigned value 1.

# nvidia-settings -a [fan:0]/GPUCurrentFanSpeed=40

  Attribute 'GPUCurrentFanSpeed' (tipingouin-home:0[fan:0]) assigned value 40.

nothing happened.

Thanks for your help.

LGDN.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nvidia-settings 295.20-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.94-0ubuntu1
Architecture: i386
Date: Sun Mar 4 09:10:51 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
SourcePackage: nvidia-settings
UpgradeStatus: Upgraded to precise on 2012-02-02 (30 days ago)
---
.proc.driver.nvidia.gpus.0: Error: [Errno 21] est un dossier: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 275.43 Wed Nov 30 17:05:58 PST 2011
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu2)
.tmp.unity.support.test.0:

ApportVersion: 1.94-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,imgjpeg,decor,mousepoll,move,obs,compiztoolbox,regex,place,imgpng,vpswitch,grid,gnomecompat,resize,screenshot,animation,wall,session,wobbly,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
DistUpgraded: Log time: 2012-02-02 21:37:25.416006
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
GraphicsCard: NVIDIA Corporation G92 [GeForce 8800 GT] [10de:0611] (rev a2) (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
JockeyStatus:
 kmod:nvidia_current - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
 kmod:nvidia_173_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
 kmod:nvidia_current_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
 kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
MachineType: HP-Pavilion GX598AA-ABF a6221.fr
NonfreeKernelModules: nvidia
Package: nvidia-graphics-drivers (not installed)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic root=UUID=89e07ea3-c731-4485-806f-88ce53d590ac ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Tags: precise possible-manual-nvidia-install ubuntu reproducible compiz-0.9
Uname: Linux 3.2.0-17-generic i686
UpgradeStatus: Upgraded to precise on 2012-02-02 (31 days ago)
UserGroups: adm admin cdrom dialout disk lp lpadmin netdev plugdev sambashare vboxusers video
dmi.bios.date: 07/27/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 5.21
dmi.board.name: Leonite2
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 6.00
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: 1111
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr5.21:bd07/27/2007:svnHP-Pavilion:pnGX598AA-ABFa6221.fr:pvr:rvnASUSTekComputerINC.:rnLeonite2:rvr6.00:cvnHewlett-Packard:ct3:cvr1111:
dmi.product.name: GX598AA-ABF a6221.fr
dmi.sys.vendor: HP-Pavilion
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 8.0.1-0ubuntu2
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2
---
.proc.driver.nvidia.gpus.0: Error: [Errno 21] est un dossier: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 295.20 Mon Feb 6 20:25:38 PST 2012
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu2)
.tmp.unity.support.test.0:

ApportVersion: 1.94-0ubuntu1
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,imgjpeg,decor,mousepoll,move,obs,compiztoolbox,regex,place,imgpng,vpswitch,grid,gnomecompat,resize,screenshot,animation,wall,session,wobbly,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
DistUpgraded: Log time: 2012-02-02 21:37:25.416006
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
GraphicsCard: NVIDIA Corporation G92 [GeForce 8800 GT] [10de:0611] (rev a2) (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
JockeyStatus:
 kmod:nvidia_173 - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
 kmod:nvidia_current - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
 kmod:nvidia_173_updates - NVIDIA binary Xorg driver, kernel module and VDPAU library (Propriétaire, Désactivé, Non utilisé)
 kmod:nvidia_current_updates - nvidia_current_updates (Propriétaire, Activé, Non utilisé)
MachineType: HP-Pavilion GX598AA-ABF a6221.fr
NonfreeKernelModules: nvidia
Package: nvidia-graphics-drivers (not installed)
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-18-generic root=UUID=89e07ea3-c731-4485-806f-88ce53d590ac ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Tags: precise possible-manual-nvidia-install ubuntu regression reproducible has-workaround compiz-0.9
Uname: Linux 3.2.0-18-generic i686
UpgradeStatus: Upgraded to precise on 2012-02-02 (32 days ago)
UserGroups: adm admin cdrom dialout disk lp lpadmin netdev plugdev sambashare vboxusers video
dmi.bios.date: 07/27/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: 5.21
dmi.board.name: Leonite2
dmi.board.vendor: ASUSTek Computer INC.
dmi.board.version: 6.00
dmi.chassis.type: 3
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: 1111
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvr5.21:bd07/27/2007:svnHP-Pavilion:pnGX598AA-ABFa6221.fr:pvr:rvnASUSTekComputerINC.:rnLeonite2:rvr6.00:cvnHewlett-Packard:ct3:cvr1111:
dmi.product.name: GX598AA-ABF a6221.fr
dmi.sys.vendor: HP-Pavilion
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu5
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.1-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 8.0.1-0ubuntu2
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.1-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu4
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Le Gluon Du Net (legluondunet) wrote :
tags: added: hw-specifc

Thank you for taking the time to report this bug and trying to help make Ubuntu better. However, it seems that you are using a proprietary software package. Specifically, NonfreeKernelModules: nvidia. Because of this the Ubuntu project can not support or fix your particular bug.

If you are interested in learning more about software repositories and Ubuntu the following pages should be informative:

1. http://www.ubuntu.com/community/ubuntustory/components - information about Ubuntu repositories
2. https://help.ubuntu.com/community/Repositories - information regarding managing repositories.

Changed in nvidia-settings (Ubuntu):
status: New → Invalid
Le Gluon Du Net (legluondunet) wrote :

Ok, but where I could report a bug for nvidia specific hardware? And I could not use "nouveau" driver with Ubuntu precise? I don't see it anywhere...

Sorry, I was in error in my previous reply. I am continuing to look into this bug for you. My apologies, and thank you for your patience.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

To help gather more information to assist in tracking the problem, please run the command 'apport-collect 946178' which will attach necessary information for debugging this as an Xorg problem. Thanks in advance.

Changed in nvidia-settings (Ubuntu):
status: Invalid → Incomplete

Please see this page for more information, including how to revert to using the nouveau drivers.
https://wiki.ubuntu.com/X/Troubleshooting/NvidiaDriverSwitching
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

affects: nvidia-settings (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
tags: added: regression-release
Le Gluon Du Net (legluondunet) wrote :

I finally installed manually 275.43 nvidia driver and fan control works again. If you would like to try this soluce, don't forget to desactivate all the nvidia driver in jockey-gtk and uninstall all nvidia packages:

$apt-get remove --purge nvidia*

apport information

tags: added: apport-collected compiz-0.9 possible-manual-nvidia-install reproducible ubuntu
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

I'm glad you found a solution that worked for you, and thank you for getting back to me.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in nvidia-graphics-drivers (Ubuntu):
status: Incomplete → Confirmed
Le Gluon Du Net (legluondunet) wrote :

I manually installed the 295.20 drivers from nvidia official site, the same bug: fan always at 100% at xorg start and I can not control it. James, do you still need the result of this command: "apport-collect 946178". To give you that debug information I have to reinstalled the ubuntu package, so do you still need it?

Regards.

Yes please, any and all information you can provide is helpful.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

apport information

tags: added: has-workaround regression
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Bryce Harrington (bryce) wrote :

@Alberto, mind raising this with NVIDIA? Looks like it's been pinpointed to a regression in 295.20 (vs 275.43).

@Le Gluon Du Net, can you test if the bug also affects 295.10?

Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: Confirmed → Triaged
Le Gluon Du Net (legluondunet) wrote :

In this moment I'm using the 295.10 version and I can monitor fan speed.

Le Gluon Du Net (legluondunet) wrote :

the bugs of the "100% fan speed at xorg start" and "can no more control nvidia fan speed in nvidia-settings" are still present in the last nvidia driver 295.33, i just tested it.

Ryan Coe (nismoryco) wrote :

These bugs are also in 295.40. I reverted back to 280.13 (the same as I was using in Oneiric without the problem) and the problem is gone.

Ryan Coe (nismoryco) wrote :

This is a correction to my previous post:
280.13 does not work in Precise due to the X server being a newer version. I installed 295.10 and the everything is working once again.

Le Gluon Du Net (legluondunet) wrote :

this bug is still present in the 295.40 version...

mrgorefest (mrgorefest) wrote :

I have the same problem with Ubuntu 12.10 (on Ubuntu 12.04 was fine)

Alberto Milone (albertomilone) wrote :

@Daniel Dadap: any ideas about this?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers