gnome-shell crashed with SIGSEGV in __fork()

Bug #936132 reported by Rovano on 2012-02-19
210
This bug affects 40 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
High
Unassigned

Bug Description

Write word in shell explorer and first charakter freezing shell.

[Upstream]
http://www.nvnews.net/vbulletin/showthread.php?t=174049
http://www.nvnews.net/vbulletin/showpost.php?p=2532350&postcount=8
"NVIDIA internally filed bug 941836 to track this issue."

[Workaround]
http://ubuntuforums.org/showthread.php?t=1928215&page=2
add the gnome3-team/gnome3 ppa
sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gnome-shell 3.2.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-16.25-generic-pae 3.2.6
Uname: Linux 3.2.0-16-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Sun Feb 19 12:43:13 2012
ExecutablePath: /usr/bin/gnome-shell
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120203)
ProcCmdline: /usr/bin/gnome-shell
ProcEnviron:
 PATH=(custom, no user)
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0xb5455ea3 <_nv022tls+19>: mov %eax,0xc(%edx)
 PC (0xb5455ea3) ok
 source "%eax" ok
 destination "0xc(%edx)" (0x0000000c) not located in a known VMA region (needed writable region)!
 Stack memory exhausted (SP below stack segment)
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gnome-shell
StacktraceTop:
 _nv022tls () from /usr/lib/nvidia-current/tls/libnvidia-tls.so.295.20
 ?? () from /usr/lib/nvidia-current/libGL.so.1
 fork () from /lib/i386-linux-gnu/libpthread.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_spawn_sync () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: gnome-shell crashed with SIGSEGV in _nv022tls()
UpgradeStatus: Upgraded to precise on 2012-02-18 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Rovano (rovano) wrote :
visibility: private → public
Rovano (rovano) wrote :

Symbol "s" will freeze shell.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed

StacktraceTop:
 ?? ()
 __fork () at ../nptl/sysdeps/unix/sysv/linux/pt-fork.c:26
 fork_exec_with_pipes (intermediate_child=-1573516288, working_directory=0x0, argv=0xace07b78, envp=0x0, close_descriptors=1, search_path=1, stdout_to_null=0, stderr_to_null=0, child_inherits_stdin=0, file_and_argv_zero=0, child_setup=0, user_data=0x0, child_pid=0xa2360e68, standard_input=0x0, standard_output=0x0, standard_error=0x0, error=0x0) at /build/buildd/glib2.0-2.31.16/./glib/gspawn.c:1232
 g_spawn_sync (working_directory=0x0, argv=0xace07b78, envp=0x0, flags=G_SPAWN_SEARCH_PATH, child_setup=0, user_data=0x0, standard_output=0x0, standard_error=0x0, exit_status=0xa2360f58, error=0x0) at /build/buildd/glib2.0-2.31.16/./glib/gspawn.c:285
 g_spawn_command_line_sync (command_line=0xace0e2b8 "/usr/bin/totem-video-thumbnailer -s 256 'file:///media/HOME/rovano/Sta%C5%BEen%C3%A9/bohemian_rhapsody.flv' '/tmp/.gnome_desktop_thumbnail.F5A69V'", standard_output=0x0, standard_error=0x0, exit_status=0xa2360f58, error=0x0) at /build/buildd/glib2.0-2.31.16/./glib/gspawn.c:722

Changed in gnome-shell (Ubuntu):
importance: Undecided → Medium
summary: - gnome-shell crashed with SIGSEGV in _nv022tls()
+ gnome-shell crashed with SIGSEGV in __fork()
tags: removed: need-i386-retrace
graingert (tagrain) wrote :
affects: gnome-shell (Ubuntu) → nvidia-graphics-drivers (Ubuntu)
graingert (tagrain) wrote :

This is a huge problem, and is preventing people using the nvidia drivers. The importance of this issue should be raised

Woonjas (woonjas) wrote :

I came across Bug #941200 which is marked as a duplicate of this bug, however I do not experience a 'freeze' when I type to locate an app, instead all windows lose their title bar making it impossible to move/resize the app but the apps continue to work.

Syslog contains the following:
Feb 28 14:34:33 e6520-nwst kernel: [ 98.789870] gnome-shell[2607]: segfault at 10 ip 00007f160c2b9c0f sp 00007f15e3c29638 error 6 in libnvidia-tls.so.295.20[7f160c2b9000+3000]
Feb 28 14:34:33 e6520-nwst gnome-session[2269]: WARNING: Application 'gnome-shell.desktop' killed by signal
Feb 28 14:34:33 e6520-nwst gnome-session[2269]: WARNING: App 'gnome-shell.desktop' respawning too quickly

Any idea when we can expect a fix?

P.S. it appears that emptying out ~/.local/share/recently-used.xbel is a workaround.

Woonjas (woonjas) wrote :

Oh and I almost forget, I'm on

Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric

graingert (tagrain) wrote :

@Woonjas I sometimes have freezes other times a complete window-manager crash

can you also say which version of the nvidia drivers you are on

graingert (tagrain) wrote :
Woonjas (woonjas) wrote :

@graingert 295.20

sdowney717 (sdowney717) wrote :

effects me, serious issue is true.

I upgraded to beta of 12.04 to see if problem went away.
With 12.04 it reports that gnome shell crashed.
With 11.10 it reports nothing, just crashes.

Logout and login to fix with 11.10, 12.04 resets itself.

Hello all

Work around: install gdm and set as session manager. I can then get a fully functional Gnome Shell in precise 12.04 as updated to todays state (Gnome Shell version 3.2.2.1-0ubuntu1).

nvidia 270, GeForce GT520 card, Xeon quad core with 12.04 64bit

The "gdm as session manager" workaround does not work for me in precise.
It still crashes when searching something.

Maybe Bug #943596 could be a Duplicate?

sdowney717 (sdowney717) wrote :

http://ubuntuforums.org/showthread.php?t=1928215&page=2

add the gnome3-team/gnome3 ppa

sudo add-apt-repository ppa:gnome3-team/gnome3
sudo apt-get update

I just did this restarted and the problem is gone away.
Fixed. Typing in the search box does not crash the system.

graingert (tagrain) wrote :

It might be worth waiting until that code gets ported to the official repositories.

Also note this is a problem with the nvidia drivers, and installing a new gnome-shell is just a workaround.

Bryce Harrington (bryce) on 2012-03-06
Changed in nvidia-graphics-drivers (Ubuntu):
importance: Medium → High
description: updated
description: updated
NickTh  (nick-athens30) wrote :

Yes i noticed that too. When nvidia proprietary driver installed then gnome crashes all the time , Only if i want to use search option(shell explorer). First character any character freezing and then crashes gnome-shell.

graingert (tagrain) wrote :

This no longer affects the currently released 12.04 gnome-shell v 3.3.90 it seems they must have found a workaround.

however the main nvidia driver issue is still there, this demo program still fails:

http://www.nvnews.net/vbulletin/showpost.php?p=2530486&postcount=4

graingert (tagrain) wrote :

Added demo program directly

quoted from link:

$ make
$ ./forktest

if you hit 'm', it will do the fork in the main thread, and work successfully.
if you hit the spacebar, it will create a thread and do the fork in there. and crash.

Bryce Harrington (bryce) on 2012-03-16
Changed in nvidia-graphics-drivers (Ubuntu):
status: Confirmed → Triaged
NickTh  (nick-athens30) wrote :

Hello again . After the last kernel update (3.2.0-19-generic-pae) , today , seems like things fixed. No crashes till now , after 2 hours of use.
Gnome-shell search option (shell explorer) works smoothly and kinda quickest i can say.

graingert (tagrain) wrote :

@nick-athens30 Can you verify you no longer have the issue by downloading running forktest program and checking that you do not get a segmentation fault?

sdowney717 (sdowney717) wrote :

well you guys did it to me again.
Getting the same type bug now after today's updates.

gnome-shell crashed with SIGABRT in raise()
https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/962547

NickTh  (nick-athens30) wrote :

@tagrain i apologize for the delay . I have a fresh install of 12.04 now and i still i have NO crashes . I don't know about the forktest program but when i run make i get this error :

"g++ -o forktest main.cpp -lglut -lGL
main.cpp:18:21: fatal error: GL/glut.h: No such file or directory
compilation terminated.
make: *** [forktest] Error 1"
I have build-essentials installed and i download the program from here (your attached file)

Now i have 3.2.0-20-generic-pae , gnome-shell and of course nvidia 295.20-0ubuntu1 .
I repeat NO crashes.
If i must do something else to prove it ( to help i mean) just tell me what .
Thanks

NickTh  (nick-athens30) wrote :

Hah .. no my friend , i cannot into search .. I DONT WANT into search (if you know what i mean). I came here to post a comment that this bug affects me too in precise pangolin version of Ubuntu 32bit. (see the tags)
I don't know about forktest program and at this time i have no time to search for a program that as i saw (from your link) is for what ? amd64? .
When the problem solved(for me) i posted again to update my comment. Nothing more , nothing less.
Thanks

graingert (tagrain) wrote :

@nick-athens30 sudo apt-get install freeglut3-dev

NickTh  (nick-athens30) wrote :

@tagrain ok. For you my friend :-P :-) .
You have right about the fault.

That is the output of

$ ./forktest
when i hit space bar

"starting fork...
Segmentation fault (core dumped)"

NickTh  (nick-athens30) wrote :

@tagrian after recent updates (3.2.0-21 generic -pae) and a lot of other packages i think that forktest works .

The output of

$ ./forktest

"starting fork...
in child
exiting child
child successfully waited for in parent..."

graingert (tagrain) wrote :

This was fixed by nvidia in 295.33

$ ./forktest
starting fork...
in child
exiting child
child successfully waited for in parent...

Changed in nvidia-graphics-drivers (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers