Ubuntu

11.04 - opening too many windows causes new windows to render blank white

Reported by legnerquero on 2011-04-01
216
This bug affects 41 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned

Bug Description

Problems with Driver (NVIDIA Driver Version: 270.30)

Blank screens have more than two windows open, wrong behavior in some applications, smplayer, cairo dock, etc, so will the edges of window, application screens suddenly go blank, sometimes not launch applications. without the driver enabled these problems disappear.

Hardware

1) GeForce 6150SE nForce 430 (GPU 0)

System Information

1) Operating System: Linux-x86_64

 Distributor ID: Ubuntu
 Description: Ubuntu Natty (development branch)
 Release: 11.04
 Codename: natty

2) NVIDIA Driver Version: 270.30

X Server Information:

1) Server Version Number: 11.0

2) Server Vendor String: The X.Org Foundation

3) Server Vendor Version: 1.10.0 (11000000)

4) NV-CONTROL Version: 1.26

legnerquero (legnerquero) wrote :

Note: The problem is with compiz enabled, disabling compiz works fine this driver.

Luke Hoersten (lukehoersten) wrote :

This bug affects me as well. Looks like maybe a compiz/video card driver memory issue because when I have too many windows open, opening more windows causes the newly opened windows to be blank white.

Resizing the windows to be smaller can sometimes allow the window content to render.

lspci:
00:05.0 VGA compatible controller: nVidia Corporation C51 [GeForce 6150 LE] (rev a2)

NVIDIA Driver Version: 270.30 (185)

summary: - Blank screens have more than two windows open, wrong behavior in some
- applications.
+ 11.04 - opening too many windows causes new windows to render blank
+ white
tags: added: compiz
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Will Miller (willmiller97) wrote :

Same here. How to fix problem? Do you change the driver to the older NVIDIA driver? Or how else do I fix it- it's very annoying.

dominik232 (dominik232) wrote :

Yep. I had the same, the only solution to get up workable compiz on new ubuntu is to install older NVIDIA drivers, it works good with 173 version for me.

Trois Singes (trois-singes) wrote :

Downgrading to 173 version solved the problem for me as well.

Druid (topaz-gb) wrote :

Same problem here

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-8-generic 2.6.38-8.42
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: nvidia
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: kevin 2410 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xdff78000 irq 22'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,14627309,00100001'
   Controls : 34
   Simple ctrls : 20
CurrentDmesg:
 [ 35.188403] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
 [ 2118.477272] Inbound IN=eth0 OUT= MAC=00:24:21:a3:e9:e2:74:f0:6d:34:88:dd:08:00 SRC=192.168.1.3 DST=192.168.1.2 LEN=90 TOS=0x00 PREC=0x00 TTL=128 ID=32513 PROTO=UDP SPT=137 DPT=41005 LEN=70
 [ 2118.745866] Inbound IN=eth0 OUT= MAC=00:24:21:a3:e9:e2:74:f0:6d:34:88:dd:08:00 SRC=192.168.1.3 DST=192.168.1.2 LEN=90 TOS=0x00 PREC=0x00 TTL=128 ID=32516 PROTO=UDP SPT=137 DPT=41005 LEN=70
 [ 2119.016674] Inbound IN=eth0 OUT= MAC=00:24:21:a3:e9:e2:74:f0:6d:34:88:dd:08:00 SRC=192.168.1.3 DST=192.168.1.2 LEN=90 TOS=0x00 PREC=0x00 TTL=128 ID=32517 PROTO=UDP SPT=137 DPT=41005 LEN=70
 [31527.928565] warning: `proftpd' uses 32-bit capabilities (legacy support in use)
Date: Sat Apr 30 03:57:34 2011
HibernationDevice: RESUME=UUID=40465b80-9c79-4b23-8948-47bea9dba5c9
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Lsusb:
 Bus 002 Device 003: ID 1bcf:0007 Sunplus Innovation Technology Inc. Optical Mouse
 Bus 002 Device 002: ID 0c45:6029 Microdia Triplex i-mini PC Camera
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: MSI MS-7309
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=216d5d6d-409d-4498-898a-85c812d70198 ro splash quiet vga=769 quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-8-generic N/A
 linux-backports-modules-2.6.38-8-generic N/A
 linux-firmware 1.52
RfKill:

SourcePackage: linux
UpgradeStatus: Upgraded to natty on 2011-04-29 (1 days ago)
dmi.bios.date: 04/09/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V9.5
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7309
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV9.5:bd04/09/2009:svnMSI:pnMS-7309:pvr1.0:rvnMSI:rnMS-7309:rvr1.0:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: MS-7309
dmi.product.version: 1.0
dmi.sys.vendor: MSI

David Dyball (david-dyball) wrote :

Confirmed that this issue is apparent for me too with an Nvidia Quadro NVS 285 + Ubuntu 11.04 default install + NVidia Drivers 270.41.06

I'll try going back a version to see whether or not that fixes the issue.

Druid (topaz-gb) wrote :

Downgrading to 173 version did not work for me, in fact it made things worse. many of the buttons would not work and the cursor changed to default in parts of Firefox and prevented hiliting text.

lazyeo (zs2king) wrote :

me too
NV 6150go

Paul Eggert (eggert-gnu) wrote :

The problem occurs for me too, on a Sun Ultra 20 M2 with NVIDIA Quadro NVS 285 graphics, running Linux x86 (not x86-64). Downgrading to the 173 version did not help.

I worked around the problem by switching to the nouveau driver, and dumping Unity (Unity 2D does not work well at all) in favor of the traditional Gnome desktop. The entire experience was unpleasant enough that on another machine, which uses GeForce 8300, I am sticking with Ubuntu 10.10.

Alain Kalker (miki4242) wrote :

This problem also affects me.

From `lspci`:
00:10.0 VGA compatible controller: nVidia Corporation C73 [GeForce 7050 / nForce 630i] (rev a2)

which is an IGP (using shared memory) on an MSI MS-7504VP mainboard.

legnerquero (legnerquero) wrote :

This bug is more than confirmed, but will be waiting here to change the status (Importance = Undecided; Assigned to = Unassigned) ?

AshleyD (amd405) wrote :

I am also affected by this bug.

Linux-x86_64, Ubuntu 11.04 (upgraded from 10.10)
from lspci: nVidia Corporation C67 [GeForce 7150M / nForce 630M] (rev a2)

A few other things I've noticed:
1. If I try to save something from a working window, the new window will sometimes be blank, but resizing it makes it appear correctly.
2. Adobe acrobat reader does not have a horizontal scrolling bar. (maybe unrelated?)

Trois Singes (trois-singes) wrote :

Is there an news about the resolution of this bug?

Goombies (matt-trostel) wrote :

Count me in as an affected user.

Ubuntu 11.04
GeForce 6150SE nForce 430 (rev a2)
nVidia driver: 270.41.06

mattman0 (matt-mjcj) wrote :

I have this issue also, upgraded to 11.04 from 10.10 then did a fresh install to try and overcome this issue.
00:12.0 VGA compatible controller: nVidia Corporation C68 [GeForce 7050 PV / nForce 630a] (rev a2)
NVIDIA UNIX x86 Kernel Module 270.41.19

g9ahwkcm (g9ahwkcm) wrote :

Just did the upgrade dance from 10.04 to 11.04, and on 11.04 no X for me...

turns out that ubuntu detected I had 4 gigs of ram and picked the pae kernel, but the dev packages weren't installed so the nvidia kernel driver didn't get built.

once I installed linux-headers-2.6.38-10-generic-pae things were much better (I also rebooted after installing this package).

I'm running 32 bit linux on a athlon dual core, with on motherboard nvidia 6150se

parq (pablo-romeroquinteros) wrote :

Same here.

The system works perfect on 10.10. After upgrading to 11.04 the problem appears. I'm using gnome (not unity), and seems to be related to compiz (i guess).

More info:

$ lspci | grep VGA
00:12.0 VGA compatible controller: nVidia Corporation C68 [GeForce 7025 / nForce 630a] (rev a2)

$ dmesg | grep NVIDIA
NVRM: loading NVIDIA UNIX x86 Kernel Module 270.41.06 Mon Apr 18 14:54:25 PDT 2011

Goombies (matt-trostel) wrote :

I've worked around this by increasing my framebuffer size in the BIOS to 256MB (doesn't fix the problem, but basically allows me to open more windows than I could previously before the problem kicks in)

I can live with this until nVidia fixes this issue as I normally don't have enough windows open simultaneously to induce the white window of death.

charles s (mausolos) wrote :

g9ahwkcm:

I tried what you did, it solved the windows (mostly) from coming up white, but now the background, terminal and more windows past two appear to come up white.

here's my stuff, spelled out:

Lenovo 3000 J series, AMD 64x2 running 32 bit

$ lspci -nn | grep VGA
00:05.0 VGA compatible controller [0300]: nVidia Corporation C51G [GeForce 6100] [10de:0242] (rev a2)

here's what i've tried so far:
wget http://us.download.nvidia.com/XFree86/Linux-x86/275.21/NVIDIA-Linux-x86-275.21.run
sudo apt-get install linux-headers-2.6.38-10-generic-pae
sudo sh NVIDIA-Linux-x86-275.21.run -n -s --x-prefix=/usr/lib/xorg/ --kernel-source-path=/usr/src/linux-headers-`uname -r`

thinking about going down to 10.04, wonder if that will be any different. worked ok (after some tweaking, not that i can remember what) in 8.04.

Even I'm badly affected by this bug. Is it resolved in Ubuntu 11.10?
Mine is: $ lspci -nn | grep VGA
00:05.0 VGA compatible controller [0300]: nVidia Corporation C51G [GeForce 6100] [10de:0242] (rev a2) running on AMD Athlon 64 32 bit. Above solution is no good for me.

AshleyD (amd405) wrote :

A fresh install of 11.04 is no longer giving me any trouble.

NoOp (glgxg) wrote :

Just simply logging in via a remote terminal, the remote allow/refuse window is blank. Window decoration is apparent. No difference if using Ubuntu, Ubuntu Classic, Ubuntu Classic (No effects). Note: I'm using nvidia-96, so Unity is not possible in 11.04 (only Unity 2D w/11.10).

2.6.38-12-generic #51-Ubuntu SMP Wed Sep 28 14:25:20 UTC 2011 i686 i686 i386 GNU/Linux

  *-display
       description: VGA compatible controller
       product: NV25GL [Quadro4 900 XGL]
       vendor: nVidia Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a3
       width: 32 bits
       clock: 66MHz
       capabilities: pm agp agp-2.0 vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=248 maxlatency=1 mingnt=5
       resources: irq:16 memory:fd000000-fdffffff memory:d0000000-d7ffffff memory:dc780000-dc7fffff memory:fe9e0000-fe9fffff

nvidia-common:
  Installed: 0.2.30.1
  Candidate: 0.2.30.1
  Version table:
 *** 0.2.30.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.2.30 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

nvidia-96:
  Installed: 96.43.20-0ubuntu1~natty1
  Candidate: 96.43.20-0ubuntu1~natty1
  Version table:
 *** 96.43.20-0ubuntu1~natty1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/restricted i386 Packages
        100 /var/lib/dpkg/status
     96.43.19-0ubuntu8 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/restricted i386 Packages

Reid Kaufmann (reid-kaufmann) wrote :

I see the same behavior in 11.10 with nvidia-current (280.13-0ubuntu6)

00:05.0 VGA compatible controller: nVidia Corporation C51 [Quadro NVS 210S/GeForce 6150LE] (rev a2)

Roger Breeden (nextgencomp) wrote :

This error also occurs in Ubuntu 11.10, but I have found it is the Nvidia drivers certain versions that cause the issue. I downloaded the most recent drivers from Nvidia and installed them and now I no longer get the White screen. I will say to do this in 11.10 you need to stop the X server in order to install them. For those that do not know how to go to the terminal and then stop the service lightdm that is what it called in 11.10 then install your drivers and then start lightdm back up, I also had to do a restart on it before it fully kick in or reboot up to you.

bugbot (bugbot) on 2012-05-31
tags: added: natty
Walter Ribeiro (wribeirojr) wrote :

This bug stopped happening for me.
nvidia-304-updates - Ubuntu 13.04

Luke Hoersten (lukehoersten) wrote :

This bug stopped happening for me as well in 12.04 since actually. I think I installed nvidia-304 from the nvidia website instead of through apt in order to get RandR and at the same time fixed the problem.

Olivier Debon (olivier-debon) wrote :

Issue popped again for some settings. I have nvidia-310 (exp) installed everything is ok if you have default compiz settings. But I must have changed something that made the issue back again. I'll try to figure out which compiz setting reproduces the issue.
[ Ubuntu 12.04.2 64bits ]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions