Ubuntu

nvidia 256.53 xorg-server 1.9.0 performance regression with antialiased text

Reported by Sidnei da Silva on 2010-09-03
358
This bug affects 74 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
High
Alberto Milone
Maverick
High
Alberto Milone

Bug Description

I'm experiencing issues similar to the ones described at:

  http://www.nvnews.net/vbulletin/showthread.php?t=154563

Switching font rendering from 'Subpixel Smoothing (LCD)' to any other setting in 'Preferences -> Appearance' makes the problem go away.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: nvidia-current 256.53-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
NonfreeKernelModules: nvidia wl
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 256.53 Fri Aug 27 20:27:48 PDT 2010
 GCC version: gcc version 4.4.5 20100824 (prerelease) (Ubuntu/Linaro 4.4.4-9ubuntu2)
Architecture: amd64
Date: Fri Sep 3 19:49:07 2010
DkmsStatus:
 nvidia-current, 256.53, 2.6.35-19-generic, x86_64: installed
 bcmwl, 5.60.48.36+bdcom, 2.6.35-19-generic, x86_64: installed
 bcmwl, 5.60.48.36+bdcom, 2.6.32-24-generic, x86_64: built
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MachineType: Apple Inc. MacBookPro5,5
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-19-generic root=UUID=296cf8e0-5328-43a8-a7d6-f96cb65444a9 ro quiet splash nomodeset elevator=deadline video=uvesafb:mode_option=1280x800-24,mtrr=3,scroll=ywrap
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: nvidia-graphics-drivers
dmi.bios.date: 06/15/09
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBP55.88Z.00AC.B03.0906151708
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-F2268AC8
dmi.board.vendor: Apple Inc.
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F2268AC8
dmi.modalias: dmi:bvnAppleInc.:bvrMBP55.88Z.00AC.B03.0906151708:bd06/15/09:svnAppleInc.:pnMacBookPro5,5:pvr1.0:rvnAppleInc.:rnMac-F2268AC8:rvr:cvnAppleInc.:ct10:cvrMac-F2268AC8:
dmi.product.name: MacBookPro5,5
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
system:
 distro: Ubuntu
 codename: maverick
 architecture: x86_64
 kernel: 2.6.35-19-generic

Sidnei da Silva (sidnei) wrote :
Harry (harry33) wrote :

Yes I can confirm there is a regression issue with xserver 1.9 (at least up to 1.9.0-0ubuntu4) and nvidia-current (at least up to 256.53).

This is most prominent when scrolling in some applications.
I have found that synaptic is a very good example of this one.
Scrolling is severely influenced there.

With xserver 1.8 branch and nvidia-current 256.44 scrolling was very fluent:
a big difference compared to xserver 1.8 branch with ati open source drivers (xserver-xorg-video-radeon).
Now the open source ati drivers are clearly faster than nvidia-current_256.53 with xserver 1.9.

But, for the time being I cannot say if this is a regression in xserver 1.9 or have certain codes changed in the new xserver so much,
that nvidia drivers ought to be changed as well.
At least it seems not to be a regression in nvidia-current, because the same driver (256.44) works very well with xserver 1.8, but not with xserver 1.9 (with IgnoreABI command).

Harry (harry33) wrote :

Just out of curiosity,
could this bug have something to do with desktop sluggishness that was observer to be caused by libcairo?
The libcairo code was temporarily changed in order to overcome the incompatibility with nvidia-current back then.
See the bug #605979

And one more thing.
This bug does not in any way affect video performance. HD videos (1920:1080) run really well.

Mahendra Tallur (mahen) wrote :

I encounter this issue as well (nvidia 256.53, Meerkat beta). BTW, the IgnoreABI option doesn't seem to be required anymore as of today.

(i.e. : playing HD videos or OpenGL apps are smooth -- scrolling text or moving a window about a window that is full of text is *extremely* slow, while it's still as smooth as it used to when moving a window over a window that doesn't contain text)

Extender (msveshnikov) wrote :

Yes, I have same bug. All works very fast without LCD smoothing (but I need it!!)

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Alberto Milone (albertomilone) wrote :

Subscribing Nvidia to this bug report

J. Cook (cookiecaper) wrote :

AaronP indicates that he thinks he has a fix to be pushed in a "future driver release". See http://www.nvnews.net/vbulletin/showpost.php?p=2315516&postcount=31 .

Harry (harry33) wrote :

And that might be an update to the newly released beta driver 260.19.04.
See: http://www.phoronix.com/scan.php?page=news_item&px=ODU3NQ

Extender (msveshnikov) wrote :

When this driver will be available in repos for Maverick?

Daniel Dadap (ddadap) wrote :

The 260.19.04 driver doesn't have this fix yet. It will be a later version that does.

Harry (harry33) wrote :

If you want to test this beta driver 260.19.04,
you will find it here (X-Updates):
https://launchpad.net/~ubuntu-x-swat/+archive/x-updates

NoahY (noahy) wrote :

I added the ppa, Upgraded the following packages:
fglrx-modaliases (2:8.723.1-0ubuntu4) to 2:8.762-0ubuntu0sarvatt
intel-gpu-tools (1.0.2+git20100324-0ubuntu1) to 1.0.2+git20100830+c935c60-0ubuntu0sarvatt
nvidia-current (256.53-0ubuntu2) to 260.19.04-0ubuntu0~xup2
nvidia-current-modaliases (256.53-0ubuntu2) to 260.19.04-0ubuntu0~xup2
nvidia-settings (256.53-0ubuntu1) to 260.19.04-0ubuntu0sarvatt

and switched back the font settings to "Subpixel Smoothing (LCDs)", and...

the problem hasn't gone away. There is still a clear speed drop in, say, simply scrolling text in the command prompt.

Harry (harry33) wrote :

NoahY,
Like Daniel wrote (comment 10), this beta driver does not yet contain that bug fix.
It will be included into the next version, perhaps into the stable 260 series driver.

eZFlow (breakdevize) wrote :

Thanks for the work around! Finally can enjoy maverick.

Extender (msveshnikov) wrote :

Yes, 260.19.06 fixed that bug!! Thanks and please rebuild repos for that critical bug ASAP

Fran Diéguez (frandieguez) wrote :

260.19.06 fix the bug for me too! Thanks!

Manuel Bua (manuel-bua) wrote :

Am i the only one with this problem *AND* these latest drivers installed?
I'm still experiencing the gnome-terminal slowness problem with the 260.19.06 beta release as well.
Ubuntu 10.10beta, GeForce 8400M GS, X server 1.9.0 on an HP Pavilion dv6500 Notebook PC.

Manuel Bua (manuel-bua) wrote :

Partially solved: i completely removed everything and just reinstalled, for some unknown reason it was still loading the old driver.
However, i've completely lost v-sync, be it xvideo textures, compiz or everything else, it just doesn't sync anymore: the new driver completely resolves the font issue btw.

Harry (harry33) wrote :

Now that we have a fix for this bug, could perhaps Alberto Milone build this into maverick's repos.
This sluggishness issue is after all quite an annoying one.

NoahY (noahy) wrote :

> Please try 260.19.06: http://www.nvnews.net/vbulletin/showthread.php?t=155137

Given all the warnings about borking Ubuntu by installing nvidia website drivers (and the fact that I tried it and ended up borking Ubuntu), I'm not sure if that is such sound advice...

Glad to hear some people know how to do such things, though :) I'll wait patiently for a Maverick package.

Thanks for the hard work.

maba (mauricio-barraza) wrote :

Just wanted to let you all know that the updated nvidia driver is in Philip Johnsson's Extra PPA:
https://launchpad.net/~philip5/+archive/extra

I used that to install 260.19.06 in Maverick and it works like a charm, no performance regression using antialiased text anymore.
After installing just the updated nvidia packages from that PPA, disable it.

GL&HF. :)

Harry (harry33) wrote :

Yes I confirm what maba just wrote in comment #22.
I only downloaded the packages nvidia-current and nvidia-settings from that PPA.
Then I installed them with dpkg in terminal.
There is no need to change sources.list that way.

Anyway, the driver runs well in maverick too. The PPA itself is for Karmic and Lucid.

Alberto Milone (albertomilone) wrote :

I'll package the new driver and put it in a PPA soon so that you can test it. I'll let you know when it's available

I think this driver should be pushed to the maverick repo ASAP!

On Fri, Sep 17, 2010 at 3:16 PM, Alberto Milone <
<email address hidden>> wrote:

> I'll package the new driver and put it in a PPA soon so that you can
> test it. I'll let you know when it's available
>
> --
> nvidia 256.53 xorg-server 1.9.0 performance regression with antialiased
> text
> https://bugs.launchpad.net/bugs/629910
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “nvidia-graphics-drivers” package in Ubuntu: Confirmed
>
> Bug description:
> I'm experiencing issues similar to the ones described at:
>
> http://www.nvnews.net/vbulletin/showthread.php?t=154563
>
> Switching font rendering from 'Subpixel Smoothing (LCD)' to any other
> setting in 'Preferences -> Appearance' makes the problem go away.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: nvidia-current 256.53-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic x86_64
> NonfreeKernelModules: nvidia wl
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86_64 Kernel Module 256.53 Fri Aug 27
> 20:27:48 PDT 2010
> GCC version: gcc version 4.4.5 20100824 (prerelease) (Ubuntu/Linaro
> 4.4.4-9ubuntu2)
> Architecture: amd64
> Date: Fri Sep 3 19:49:07 2010
> DkmsStatus:
> nvidia-current, 256.53, 2.6.35-19-generic, x86_64: installed
> bcmwl, 5.60.48.36+bdcom, 2.6.35-19-generic, x86_64: installed
> bcmwl, 5.60.48.36+bdcom, 2.6.32-24-generic, x86_64: built
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
> MachineType: Apple Inc. MacBookPro5,5
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-19-generic
> root=UUID=296cf8e0-5328-43a8-a7d6-f96cb65444a9 ro quiet splash nomodeset
> elevator=deadline video=uvesafb:mode_option=1280x800-24,mtrr=3,scroll=ywrap
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: nvidia-graphics-drivers
> dmi.bios.date: 06/15/09
> dmi.bios.vendor: Apple Inc.
> dmi.bios.version: MBP55.88Z.00AC.B03.0906151708
> dmi.board.asset.tag: Base Board Asset Tag#
> dmi.board.name: Mac-F2268AC8
> dmi.board.vendor: Apple Inc.
> dmi.chassis.asset.tag: Asset Tag#
> dmi.chassis.type: 10
> dmi.chassis.vendor: Apple Inc.
> dmi.chassis.version: Mac-F2268AC8
> dmi.modalias:
> dmi:bvnAppleInc.:bvrMBP55.88Z.00AC.B03.0906151708:bd06/15/09:svnAppleInc.:pnMacBookPro5,5:pvr1.0:rvnAppleInc.:rnMac-F2268AC8:rvr:cvnAppleInc.:ct10:cvrMac-F2268AC8:
> dmi.product.name: MacBookPro5,5
> dmi.product.version: 1.0
> dmi.sys.vendor: Apple Inc.
> system:
> distro: Ubuntu
> codename: maverick
> architecture: x86_64
> kernel: 2.6.35-19-generic
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/629910/+subscribe
>

Extender (msveshnikov) wrote :

But 260.19.06 has some stability problems (with Ubuntu latest kernel). I have Gt240 and often screen frezzes 10-30 seconds (mainly after console switch or nvidia-settings)

Harry (harry33) wrote :

I have not seen any instability issues with the new beta driver 260.19.06 in my maverick 64-bit setup.
The sluggishness issue is completely gone and also gnome-shell works fluently now.

Please pay attention to that Brandon Snider has uploaded this new beta driver (nvidia-current) in X Updates PPA:
https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
It is built both against lucid and maverick.

Note also that the X updates lucid build cannot be installed on maverick.
The lucid package nvidia-current provides virtual package xserver-xorg-video-6, which would break mavericks xserver 1.9.
The maverick package nvidia-current provides virtual package xserver-xorg-video-8, suitable for xserver 1.9.
Note also, that this is the way it should be.

Extender (msveshnikov) wrote :

I reinstalled packages from that PPA, for now all working good. I suspect standby mode is cause of instability, will check tomorrow after sleep.

eZFlow (breakdevize) wrote :

No issues with the latest beta so far..

Extender (msveshnikov) wrote :

After two suspends - lags and freezings when opening "NVidia X Server settings". Or maybe file another bug on 260.19.06 driver?

This update also fixed the issue for me

Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → Medium
Changed in nvidia-graphics-drivers (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
status: Confirmed → In Progress
importance: Medium → High
Horst Schirmeier (horst) wrote :

260.19.06 fixed the issue here, too (nVidia Corporation G98M [Quadro NVS 160M]). No more problems whatsoever.

Extender (msveshnikov) wrote :

I think 260.19.06 have problems only on GT240 card, only on 64-bit, and in combination with suspend/hibernate.
See http://www.nvnews.net/vbulletin/showthread.php?p=2320537
That bug (performance) is surely fixed.

capacman (achalil) wrote :

Disabling Subpixel Smoothing fixed some issues for me.

Makoto (makotothedragon) wrote :

Echoing similar performance regressions with this particular driver - performance feels sluggish.

Hardware: NVIDIA GT 240
OS: Ubuntu Lucid (10.04 x64)
RAM: 8GB

I'm noticing a trend - the issue seems to be happening more with GT 240 cards rather than any other type.

Magnus (koma-lysator) wrote :

It happens with my GT 200 [GeForce GTX 260] as well.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 260.19.06-0ubuntu1

---------------
nvidia-graphics-drivers (260.19.06-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Fixed an interaction problem with a change in X server
      behavior that caused slow text rendering on X.Org xserver
      1.9 (LP: #629910).
    - Enhanced VDPAU to support interop with CUDA and OpenGL
      when Xinerama is active.
    - Fixed a bug in VDPAU that prevented temporal-spatial
      de-interlacing from operating when temporal de-interlacing
      was not also enabled.
    - Added support for configuring the dithering depth used when
      driving a flat panel with a GeForce 8 family or Quadro
      4600/5600 or newer GPU. See the "Dithering Controls" in the
      Flat Panel page in nvidia-settings.
  * debian/headers, nvidia-current-dev.install{.in}:
   - Put the headers from 256.53 in debian/headers and install
     them in nvidia-current-dev as usual. Starting from the 260
     series, these headers are no longer distributed with the
     Nvidia installer. In Natty we'll package them separately
     but for now we'll keep them in nvidia-current-dev.
  * debian/dkms/patches/nvidia-2.6.36-ioctl.patch:
    - Refresh patch.
 -- Alberto Milone <email address hidden> Mon, 04 Oct 2010 15:02:13 +0200

Changed in nvidia-graphics-drivers (Ubuntu Maverick):
status: In Progress → Fix Released
Charles Profitt (cprofitt) wrote :

My card is affected - Quadro FX 570M -- I am loading the PPA and will let folks know what happens after it is updated and restarted.

Sune Bredahl (sune-bredahl) wrote :

I have a GTX 470 and just updated to the latest version via update-manager and everything seems to be fixed by the 260.19.06 driver update! Thanks!

(does not fix my other nvidia bug # 652731 though, but thats a different issue)

Charles Profitt (cprofitt) wrote :

I am getting better performance but I am still seeing slightly elevated CPU usage. I would think this version of the driver must make it to Maverick.

Yuriy Tkachenko (yuriytk) wrote :

Update to 260.19.06-0ubuntu1 really fixed this issue except for Firefox, in which scrolling is still sluggish.

Arnaud Soyez (weboide) wrote :

Same as Yuriy. My card is a 9800 GT.

The issue seems fixed everywhere except Firefox.
Epiphany, Chromium (and other apps that I've tried) behave correctly (scroll is very smooth).

auxbuss (launchpad-auxbuss) wrote :

Maverick/GeForce GT 330M/Sony Vaio f-series

Update to 260.19.06-0ubuntu1 has resulted in my system displaying a black screen where gdm/login should occur, Logs show no issues. Machine is currently unusable.

How do I revert this?

quiricada (raraland) wrote :

core i7 920 @ 2.67
ram 3gb
dual geforce 9500gt
card 1 drives a digital lcd and an analog lcd using twinview
card 2 drives a samsung tv thru vga port

ubuntu 10.10 rc
2.6.35-22-generic

on boot up, after grub, dual screen blanks out, then after a while, nvidia logo comes up on both screen (twinview), then after a minute or so, the login screen shows up

after login in, the screen freezes for about 20 seconds before desktop is drawn and mouse becomes responsive

on gksu, such as going into synaptic, the screen grey out is laggy before the "sudo" password prompt shows up, after entering password, the grey effect freezes for about 20 seconds before it becomes "normal " and responsive and synaptic appear.

intermittent freeze up, mouse pointer is "lost", then it will pop back and become normal again, cpu spike on the panel system monitor widget

quiricada (raraland) wrote :

nvidia 260.19.06-0ubuntu1

auxbuss (launchpad-auxbuss) wrote :

I workaround my issue by installing the 256.53 drivers directly from nvidia. So anyone else facing an unusable machine that was fine before the 260 downdate, give this a try.

auxbuss (launchpad-auxbuss) wrote :

@quiricada How long did you leave the blank screen before the login screen appeared. Two minutes, five, ten, twenty?

quiricada (raraland) wrote :

@auxbuss

after grub
it goes blank for about 20 seconds
then the nvidia logo comes up for about 1 minute
then the generic background comes up for about 15 seconds
then my chosen photo background comes up for about 15 seconds
then the top and bottom panel appears
then the gnome-do window
then another 5 - 10 seconds before the mouse become responsive and everything becomes "normal"

also (forgot to add this to my previous post)
on shutdown
everything freeze for about 2 minutes before the usual ubuntu shutdown routine of scrolling shutdown messages etc starts to roll

auxbuss (launchpad-auxbuss) wrote :

I left the machine for 1/2 hour, but it does not progress from the blank screen. I simply cannot use 260.19.06-0ubuntu1. This is a huge regression for me. I appreciate it is not this bug, but I cannot find the appropriate bug to file against . Can anyone point me to the appropriate bug for: Maverick Nvidia driver 260.19.06 hangs after starting X?

quiricada (raraland) wrote :

today, i disabled card 2 (see above post) that's running a separate xserver, leaving just card 1 driving 2 monitors on twinview. reboot, and so far, the freeze problem haven't shown up yet.

so is there some problem running 2 xserver?

Florin Coras (fcoras) wrote :

So did the Nvidia 260.19.06 driver solve the issues for you? I've got an Nvidia Quadro 140M NVS, Maverick RC and 260.19.06-0ubuntu1 installed and I'm still seeing poor system performance (eg. scrolling or running a verbose script in gnome-terminal eats one of the cores of my CPU).

Is it just me?

eZFlow (breakdevize) wrote :

I notice that sometimes my whole desktop is slow after a reboot. I have to
re-login to solve it.

On Sat, Oct 9, 2010 at 1:53 PM, Florin Coras <email address hidden> wrote:

> So did the Nvidia 260.19.06 driver solve the issues for you? I've got an
> Nvidia Quadro 140M NVS, Maverick RC and 260.19.06-0ubuntu1 installed and
> I'm still seeing poor system performance (eg. scrolling or running a
> verbose script in gnome-terminal eats one of the cores of my CPU).
>
> Is it just me?
>
> --
> nvidia 256.53 xorg-server 1.9.0 performance regression with antialiased
> text
> https://bugs.launchpad.net/bugs/629910
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “nvidia-graphics-drivers” package in Ubuntu: Fix Released
> Status in “nvidia-graphics-drivers” source package in Maverick: Fix
> Released
>
> Bug description:
> I'm experiencing issues similar to the ones described at:
>
> http://www.nvnews.net/vbulletin/showthread.php?t=154563
>
> Switching font rendering from 'Subpixel Smoothing (LCD)' to any other
> setting in 'Preferences -> Appearance' makes the problem go away.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: nvidia-current 256.53-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic x86_64
> NonfreeKernelModules: nvidia wl
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86_64 Kernel Module 256.53 Fri Aug 27
> 20:27:48 PDT 2010
> GCC version: gcc version 4.4.5 20100824 (prerelease) (Ubuntu/Linaro
> 4.4.4-9ubuntu2)
> Architecture: amd64
> Date: Fri Sep 3 19:49:07 2010
> DkmsStatus:
> nvidia-current, 256.53, 2.6.35-19-generic, x86_64: installed
> bcmwl, 5.60.48.36+bdcom, 2.6.35-19-generic, x86_64: installed
> bcmwl, 5.60.48.36+bdcom, 2.6.32-24-generic, x86_64: built
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
> MachineType: Apple Inc. MacBookPro5,5
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-19-generic
> root=UUID=296cf8e0-5328-43a8-a7d6-f96cb65444a9 ro quiet splash nomodeset
> elevator=deadline video=uvesafb:mode_option=1280x800-24,mtrr=3,scroll=ywrap
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: nvidia-graphics-drivers
> dmi.bios.date: 06/15/09
> dmi.bios.vendor: Apple Inc.
> dmi.bios.version: MBP55.88Z.00AC.B03.0906151708
> dmi.board.asset.tag: Base Board Asset Tag#
> dmi.board.name: Mac-F2268AC8
> dmi.board.vendor: Apple Inc.
> dmi.chassis.asset.tag: Asset Tag#
> dmi.chassis.type: 10
> dmi.chassis.vendor: Apple Inc.
> dmi.chassis.version: Mac-F2268AC8
> dmi.modalias:
> dmi:bvnAppleInc.:bvrMBP55.88Z.00AC.B03.0906151708:bd06/15/09:svnAppleInc.:pnMacBookPro5,5:pvr1.0:rvnAppleInc.:rnMac-F2268AC8:rvr:cvnAppleInc.:ct10:cvrMac-F2268AC8:
> dmi.product.name: MacBookPro5,5
> dmi.product.version: 1.0
> dmi.sys.vendor: Apple Inc.
> system:
> distro: Ubuntu
> codename: maverick
> architecture: x86_64
> kernel: 2.6.35-19-generic
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/629910/+subscribe
>

Extender (msveshnikov) wrote :

Thats another bug of 260.19.06 beta driver, we are waiting for official release from nvidia...

Magnus (koma-lysator) wrote :

The 260.19.06 beta did in fact solve all my issues.

And I think my issues were related to font rendering, so I used to have poor performance when scrolling a verbose script in terminal, etc.

eZFlow (breakdevize) wrote :

Is there a bugreport?

On Sat, Oct 9, 2010 at 4:28 PM, Extender <email address hidden> wrote:

> Thats another bug of 260.19.06 beta driver, we are waiting for official
> release from nvidia...
>
> --
> nvidia 256.53 xorg-server 1.9.0 performance regression with antialiased
> text
> https://bugs.launchpad.net/bugs/629910
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “nvidia-graphics-drivers” package in Ubuntu: Fix Released
> Status in “nvidia-graphics-drivers” source package in Maverick: Fix
> Released
>
> Bug description:
> I'm experiencing issues similar to the ones described at:
>
> http://www.nvnews.net/vbulletin/showthread.php?t=154563
>
> Switching font rendering from 'Subpixel Smoothing (LCD)' to any other
> setting in 'Preferences -> Appearance' makes the problem go away.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 10.10
> Package: nvidia-current 256.53-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic x86_64
> NonfreeKernelModules: nvidia wl
> .proc.driver.nvidia.version:
> NVRM version: NVIDIA UNIX x86_64 Kernel Module 256.53 Fri Aug 27
> 20:27:48 PDT 2010
> GCC version: gcc version 4.4.5 20100824 (prerelease) (Ubuntu/Linaro
> 4.4.4-9ubuntu2)
> Architecture: amd64
> Date: Fri Sep 3 19:49:07 2010
> DkmsStatus:
> nvidia-current, 256.53, 2.6.35-19-generic, x86_64: installed
> bcmwl, 5.60.48.36+bdcom, 2.6.35-19-generic, x86_64: installed
> bcmwl, 5.60.48.36+bdcom, 2.6.32-24-generic, x86_64: built
> InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
> MachineType: Apple Inc. MacBookPro5,5
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.35-19-generic
> root=UUID=296cf8e0-5328-43a8-a7d6-f96cb65444a9 ro quiet splash nomodeset
> elevator=deadline video=uvesafb:mode_option=1280x800-24,mtrr=3,scroll=ywrap
> ProcEnviron:
> LANG=en_US.utf8
> SHELL=/bin/bash
> SourcePackage: nvidia-graphics-drivers
> dmi.bios.date: 06/15/09
> dmi.bios.vendor: Apple Inc.
> dmi.bios.version: MBP55.88Z.00AC.B03.0906151708
> dmi.board.asset.tag: Base Board Asset Tag#
> dmi.board.name: Mac-F2268AC8
> dmi.board.vendor: Apple Inc.
> dmi.chassis.asset.tag: Asset Tag#
> dmi.chassis.type: 10
> dmi.chassis.vendor: Apple Inc.
> dmi.chassis.version: Mac-F2268AC8
> dmi.modalias:
> dmi:bvnAppleInc.:bvrMBP55.88Z.00AC.B03.0906151708:bd06/15/09:svnAppleInc.:pnMacBookPro5,5:pvr1.0:rvnAppleInc.:rnMac-F2268AC8:rvr:cvnAppleInc.:ct10:cvrMac-F2268AC8:
> dmi.product.name: MacBookPro5,5
> dmi.product.version: 1.0
> dmi.sys.vendor: Apple Inc.
> system:
> distro: Ubuntu
> codename: maverick
> architecture: x86_64
> kernel: 2.6.35-19-generic
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/629910/+subscribe
>

Florin Coras (fcoras) wrote :

  @ Magnus
I also thought 260.19.06 solved the issues for me. For example, another
'common' regression which seemed to be solved was scrolling in Firefox
(Chrome wasn't affected, at least not for me). But, what I didn't
mention in my previous post is that for me this works only after a
(re)start and only for a certain period of time (maybe it depends on the
number of open applications). I'm not sure if this is the same problem
as the one reported by eZFlow and Extender or something only I
encountered. Nevertheless, it seldom happens to work properly and only
under light system load.

Nicolay Doytchev (lightrush) wrote :

Are we getting an update to 260.19.12 which is the latest certified driver from NVIDIA instead of the Beta we are currently running?

Hello,

I'm also suffering from performance problems in gnome-terminal and others. Switching on and off again the "Desktop Effects" makes it go away for a while.

Is there a place where one can get the new nvidia package (260.19.12) as a Ubuntu .deb?

Extender (msveshnikov) wrote :

Yes, of course, it's Ubuntu x-swat PPA. Even newer version is there.

Gerry JJ (mjau) wrote :

It seems I just ran into this problem on Ubuntu 12.04 (final beta) with nvidia's binary drivers v295.40, using XFCE. Geany would randomly become extremely slow, sometimes taking seconds to update the text view. Whenever this happened, Xorg used 60-100% CPU. Switching off subpixel rendering in XFCE's display settings fixed it.

Gerry JJ (mjau) wrote :

Sorry, I spoke to soon: Switching off subpixel rendering was only a temporary fix; the problem is suddenly back. Worked for a good while though (tested a while before posting the previous comment).

Nicolay Doytchev (lightrush) wrote :

Gerry, unless you need fast 3D, simply use Nouveau instead.

To post a comment you must log in.