Ubuntu

nvidia-current 195.36.15 + kernel 2.6.32 + dual cards crashes system

Reported by vincefn on 2010-05-02
120
This bug affects 19 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers (Ubuntu)
High
Alberto Milone
Lucid
Undecided
Unassigned
Maverick
High
Alberto Milone

Bug Description

This is a followup on a bug discussion started in bug https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/548362

This bugs is related to a crash when loading X, for PC with at least two nVidia graphics cards and using the nvidia-current drivers (195.36.15) with kernel 2.6.32-any version.

In my case the installation was done with a clean install of Kubuntu Lucid Lynx - booting with the two graphics cards and the nouveau driver works fine. Installing the nVidia driver went also fine, but during reboot the computer froze right around the time X should load. The computer is totally unresponsive, only a hard reset allows rebooting.

The booting issue goes away if one of the two cards is removed or, if using a 2.6.31 kernel with the two cards attached.

Note that in my case only one card has two screens attached, the other has non, for GPU computing.

Using the 195.36.24 nvidia-current driver (from ppa) gives the same results.

This bug is still present after applying all available updates for Lucid.

Attached is the nvidia-bug-report, which aggregate most useful information. What I did was:
1) Start from working 2.6.31
2) reboot on 2.6.32 => crash
3) wait 2 minutes
4) hard reboot to 2.6.31
5) nvidia-bug-report.sh

  In the nvidia-bug-report text file you have aggregated (among other files) the Xorg.0.log and Xorg.0.log.old (just search for 'Xorg.0' to find them). However at the beginning of each log you'll see that the kernel is 2.6.31... In other words during the 2.6.32 boot X did not manage to start logging...

Relevant links:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/548362

http://www.nvnews.net/vbulletin/showthread.php?p=2243704
   => apparently there is an incompatibility between current nvidia graphics driver and the new VGA arbiter (not present in 2.6.31 ?)

vincefn (vincent-favre-nicolin) wrote :
Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
Captain Chaos (launchpad-chaos) wrote :

Same here. Dual NVIDIA Geforce 8800 GTX cards, Lucid Lynx 64-bit Beta 2, after installing nvidia-current drivers with jockey, system will no longer boot. It never even gets as far as writing an Xorg.0.log.

The previous bug report was already about exactly this issue. It's a pity that there is apparently a knee-jerk reaction around here to automatically dismiss any bug report where someone even mentions the NV**IA webs*te...

Dax Marola (lord.xadar) wrote :

Same here.
Easy but inefficient workaround: installing the other nvidia driver (version 173) but system is much slower.
Other workaround: installing kernel 2.6.31 (just get that on kernel-ppa).
Hope to see this solved in this release and not until 6 more months.

vincefn (vincent-favre-nicolin) wrote :

Alan wrote:
"This may be related to https://bugs.launchpad.net/ubuntu/+source/casper/+bug/519123"

 Apparently not - that other bug happens when booting the live CD, which I believe does not use the nvidia driver but rather nouveau. Moreover removing the second card does not help, contrary to this bug (573557).

Eddy (krionic) wrote :

I have the same problem. Just added an old hdd and did a clean install.

Hardware:
Asus P5NE-SLi Motherboard
Intel Q6600 Core2 Quad Processor
4GB DDR Ram
2x nvidia 8600 GT Video cards (linked by SLi cable)

Process was as follows:
1. Installed clean Ubuntu without problems
2. Logged in for first time without a problem
3. Installed the NVidia-Current drivers as provided by the Hardware Drivers panel in System --> Administration
4. Reboot and get a blank screen.

At this point I restarted into my regular build and took a look at the log files. Kern.log and messages in /var/log show the following lines:
May 2 13:22:01 eddy-testdesktop kernel: [ 266.445331] nvidia: module license 'NVIDIA' taints kernel.
May 2 13:22:01 eddy-testdesktop kernel: [ 266.445335] Disabling lock debugging due to kernel taint
May 2 13:22:01 eddy-testdesktop kernel: [ 267.034199] NVRM: The NVIDIA probe routine was not called for 2 device(s).
May 2 13:22:01 eddy-testdesktop kernel: [ 267.034203] NVRM: This can occur when a driver such as rivafb, nvidiafb or
May 2 13:22:01 eddy-testdesktop kernel: [ 267.034204] NVRM: rivatv was loaded and obtained ownership of the NVIDIA
May 2 13:22:01 eddy-testdesktop kernel: [ 267.034205] NVRM: device(s).
May 2 13:22:01 eddy-testdesktop kernel: [ 267.034207] NVRM: Try unloading the rivafb, nvidiafb or rivatv kernel module
May 2 13:22:01 eddy-testdesktop kernel: [ 267.034208] NVRM: (and/or reconfigure your kernel without rivafb/nvidiafb
May 2 13:22:01 eddy-testdesktop kernel: [ 267.034209] NVRM: support), then try loading the NVIDIA kernel module again.
May 2 13:22:01 eddy-testdesktop kernel: [ 267.034211] NVRM: No NVIDIA graphics adapter probed!
May 2 13:22:21 eddy-testdesktop kernel: Kernel logging (proc) stopped.

Eddy (krionic) wrote :

I'm attaching a complete listing of my logs, seeing as I was beat to creating this bug report. :-)

tixetsal (tixetsal) wrote :

I have the same problem. ASUS P5N7A-VM MOBO with 8500GT vid card using "hybrid SLI."
I was first using the default driver, but I wanted a little more performance. The current nvidia driver worked fine right after installation. Today I started getting notice upon boot that I was running in "low graphics mode," and I could sometimes get X to load correctly if I rebooted a few times. I removed the current nvidia driver and rebooted. That's when the really crippling behavior started. I would see some text about the nouvea driver echoed on the screen, and then the boot process would halt with the machine hard-locked. In the BIOS, I disabled the PCI-E 8500GT and was able to make the machine boot. I tried different combos of BIOS settings (PCI-E card off and on) and drivers (173, current, and via running the script for the nividia installer). The best results that I had was a machine that would use the nvidia driver but would hard lock any time that I tried to stop gdm (logout, reboot, shutdown, gdm stop, etc).
I have now physically removed my second video card, removed all of the drivers, reinstalled the current nvidia driver from the repos, and everything is working well with one card.

Jon Sharpe (nomad64) wrote :

I am having the same problem with my setup:
MSI P6N SLI Motherboard
Pentium Core 2 Duo E6850 @ 3.00GHz
2xGeForce 9600 GT cards (SLI)

Machine works fine with only one card, but hard locks at boot up with both cards in. The default (nouvea) driver works fine with both cards.

Daniel Dadap (ddadap) wrote :

Thanks for all the reports. We have tracked this down to a problem with the kernel's VGA arbiter trying to move VGA ownership to a GPU that hasn't POSTed. We're working with the developers of the VGA arbiter to get this fixed in the kernel.

In the meantime, we have a patch which works around the issue by preventing the VGA arbiter from moving VGA ownership away from the default device. It is attached as "NVIDIA_kernel-195.36.24-682377.diff". You can apply the patch by downloading the latest installer from http://www.nvidia.com/object/linux-display-ia32-195.36.24.html (32-bit) or http://www.nvidia.com/object/linux-display-amd64-195.36.24.html (64-bit) and running the installer with the "--apply-patch /path/to/patch.diff" option. This will create a patched installer with a name ending in "-custom.run", which will install a driver with this workaround.

If you're not comfortable with applying the patch yourself, or with working out the conflicts between the driver as installed by the NVIDIA installer and the driver as installed by Jockey (the restricted drivers manager) then please wait until an updated package is available through Jockey.

Changed in nvidia-graphics-drivers (Ubuntu):
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
Filippo82 (filcorti) wrote :

Ok, Ill make a clean install of lucid and then install the patched drivers. Do u suggest to uninstall Nuoveudrivers or anything else before the installation?Thank You

Filippo82 (filcorti) wrote :

Mmm Installation has failed.
I attach the nvidia installer log

Alberto Milone (albertomilone) wrote :

@Daniel
Thanks a lot for the patch

Requesting an SRU

TESTCASE:
plug in two or more nvidia cards, install the nvidia driver (nvidia-current) and boot into kernel 2.6.32 (Lucid's default kernel). Without the patch from upstream the system will freeze.

Dax Marola (lord.xadar) wrote :

The installer fails for me, patched or unpatched, maybe because there's some other module loaded (nouveau). The error is the same of Filippo82.

Filippo82 (filcorti) wrote :

Hi everyone... well I tried to install the drivers with
sudo sh NVIDIA-Linux-x86-195.36.24-pkg1-custom.run -k$(uname -r)
Installation goes on but at the restart I cannot load nvidia.ko
Any help appreciated!
Thanks for working on this bug

Filippo82 (filcorti) wrote :

...testing and testing.... The error says Cannot allocate memory nvidia.ko not loaded.
So I added vmalloc=256M to my kernel line....
Now my cards fans finally are not at full speed and at the command
sudo modprobe nvidia
I dont receive anything....
But.... no 3d effects

Alberto Milone (albertomilone) wrote :

Here is my PPA with the patched package (please follow the instructions):
https://launchpad.net/~albertomilone/+archive/proprietary-video-improvements

Note: please don't try the nvidia installer and the Ubuntu packages at the same time.

Dax Marola (lord.xadar) wrote :

It...can...be...done!

This is what I did: installed Alberto's package through synaptic, but I had no effects... and no xorg.conf.
The easy way: add Alberto's repository and then use jockey (Hardware drivers), everything working as it should!

Thank you Alberto for the package! And thank you Daniel for the patch!

Accepted nvidia-graphics-drivers into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nvidia-graphics-drivers (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Daniel Muller (daniel-muller) wrote :

I'm able now to boot this kernel (linux-image-2.6.32-22-generic-pae installed from "proposed").

Tested on 32bit Lucid
Dual nVidia GeForce 9800 GT
nVidia Driver: 195.36.15-0ubuntu3

Thanks for the fixes

KillerKiwi (killerkiwi2005) wrote :

What about the 173 driver?

Installing the proprietary driver with patch, everything works normally.
Installing the nvidia-current package, install goes OK, but trying to start kde results in the "login loop" -- the greeter comes up, login, the splash screen starts, then jumps back to the greeter. Note that this does NOT happen with the proprietary patched driver.
1. .Xauthority and .ICEauthority are both owned by the appropriate user.
2. Moving .kde out of the way does not solve the problem -- same behavior.
3. Gnome works normally, compositing in gnome works normally.
4. tail of /var/log/kdm.log:
------------------------------------------------
X.Org X Server 1.7.6
Release Date: 2010-03-17
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-27-server x86_64 Ubuntu
Current Operating System: Linux Wolfenstein 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz root=UUID=d3568e88-de4b-4e77-99f9-ea6e9547516d ro nomodeset
Build Date: 23 April 2010 05:11:46PM
xorg-server 2:1.7.6-2ubuntu7 (Bryce Harrington <email address hidden>)
Current version of pixman: 0.16.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Tue May 4 14:23:55 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/usr/lib/X11/xorg.conf.d"
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /tmp/1346053230/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /tmp/0459924307/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address.
IBusInputContext::createInputContext: no connection to ibus-daemon
kdmgreet: Fatal IO error: client killed
 ddxSigGiveUp: Closing log
----------------------------------------------

Since the proprietary patched driver works normally, and the nvidia-current does not, this suggests there is still some problem with the nvidia-current driver. Sorry, jockey does not work on my system, it just gives a blank screen. So I must use apt-get install nvidia-current. Also I cannot do a "clean" install -- the boot CDs all crash, including alternate cds (separate issue - bug report filed).

Dax Marola (lord.xadar) wrote :

@KillerKiwi: in my case the 173 driver has the performance of a slug (it's too slow).

Jon Sharpe (nomad64) wrote :

I added Alberto's PPA (above) to the apt-get sources and installed it successfully. Upon reboot, there wasn't a change and the nVidia X Server Utility said that I wasn't using the nVidia drivers. Ran "sudo nvidia-xconfig --sli=On" and then "sudo /etc/init.d/gdm restart"

Everything is working fine now, and the nVidia X Server Utility shows the correct driver and SLI enabled. I am running Lucid kernel version 2.6.32-21-generic.

Eddy (krionic) wrote :

Tested on 64-bit Lucid

Upgraded kernel to linux-image-2.6.32-22-generic. (Restart required)
Installed package Nvidia-current (195.36.65-Oubuntu3). (Restart required)
From a terminal:
1. sudo service gdm stop
2. sudo nvidia-xconfig --sli=on
3. startx

Drivers load and no further conflicts encountered.

I noticed you can still install the nvidia-current with the .21-generic kernel. I suggest making a dependency for >= .22

Martin Pitt (pitti) on 2010-05-05
tags: added: verification-done
removed: verification-needed
Filippo82 (filcorti) wrote :

Nice....
- added Alberto's ppa (grazie Alberto! Thank you!)
- Nvidia-current (195.36.65-Oubuntu3) installed Restart
- Ctrl F1, gdm stopped
- sudo nvidia-xconfig --sli=on
- startx

and... my windows started wobbling :)

Thanks a lot for the quick fix !

I tested the -proposed packages (manually installed nvidia-current-dev, nvidia-current and nvidia-current-modaliases with version=195.36.15-0ubuntu3), and they work fine !

I tested this with my two nvidia cards, 9600GT+GTX295, without any problem, CUDA also works as expected.

I tried with kernel 2.6.32-21-server and 2.6.31-21-generic - both are working fine => so, no need to require kernel-version>=2.6.32.

Incidentally, if the nvidia-current package is accepted, why not switch to 195.36.24 rather than 195.36.15 ? Especially since 195.36.24 is now the official release, fixing a few bugs, and the patch was also written for 195.36.24 ?

Willie (willjrckt) wrote :

My thanks as well. Before the new nvidia package booting with the 2.6.32-21 kernel would hang even when trying the recovery boot option, which would require me to boot into the 2.6.31-20 kernel do make any configuration changes.

Tested with : ASUS P5NE-SLI motherboard with GeForce 9800 GT in SLI mode on Ubuntu lucid 64 bit version.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers - 195.36.15-0ubuntu3

---------------
nvidia-graphics-drivers (195.36.15-0ubuntu3) lucid-proposed; urgency=low

  * debian/dkms/patches/vga_arbiter_workaround.patch:
    - Prevent X from crashing with kernel 2.6.32 when 2 or more
      nvidia cards are available (LP: #573557).
 -- Alberto Milone <email address hidden> Tue, 04 May 2010 13:03:46 +0200

Changed in nvidia-graphics-drivers (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to maverick.

Changed in nvidia-graphics-drivers (Ubuntu Maverick):
status: Confirmed → Fix Released

"This bug was fixed in the package nvidia-graphics-drivers - 195.36.15-0ubuntu3"

Well, not quite.

I am running kubuntu 10.04, with kde desktop. When I boot with the nvidia-current driver (which is 195.36.15-0ubuntu3) I get to the kdm login screen. I log in, the kde ksplasher screen starts, then quits, and I get thrown back to the login screen (the "kde login loop problem"). Switching to a gnome session works, and gnome appears to be working properly (the visual effects all work). But I can't get into kde at all.

What I did:
1. Logged out of kde, into the console.
2. sudo service kdm stop ;; kill x
3. sudo nvidia-installer --uninstall ;; remove patched proprietary drive that works properly
4. sudo apt-get install nvidia-current nvidia-settings ;; install 195.36.15-0ubuntu3
5. sudo reboot
6. boot with 'nomodeset' kernel option
7. Gets to kdm greeter, and after login, loops back to greeter. Only way out is to choose something other than kde.
8. Tried turning off compositing in kwinrc - didn't help.
9. Tried removing my xorg.conf - didn't help.
10 tried using 'sudo nvidia-xconfig' to set up a new xorg.conf - didn't help.
11. Removing the nvidia-current package and reinstalling the patched proprietary driver - fixes.

So there is something in nvidia-current that still isn't working right. (unless I messed something)

Alberto Milone (albertomilone) wrote :

@doctordruidphd
First of all, the fact that X starts (as you can see kdm) is a clear sign that you're not experiencing the same issue any more.

Furthermore, as I said in bug #548362, installing the driver from the nvidia installer must have left your system in a broken state (as you're not using the alternatives system any more). See the following comment:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/548362/comments/37

At this point I suggest that you either keep using the nvidia installer or that you perform a clean installation of Ubuntu and use only our packages.

"At this point I suggest that you either keep using the nvidia installer or that you perform a clean installation of Ubuntu and use only our packages."

I managed to get the problem solved. I removed the proprietary driver, using "sudo nvidia-installer --uninstall".
Next, apt-get install nvidia-current. Then, do an apt-get remove --purge nvidia-current. This gets rid of most of the hanging config files, plus it spits out a list of "not empty" files and directories, which I manually removed. I had to purge xserver-xorg-video-nouveau, too.Then I was able to install the driver from gnome (kde still wouldn't start) using jockey. Then I could put back my custom xorg.conf (which is needed to run the two video cards in sli configuration). Now all is well with kde, except jockey is unhappy that I have a custom xorg.conf. Too bad. It's alive.

By the way, a workaround has been found to get the live cds to boot on Dell systems. Doing that, I was able to do a "clean" install. What I found is that all of the video drivers are located in exactly the same places as on the supposedly corrupt system. So for this system, they are being installed somewhere other than specified in https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers/+bug/548362/comments/37, even in a clean install.

gled (t-mahe) wrote :
Download full text (4.5 KiB)

Hi, this bug seems not resolved for me,

One nvidia Geforce 210 (PCIE 03:00.0 ) , two Geforce 6200 ( PCI 04:08.0 & 04:09.0 ) on a Dell E521 ( Amd ) with 4G ram.

I made a fresh install of ubuntu 10.04. Upgraded all using "synacptic".

When booting without using nvidia, no problem, I get only two screens working ( the g210 ones ).

I have nvidia-current|nvidia-current-modaliases|nvidia-current-dev 195.36.15-0ubuntu3 installed.

Activated proprietary drivers using jockey.

First reboot is OK, I get a single screen on my G210.

launch nvidia-settings, activate only 4 screens ( ie 2 screens on the G210, one on each 6200 =.

After reboot there's a black screen that never ends.

Ok let's reboot in recovery mode, comment the two 6200 screens, no more problems.

Interesting parts of logs:

/var/log/messages:

May 19 12:40:56 gled-desktop kernel: [ 0.429785] vgaarb: device added: PCI:0000:03:00.0,decodes=io+mem,owns=io+mem,locks=none
May 19 12:40:56 gled-desktop kernel: [ 0.429790] vgaarb: device added: PCI:0000:04:08.0,decodes=io+mem,owns=none,locks=none
May 19 12:40:56 gled-desktop kernel: [ 0.429794] vgaarb: device added: PCI:0000:04:09.0,decodes=io+mem,owns=none,locks=none

May 19 12:40:56 gled-desktop kernel: [ 10.059512] nvidia: module license 'NVIDIA' taints kernel.
May 19 12:40:56 gled-desktop kernel: [ 10.059517] Disabling lock debugging due to kernel taint
May 19 12:40:56 gled-desktop kernel: [ 10.414331] kjournald starting. Commit interval 5 seconds
May 19 12:40:56 gled-desktop kernel: [ 10.640233] ACPI: PCI Interrupt Link [APC5] enabled at IRQ 16
May 19 12:40:56 gled-desktop kernel: [ 10.640255] nvidia 0000:03:00.0: PCI INT A -> Link[APC5] -> GSI 16 (level, low) -> IRQ 16
May 19 12:40:56 gled-desktop kernel: [ 10.640268] vgaarb: device changed decodes: PCI:0000:03:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
May 19 12:40:56 gled-desktop kernel: [ 10.640271] vgaarb: transferring owner from PCI:0000:03:00.0 to PCI:0000:04:09.0
May 19 12:40:56 gled-desktop kernel: [ 10.640741] nvidia 0000:04:08.0: enabling device (0000 -> 0002)
May 19 12:40:56 gled-desktop kernel: [ 10.641767] ACPI: PCI Interrupt Link [APC1] enabled at IRQ 16
May 19 12:40:56 gled-desktop kernel: [ 10.641775] nvidia 0000:04:08.0: PCI INT A -> Link[APC1] -> GSI 16 (level, low) -> IRQ 16
May 19 12:40:56 gled-desktop kernel: [ 10.641792] vgaarb: device changed decodes: PCI:0000:04:08.0,olddecodes=io+mem,decodes=none:owns=none
May 19 12:40:56 gled-desktop kernel: [ 10.642062] nvidia 0000:04:09.0: enabling device (0000 -> 0002)
May 19 12:40:56 gled-desktop kernel: [ 10.642365] ACPI: PCI Interrupt Link [APC2] enabled at IRQ 17
May 19 12:40:56 gled-desktop kernel: [ 10.642381] nvidia 0000:04:09.0: PCI INT A -> Link[APC2] -> GSI 17 (level, low) -> IRQ 17
May 19 12:40:56 gled-desktop kernel: [ 10.642393] vgaarb: device changed decodes: PCI:0000:04:09.0,olddecodes=io+mem,decodes=none:owns=none
May 19 12:40:56 gled-desktop kernel: [ 10.642605] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.15 Fri Mar 12 00:29:13 PST 2010
May 19 12:41:36 gled-desktop kernel: Kernel logging (proc) stopped.
--> failure, have to hard reboot...

/var/log/...

Read more...

Alberto Milone (albertomilone) wrote :

@gled
You said that first reboot was ok, except for the fact that you could use only one screen. Were you still affected by the problem you wouldn't even get 1 screen to work as the xserver would crash.

This bug is fixed. I think you're experiencing either some misconfiguration problem or maybe some hardware limitation.

gled (t-mahe) wrote :

Well maybe it's not the same bug, or misconfiguration but:

- I made a fresh install this morning because before I was on ubuntu 10.04 too and made too much tests with nvidia official drivers && removing/installing nvidia-current so I installed fresh, thinking that maybe I messed up things with the fixed driver.

- The thing is that using the previous nvidia-current ( 195.36.15 not fixed ), the behaviour was the same, ie, one card only declared in xorg.conf ( no device section for the others or at least screen section commented out in "ServerLayout" ), no problem, X did not care about the 2 others. Adding the config for the two others ( or at least one of the others ) leads to failure.

- I don't believe in hardware limitation, because everything is working great under debian 5 or ubuntu 9.10.
I also tried with my xorg.conf from these previous distrib, and it is failing under U-10.04.

- last: Is the line "vgaarb: transferring owner from PCI:0000:03:00.0 to PCI:0000:04:09.0" normal ?

Regarding misconfiguration, how can nvidia-settings mess up things ? It's the way everyone is doing its config, and I purposely did simple things ( no fancy X options, no hand editing appart commenting out the screens from the 6200 in ServerLayout to be able to boot and report this to you ).

If you want me to test or provide debugs/strace... don't hesitate... you can contact me here or by mail if you want I'll be glad to help !
I really want to fix this so I can prove my admin that winblows sucks :) , and don't know much about this, I'm a developper too, but in voip, not in desktop env...

@gied:
The behavior looks a bit different so it's not the same bug - which is why you'll have to file another bug report, otherwise you won't get attention.

It would be interesting to test if you can solve your issues by using kernel 2.6.31, as I did before (you can find it in ftp://ftp.ubuntu.com/ubuntu/pool/main/l/linux/) - if you can boot normally with 2.6.31 and not 2.6.32 (without any other changes), then it may be related to the current bug report, and would interest guys @nvidia.

You should also post all relevant info (e.g. xorg.conf)

PS: I also have the "vgaarb: transferring owner" messages in my log, around boottime, so it's probably harmless.

gled (t-mahe) wrote :

boot is ok using 2.6.31 ( although I forgot to install kernel-headers and had some fear with nvidia module not being loaded at first )

Nevermind, I reinstalled debian 5 which I know is stable, too bad for the ease of use, but stability is at that cost, and I need to work...

If you need me for some debug, ask :=)

Alberto Milone (albertomilone) wrote :

@gled
If you didn't install the headers the nvidia module wasn't built and loaded for sure, therefore your test doesn't prove much.

If you're available to help debugging the problem, please file a new bug report and I'll make sure to subscribe upstream.

Thanks

gled (t-mahe) wrote :

Alberto, I expressed myself wrong or you misunderstand me, I did install then the kernel headers and reenable nvidia driver.

I wouldn't have posted if I had not tested with the nvidia-current loaded, I know it's non-sense if it boots with another driver...

Anyway, let me the time to reinstall a ubuntu and I'll open a bug report...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers