Ubuntu

ABI change in xorg 1.9 breaks legacy nvidia-96 drivers in Maverick

Reported by Darik Horn on 2010-08-30
850
This bug affects 174 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
X.Org X server
Invalid
Undecided
Unassigned
jockey (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Alberto Milone
nvidia-graphics-drivers-96 (Ubuntu)
Medium
Alberto Milone
Maverick
Medium
Alberto Milone

Bug Description

Per bug 616394, xorg-1.9 is incompatible with the nvidia-96 and nvidia-173 driver packages that are currently in Maverick. These are the proprietary drivers in Ubuntu for Nvidia hardware prior to the GeForce 6000 series.

Perhaps a "Breaks: nvidia-96, nvidia-173" or some such line could be added to the xserver-common control file to keep the X.org 1.7 installation from Lucid intact during an upgrade to Maverick.

Bryce Harrington (bryce) on 2010-08-31
Changed in xorg-server (Ubuntu):
status: New → Confirmed
Bryce Harrington (bryce) on 2010-08-31
tags: added: maverick
NoOp (glgxg) wrote :

Any update on nvidia-96 and maverick (10.10)? The 10.10 release date is drawing near & still no working nvidia-96 in maverick. Quite a few legacy cards will be affected by this issue:

====
http://www.nvidia.com/object/linux-display-ia32-96.43.18-driver.html
GeForce 4 MX series:
MX 440, MX 440 (AGP 8X), MX 420 (AGP 8X), MX 420, MX 440-SE, MX
Integrated GPU, MX 460, MX 440SE (AGP 8X), MX 4000

Quadro NVS series:
NVS 285, NVS 55/280 PCI, NVS 210, NVS 420, NVS 450, NVS 50, NVS 295, NVS
280, NVS 440, NVS 290

Quadro 4 Go series:
500 GoGL, 550 XGL, 700 GoGL

Quadro 2 Go series:
MXR/EX/Go

GeForce 4 Ti series:
Ti 4800, Ti 4800 SE, Ti 4400, Ti 4200 (AGP 8X), Ti 4200, Ti 4600

GeForce 2 series:
Ti 200, GeForce3, Ti 500

Quadro 2 MXR series:
Quadro2 MXR/EX/Go
====

Including my machines with nVidia NV25GL [Quadro4 900 XGL] cards in them.

luk1don (luk1don) wrote :

I confirm too. Last working version with the nvidia-96 is: xserver-xorg-core 2:1.8.1.902-0ubuntu2.
The solution is downgrade to that package but it breaks some dependencies...

Charlie Jolly (charlie-jolly) wrote :

Breaking 3D acceleration needs a big fat warning for anyone upgrading...

As a note: 260.xx beta drivers on Nvidia site incorrectly stated as being compatible with GeForce 5 series, at least with AGP cards....

Wish there was an easy menu so I could choose my driver... e.g. NV, Nvidia, Nouveau, Vesa etc

Going to try and downgrade xorg trick..

Charlie Jolly (charlie-jolly) wrote :

>[ 562.979] (II) LoadModule: "nvidia"
>[ 562.980] (II) Loading /usr/lib/xorg/extra-modules/nvidia_drv.so
>[ 563.018] dlopen: /usr/lib/xorg/extra-modules/nvidia_drv.so: undefined symbol: miEmptyData
>[ 563.018] (EE) Failed to load /usr/lib/xorg/extra-modules/nvidia_drv.so
>[ 563.018] (II) UnloadModule: "nvidia"
>[ 563.018] (EE) Failed to load module "nvidia" (loader failed, 7)
>[ 563.018] (EE) No drivers available.

THe Same Problem would be IF I Upgrade to Maverick... I Hope it doesnt take so long to fix it, because there alot people with such Cards... Just Like me and my Geforce 4 Ti 4200 AGP :D

DoDuS (sveterv) wrote :

If I only knew about that problem before upgrade I have just made few hours ago :( (10.04.1->10.10) Now I'm stuck with nv driver, as nouveau is so slow on my machine, that even moving mouse pointer over menus makes lag. That's really bad, I hope nvidia-96 binary drivers will work with Ubuntu 10.10 as soon as possible.

Here is what Xorg.0.log says:

[ 241.130] (II) LoadModule: "nvidia"
[ 241.130] (II) Loading /usr/lib/xorg/extra-modules/nvidia_drv.so
[ 241.131] dlopen: /usr/lib/xorg/extra-modules/nvidia_drv.so: undefined symbol: miEmptyData
[ 241.131] (EE) Failed to load /usr/lib/xorg/extra-modules/nvidia_drv.so
[ 241.131] (II) UnloadModule: "nvidia"
[ 241.131] (EE) Failed to load module "nvidia" (loader failed, 7)
[ 241.131] (EE) No drivers available.
[ 241.131]
Fatal server error:
[ 241.131] no screens found

Darik Horn (dajhorn) wrote :

An NVIDIA staffer said that the nvidia-173 drivers are being updated for X.org 1.9 here:

http://www.nvnews.net/vbulletin/showpost.php?p=2325872&postcount=2

On 09/30/2010 01:35 PM, Darik Horn wrote:
> An NVIDIA staffer said that the nvidia-173 drivers are being updated for
> X.org 1.9 here:
>
> http://www.nvnews.net/vbulletin/showpost.php?p=2325872&postcount=2
>

Unfortunately it's very quiet on the 96 front:
<http://www.nvnews.net/vbulletin/showthread.php?t=154895&highlight=xorg+1.9>

And nvidia-173 drivers are updated..

    * Added support for X.Org xserver 1.9.
    * Updated nvidia-installer to detect the nouveau kernel module and fail with an appropriate error message.

http://www.nvnews.net/vbulletin/showthread.php?p=2326225

I now have 173.14.28 running in Maverick, Xserver 1.9 with Geforce FX5700 Ultra.

As noted in a post from Mytonn, the drivers are from http://www.nvnews.net/vbulletin/showthread.php?p=2326225 .

Darik Horn (dajhorn) wrote :

Kudos to Aaron at Nvidia for providing excellent ongoing Linux support.

Darik Horn (dajhorn) wrote :

I don't see the new 173.14.28 driver in the Ubuntu x-swat queue, so I updated the nvidia-173 package and put it here:

  https://launchpad.net/~dajhorn/+archive/x-updates/

This updated Nvidia driver is compatible with my 32-bit Ubuntu 10.10 Maverick RC computer where I have older hardware. The 64-bit build installs cleanly, but I haven't tested it.

An updated nvidia-96 driver isn't yet availabe on the upstream FTP server.

Ryu Ito (kumaryu-watchtower) wrote :

As reported in:

Ubuntu “nvidia-graphics-drivers-173” package Bugs Bug #626918
"Nvidia 173 driver does not work with xserver 1.9 "

nvidia-graphics-drivers-173 (173.14.28-0ubuntu1) maverick

has now been released. I can confirm that it is now included in the most recent set of updates for maverick.

auxbuss (launchpad-auxbuss) wrote :

A regular aptitude upgrade installed the updated nvida-173-modaliases and has made my maverick machine useless. I get a black screen after starting X. No gdm/login appears. /var/log/Xorg.0.log indicates no problems at all; it reaches "enabled".

Maverick/GeForce GT 330M/Sony Vaio f-series

Julien Aubin (gojulgarbmail) wrote :

auxbuss > You should use package nvidia-current, not NVidia-173. I'm not even sure your card is supported by driver nvidia-173...

auxbuss (launchpad-auxbuss) wrote :

To be honest, looking at the nvidia package installed, I'm not clear what I should or should not have. I've not had problems here before, so I've never looked. For background, this machine was upgraded from Lucid. I have the following installed:

nvidia-173-modaliases
nvidia-96-modaliases
nvidia-common
nvidia-current
nvidia-current-modaliases
nvidia-settings

It looks like 173, 96, and common can go, so I'll try that and leave this bug alone. Apologies.

Omega-xis (nieknooijens) wrote :

got an older model with geforce 4-mx which is affected.
however, my quadcore with the nvidia 9600GTX isn't affected, it works fine on that machine.

Changed in ubuntu-release-notes:
status: New → In Progress
Felix (apoapo) wrote :

I experience non-working drivers with a "geforce 4200 ti"

I have a newer Nvidia GTS250, Ubuntu 10.10 final boot CD just gives me screen with big green squares after 20-30 seconds of choosing an option from the grub. Have been facing this issue since the beta and sadly the issue exists even in the final version.

Here's a video of what I see. http://www.youtube.com/watch?v=KKiks45jMEU

Brian Rogers (brian-rogers) wrote :

Hardeep, you should file a new bug report for that. It's not related to this bug.

Philip Muškovac (yofel) wrote :

@Hardeep: Please file a bug against xserver-xorg-video-nouveau as ubuntu uses nouveau until you install the proprietary nvidia driver yourself. (Meaning the live disk uses nouveau)

Xebozone (markdavidoff) wrote :

Confirmed still not working with my
HP GFX PCA GeForce4 MX440-8X 64MB DDR w/comp TV (part no. 5187-3706)

even with nvidia-current drivers installed

belovedmonster (jd-hartland) wrote :

Xebozone, your card will use nvidia-96, which hasn't been fixed by the Nvidia guys yet (unless something has changed I'm not aware of). Until they issue a fix this bug can't be fixed. We are waiting on them to supply the fix.

mutineer612 (mutineer612) wrote :

I recently upgraded from 10.4 to 10.10 x64 and found out the hard way that 10.10 has issues with nVidia GeForce8400 due to newer version of Xorg 1.9. I had the nVidia driver 'current' working with my nVidia GeForce 8400 when I performed the upgrade from 10.4, and after rebooting found that the system booted to a purple background image with no login prompt. I tried booting into recovery mode by holding shift while booting and disabling the nVidia driver and rebooting.

Now with the driver removed the system boots to purple background screen with the ubuntu status indicators (dots) and makes the drum sound normally followed by the login prompt, but I'm unable to see it and none of the function keys work to drop to a console. However if I perform the reboot again with the drivers removed I'm able to hold down the shift key while booting and enter recovery mode again and then select safe graphics mode to access the system, and this seems to work ok, but I cannot get the system to boot without performing these manual steps.

Adam Reeve (adreeve) wrote :

Mutineer612, this bug has nothing to do with your problem, it is for older cards using the nvidia-96 drivers. If you think you've found a bug and can't find it reported in Launchpad then please create a new bug report.

eMcE (emce) wrote :

Confirmed. Affect me too :( after upgrade from 10.04.
GF5200 AGP, Ubu 10.10, Xorg 1.9

calinflorin (calinflorin2000) wrote :

Same here with nvidia gt240. When trying to install I get pixel-ed screen in 10.10 and cut-off window screen in 10.04 LTS.

Antoine Jouve (aj94tj) wrote :

This bug affects my Geforce MX440. But I fear that this bug won't be fix one day because the nvidia's guys don't care about our old graphics cards :(

Laurent (laurent-q) wrote :

Same problem for me with my GeForce 8500 GT and the nvidia-173(current) after a fresh install of 10.10

G M Slater (precipitous-media) wrote :

For what it's worth - I have a GeForce 7300 and am running the Current driver (UbuntoStudio). I can boot into the generic kernel fine, but trying to boot into either 2.6.35-20-Low Latency, or 2.6.33-29-Realtime gives me only a command prompt. Unfortunately, I must have one of these kernels working for music production...

LostOverThere (lostoverthere) wrote :

Yeah, this is a huge problem for people with legacy cards (which is a great deal of people running Linux). I had huge problems even setting the correct resolution (which wasn't detected correctly).

Running a Geforce MX 440 (AGP 8X) here.

Rob Bruce (r-bruce) wrote :

Affects my PCI Express 2 Quadro FX 580. I didn't even think this was all that old of a card (it's still available).

Algo (algo-lkma) wrote :

Too bad, affect my Geforce2 MX400 too.

As a temporary solution, I edit xorg.conf, and change:

From

 Driver "nv"

To

 Driver "vesa"

At least, we can run xWindows ^_^

ludwigmace (mason-schoolfield) wrote :

If you're not sure if your card uses a legacy Nvidia driver or not, please see this list:
http://www.nvidia.com/object/IO_32667.html

It looks like this bug report is specifically for nvidia-96 and nvidia-173 drivers. So if your card (or its PCI ID) isn't on the above list underneath the 173.14.xx or 96.43.xx sections then unfortunately you won't find much help in this bug report; somebody out there please correct me if I'm wrong :)

And since 173.14.xx has already been fixed it looks like we're basically waiting on 96.43.xx drivers, which I'm guessing will be out in about a week or so.

eMcE (emce) wrote :

Maybe this helps someone.
Its from OMG website.
Thnx to "saurabhneo23"
http://www.omgubuntu.co.uk/2010/10/nvidia-96-driver-ubuntu-10-10-fix/#comment-86227499

--

"If you can't fix it then downgrade it " :D

Well those who couldn't get their Nvidia drivers working with Ubuntu 10.10 due to newer version of Xorg-Xserver try to do the following : (it worked for me ;))

1) Remove any form of Nvidia drivers , configuration files and anything related to it. I dropped to vesa drivers but that is not necessary.
1) Backup /etc/apt/sources.lst and change all instances of "maverick" for "lucid"
2) In Synaptic, remove xserver-xorg
3) Reload/update the sources and install xorg
4) Install the Nvidia driver which you know worked with Lucid. In my case it is 195.36.24
5) change the sources.lst back to maverick
6) Reconfigure the xserver: sudo dpkg-reconfigure xserver-xorg
7 ) Now run these commands one after the another :
-- sudo update-alternatives --config gl_conf
-- sudo ldconfig
-- sudo update-initramfs -u
-- sudo nvidia-xconfig
8) Now using synaptic lock the version of these downgraded packages (xorg, nvidia-current, etc ) so that they don't get upgraded automatically
9) Restart.

Rob Bruce (r-bruce) wrote :

@ludwigmace
Thanks for that link. Looks like I have a different problem (albeit having the same net effect) thus a different bug.

Anyway, for anyone wondering what the PCI ID of their Nvidia card is but not knowing where to look, try

 lspci -d 10de: -nn

(to filter out everything by Nvidia)

or just:

 lspci -nn

(if you want to see all your PCI hardware by every manufacturer.)

The PCI ID is the XXXX in the [10de:XXXX] that follows the manufacturer and product names

Infocenter has the info too, but you've got to dig through a few layers and didn't immediately pop out at me.

roddi (ruotger-skupin) wrote :

Oh Man!

instead of warning you or downgrading the driver to something without acceleration that works, they let you run into that known trap! I'm really disappointed. Luckily Linux is only a hobby for me.

R

I ran into this issue while upgrading from 10.4 to 10.10 on my 6 years old Dell Inspiron 8600.

According to lspci, my card is:
01:00.0 VGA compatible controller: nVidia Corporation NV28 [GeForce4 Ti 4200 Go AGP 8x] (rev a1)

If I try to use the nvidia driver in my Xorg configuration file, then X windows fails to start. If I comment out the driver line, then I think I was getting a generic driver, but the resolution was awkward, and I didn't the proper aspect ratio (the screen was compressed) and I couldn't get nice resolution).

So I removed the proprietary driver, and now X Windows is able to start, and the resolution is as usual. I think this is due to the "NOUVEAU" driver that comes by default (I saw that in /var/logs/Xorg.0.log).

The main drawback: all the animated icons and windows decorations look very awful. It is like the bitmaps are off or something like it. I still prefer this option over the bad aspect/resolution, or downgrading Xorg.

Hopefully the Nvidia 96 driver will be updated to fix the issue with Xorg, or the nouveau driver will be updated to remove the annoying bitmap effects (I don't know how else to describe this).

To be fair, the issue touches several software components, and it is not easy to convince all of them to march towards the same release schedule.

eMcE (emce) wrote :

Update:

--
1) Remove any form of Nvidia drivers , configuration files and anything related to it. I dropped to vesa drivers but that is not necessary.
1) Backup /etc/apt/sources.lst and change all instances of "maverick" for "lucid"
2) In Synaptic, remove xserver-xorg and jockey-gtk
3) Reload/update the sources: sudo apt-get update and install xorg and jockey
There may be needed reboot.
4) Install the Nvidia driver which you know worked with Lucid. In my case it is 195.36.24
5) change the sources.lst back to maverick
6) Reconfigure the xserver: sudo dpkg-reconfigure xserver-xorg
7 ) Now run these commands one after the another :
-- sudo update-alternatives --config gl_conf
-- sudo ldconfig
-- sudo update-initramfs -u
-- sudo nvidia-xconfig
8) Now using synaptic lock the version of these downgraded packages (xorg, nvidia-current, etc ) so that they don't get upgraded automatically
9) Restart.

Robert Hooker (sarvatt) on 2010-10-19
summary: - ABI change in xorg 1.9 breaks legacy nvidia-96 and nvidia-173 drivers in
- Maverick
+ ABI change in xorg 1.9 breaks legacy nvidia-96 drivers in Maverick
luk1don (luk1don) on 2010-11-05
affects: xorg-server (Ubuntu Maverick) → nvidia-graphics-drivers-96 (Ubuntu Maverick)
Philip Muškovac (yofel) on 2010-11-13
Changed in nvidia-graphics-drivers-96 (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in nvidia-graphics-drivers-96 (Ubuntu Maverick):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-96 (Ubuntu Maverick):
assignee: nobody → Alberto Milone (albertomilone)
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Triaged → In Progress
Changed in nvidia-graphics-drivers-96 (Ubuntu Maverick):
status: Triaged → In Progress
Martin Pitt (pitti) on 2010-11-22
Changed in jockey (Ubuntu Maverick):
assignee: nobody → Alberto Milone (albertomilone)
status: New → In Progress
Changed in nvidia-graphics-drivers-96 (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) on 2010-11-23
Changed in jockey (Ubuntu Maverick):
status: In Progress → Fix Committed
Changed in jockey (Ubuntu):
status: New → Fix Committed
99 comments hidden view all 179 comments

@NoOp
That's because you removed nvidia-common (which is what Jockey uses to do hardware detection with nvidia).

In other words I think things are ok. A one-line change in Jockey didn't cause that.

Hey guys, can you help me? I don't know why packages from maverick-proposed repository not worked in my ubuntu.

For the first i was remove dajhorn repository from my repository list by "sudo apt-add-repository --remove ppa:dajhorn/nvidia-96".
After: apt-get update.

Then "apt-cache policy jockey-common" told:

jockey-common:
  Установлен: 0.5.10-0ubuntu5.2
  Кандидат: 0.5.10-0ubuntu5.2
  Таблица версий:
 *** 0.5.10-0ubuntu5.2 0
        500 http://mirror.yandex.ru/ubuntu/ maverick-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     0.5.10-0ubuntu5.1 0
        500 http://mirror.yandex.ru/ubuntu/ maverick-updates/main i386 Packages
     0.5.10-0ubuntu5 0
        500 http://mirror.yandex.ru/ubuntu/ maverick/main i386 Packages

and "apt-cache policy nvidia-96" told:

nvidia-96:
  Установлен: (отсутствует)
  Кандидат: 96.43.19-0ubuntu1
  Таблица версий:
     96.43.19-0ubuntu1 0
        500 http://mirror.yandex.ru/ubuntu/ maverick-proposed/restricted i386 Packages
        100 /var/lib/dpkg/status
     96.43.18-0ubuntu1 0
        500 http://mirror.yandex.ru/ubuntu/ maverick/restricted i386 Packages

Then tried to install nvidia-96: "sudo apt-get install nvidia-96"

Then rebooted and recieved this:

[ 54.450] (II) NVIDIA(0): Initialized GART.
[ 54.458] (EE) NVIDIA(0): Failed to allocate/map the primary surface!
[ 54.459]
Fatal server error:
[ 54.459] AddScreen/ScreenInit failed for driver 0
[ 54.459]
[ 54.459]
Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
[ 54.461] Please also check the log file at "/var/log/Xorg.3.log" for additional information.
[ 54.461]
[ 54.584] ddxSigGiveUp: Closing log

Why it's not working for me ?

Darik Horn (dajhorn) wrote :

Petr: Delete the /etc/xorg.conf file, toggle the nvidia-96 driver off/on at System -> Administration -> Additional Drivers, and restart the computer.

The "Failed to allocate/map the primary surface" error is caused by a missing AddARGBGLXVisuals option in the xorg.conf file. Jockey creates a correct xorg.conf file.

Some cards don't start if this option is missing, and others get GL artifacts like the desktop wallpaper being used in all transparencies.

> @NoOp
> That's because you removed nvidia-common (which is what Jockey uses to do hardware detection with nvidia).
>
> In other words I think things are ok. A one-line change in Jockey didn't
> cause that.
>

Ah. Got it. That makes sense. Thanks.

Darik Horn, thanks for your advise, but still not working.

petka@petka-ubuntu-pc:~$ cat /var/log/Xorg.1.log
....
[ 49.159] (II) NVIDIA(0): Initialized GART.
[ 49.178] (EE) NVIDIA(0): Failed to allocate/map the primary surface!
[ 49.181]
Fatal server error:
[ 49.183] AddScreen/ScreenInit failed for driver 0
[ 49.183]
[ 49.183]
Please consult the The X.Org Foundation support
  at http://wiki.x.org
 for help.
[ 49.183] Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[ 49.183]
[ 49.369] ddxSigGiveUp: Closing log

petka@petka-ubuntu-pc:~$ cat /etc/X11/xorg.conf

Section "Screen"
 Identifier "Default Screen"
 DefaultDepth 24
 Option "AddARGBGLXVisuals" "True"
EndSection

Section "Module"
 Load "glx"
EndSection

Section "Device"
 Identifier "Default Device"
 Driver "nvidia"
 Option "NoLogo" "True"
EndSection

Manfred Hampl (m-hampl) wrote :

@Petr: Some ideas:
1. In several messages about problems with the nVidia driver it is recommended to add not only
-> Option "AddARGBGLXVisuals" "True"
but also
-> Option "DisableGLXRootClipping" "True"
to the xorg.conf file
Can you try that?
2. you might also try to delete your xorg.conf and re-create it with nvidia-xsettings
3. any error messages related to the video card in your boot logs?

Algo (algo-lkma) wrote :

In case having problem, can try to remove compiz first.
At first my Ubuntu always halted with the new driver too!

luk1don (luk1don) wrote :

Petr A. Sokolnikov@
Probably a framebuffer problem. Try options in kernel line, eg.:
vga=794, vga=791, vga=798, ... or some changes in grub configuration.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.6-0ubuntu1

---------------
jockey (0.6-0ubuntu1) natty; urgency=low

  [ Alberto Milone ]
  * data/handlers/nvidia.py:
    - Re-enable nvidia-96 now that it's compatible with xserver 1.9.
      (LP: #626974).

  [ Martin Pitt ]
  * New upstream release 0.6:
    - Add support and test case for reading modaliases from package headers.
    - Put back "Additional Drivers" progress window title. Thanks Bilal
      Akhtar! (LP: #323815)
    - jockey/detection.py, get_hardware(): Disable printer detection.
      cupshelpers.getDevices() is excruciatingly slow (about 15 seconds), and
      jockey is not normally used directly to install printer drivers.
      Instead, system-config-printer picks up new printers, and calls jockey
      with the device ID, so jockey does not need to detect printers by
      itself.
    - jockey-kde: Use runtime .ui loading instead of pykdeuic4; the latter
      just keeps breaking.
    - gtk/jockey-gtk.ui: Drop obsolete has_separator property; Explicitly set
      topmost GtkVBox fill property to True, as the default changed in GTK 3.0
      (GNOME #634592)
    - Various test suite fixes.
  * debian/control: Drop now obsolete python-{qt4,kde}* build dependencies.
  * debian/jockey-kde.install: Install the KDE *.ui files.
  * jockey/oslib.py, has_repositories(): Greatly speed up (5 seconds →
    negligible) by calling "apt-cache policy" instead of creating an
    apt.Cache() object.
  * Drop data/handlers/b43.py, our linux-firmware package ships the b43
    firmware now. Also, the wl driver is generally a lot better.
  * Add support for putting modalias definitions in driver package's
    debian/control, so that we can replace the /usr/share/jockey/modaliases/*
    lists with lookups in the package database (see blueprint
    hardware-desktop-n-package-field-modaliases). With this we can drop the
    foo-modaliases packages, and shipping third-party driver packages will
    just work in Jockey without any further integration.
    - Add debian/debhelper/dh_jockey: Debhelper program to produce a
      ${modaliases} substvar from scanning .ko files or
      debian/packagename.modaliases.
    - Add debian/debhelper/test_dh_jockey: Automatic test script for
      dh_jockey.
    - Add debian/debhelper/modaliases.pm: dh_auto sequencer for dh_modaliases.
    - debian/control: Add dh-modaliases package.
    - debian/dh-modaliases.install: Install dh_modaliases and modaliases.pm.
    - debian/rules: Create manpage from dh_modaliases POD.
    - jockey/oslib.py: Add apt implementation for package_header_modaliases().
    - tests/oslib.py: Add test case for our package_header_modaliases()
      implementation. This only really tests anything if there is at least one
      package with a "Modaliases:" field in the local apt repository.
  * jockey/oslib.py: Change deprecated apt.apt_pkg.Config.Set() to .set().
  * debian/rules: Drop simple-patchsys.mk, we don't need it (patches are
    inline, maintained in bzr).
 -- Martin Pitt <email address hidden> Thu, 25 Nov 2010 19:49:00 +0100

Changed in jockey (Ubuntu):
status: Fix Committed → Fix Released
Sebastiano (lafayette84) wrote :

Still have problems even with new driver version. Reading through X log, it seems that glx module loaded is the one shipped by X.org and not by NVIDIA. is that correct?

X won't start and crashes with a segfault, even if AddARGBGLXVisuals is true in xorg.conf (created from scratch by jockey).
Any idea?

Sebastiano (lafayette84) wrote :

Well, I did it. Browsing a bit through NVIDIA forums, I discovered that I was missing the correct ModulePath in xorg.conf to load libglx of Nvidia, not X.org's one.
Anyway, I'm a bit curious because jockey did create the X.org configuration file for me, and that line was not added.
Is jockey in fault, or on a default system Nvidia glx module will have priority over others?

For the ones who just want to know, in case, how I solved:
in xorg.conf, in section "Files", be sure that the first module path is Nvidia one

....
Section "Files"
        ModulePath "/usr/lib/nvidia-96/xorg/"
 ModulePath "/usr/lib/xorg/modules"
.....

@Sebastiano: there's no need to add that line as the alternatives system + our patched xserver should take care of that.

Can you attach the output of the following command, please?

update-alternatives --display gl_conf

Sebastiano (lafayette84) wrote :

Here it is. Strange, seems all ok. I haven't attached Xorg log before the adding of new module path, but crashed clearly because it was loading X.org libglx.so file.

---
sebastiano@oldbuntu:~$ update-alternatives --display gl_conf
gl_conf - auto mode
  link currently points to /usr/lib/nvidia-96/ld.so.conf
/usr/lib/mesa/ld.so.conf - priority 500
  slave xorg_extra_modules: /usr/lib/xorg/x11-extra-modules
/usr/lib/nvidia-96/ld.so.conf - priority 9600
  slave man_nvidiaxconfig.gz: /usr/share/man/man1/alt-nvidia-96-xconfig.1.gz
  slave nvidia-autostart.desktop: /usr/share/nvidia-96/nvidia-autostart.desktop
  slave nvidia-smi.1.gz: /usr/share/man/man1/alt-nvidia-96-smi.1.gz
  slave nvidia_bug_report: /usr/lib/nvidia-96/bin/nvidia-bug-report.sh
  slave nvidia_desktop: /usr/share/nvidia-96/ubuntu-nvidia-settings.desktop
  slave nvidia_drv: /usr/lib/nvidia-96/xorg/nvidia_drv.so
  slave nvidia_modconf: /lib/nvidia-96/modprobe.conf
  slave nvidia_smi: /usr/lib/nvidia-96/bin/nvidia-smi
  slave nvidia_xconfig: /usr/lib/nvidia-96/bin/nvidia-xconfig
  slave xorg_extra_modules: /usr/lib/nvidia-96/xorg
  slave xvmcconfig: /usr/lib/nvidia-96/XvMCConfig
Current 'best' version is '/usr/lib/nvidia-96/ld.so.conf'.

@luk1don,

I was tried different vga modes in /etc/default/grub, but still got error.

dmesg wrote:
[ 99.118023] agpgart-intel 0000:00:00.0: AGP 3.0 bridge
[ 99.118052] agpgart-intel 0000:00:00.0: bridge is in legacy mode, falling back to 2.x
[ 99.118065] agpgart-intel 0000:00:00.0: putting AGP V2 device into 4x mode
[ 99.118119] nvidia 0000:01:00.0: putting AGP V2 device into 4x mode
[ 100.654542] Xorg:1844 conflicting memory types e8000000-e8500000 uncached-minus<->write-combining
[ 100.654552] reserve_memtype failed 0xe8000000-0xe8500000, track write-combining, req write-combining
[ 100.656966] Xorg:1844 conflicting memory types e8000000-e8500000 uncached-minus<->write-combining
[ 100.656975] reserve_memtype failed 0xe8000000-0xe8500000, track write-combining, req write-combining

in Xorg.0.log:

[ 88.122] (EE) NVIDIA(0): Failed to allocate/map the primary surface!
[ 88.123]
Fatal server error:
[ 88.123] AddScreen/ScreenInit failed for driver 0

Please, any idea, how can I fix it?

2 comments hidden view all 179 comments
Manfred Hampl (m-hampl) wrote :

@Petr:
Your problem seems to be the same as bug 605837

As a workaround adding the nopat option to your kernel boot command line should help. Please give it a try.

@Manfred Hampl: Thanks! It work's!

Have tested proposed as outlined in post #137. No issues at all with installation.
Driver works well and I even got my old bugs with non-working Suspend and Hibernate back ;-)

From my end ready for prime time
BRGDS
//Stefan

Newk (newk) wrote :

i'm back to 10.04
:(
X kept breaking... i can't trust 10.10 yet

yaztromo (tromo) wrote :

Got my X working now using the proposed drivers HOWEVER

- Sometimes X will freeze whilst starting GDM and the only solution is to pull the power
- Minimizing applications causes X to freeze for two seconds every time

Running Xubuntu 10.10

lspci:
VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)

Graham Knap (graham-knap) wrote :

If you don't want to enable the proposed-updates repository, and would prefer to install updated the packages manually, this method worked for me and my GeForce 4 Ti 4200:

1. Download and install the new jockey packages.

https://launchpad.net/ubuntu/+source/jockey/0.5.10-0ubuntu5.2/+build/2060531

2. Jockey should now offer the nVidia 96 driver. Enable it. This will install version 96.43.18, which won't actually work, so don't reboot yet. However, this step is still useful because it installs dependencies, and makes the necessary configuration changes to enable the driver.

3. Download and install the new driver package.

https://launchpad.net/ubuntu/+source/nvidia-graphics-drivers-96/96.43.19-0ubuntu1/+build/2057864

4. Reboot.

Jukka Siitari (reed-siitari) wrote :

Still no released fix for this bug!!!

My Ubuntu has been unusable for 3 months now! Starts only to command prompt after upgrading to Maverick. I do not want to go back to playing with command prompt/scripts/whatever of the (very) old MS-DOS days. A computer is a tool for me, not a toy to play with.

Quote from Ubuntu pages: "Users of the official release, in contrast, expect a high degree of stability. They use their Ubuntu system for their day-to-day work, and problems they experience with it can be extremely disruptive. Many of them are less experienced with Ubuntu and with Linux, and expect a reliable system which does not require their intervention."

@Jukka
I thought the package had already been accepted into updates but this doesn't seem to be the case.

You can follow the instructions in comment #137 to enable the -proposed repository and install the new package:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-96/+bug/626974/comments/137

Jukka Siitari (reed-siitari) wrote :

OK Alberto!

Got Maverick "almost" working as per instructions of comment #137. Took a while, though.

There are still some issues in Maverick, however, although they mostly are not related to this bug. There is one thing, however, which might be related to the instructions in #137: The "Software Sources" line has disappeared from the desktop, ie. from System -> Administration. And because #137 instructs to edit the /etc/apt/sources.list, I wonder if the disappearance was caused by that. Copying the back-up file back to sources.list did not help. I can still get to the "Software Sources" through Synaptic (Settings -> Repositories), but the direct link is missing.

Thanks anyway!

Martin Pitt (pitti) on 2011-01-15
tags: added: verification-done
removed: verification-needed
Deno (denis-havlik) wrote :

Installing the 96.43.19 from maverick-proposed solved the issue on my Dell Latitude D800 oldie (GeForce4 4200 Go card).

FYI:
- I had to use the text install to get the 10.10 installed on this laptop in the first place;
- X worked after reboot, but the mouse cursor had a "shadow" ca. 1 cm apart from the real cursor position (with nv driver, I presume);
- installation of original 10.10 nvidia drivers resulted in text-only mode for a while; and
- the #137 method saved the day (thx).

Deno (denis-havlik) wrote :

OK, something is broken now: kpackagekit (I'm on kubuntu) replies "unknown error"on every mouse click. On console output it complains about missing the ibus-daemon...

synaptic work fine, so it's bye-bye kpackagekit...

Installed nvidia-96, jockey-common, and jockey-gtk from maverick-proposed on my Compaq Presario R3000 and rebooted and the problem is now fixed (amd64).

Geoff (geoffch) wrote :

I installed jocky-gtk, jockey-common, nvidia-96, nvidia-96-modaliases from maverick-proposed on my Dell desktop with a Geforce3 Ti 200. Problem solved. However, there was a side effect: now vino-server aborts with "** ERROR **: Failed to register GObject with DBusConnection". Is there something else that I need to update something else to maverick-proposed?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package jockey - 0.5.10-0ubuntu5.2

---------------
jockey (0.5.10-0ubuntu5.2) maverick-proposed; urgency=low

  * data/handlers/nvidia.py:
    - Re-enable nvidia-96 now that it's compatible with xserver 1.9
      (LP: #626974).
 -- Alberto Milone <email address hidden> Mon, 22 Nov 2010 11:46:49 +0100

Changed in jockey (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-96 - 96.43.19-0ubuntu1

---------------
nvidia-graphics-drivers-96 (96.43.19-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release:
    - Switch to new xsfbs variables to get the server ABI
      (LP: #616214).
    - Add support for X.Org xserver 1.9 (LP: #626974).
  * debian/nvidia-96.postinst{.in}:
    - Call dpkg-trigger with "--by-package".
  * debian/dkms/patches/nvidia-2.6.36-ioctl.patch:
    - Add compatibility with kernel 2.6.3{6|7}.
 -- Alberto Milone <email address hidden> Sat, 20 Nov 2010 17:36:13 +0100

Changed in nvidia-graphics-drivers-96 (Ubuntu Maverick):
status: Fix Committed → Fix Released
Bryce Harrington (bryce) wrote :

I'm assuming this task was just left open in error and that the issue also is solved in natty's package.

Changed in ubuntu-release-notes:
status: In Progress → Fix Released
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: In Progress → Fix Released
Larry Siden (lsiden) wrote :

This problem is affecting me too. I have tried:

* installing the PPA ubuntu-x-swat-x-updates-maverick (results in Hash Sum Mismatch when trying to install nvidia driver)
* following suggestions from #36 to downgrade back to Lucid.
* installing driver from maverick-proposed (apt-get install nvidia-current/maverick-proposed => E: Unable to locate package nvidia-graphics-drivers-96)
* installing proprietary driver directly from Nvidia site.

I've been at it all afternoon reading this and other threads and trying suggestions and nothing has worked. Does anybody have a fix for this?

A side-question. How do I know which driver I need for my chipset. lspci says I have NVidia NV44A [GeForce 6200]. Does that need the 96 or 170 driver or something else? I don't even know what those numbers mean. I assume that they must correspond to chipsets. I've been to the nvidia site but don't know what to look for.

I wish there was a clear set of instructions somewhere. Alternately, someone please tell me what kind of card I need to upgrade to for which there are good drivers in Maverick. I'd gladly pay a few extra bucks to have a working system again because I depend on it for my work. What a mess this has been for me and for others!

Larry Siden (lsiden) wrote :

BTW - I tried running jockey-text (I have only a simple tty console right now) with -u, -c, -l, and it prints only "GtkWarning: could not open display" which doesn't make sense since jockey-text is supposed to be for non-graphics terminals. I know this is probably a separate issue, but I just thought I'd mention it.

Manfred Hampl (m-hampl) wrote :

@Larry: from ftp://download.nvidia.com/XFree86/Linux-x86/260.19.06/README/supportedchips.html it seems to me that you need the 260 (for natty 270) family of drivers, not the 96 one.

Larry Siden (lsiden) wrote :

Thanks. I finally got the proprietary driver from Nvidia to install and
it's working so I'll leave well enough alone and hope that they fix the
problem in the next Ubuntu release (11.4) so I can go back to the distro
package.

-Larry Siden

The United States is a nation of laws, badly written and randomly enforced.
--Frank Zappa 1940-1993

On Mon, Apr 11, 2011 at 2:10 AM, Manfred Hampl <email address hidden>wrote:

> @Larry: from
>
> ftp://download.nvidia.com/XFree86/Linux-x86/260.19.06/README/supportedchips.html
> it seems to me that you need the 260 (for natty 270) family of drivers,
> not the 96 one.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/626974
>
> Title:
> ABI change in xorg 1.9 breaks legacy nvidia-96 drivers in Maverick
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/626974/+subscribe
>

clopezsandez (clopezsandez) wrote :

I do not think so; I have been trying 11.04 and I have the same problem (a black screen in 10 seconds).

Bryce Harrington (bryce) on 2011-06-28
Changed in xorg-server:
status: New → Invalid
Larry Woodring (larry-w) wrote :

So, what's the current situation? Will these drivers be supported with an update to Maverick now? What does the "invalid" status in xorg-server mean?

Manfred Hampl (m-hampl) wrote :

As far as I know the current situation is as follows:

There is a working version of the dedicated proprietary nvidia-96 driver for Ubuntu 10.10 - not delivered with the installation or upgrade CD's, but available from the standard repositories for normal package installation.

The issue with Ubuntu 11.04 (there is no working dedicated proprietary nvidia -96 driver for xorg 1.10 available yet) is not the topic of this bug, but dealt with in bug #741930

Setting the status on X.org X server to 'invalid' mens that the changes have to be done / have been done on other packages, and X.org X server is not to be blamed.

Luigi Maselli (grigio) wrote :

It happened again with Ubuntu 12.04 Precise Pangolin :(

Displaying first 40 and last 40 comments. View all 179 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions