Ubuntu

Mouse and keyboard stop working after selecting user

Reported by Daniel Cordeiro on 2010-04-01
292
This bug affects 63 people
Affects Status Importance Assigned to Milestone
gdm (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-96 (Ubuntu)
High
Alberto Milone

Bug Description

Binary package hint: gdm

Steps to reproduce:
- When gdm starts, my mouse and keyboard are working fine.
- Select any user from the list
- Keyboard and mouse stops working
- GDM freezes, then restart
- Keyboard and mouse are working fine until I select any user.

This bug seen to be affecting more users: http://ubuntuforums.org/showthread.php?t=1443520

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gdm 2.30.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Apr 1 12:55:52 2010
ProcEnviron:
 LANGUAGE=pt_BR:pt:en
 PATH=(custom, user)
 LANG=pt_BR.utf8
 SHELL=/bin/bash
SourcePackage: gdm

Daniel Cordeiro (dcordeiro) wrote :
Igor Tarasov (tarasov-igor) wrote :

I get exactly the same error, using nvidia-96 driver and having gdm theme installed (in my case it is xubuntu-gdm-theme). If you remove *-gdm-theme package it starts working.

But as it is, it makes xubuntu/ubuntu unusable for unexperienced user after they have installed nvidia drivers. So, in my opinion this is very important bug. It seems that this bug has appeared just recently with latest gdm update.

macstevejb (macstevejb) wrote :

Having the same problem with Lucid Beta 1 using nvidia v96 driver.

The only way I can start x and boot to gnome desktop is to bypass gdm altogether.

Clearly it has sometjhing to do with the way gdm interacts with said nvidia graphics.

I have been testing Lucid since Alpha 3 and this only started happening after updates on April 1st.

Incidentally, I have another box using the same graphics card but no proprietory drivers installed. Using the default Nouveau driver, I have no problems with gdm login.

Same problem here with fully updated Lucid Beta1. I have been manually bypassing gdm for a week now. To top it off, if I enable the nouveau driver I can't get past the boot splash at all (<a href="https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/544088" title="Ubuntu 10.4 freezes on x-server start with Geforce 3 TI200">bug #544088</a>), but that's another story. So, this bug is the lesser of two evils, but still annoying.

See <a href="http://ubuntuforums.org/showthread.php?t=1436466" title="GDM crashes with NVIDIA 96 driver activated">this thread</a> for even more affected users.

Jonathan Rothwell (jrothwell97) wrote :

Also getting this bug with the NVIDIA 96 driver, any GRUB configuration and Lucid with all updates applied.

Everything works fine with Nouveau, so this appears to be specific to the NVIDIA driver.

zhangsong023 (zhangsong023) wrote :

Yes, nvidia 96 driver with the latest update, the same problem is still here.

Changed in gdm (Ubuntu):
status: New → Confirmed
scalawag (scalawag-) wrote :

Same here.
Ubuntu 10.04 i386 Beta1 fully updated
2.6.32-19-generic-pae
Nvidia 96
GDM restarts when i choose an user.

Ross Gardiner (ross-gmx) wrote :

Same here.
It seems to be triggered by the appearance of the password field itself: if you choose to enter a username you can do that fine, but as soon as you hit return to get to password entry gdm restarts.

Identical problem:

lucid-desktop-i386.iso 6-Apr-2010
Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1

Nvidia 96.43.14

Acron_0248 (acron0248) wrote :

Another affected since apr 1 update (i think):

Ubuntu Lucid
kernel: 2.6.32-16-generic (x86)
nvidia-96: 96.43.14-0ubuntu12

Did the partial distribution upgrade to Beta2 this morning, plus a hundred or so updates later in the day (including some nvidia packages). Unfortunately, this bug still exists. Can not log in normally! Seems like a pretty important bug to me. Is anyone else worried by the seeming lack of movement on this issue?

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: New → Confirmed

Just did a clean install of beta 2. The bug's still there.

Wayne Towe (wwtowe) wrote :

I am seeing the exact same problem.

mlkovacs (michaellkovacs) wrote :

Same here, I installed nvidia_96 through Jockey today after a buch of updates on a fresh install of Beta 2. nvidia_96 fails to install properly, Then after a reboot, GDM crashes after clicking on a user. GDM restarts after a few seconds. I switched to tty1 and sudo stop gdm && startx. Gnome desktop loads with nvidia accelerated graphics. nvidia module is actually loaded and running. Compiz effects are working. But Jockey still reports that nvidia was disabled. This is my kids computer so I cant expect her to login through the cli so its back to nouveau for now.

Igor Tarasov (tarasov-igor) wrote :

Confirming. Made all updates, installed xubuntu-gdm-theme back and the bug is still here. Removed xubuntu-gdm-theme for now, waiting for patch. Bug importance should be critical, such bugs just shouldn't get into release, since for unexperienced users it just means that system is unusable.

Yep, this bug is now affecting me too. Weird because Ubuntu 10.04 was working fine on this Dell Inspiron 2650 for some time before. So now I used scalawag_'s suggestion at http://ubuntuforums.org/showpost.php?p=9054571&postcount=7 to get to the Ubuntu Desktop:

At the gdm screen:
Ctrl+alt+F2
login with username and password
sudo service gdm stop
startx

After I was booted into the GUI, I created a special user(I used username: freeuser) via System>Administration>Users and Groups, set it up with admin privileges, then enabled the "Don't ask for password on login" setting. So then after I reboot, I click the user "freeuser" and it logs in automatically (sometimes gdm restarts and I have to click it a second time, but after that it works). Then after that, I had to(as I've always had to do with this machine while the nvidia graphics are installed) set "Appearance Preferences"(right-click the desktop, click "Change Desktop Background", then "Visual Effects"), from Normal to None.

Something else I notice is that my nvidia driver won't install properly. I click System>Administration>Hardware Drivers and then try to activate the driver(version 96) but it fails with "Sorry, installation of this driver failed. Please have a look at the log file for details: /var/log/jockey.log" (attached).

Seems unlikely that any typical new user could even make any of this work. So in the case of this Dell Inspiron 2650 anyway, this problem is a vote for buying Ubuntu preinstalled.

Thanks to everyone helping with this!
Shannon VanWagner - humans-enabled.com

Whoops, I meant to attach my jockey.log in #16. So I've done one better.. I've attached the jockey.log and I generated a log from 'sudo nvidia-bugreport.sh' and tarred them up together in the attachment.

Cheers!
Shannon VanWagner

@Shannon, the jockey problem is something unrelated to this bug. See bug #552653, which is probably where you should be posting your logs.

Still broken with yesterday's nvidia-96 update.

It definitely appears to be triggered either by the appearance of the password field or the appearance of the options on the lower panel.

Additionally, please record another vote in favour of marking this bug as critical: it could make the system practically unusable for a large proportion of users out of the box.

Igor Tarasov (tarasov-igor) wrote :

Interesting thing is that exactly password field triggers the bug. If you choose "other..." you get text field to enter user name and it works great. But when you hit enter and password field appears - everything hangs and GDM restarts.

Sebastien Bacher (seb128) wrote :

is everybody getting the issue using nvidia drivers? does it happen with nv or nouveau? do you get any error in Xorg.0.log or the system logs when you get the hang issue?

Igor Tarasov (tarasov-igor) wrote :

Attached - xorg log. Diff with uncrashed GDM Xorg log show that crash happens somewhere around line 274.

Also there is nothing special in dmesg log, just a regular nvidia driver restart.

And in syslog:

Apr 13 03:29:44 tigr-desktop gdm-simple-greeter[2863]: Gtk-WARNING: /build/buildd/gtk+2.0-2.20.0/gtk/gtkwidget.c:5636: widget not within a GtkWindow
Apr 13 03:29:59 tigr-desktop gdm-simple-greeter[2863]: WARNING: Unable to parse history: (null) 5#012

HTH.

@Sebastien: This is definitely nvidia-96 specific. Many people have stated, both here and on the forums, that this does not happen with other drivers (I also have no problem with nouveau enabled).

The attached Xorg.0.log is from after crashing gdm (twice, just for fun). I can also confirm the exact same errors that TIGR posted in my syslog.

JimBo (barreda-jm) wrote :

Bug still present for me (Geforce MX440 + nividia-96) with beta 2 + daily updates.
But login screen works fine with nv driver.
With nvidia proprietary, login screen seems incomplete : no "Language/Keyboard/Session" selection at bottom of the screen, in the bar...

zeimusu (james-kilfiger) wrote :

See also bug 539440

Alberto Milone (albertomilone) wrote :

I'm subscribing upstream (Nvidia) so that they can comment on the bug.

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Alessio (alessio) wrote :

same problem here...

now I tried to install gdm2setup and change gtk theme to clearlooks, I try do login and logout about ten times and only once gdm locked up and restart, then I seems now I can login with nvidia-96 drivers enabled

this is the solution or not, but anyway I believe this is a good workaround to the problem

Aaron Plattner (aplattner) wrote :

I'll try to take a look at this soon. It's suspicious that it started occurring with a GDM update, but it'll take some digging to figure out what's going wrong.

Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: nobody → Aaron Plattner (aplattner)
Aaron Plattner (aplattner) wrote :

I can't reproduce this problem. I used the default Ubuntu GDM setup, and I also tried installing xubuntu-gdm-theme. I don't think the latter worked correctly, though because I get a boring purple background and a little terminal picture at the top of the login prompt. Hopefully the xubuntu theme isn't supposed to be quite so ugly...

I'll need to try with a fresh install, I guess, though I won't have time to do that any time soon.

Sebastien Bacher (seb128) wrote :

Thanks Aaron for looking into the issue. Whatever gdm is doing it should not crash the video driver or server and it's not an issue using other drivers. You can see the gdm changes on https://launchpad.net/ubuntu/+source/gdm/+changelog

Sebastien Bacher (seb128) wrote :

There has been no change to gdm out of keyboard layout selection and gdmsetup updates before the bug report started, if the issue has been triggered by something else it could rather be a gtk or theme update

Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: Aaron Plattner (aplattner) → Daniel Dadap (ddadap)
Aaron Plattner (aplattner) wrote :

I managed to track down the cause of this problem. I'll try to get it fixed soon. It is indeed a bug in the NVIDIA X driver.

Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: Daniel Dadap (ddadap) → Aaron Plattner (aplattner)
status: Triaged → In Progress
Changed in gdm (Ubuntu):
status: Confirmed → Invalid
JimBo (barreda-jm) wrote :

I think the bug is directly connected to the password authentication in gdm.
I deactivated passwords in gdm (adding "auth sufficient pam_listfile.so item=user sense=allow file=/etc/gdm/nopassusers.txt onerr=fail" in /etc/pam.d/gdm file + my user name in /etc/gdm/nopassusers.txt) ; and I can login & logout perfectly in gdm

The Real Dave (davidj086) wrote :

I have the same problem, and am using the Nvidia-96 driver, on a Geforce4 MX440 AGP.

Aaron Plattner (aplattner) wrote :

This should be fixed in the next legacy driver release.

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: In Progress → Fix Committed
NoOp (glgxg) wrote :

Can you advise when that might be?
https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/516520
seems related.

@jmBARREDA: your workaround may be related to #516520. Note that setting gdm to autologin does the same, but removing nvidia-96 provides for a proper gdm login. See:
<https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/516520/comments/89>

Aaron Plattner (aplattner) wrote :

NoOp, it looks like that bug got hijacked. This problem sounds unrelated to the problem originally reported in that bug.

@Aaron: Just noticed that the FinalFreeze starts today. Will this fix be pushed through anyway? I hope so, it would suck to have to wait another 2 weeks for the updated package.

Ivan Gualandri (ivang) wrote :

i have the same problem.
I have nvidia-96 package installed.

Paul Mouriño (pruebapei) wrote :

The same problem. Ge Force4 420 Go and 96.xx package, both from the universe and from nvidia site. Deleting the xorg.conf return to de generic driver.

Aaron Plattner (aplattner) wrote :

disco_stew: I don't know when an updated driver will be released. Once a driver is released, I'll reassign this bug to Alberto to handle the Ubuntu nvidia-96 package update. Presumably this bug would be an SRU candidate, if it turns out that's necessary.

You ought to be able to work around this problem by disabling Composite or RenderAccel, though I haven't actually tried that.

Sebastien Bacher (seb128) wrote :

Thank you for your comment Aaron, do you know if all nvidia-96 users are affected by this issue or if it's specific to some cards? We might want to disable Composite or RenderAccel for those cards or move those users to nouveau on upgrade until the new driver version is available otherwise it seems quite some user will get hit by this when upgrading to lucid...

Aaron Plattner (aplattner) wrote :

It should affect any card using the 96.43.* drivers.

Igor Tarasov (tarasov-igor) wrote :

Sebastien Bacher, dropping to nouveau is not always a good idea. In my situation, with geforce4 440 mx nouveau just isn't working. At all - X server won't even start. However, nv driver works.

Paul Mouriño (pruebapei) wrote :

It happens to me when I upgrade to lucid

Darrin Abend (dagnir1) on 2010-04-15
Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Fix Committed → Fix Released
Aaron Plattner (aplattner) wrote :

Darrin, what fix are you referring to? The fix for this bug has not yet been released.

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Fix Released → Fix Committed

That was a mistake and I wasn't even sure if I changed something. Sorry.

----- Original Message ----
From: Aaron Plattner <email address hidden>
To: <email address hidden>
Sent: Thu, April 15, 2010 6:30:46 PM
Subject: [Bug 553200] Re: Mouse and keyboard stop working after selecting user

Darrin, what fix are you referring to? The fix for this bug has not yet
been released.

--
Mouse and keyboard stop working after selecting user
https://bugs.launchpad.net/bugs/553200
You received this bug notification because you are a direct subscriber
of the bug.

Status in “gdm” package in Ubuntu: Invalid
Status in “nvidia-graphics-drivers-96” package in Ubuntu: Fix Released

Bug description:
Binary package hint: gdm

Steps to reproduce:
- When gdm starts, my mouse and keyboard are working fine.
- Select any user from the list
- Keyboard and mouse stops working
- GDM freezes, then restart
- Keyboard and mouse are working fine until I select any user.

This bug seen to be affecting more users: http://ubuntuforums.org/showthread.php?t=1443520

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gdm 2.30.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Apr 1 12:55:52 2010
ProcEnviron:
LANGUAGE=pt_BR:pt:en
PATH=(custom, user)
LANG=pt_BR.utf8
SHELL=/bin/bash
SourcePackage: gdm

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/gdm/+bug/553200/+subscribe

Just to echo TiGR's remarks in post #44 - I also have problems with an MX440 using the nouveau driver. Detailed briefly in this post:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/539878/comments/13

domink (domingo-berron) wrote :

Hi all,
Probably this information is previously known... but... just in case...

I'm using lucid with a NVidia GeForce MX440 and I have the same problem. This morning I tried to login on console mode and then start the XWindows (startx). The result is the good one. The XWindows looks working properly.
I tried to use the password box, for example using the Updates Manager and it works.

Now I'm thinking if it is possible to pass the xorg.conf file as a parameter to startX. Do you know?

If this is possible, I will have a workaround that it will valid for me until the issue was fixed.

If I remove the xorg.conf from /etc/X11 the system start on Low graphics mode but it works.

My idea is remove this file and if any user needs to run on High Resolution (only me ... :-)) he could open the terminal, stop the gdm and send startx with the xorg.conf.NVIDIA file as parameter.

Is this possible?

Regards and thanks on advance,

Domin

Paul Mouriño (pruebapei) wrote :

Starting X directly from the console jump the gdm login,but produce some rare effects: you have to put passwords again, nvidia settings seems not launching.
These issue is very frustrating.

Aaron Plattner (aplattner) wrote :

This is fixed in a release candidate. Reassigning to Alberto to update the Ubuntu packages.
     ftp://download.nvidia.com/XFree86/Linux-x86/96.43.17/
     ftp://download.nvidia.com/XFree86/Linux-x86_64/96.43.17/

Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: Aaron Plattner (aplattner) → Alberto Milone (albertomilone)
assignee: Alberto Milone (albertomilone) → Aaron Plattner (aplattner)
assignee: Aaron Plattner (aplattner) → Alberto Milone (albertomilone)
Paul Mouriño (pruebapei) wrote :

Excelent!! That fix the problem.

W00t. Thanks Aaron for all your work on this issue.

new2linux (darfsten-wi) wrote :

i have a similar problem. i am using nvidia 96.43.14 and if I click on the password box gdm crashes and restarts. I can however use xdm just fine. i am using lucid all up to date as of 4-20-10.
here are log ouput:
cat /var/log/gdm/:0-greeter.log
Window manager warning: Failed to read saved session file /var/lib/gdm/.config/metacity/sessions/107a462c227fba2906127175887057632200000012080007.ms: Failed to open file '/var/lib/gdm/.config/metacity/sessions/107a462c227fba2906127175887057632200000012080007.ms': No such file or directory
** (process:1220): DEBUG: Greeter session pid=1220 display=:0.0 xauthority=/var/run/gdm/auth-for-gdm-1EHe8v/database

(gnome-power-manager:1222): GLib-GObject-WARNING **: /build/buildd/glib2.0-2.24.0/gobject/gsignal.c:2273: signal `proxy-status' is invalid for instance `0x8997588'
gdm-simple-greeter[1220]: Gtk-WARNING: /build/buildd/gtk+2.0-2.20.0/gtk/gtkwidget.c:5636: widget not within a GtkWindow
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1200047 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1200047 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

** (ck-history:1234): WARNING **: Unable to parse session removed event: seat-id='Seat1' session-id='Session6' session-type='' session-x11-display=':0' session-x11-display-device='/dev/tty8' session-display-device='/dev/tty1' session-remote-host-name='' session-is-local=TRUE session-unix-user=1000 session1270814665.159 type=SEAT_ADDED : seat-id='Seat1' seat-kind=0

(gnome-power-manager:1222): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
Window manager warning: CurrentTime used to choose focus window; focus window may not be correct.
Window manager warning: Got a request to focus the no_focus_window with a timestamp of 0. This shouldn't happen!
gnome-settings-daemon: Fatal IO error 104 (Connection reset by peer) on X server :0.0.

/var/log/xorg.0.log
http://pastebin.com/8KP37RKq

Alberto Milone (albertomilone) wrote :

I have uploaded the fix in Ubuntu Lucid, however my upload will be approved only after Lucid's RC is released.

In the meantime, if you want to test the driver, you can install it from my PPA (as soon as the packages are built):
https://launchpad.net/~albertomilone/+archive/proprietary-video-improvements

Installed updated driver from the PPA and this issue is solved. I can log in from gdm with no freeze.

Alex - Microsmeta (microsmeta) wrote :

ftp://download.nvidia.com/XFree86/Linux-x86/96.43.17

solves GDM password login hang on Lynx RC TEST ISO, but Desktop Effects are impossible to start again!!
(Acceleration was finally working in Ubuntu Desktop i386 (20100419.1)

HARDWARE - NVIDIA Geforce4 MX 440 64 Mega & NVIDIA Geforce2 MX 400 64 Mega with Nvidia-96 (96.43.16) drivers.

Igor Tarasov (tarasov-igor) wrote :

Installed driver from PPA, and X stopped starting. I have tried uninstalling/reinstalling/purging. Nothing helped. Had to fall back to older version.

Aaron Plattner (aplattner) wrote :

TiGR, please reinstall the 96.43.17 driver, try to start X again, run nvidia-bug-report.sh, and attach the resulting nvidia-bug-report.log.gz file here.

The Real Dave (davidj086) wrote :

Installed from PPA, and issue is fixed. Thanks Aaron and Alberto :)

NoOp (glgxg) wrote :

PPA 96.43.17 driver working for me on 2 systems w/NV25GL [Quadro4 900 XGL] cards. GDM login works, compiz (Desktop Cube, Rotate Cube & Cube Reflection & Deformation) working fine. Thanks for the fix.

Robert Hooker (sarvatt) wrote :

Alex - Microsmeta: Installing the driver from nvidia.com will not work in lucid unfortunately because of the alternatives system in place now. You want to uninstall it and use the alberto's PPA version.

Robert Hooker (sarvatt) wrote :

TiGR: Did you purposefully boot that old kernel with a newer one installed? The kernel module probably didn't get built for one that far back by default.

Igor Tarasov (tarasov-igor) wrote :

Well, it seems that system reboot was required. That's strange, since I don't remembery any driver updates that required reboot. After I reinstalled the driver and rebooted the system everything works great.

I tried loading up Mr. Milone's PPA for lucid and I received this error:
  404 Not Found
W: Failed to fetch http://ppa.launchpad.net/albertomilone/ppa/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found

Am I doing something wrong?

I'll go and get the download from the ftp site instead.

Thanks!
Shannon

Is there a PPA for Lucid? I tried using the apt-add-repository in my Ubuntu 10.04 and sudo apt-get update fails with:
  404 Not Found
W: Failed to fetch http://ppa.launchpad.net/albertomilone/ppa/ubuntu/dists/lucid/main/binary-i386/Packages.gz 404 Not Found

Thanks very much!

Alberto Milone (albertomilone) wrote :

@Shannon
Please remove the repository that you added (as it's an html page), then follow the instructions available on this page:
https://launchpad.net/+help/soyuz/ppa-sources-list.html

and use the following PPA:
ppa:albertomilone/proprietary-video-improvements

Alex - Microsmeta (microsmeta) wrote :

@Robert Hooker - Thank you, Alberto Milone's PPA solved the issue. Desktop Effects activated with 96.43.17 and the password at GDM login is now working!

This is what I have done:
-Installed Ubuntu Desktop i386 (20100419.1) test ISO on Wubi (ONLY TO TEST ;-) )
(Other Bug found & FIX - if installation at 93% + stops, press enter
or move the mouse to awake the installation again and again until finished!)
-When offered the installation on NVIDIA proprietary drivers, refuse and add the PPA to the sources.
-Search for updates, then install the new PPA nvidia-96 mode aliases (96.43.17)
-Restart the system and activate Desktop Effects if not already ebabled.

JimBo (barreda-jm) wrote :

Update from ppa:albertomilone/proprietary-video-improvements worked for me...
Thx Alberto Milone.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-96 - 96.43.17-0ubuntu1

---------------
nvidia-graphics-drivers-96 (96.43.17-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - Fixed a bug that caused X server crashes when certain
      rendering occurred. This was triggered by the Ubuntu
      10.04 GDM login theme (LP: #553200).
 -- Alberto Milone <email address hidden> Tue, 20 Apr 2010 08:19:07 +0200

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Fix Committed → Fix Released
NoOp (glgxg) wrote :

On 04/22/2010 08:37 AM, Launchpad Bug Tracker wrote:
> This bug was fixed in the package nvidia-graphics-drivers-96 -
> 96.43.17-0ubuntu1
>
> ---------------
> nvidia-graphics-drivers-96 (96.43.17-0ubuntu1) lucid; urgency=low
>
> * New upstream release:
> - Fixed a bug that caused X server crashes when certain
> rendering occurred. This was triggered by the Ubuntu
> 10.04 GDM login theme (LP: #553200).
> -- Alberto Milone <email address hidden> Tue, 20 Apr 2010 08:19:07 +0200
>
> ** Changed in: nvidia-graphics-drivers-96 (Ubuntu)
> Status: Fix Committed => Fix Released
>

Disabled Alberto's PPA & reloaded 96.43.17-0ubuntu1 from standard (Main)
repositories, rebooted just to be sure - no issues & working well. Note:
32bit only ATT as the 64bit is still being built. Again, thanks for the fix.

Woops, I had bungled up the PPA install. So I removed it and then ran sudo apt-get update && sudo apt-get upgrade and since Alberto's changes have been included in the updates everything is now fixed.

Awesome! Thanks so much for fixing this!
Shannon VanWagner
Ubuntu 10.04 on Dell Inspiron 2650 Notebook with NVIDIA graphics

pond (whitecloudxxx) wrote :

Got my 2650 working by using an external USB mouse and enabling "pointer can be controlled using the keyboard" switch under the /system/preferences/keyboard path of the main menu.

The keyboard and mouse pad work now 100%

Cliffystones (cstones2u) wrote :

It's sad that this was reported over a month ago, and I had to hose my desktop to find out it wasn't fixed!

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Francesco Potortì (pot) wrote :

This cannot be installed on a 10.4, though. Are backports planned?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers