Ubuntu

X cannot start after upgrade to Karmic

Reported by Massimiliano Ballerini on 2009-11-06
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-96 (Ubuntu)
Undecided
Alberto Milone

Bug Description

I have updated my Ubuntu to Karmik 2 days ago.

I had nvidia drivers 96 installed WORKING in Jaunty, and now it load up the system and show the ubuntu logo white on black, then it show a "flashing" shell prompt.

It looks like gdm tries to start X in an infinite loop and X crashes everytime to the shell. I press CTRL+ALT+CANC and the system reboot.

Accessing in recovery mode, i delete the xorg.conf, reboot and then ubuntu working fine with mesa driver (but no dri).

I saw other bugs posted much like this one, but they result fixed.

The package with module actually compile and load on kernel 2.6.31-14-generic, but it looks like it's not compatible with last xorg server or some of its components. I tried reinstall, but didn't work.

Here's my video card:
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)
 Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 16
 Memory at fd000000 (32-bit, non-prefetchable) [size=16M]
 Memory at f0000000 (32-bit, prefetchable) [size=128M]
 Expansion ROM at fea00000 [disabled] [size=128K]
 Capabilities: [60] Power Management version 2
 Capabilities: [44] AGP version 3.0
 Kernel driver in use: nvidia
 Kernel modules: nvidia, nvidiafb

The xorg.conf it is standard created by nvidia driver installer (it just say "driver nvidia")

Here's one log out X loop:

Just found out purging the package nvidia-96-kernel-source, made the NV standard driver dri work again.

I forgot... The version of the nvidia driver the upgrade to Karmik installed is:
nvidia-glx-96_96.43.13-0ubuntu6_i386

description: updated

Tried today to switch again to nvidia proprietary driver after new kernel release, the behaviour is the same. This problem still isn't solved.

Confirmed that nvidia-96-kernel-source is to be purged if you want to restore situation to mesa nv driver. This means actually the nvidia proprietary module LOADS on the kernel.

Could be a xserver compatibility issue?

Changed in nvidia-graphics-drivers-96 (Ubuntu):
assignee: nobody → Massimiliano Ballerini (mballerini)
assignee: Massimiliano Ballerini (mballerini) → Alberto Milone (albertomilone)
Bryce Harrington (bryce) on 2010-03-18
tags: added: karmic
bugbot (bugbot) wrote :

This bug report was filed against an old version of Ubuntu.
Can you confirm whether this is still an issue in natty?

If you don't mind, it would be very helpful if you could update the bug
report in launchpad to 'Fix Released' if it is no longer an issue for
you, or if it is still occurring under natty, please tag the bug 'natty'
so it's easier for us to track.

Changed in nvidia-graphics-drivers-96 (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments