package libnvidia-common-450-server 450.51.06-0ubuntu0.20.04.2 failed to install/upgrade: trying to overwrite '/usr/share/nvidia/nvidia-application-profiles-450.80.02-key-documentation', which is also in package libnvidia-common-450 450.80.02-0ubuntu0.20.04.2

Bug #1899522 reported by John McLoughlin on 2020-10-12
154
This bug affects 26 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-450 (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-450-server (Ubuntu)
Undecided
Unassigned

Bug Description

During sudo apt-get upgrade, there was an error while this package was installing. On restarting my computer, the resolution was set to 800*600 and my gpu (nvidia 1060 6gb) wasn't recognized. Uninstalling the driver and reverting to the nouveu drivers fixed the resolution issue and reinstalling the nvidia-450 drivers via software & updates allowed for everything to go back to normal.

Steps to reproduce: On a machine with an nvidia 1060 6gb, run sudo apt-get update followed by sudo apt-get upgrade, this should result in an error during dpkg. Restart the computer to see the driver issue with display resolution and gpu not labelled correctly.

Steps to resolve for the time being: Uninstall and reinstall nvidia-450 via software & updates, restart computer.

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: libnvidia-common-450-server 450.51.06-0ubuntu0.20.04.2
ProcVersionSignature: Ubuntu 5.4.0-48.52-generic 5.4.60
Uname: Linux 5.4.0-48-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu27.9
Architecture: amd64
CasperMD5CheckResult: skip
Date: Mon Oct 12 18:12:58 2020
Dependencies:

DuplicateSignature:
 package:libnvidia-common-450-server:450.51.06-0ubuntu0.20.04.2
 Unpacking libnvidia-common-450-server (450.80.02-0ubuntu0.20.04.3) over (450.51.06-0ubuntu0.20.04.2) ...
 dpkg: error processing archive /tmp/apt-dpkg-install-OfgM3I/33-libnvidia-common-450-server_450.80.02-0ubuntu0.20.04.3_all.deb (--unpack):
  trying to overwrite '/usr/share/nvidia/nvidia-application-profiles-450.80.02-key-documentation', which is also in package libnvidia-common-450 450.80.02-0ubuntu0.20.04.2
ErrorMessage: trying to overwrite '/usr/share/nvidia/nvidia-application-profiles-450.80.02-key-documentation', which is also in package libnvidia-common-450 450.80.02-0ubuntu0.20.04.2
InstallationDate: Installed on 2020-10-01 (11 days ago)
InstallationMedia: Ubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
PackageArchitecture: all
Python3Details: /usr/bin/python3.8, Python 3.8.5, python3-minimal, 3.8.2-0ubuntu2
PythonDetails: N/A
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt 2.0.2ubuntu0.1
SourcePackage: nvidia-graphics-drivers-450-server
Title: package libnvidia-common-450-server 450.51.06-0ubuntu0.20.04.2 failed to install/upgrade: trying to overwrite '/usr/share/nvidia/nvidia-application-profiles-450.80.02-key-documentation', which is also in package libnvidia-common-450 450.80.02-0ubuntu0.20.04.2
UpgradeStatus: No upgrade log present (probably fresh install)

tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-450-server (Ubuntu):
status: New → Confirmed
Hans Joachim Desserud (hjd) wrote :

The underlying problem is that the file '/usr/share/nvidia/nvidia-application-profiles-450.80.02-key-documentation' is present in both packages, so they run into a conflict when attempting to install both.

Changed in nvidia-graphics-drivers-450 (Ubuntu):
status: New → Confirmed
koanvi (koanvi) wrote :

and how to avoid that conflict? remove old driver before install a new one?

meng (mengen100) wrote :

Hi I solved it by following this command:
sudo apt-get -o Dpkg::Options::="--force-overwrite" install -f libnvidia-common-450-server
Answer from:
https://askubuntu.com/questions/1285472/ubuntu-18-04-broken-install-problem-with-libnvidia-common-450-package

Hope it's not too late..

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers