nvidia-390 does not show GUI

Bug #1773113 reported by Nicolae Righeriu on 2018-05-24
222
This bug affects 45 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Undecided
Unassigned

Bug Description

I know this bug is a duplicate, I am opening it because it seems that for # #1752053 it is marked as "Fix Released" although many people are still affected and complaining about it and nobody can or will change that status. So it is an attempt to raise more attention, as HDMI currently isn't usable for me on Ubuntu 18.04 (it affected me on 16.04 as well).
Put in short, after Nvidia drivers are installed and I switch from Nvidia card to the intel one, the GUI can't be opened anymore

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
maf2 (sw-mariusz) wrote :

The graphical display failed to boot on laptop. The same system Ubuntu 18.04 works on the desktop.

https://drive.google.com/file/d/19i41gRcpzIErlU82Ekk-Hq5JUpUByHEw/view?usp=sharing

Kyle Weber (kyew01) wrote :

390 is completely useless for me as well.

Daniel Weaver (leinardosmith) wrote :

My laptop: Acer 15.6" FHD E5-575G-57A4 7th Gen Intel Core i5 7200U NVIDIA GeForce GTX 950M
Using the nvidia-driver-390 package it boots up to a black screen. The only way for me to fix this currently is to boot into safe mode and revert the drivers to xserver-xorg-video-nouveau. Please let me know if I can provide any logs to help diagnose this issue and get it fixed asap.

Same here. Installing nvidia-390 drivers on my Dell XPS 15 9560 results in an unbootable system. I have tried many, if not all, of the fixes suggested in bug report #1752053, but none of them will allow me to boot my system once the drivers are installed. I have even tried the latest nvidia-396 with the same results. Either I get a boot-loop, or else the login screen does not appear at all and I am only greeted with a black screen w/blinking cursor. Someone reported that a fix was released.....can you please SHARE THE FIX??? Without proper diplay drivers, I cannot even use the display ports or any of the HDMI ports on this device. How frustrating that this display problem returns over and over again with each and every Ubuntu release! SMH...

Ren (milchmannag) wrote :

Same issue with (X)ubuntu 18.04 with lightdm and nvidia-driver-390 and also nvidia-driver-340. Following setup (notebook):

$ lspci | egrep 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M LE] (rev a1)

After driver installation and reboot only blinking cursor no login, can't even switch to console with [Ctrl] + [Alt] + [F*]. Only recover possible through recovery mode and purging all nvidia-*.

Victor (vgutierrez) wrote :

Same issue with ubuntu 18.04 nvidia-driver-390 (GeForce GT740M). I have these packages libglvnd and xorg-server from bionic-proposed, but it is not working. I had to purge all nvidia in order to use ubuntu sudo apt remove --purge nvidia-*.

After upgrade to 18.04 my Asus X550LNV with NVIDIA GeForce 840M [GM108M] is only usable with the nouveau-drivers. I've tried many combos with the NVIDIA drivers but only get to login loop, frozen startup process or can switch to a terminal but in no circumstances can I get to GUI with the NVIDIA drivers installed.

Unfortunately this not only problem, there are more. :(

I don’t think anyone is working on these issues for us...? There are no updates anywhere, and this is a real serious problem for so many of us. ☹️

Installing nvidia-396 from graphics-drivers PPA solved the issue for me. Only the nvidia-settings app fails silently when I try to open it.

Janek Schleicher (hanfried) wrote :

I've got the same issue with a GTX 1080 on a desktop (lenovo ideacentre). Upgraded over time from 16.04 (as hibernate didn't work to)->17.04.->17.10 and last week to 18.04.
I tried installing nvidia-390 and nvidia-396 with all three methods (bionic package, ppa package, nvidia run script). I even tried to install the older nvidia-387 with nvidia-run script after switching nouveau driver off. Didn't work as some kernel headers don't seem to fit, so installation script aborted. I also tried to upgrade the kernel from 4.15.0-22.24 to 4.15.18, 4.16.13 and newest 4.17 release with ukuu. With newer kernels, I did not even got a gui screen (even with and without nvidia-drivers). I also tried to switch to wayland, but couldn't get it working, allthough I switched to lightdm and seen the login screen with the option (but didn't logged me in successfull).

At some point it gets absurd, if I'd handle kernel versions and co, I could use arch linux or w/e and not use ubuntu. Atm, I only can either reinstall 17.10 (that runs out of support soon), what's pretty meh, or use my desktop as pure server without a gui where I could at least run a jupyter notebook server and use it for machine learning as intended. But of course, I didn't bought it as server system intentionally. Has anybody a clue how likely the bug keeps in 18.04 (will it be fixed when 17.10 is out of support).

To be honest, that's first time I serious think about switching distributions :-o Since I've left Windows I never rebooted my computer so often. Here, the most nasty about the bug is that it is so silent after release-upgrading. I only discovered after wondering what makes machine learning slower as usual. So, I assume there will be much more new 18.04 users who have the same problem, but have not yet realized something is wrong as not everybody runs tensorflow-gpu/pytorch or games all the time.

Hans Hansen (hans005) wrote :

I had a variant of this problem (on Lenovo P51, M2200 Nvidia):

After upgrade from 17.10, where everything worked fine, to 18.04 the laptop still booted normally (I DID get login and desktop) but when I suspended or locked the screen I also got black screen and curser in upper left corner.

Now everything more or less works again by using this workaround from Bug #1752053 posting #123:

---------snip----------------
I found a silly workaround (after trying many many other suggestions / driver re-installs), now using nvidia-driver-396 or nvidia-driver-390; create (if not exists) a file /etc/rc.local, with this content:

#!/bin/bash

sleep 1

exit 0

And make it executable: chmod 755 /etc/rc.local
---------snip----------------

Maybe this helps some people.

R B (rz100) wrote :

Same here. After 18.04 install, I did an "apt upgrade", which installed nvidia-390 stuff among other things. After that no GUI. I tried to purge nvidia-* and reinstall nvidia-384, that did not work either. Same story with kubuntu-18.04.

Battant (mparchet) wrote :

Hello,

The GUI (graphicc user interface)!dose not start If i have no internet connection (offline )

An other personé (novice on ubuntu ) has upgrade Ubuntu 16.04 to Ubuntu 18.04 Have the same probkeme

The internet must connect at start (Ethernet or WiFi)

Same problem whith the live dvd ?

Why this internet connection deprndence

Why the GUI coud’nt Start ofline

Could you confirme this and help me to fix this issue

Thanks for your support

Best regards

Battant

William S Gregory (0c-bill) wrote :

I have what seems to be a similar problem. Have a machine with stock Ubuntu 18.04 clean install. Ran fine with latest recommended proprietary driver for over 2 weeks. Then Friday the 15th June, 2018 it refuses to use the proprietary drivers. The latest Kernel version will not even show the login screen, just hangs in the tty 1. The previous kernel shows the login screen, but it is choppy and will not accept valid login credentials.

Also, noticed that lspci shows that only nvidiafb and nouveau modules are loaded, no drm or nvidi_xxx.

I have purged and installed three different sets of drivers with no success thus far.

Battant (mparchet) wrote :

Hello

If you refuse to install the trees party it seems WiFi can’t work

Is it possible to install Nvidia free driver and WiFi property drivers ?

  Thanks for your support

 Best regards

Battant

samurailink3 (samurailink3) wrote :

Can we get an update here? I have a system that is useless as a desktop until this is resolved.

Doris (kagami06) wrote :

I have the same problem as everybody here.(MSI PE60 - Nvidia GTX960M)
I tried to install nvidia 390 in many many ways. And every time, it boot on a black screen or it's flooded with PCIe Bus error that NEVER stops. (Really, +25 hours running, I've tried...) Can't even switch to console. So I have to go to the recovery mode to purge nvidia 390 driver.

Also as said in the bug description, I can't use HDMI anymore.

Now in lcpi, as I am in the nouveau driver, nvidiafb and nouveau is written.

I tried all the solutions I could find on the web without success.

Please fix this issue and make an update for us.

Battant (mparchet) wrote :

Hello,

I have make a boot usbpen whith esay2boot.com whith ubuntu 18.04, xubntu 18.04, lubuntu 18.04, kubuntu 18.04 and ubuntu 16.04

I tried to install ubuntu 18.04 and xubuntu 18.04

Sane result : unable to log in with a correct username and password.

If I take the terminal (atrl alt f2) and I enter the correct login and password i get the "incorrect login " message

Same result with an ubuntu 18.04 fresh install.

So I take a xubuntu 17.10 backup and upgrade to xubuntu 18.04

Result no problem

but when I migrate to ubuntu, unable to login again

whith ubuntu 16.04, same result.

An ubdate sutch as bad security update is it the problem source ?

Thanks for your support

Best regards

Battant

I just tried again to test if nvidia updates would fix this ugly bug. In summary: no.

I also tried the graphics-drivers ppa mentioned (specifically tried the 340 and 390 drivers) with the same negative results.

The only working solution for my nvidia-prime laptop (nvidia+intel) is using nouveau+Wayland. Nvidia does not work at all. This is suboptimal as Wayland is less stable and there is a performance penalty when using nouveau.

hoan (hoan) wrote :

Here is a live iso xubuntu-bionic with nvidia-390.48 and prime from MatheuGras-TimRichardson

It switched correctly on live testing with Acer VN7 laptop 4GB

https://sourceforge.net/projects/toysbox/files/bionic-nvidia/xubuntu-18.04-4.15.0-24-nvidia.iso

  Screenshots + Logs are on the site

 xubuntu@xubuntu:~$ cat /proc/cmdline BOOT_IMAGE=(loop)/casper/vmlinuz iso-scan/filename=/iso/xubuntu-18.04-4.15.0-24-nvidia0.iso file=/cdrom/preseed/xubuntu.seed waitusb=5 boot=casper

xubuntu@xubuntu:~$ uname -a
Linux xubuntu 4.15.0-24-generic #26-Ubuntu SMP Wed Jun 13 08:44:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

xubuntu@xubuntu:~$ inxi -G
Graphics:
Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
Card-2: NVIDIA GM107M [GeForce GTX 860M]
Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau) Resolution: 1920x1080@60.02hz
OpenGL: renderer: GeForce GTX 860M/PCIe/SSE2 version: 4.6.0 NVIDIA 390.48

xubuntu@xubuntu:~$ xrandr --listproviders
Providers: number : 2
Provider 0: id: 0x23a cap: 0x1, Source Output crtcs: 0 outputs: 0 associated providers: 1 name:NVIDIA-0
Provider 1: id: 0x44 cap: 0x6, Sink Output, Source Offload crtcs: 3 outputs: 2 associated providers: 1 name:modesetting

xubuntu@xubuntu:~$ glxinfo | grep NVIDIA
server glx vendor string: NVIDIA Corporation
client glx vendor string: NVIDIA Corporation
OpenGL vendor string: NVIDIA Corporation OpenGL core profile version string: 4.6.0 NVIDIA 390.48 OpenGL core profile shading language version string: 4.60 NVIDIA
OpenGL version string: 4.6.0 NVIDIA 390.48
OpenGL shading language version string: 4.60 NVIDIA
OpenGL ES profile version string: OpenGL ES 3.2 NVIDIA 390.48

xubuntu@xubuntu:~$ glxgears
Running synchronized to the vertical refresh. The framerate should be approximately the same as the monitor refresh rate.
 69297 frames in 5.0 seconds = 13859.334 FPS
 68090 frames in 5.0 seconds = 13617.823 FPS

xubuntu@xubuntu:~$ glxspheres64 Polygons in scene: 62464 (61 spheres * 1024 polys/spheres) Visual ID of window: 0xa8 Context is Direct OpenGL Renderer: GeForce GTX 860M/PCIe/SSE2
1914.953887 frames/sec - 2137.088538 Mpixels/sec
1964.035952 frames/sec - 2191.864122 Mpixels/sec

Mathew Garland (kromosome) wrote :

Ubuntu 18.04
Mate & XFCE
Running Nvidia 390 - NVIDIA Corporation GM107M [GeForce GTX 850M] (rev a2)

Same issue faced here. Initially everything was running well until I tried installing the CUDA libraries for Machine Learning purposes. This was the start of this disaster.

This Issue should be considered a show stopper!

Sebastian (betriebsrat-3) wrote :

Ubuntu 18.04 (mint 19)
Cinnamon
Running Nvida 390 on Thinkpad W541

Same issue. Interestingly it works while being docked and connected to multiple monitors via dock. Could find a way to make it worked undocked yet. Tried all PPA drivers, alternative displaymanagers(slim, gdm) and what not.

I saw somewhere else i believe that you can comment out:
     Option "PrimaryGPU" "Yes"
in
/usr/share/X11/xorg.conf.d/11-nvidia-prime.conf

to make it work.
Well it does show the login screen afterwards but cinnamon is contantly crashing and everything being super slow. But that might be a hint to the right direction.

Mathew Garland (kromosome) wrote :

*** WORKAROUND CONSISTENTLY WORKING ***

After doing the following:

$ sudo apt purge nvidia-*
$ sudo apt install nvidia-390 nvidia-driver-390

I have been able to consistently work around this bug by doing the following on each boot:

1) On boot commence press ESC once
2) Enter the Advanced Options for Ubuntu
3) Enter password for encrypted disk as appropriate
4) In Recovery Menu, select, "Network" and then, "Yes" in the modal confirmation dialog which is asking you to continue.
5) When the init process reaches: [OK] Reached Target Swap the initialisation process hangs. At this point, press CTRL + C once.
6) Wait for the boot process to complete and then select your desired desktop/display manager from the graphical display as appropriate, mine is MATE.
7) Provide your password as appropriate and login

Some errors may be encountered upon display manager starting, some errors of mine referenced XOrg, but nothing which prevents me using my system.

Good luck!

Mat

Mathew Garland (kromosome) wrote :

oops, see steps above, in between step 1 & 2, choose Ubuntu Recovery from Advanced Options Menu

Janek Schleicher (hanfried) wrote :

With end-of-life of ubuntu 17.10 the issue is more urgent than ever.

Sebastian (betriebsrat-3) wrote :

seems to be the issue is resolved with an update run of the following packages:
 Upgrade: perl-base:amd64 (5.26.1-6ubuntu0.1, 5.26.1-6ubuntu0.2), screen:amd64 (4.6.2-1, 4.6.2-1ubuntu1), libsystemd0:amd64 (237-3ubuntu10.2, 237-3ubuntu10.3), libsystemd0:i386 (237-3ubuntu10.2, 237-3ubuntu10.3), grub-common:amd64 (2.02- 2ubuntu8.1, 2.02-2ubuntu8.2), perl-modules-5.26:amd64 (5.26.1-6ubuntu0.1, 5.26.1-6ubuntu0.2), console-setup-linux:amd64 (1.178ubuntu2, 1.178ubuntu2.3), grub2-common:amd64 (2.02-2ubuntu8.1, 2.02-2ubuntu8.2), udev:amd64 (237-3ubuntu10.2, 237-3ubuntu10.3), console-setup:amd64 (1.178ubuntu2, 1.178ubuntu2.3), dkms:amd64 (2.3-3ubuntu9.1, 2.3-3ubuntu9.2), grub-pc:amd64 (2.02-2ubuntu8.1, 2.02-2ubuntu8.2), libudev1:amd64 (237-3ubuntu10.2, 237-3ubuntu10.3), libudev1:i386 (237- 3ubuntu10.2, 237-3ubuntu10.3), libperl5.26:amd64 (5.26.1-6ubuntu0.1, 5.26.1-6ubuntu0.2), localechooser-data:amd64 (2.71ubuntu2, 2.71ubuntu3), grub-pc-bin:amd64 (2.02-2ubuntu8.1, 2.02-2ubuntu8.2), udisks2:amd64 (2.7.6-3, 2.7.6-3ubuntu0. 1), libnss-myhostname:amd64 (237-3ubuntu10.2, 237-3ubuntu10.3), systemd-sysv:amd64 (237-3ubuntu10.2, 237-3ubuntu10.3), gir1.2-udisks-2.0:amd64 (2.7.6-3, 2.7.6-3ubuntu0.1), libpam-systemd:amd64 (237-3ubuntu10.2, 237-3ubuntu10.3), systemd: amd64 (237-3ubuntu10.2, 237-3ubuntu10.3), libnss-systemd:amd64 (237-3ubuntu10.2, 237-3ubuntu10.3), keyboard-configuration:amd64 (1.178ubuntu2, 1.178ubuntu2.3), libudisks2-0:amd64 (2.7.6-3, 2.7.6-3ubuntu0.1), perl:amd64 (5.26.1-6ubuntu0. 1, 5.26.1-6ubuntu0.2)

Nguyen Xuan Viet (vietnx) wrote :

Yes, it seems this bug does not happen any more on my PC.
But the update alone does not resolve the issue.
After I remove - install the drivers, lightdm and gdm several times, suddenly it works :))

Serhiy Zahoriya (xintx-ua) wrote :

I've managed to get it working, the last thing I did was creating this file

$ cat /etc/modprobe.d/zz-nvidia.conf
options nvidia_390_drm modeset=1
options nvidia_drm modeset=1

But I'm not sure this is the only thing required. AFAIU, only one of these lines is correct but it works with both of them present and I'm really tired of restarting everything to figure out which one.

Marek Grand (grandm) wrote :

Hi,
I think this helps no matter the OS, I mean, "unices"...
I did that on fedora 29 modular. Delete every xorg.conf-files you can find.
$ sudo rm /etc/X11/xorg.conf
(on fedora there's one in /usr/share/X11 too)
($ sudo rm /usr/share/X11/xorg.conf)
Then restart the login manager (or reboot)
$ sudo service [login-manager here, either gdm, xdm, lightdm, sddm, whatever] restart

I assumed this 'cause nvidia-xconfig was said to be deprecated. Thank you fedora :)

Marek Grand (grandm) wrote :

Oh, I'd like to add it isn't perfect yet, as it gets you to software rendering on Cinnamon.
MATE+compiz should work fine. I'll confirm or infirm this later on.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers