nouveau/nvidia drivers do not work with display in Bionic on Asus GL703VD Laptop

Bug #1761261 reported by Luke Williams on 2018-04-04
This bug affects 4 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-390 (Ubuntu)
Alberto Milone
xserver-xorg-video-nouveau (Ubuntu)
Alberto Milone

Bug Description

Tried to install Bionic Desktop on my Asus GL703VD ROG Laptop with NVIDIA GTX 1050M Video Card (with i915 Intel graphics card when not using 3D) and the installer does not display. I have tried nouveau.modeset=0 and nomodeset boot options to no avail. I was able to finally install Bionic by hooking up the laptop to a projector, but after a reboot, the laptop display still did not work and I had to set the account to autologin otherwise I could not login to the laptop. I then install openssh-server so that I could ssh into the laptop and I installed the nvidia-390 drivers from ppa:graphics-drivers/ppa which installed, but still no local display.

In Artful, I could install with the nouveau.modeset=0 and then installing the proprietary NVIDIA drivers and everything (except touchpad, LP: 1738263) worked.

lspci shows the graphics card and NVIDIA card, and lsmod does show that before NVIDIA drivers install, it is using nouveau, asus_wmi, and i915 for graphcis, and once NVIDIA drivers are install, lsmod only shows i915 and asus_wmi for graphics while nvidia is used for gpu and 3D, but still no display on the laptop.

lsmod_prenvidia.txt shows the nouveau driver and the /proc/cmdline
lsmod_nvidia.txt shows nvidia drivers installed and the /proc/cmdline
lspci.txt shows the detected hardware
lshw.txt shows the hardware in the laptop.

Please let me know if you need any other information.


Luke Williams (wililupy) wrote :
Luke Williams (wililupy) wrote :
Luke Williams (wililupy) wrote :
Luke Williams (wililupy) wrote :
Luke Williams (wililupy) on 2018-04-05
description: updated
Luke Williams (wililupy) on 2018-04-05
Changed in nvidia-graphics-drivers-390 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Changed in xserver-xorg-video-nouveau (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
Davide Villa (davidev) wrote :

Same problem on my ASUS GL703VD.
I tried the 18.04 beta today starting a live session with the suggested boot option (modprobe.blacklist=nouveau).
I can work using an external monitor connected to the HDMI interface. The laptop display become black during the boot just after few seconds but I can see the boot progress on the external monitor.

The system works fine with Ubuntu 17.10 with the old kernel 4.13.0-38-generic.

I tried the new kernel 4.16 with ubuntu 17.10 from the mainline repository but the problem is the same: black laptop screen during boot, external HDMI monitor working.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Confirmed
Davide Villa (davidev) wrote :

Maybe the back-light problem is related to the patch for the Elan1200 touchpad:

Alberto Milone (albertomilone) wrote :

can you attach your /var/log/gpu-manager.log, please?

Davide Villa (davidev) wrote :

Here's my log file, as requested, running on the "standard" 17.10 kernel with the latest nvidia driver.
investigating my issue I tried to install the 4.15 and 4.16 series kernel using this version of the nvidia driver.
the monitor works fine in the 4.15.3 version, but in the 4.15.4 and higher the monitor remains off.

Luke Williams (wililupy) wrote :

I have noticed the same thing. I am running on 16.04 with the HWE 17.10 kernel and monitor works.
I installed the bionic 4.14.0-17 kernel and I was able to still use the laptop display. I tried the latest Bionic kernel (4.15.0-13) and it does not work.
During testing on another bug (LP:1738263) I tested Artful with the Bionic kernel 4.15.0-10 and everything appeared to be working normally with the exception that DKMS failed to build the NVIDIA modules due to not being compatible with the the header files. However, when you install anything newer, the display fails to stay on past the GRUB menu.

Luke Williams (wililupy) wrote :

It could be a backlight issue. I tried with the latest daily-build (April 16, 2018) and I boot up with the nouveau.modeset=0 kernel param and it shows the splash screen, and then I hear the login sound, and if I turn off the lights in my office and look closely, I can see the display, but it looks like the backlight for the screen is not lit. I tried adjusting the brightness using the FN+F7/F8 (Which adjust brightness) and they don't work (They don't work on any other distribution/Release as well. Only things that work are volume control and Projector options).

Davide Villa (davidev) wrote :

Hi all,
I found this bug report:
and this patch seems to solve the backlight problem (and the ELAN jercky touchpad as well)
I don't know how to compile the kernel with this patch.
maybe someone can build the kernel for me to test on my laptop or let me know how to build myself.

The attachment "spth-pinctrl-fix.diff" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Luke Williams (wililupy) wrote :

So I patched the 4.15.0-15-generic kernel from with the supplied patch and then intstalled the kernel on my 16.04 xenail laptop and everything works as it should. The display came up, the touch pad is responsive and working normally. I have enclosed my dumps of lswh, lspci, lsmod and my cmdline output.

How I installed this:
I build a bionic container on my laptop:
lxc launch ubuntu-daily:bionic kernel
lxc file push spth-pinctrl-fix.diff kernel/root/
lxc exec kernel bash
apt update && apt upgrade -y
apt build-dep linux-image-`uname -r`
apt install fakeroot
git clone git://
cd ubuntu-bionic
cp ../spth-pinctrl-fix.diff .
patch -p1 < spth-pintctrl-fix.diff
fakeroot debian/rules clean
fakeroot debian/rules binary-headers binary-generic binary-perarch

After the build and the output of the deb files:
mkdir ~/kernel-test
cd ~/kernel-test
lxc file pull kernel/root/linux-image-4.15.0-15-generic_4.15.0-15.16_amd64.deb .
lxc file pull kernel/root/linux-image-extra-4.15.0-15-generic_4.15.0-15.16_amd64.deb .
lxc file pull kernel/root/linux-headers-4.15.0-15_4.15.0-15.16_all.deb .
lxc file pull kernel/root/linux-headers-4.15.0-15-generic_4.15.0-15.16_amd64.deb .

Also, the linux-headers-4.15.0-15 deb depends on libssl1.1, which is default in Bionic, but not in Xenial, so I had to download that deb file from here:

And then I just used dpkg -i to install the files and reboot the laptop and it started up properly.

While the laptop display works and the touchpad is responsive and works properly. there are still issues with the FN+F7/F8 brightness controls, and the other FN options that should work out of the box, but at least the display works with the 4.15.0-15 kernel

Luke Williams (wililupy) wrote :

I tried testing with the latest RC build of the 4.17 kernel from (Torvald's GIT) and built the kernel following the instructions here [1].
After installing the kernel and headers, it looks like it regressed and the display did not work (backlight) and I could not switch terminals. I was able to reboot my laptop and switch the the previous kernel. My next test will be with the patches and see what happens.

Luke Williams (wililupy) wrote :

Trackpad and Graphics work with the spth-pincntrl-fix.diff patch on the 4.17 kernel, however, the wifi card does not work, and if you close the lid or it goes to hibernate, the system becomes unresponsive.

I removed this kernel and am working again on the 4.15.0-20 kernel with the patch.

Luke Williams (wililupy) wrote :

So I built a kernel from the Upstream LTS (4.17.3) and tried to apply the patch, which failed. So I removed it and tried a clean build and was able to get Xenial to boot up with this kernel. I then decided to install Bionic and install this kernel on my laptop however, I noticed that when I downloaded the latest version (as of July 2, 2018) the laptop display worked. I checked and I am running Bionic with the 4.15.0-24 kernel. I then installed the NVIDIA proprietary drivers and low and behold the laptop is working. (I had to modify my grub to include nouveau.modeset=0 since after logging in the display would hang, but after passing the kernel parameter everything worked out of the box.)

This is quite amazing! I'm going to check out the ChangeLog to see what patches you have running on this.

For the most part, things are working normally. I did notice if I try to go to the TTY1 or TTY2, I get the GNOME login Screen on TTY1 and my normal desktop on TTY2, but TTY3-6 are standard terminals. The brightness control keys still do not work, but the touchpad works so far from initial testing (Haven't tried the 5 finger test on it yet, but 4 fingers works) and the hibernate issue when the lid closes seems to be fixed since I was able to resume when I opened the laptop and pressed space bar to turn it back on.

I will continue to test, but we may have a winner winner chicken dinner for this bug.


To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.