nvidia-390 fails to boot graphical display

Bug #1752053 reported by walkerstreet on 2018-02-27
492
This bug affects 100 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
nvidia-graphics-drivers-390 (Ubuntu)
Critical
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Unassigned

Bug Description

I'm using Bionic with the new 4.15 kernel. I've been using the nvidia-384 driver with no problem for a while. Today I issued "sudo apt-get upgrade" and I was prompted to upgrade the nvidia driver to the nvidia-390. After installing the driver and rebooting, I was only able to boot in to the tty terminal. The graphical display failed to boot. I have had similar problems with nvidia driver version 390 with Arch Linux and with Open Suse Tumbleweed.

Igor Mokrushin (mcmcc) wrote :

Same thing, after update and reboot I get only to console...

My notebook Asus ROG GL553VE with installed Kubuntu 18.04.

x15 (x15) wrote :

Same thing too. 18.04 Kubuntu with GTX 560, ASUS P6T Deluxe V2

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: New → Confirmed
x15 (x15) wrote :

Before reboot there was no libGl....
After reboot the log says:

Parse error on line 5 of section OutputClass in file /usr/share/X11/xorg.conf.d/nvidia-drm-outputclass-ubuntu.conf "Option" is not a valid keyword in same section.
Problem parsing the config file
Error parsing the config file
Fatal server error:
no screens found(EE)

Igor Mokrushin (mcmcc) wrote :

This packages are broken, library files install in root directory /#...
Also, there is no replace of alternative symbolic links ones in /etc/alternatives, they remain from previous versions to non-existent files...

Alberto Milone (albertomilone) wrote :

The new driver is not going to work without libglvnd and xorg-server from bionic-proposed. Sorry for the inconvenience.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
importance: Undecided → Critical
tags: added: regression-release
Steve Langasek (vorlon) wrote :

If it doesn't work without the libglvnd and xorg-server from bionic-proposed, then there should be versioned Depends: or versioned Breaks: expressing this. Alberto, can you make sure this is added in the next upload?

Brian Murray (brian-murray) wrote :

I had to install the following packages from bionic-proposed to get a working X session again.

libglvnd0, xserver-xorg-core, and libgl1-mesa-glx.

tags: added: rls-bb-incoming
Dejan V. (lnxsurf) wrote :

Hi,
I have the same problem...

I tried to install
libglvnd0, xserver-xorg-core, and libgl1-mesa-glx

but it doesn't work for me...

walkerstreet (dbonner) wrote :

I added bionic-proposed and upgraded to the latest: libglvnd0, xserver-xorg-core, and libgl1-mesa-glx
After doing that, I get a blank screen. I have to Ctrl-Alt-F1 to go to tty console mode.
So the suggested fix did not work for me either.

I encountered a dead symbolic link for libvdpau.so:

$ ls -l /usr/lib/x86_64-linux-gnu/libvdpau_nvidia.so
lrwxrwxrwx 1 root root 31 Feb 22 18:50 /usr/lib/x86_64-linux-gnu/libvdpau_nvidia.so -> vdpau/libvdpau_nvidia.so.390.25

libvdpau_nvidia.so.390.25 is located in the same directory, not in the subdirectory vdpau: https://packages.ubuntu.com/bionic/amd64/libnvidia-decode-390/filelist

Which can be fixed using the following commands:
cd /usr/lib/x86_64-linux-gnu/
sudo ln -sf libvdpau_nvidia.so.390.25 libvdpau_nvidia.so

Chris (cmseuk) wrote :

I already have libglvnd0, xserver-xorg-core, and libgl1-mesa-glx installed. I am not using an nvidia driver or hardware and I have the same problem. Unable to boot into system.

Chris (cmseuk) wrote :

 "Started gnome display manager.....service link was shutdown. Tried to start xserver and got libGl.so not found error.

Chris (cmseuk) wrote :

I upgraded to proposed and the issue is fixed.

x15 (x15) wrote :

I've able to run jwm (startx jwm) and rxvt. Firefox and konsole need libGl but Vialdi, OneTeam and Thunderbird work fine somehow....

Ive had this same problem. I have an nvidia 960m in my laptop using nvidia-390. After I upgraded, I got the “Option is not a valid keyword...” as well. For future refernce, you can get a rudamentary GUI
1. apt removing and apt purging all things nvidia then rebooting
2. At the GRUB screen, add “nomodeset” to the kernel parameters
3. Upon arriving at the lightdm login screen, switch to TTY 1 with ctrl + alt + F1 and chown the .Xauthority file to your_user:your_user
4. Switch back to the login with ctrl + alt + F7 and login like usual.

It’ll look ugly but it works. Tested on Unity.

Changed in nvidia-graphics-drivers-390 (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)

I haven’t fully upgraded to proposed yet but adding the symlink and the packages Alberto specified did not solve my problem.

Dejan V. (lnxsurf) wrote :

How did you install the proposed packages? I think I did but no change appeared.

Uncomment proposed repo in `/etc/apt/sources.list` then run `sudo apt update` then you can either install the packages you want specifically or you can `sudo apt upgrade` to update all of them at once.

Dejan V. (lnxsurf) wrote :

Hmm... I don't have any line commented. So would you print me the lines which I have to uncomment, please?

Sergei Beilin (saabeilin) wrote :

Updating to `proposed` did not help me. I've tried uninstalling/purging `nvidia-*` and installing it back, still having the black screen.

Tried to switch to Intel adapter using prime-select, it complains that it's not supported.

Purging nvidia-390 and installing nvidia-340 works (though Nvidia always runs on top clock, even on battery, overheating my knees, and always on 100% brightness)

Dell Latitude 6430, NV520.

@lnxsurf, “deb http://us.archive.ubuntu.com/ubuntu/ bionic-proposed multiverse main universe restricted” that line gets added to your sources file.

Dejan V. (lnxsurf) wrote :

Great! Thanks alot for your help.
I used “deb http://de.archive.ubuntu.com/ubuntu/ bionic-proposed multiverse main universe restricted"
Then I installed the mentioned packages but still it did not work.
After I executed "sudo apt dist-upgrade" everything got better. I could start my desktop again.

Confirmed on Unity for me, adding proposed and running sudo apt update && sudo apt upgrade works. I can boot fully with no problems into lightdm and unity runs fine after logon.

Chris McDonough (chrism-plope) wrote :

After having the same problem, I dist-upgraded to proposed and can confirm that it fixed it (I did an apt-get purge nividia* before the dist-upgrade then a apt-get install nvidia-384 after the dist-upgrade)/

One thing that this minor bug pointed out to me is that it has become inconvenient in the current strategy to revert to an older Nvidia driver version, as nvidia-384 is now a transitional package that depends on nvidia-390. Even after adding the graphics-driver ppa, it was not trivially possible to downgrade from 390. I understand the intent (upgrade folks to the latest proprietary thing without them needing to take extra action), but I sort of wonder whether the packages should be renamed so they don't match the graphics-driver ppa names, such that we could purge nvidia, then add the ppa, then do e.g. apt-get install nvidia-387 and actually get 387 instead of 390.

Nate Swanson (nswanson08) wrote :

The proposed repo with dist-uprade worked for me

walkerstreet (dbonner) wrote :

I have successfully installed the driver using the proposed repo packages on my laptop. I need to try my desktop again.
Does anyone know how to use nvidia prime-select and bumblebee/optirun with this driver. My laptop battery might drain fast using this mode.

Peter Silva (peter-bsqt) wrote :

tried the *proposed* recipe above. no luck for me:
as it is installing, it errors:

npacking nvidia-dkms-390 (390.25-0ubuntu1) over (390.25-0ubuntu1) ...
Setting up nvidia-dkms-390 (390.25-0ubuntu1) ...
dpkg: error: version '-' has bad syntax: revision number is empty
dpkg: error: version '-' has bad syntax: revision number is empty
update-initramfs: deferring update (trigger activated)
INFO:Enable nvidia
...

and the xorg doesn't find the nvidia driver on startup.

Renaud Lepage (cybik) wrote :

I managed to fix my setup by using the Graphics Drivers PPA (https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa) and forcing the install of version 390.25-0ubuntu0~gpu18.04.1 (apt-get install nvidia-390=390.25-0ubuntu0~gpu18.04.1 or something). I suspect version 390.25-0ubuntu1 is broken.

Brian Murray (brian-murray) wrote :

For the development release of Ubuntu it is not recommended to install the packages from -proposed because they have not passed automated testing yet. I only installed the exact packages I needed and then disabled -proposed. Here's the full set of packages I installed incase I missed one.

Start-Date: 2018-02-27 10:58:32
Commandline: apt-get install nvidia-driver-390
Requested-By: bdmurray (1000)
Install: nvidia-compute-390:amd64 (390.25-0ubuntu1, automatic), libnvidia-encode-390:amd64 (390.25-0ubuntu1, automatic), xserver-xorg-video-nvidia-390:amd64 (390.25-0ubuntu1, automatic), libnvidia-fbc1-390:amd64 (390.25-0ubuntu1, automatic), libnvidia-decode-390:amd64 (390.25-0ubuntu1, automatic), nvidia-compute-no-dkms-390:amd64 (390.25-0ubuntu1, automatic), libnvidia-cfg1-390:amd64 (390.25-0ubuntu1, automatic), nvidia-utils-390:amd64 (390.25-0ubuntu1, automatic), libnvidia-fbc1-390-i386:i386 (390.25-0ubuntu1, automatic), libnvidia-ifr1-390-i386:i386 (390.25-0ubuntu1, automatic), nvidia-compute-utils-390:amd64 (390.25-0ubuntu1, automatic), libnvidia-ifr1-390:amd64 (390.25-0ubuntu1, automatic), nvidia-driver-390:amd64 (390.25-0ubuntu1), libnvidia-encode-390-i386:i386 (390.25-0ubuntu1, automatic), screen-resolution-extra:amd64 (0.17.2, automatic), libnvidia-decode-390-i386:i386 (390.25-0ubuntu1, automatic), nvidia-settings:amd64 (384.69-0ubuntu1, automatic)
End-Date: 2018-02-27 10:58:38

Start-Date: 2018-02-27 11:12:22
Commandline: apt-get install libgl1-mesa-glx
Requested-By: bdmurray (1000)
Install: libegl1:amd64 (1.0.0-2ubuntu1, automatic), libgl1:amd64 (1.0.0-2ubuntu1, automatic), libopengl0:amd64 (1.0.0-2ubuntu1, automatic), libgles2:amd64 (1.0.0-2ubuntu1, automatic), libglvnd-dev:amd64 (1.0.0-2ubuntu1, automatic), libglx0:amd64 (1.0.0-2ubuntu1, automatic), libglvnd-core-dev:amd64 (1.0.0-2ubuntu1, automatic), libglx-mesa0:amd64 (18.0.0~rc4-1ubuntu1, automatic)
Upgrade: libgles2-mesa:amd64 (17.3.3-0ubuntu1, 18.0.0~rc4-1ubuntu1), libegl1-mesa-dev:amd64 (17.3.3-0ubuntu1, 18.0.0~rc4-1ubuntu1), libglapi-mesa:amd64 (17.3.3-0ubuntu1, 18.0.0~rc4-1ubuntu1), mesa-common-dev:amd64 (17.3.3-0ubuntu1, 18.0.0~rc4-1ubuntu1), libegl1-mesa:amd64 (17.3.3-0ubuntu1, 18.0.0~rc4-1ubuntu1), libwayland-egl1-mesa:amd64 (17.3.3-0ubuntu1, 18.0.0~rc4-1ubuntu1), libgles2-mesa-dev:amd64 (17.3.3-0ubuntu1, 18.0.0~rc4-1ubuntu1), libgl1-mesa-dev:amd64 (17.3.3-0ubuntu1, 18.0.0~rc4-1ubuntu1), libgl1-mesa-glx:amd64 (17.3.3-0ubuntu1, 18.0.0~rc4-1ubuntu1)
End-Date: 2018-02-27 11:12:26

Bruce Pieterse (octoquad) wrote :

I've installed the packages from proposed and I can see that X can now load the nvidia module, but out of curiosity, would it cause:

org.gnome.Shell.desktop[4934]: /usr/bin/gnome-shell: error while loading shared libraries: libEGL.so.1: cannot open shared object file: No such file or directory

Due to that the following occurs:

gnome-session-binary[4911]: Unrecoverable failure in required component org.gnome.Shell.desktop
gnome-session[4911]: gnome-session-binary[4911]: CRITICAL: We failed, but the fail whale is dead. Sorry....
gnome-session-binary[4911]: WARNING: App 'org.gnome.Shell.desktop' respawning too quickly
gnome-session-binary[4911]: CRITICAL: We failed, but the fail whale is dead. Sorry....

$ locate -e libEGL.so.1
/usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1
/usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1.0.0

Any ideas, or should this specific library problem be reported against gnome-shell?

Brian Murray (brian-murray) wrote :

 $ dpkg -S /usr/lib/x86_64-linux-gnu/libEGL.so.1
libegl1:amd64: /usr/lib/x86_64-linux-gnu/libEGL.so.1

So install libegl1.

Francois Thirioux (fthx) wrote :

Maybe it's not the place to do that but could it be possible that an Ubuntu developer tell us what are the changes in this new driver & packaging ?
Questions :
- will it be possible to use Wayland running Nvidia ?
- will it be possible to change GPU without rebooting ?
- will it be possible to do like Nouveau, I mean launch an app using the discrete GPU (right click menu) ?
- how can we now switch GPU on an Optimus configuration ?
Ubuntuforums dev section :
https://ubuntuforums.org/forumdisplay.php?f=427

Alberto Milone (albertomilone) wrote :

@walkerstreet: disabling the dGPU won't work, because of logind:
https://github.com/systemd/systemd/issues/6908

@Peter Silva: that is not an actual error. You are going to need the new xserver and the new libglvnd from bionic-proposed.

walkerstreet (dbonner) wrote :

My desktop computer won't display the X desktop on my monitor after installing the new driver with the Bionic-proposed packages. I get a blank screen except for a tty cursor in the top left corner of the screen. I can view the X desktop remotely using Teamviewer though, which is really wierd. Typing nvidia-smi verifies that driver 390.25 is installed and running. I have 2 nvidia 1080Ti cards. Since the new driver is unusable on my desktop, I have reverted back to nvidia-384. Does anyone have any suggestions as to how I can get the new driver to display the X desktop on my monitor?

Peter Silva (peter-bsqt) wrote :

I now have drivers from bionic proposed, the problem I had before
was that I had attempted to manually correc nvidia-drm-outputclass-ubuntu.conf by commenting out the lines which had caused errors before,
and re-installing wasn't overwriting it.
I returned it to default state. I can now get the lightdm up.

on xorg.0.log it seems to load now, I get to the login dialog,
but none of my sessions will load ( I just go back to the lightdm dialog.) there are no errors, it just dumps me back at the lightdm
screen. I added a bunch of -desktop packages to see if it was an
environment thing. The failure to login happens with *ubuntu*, *unity (default)*, *Ubuntu on Wayland*. With *mate* it doesn't exist, but I get a screen with a single icon, and no other elements of a desktop, so I can only open
shells.

Try switching to a TTY when the lightdm screen comes up and running “chown your_user:your_user .Xauthority” then try to login with lightdm.

Peter Silva (peter-bsqt) wrote :

OK, video is back now: apt-install ubuntu-mate-desktop fixed something.
It was already installed, but doing it again tickled something. I logged into
mater, and there was half a dozen core dumps of various components, and then
everything started working. (I don´t actually use mate, it was just trying
to see if issue was related to desktop environment in use.) I logged out, and now everything is now normal again.

now I can log in again, with the same environment I had before the problem.
I´ve now commented out bionic proposed from /etc/apt/sources.list
stuff looks ok.

Bruce Pieterse (octoquad) wrote :

Thanks Brian,

Looks like libegl1 landed today. Picked it up with a normal apt update and everything is good again.

Chris McDonough (chrism-plope) wrote :

Downgraded from proposed using pins and after a dist-upgrade it works, thanks!

Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Confirmed → Incomplete
assignee: Alberto Milone (albertomilone) → nobody
Changed in mesa (Ubuntu):
status: New → Incomplete
Changed in nvidia-graphics-drivers-390 (Ubuntu):
status: Incomplete → Fix Released
Changed in mesa (Ubuntu):
status: Incomplete → Fix Released
Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Invalid
77 comments hidden view all 157 comments

#116 worked for me, thanks

Tom (tom-lorinthe) wrote :

#117 worked for me, although "suspend" is still shaky; 50% of time I need to force power off.

tried #116 and also #108. Now all I get is a boot loop at the lighdm login screen. Put in password and it brings me back to login screen. This is so frustrating....smh

Tom (tom-lorinthe) wrote :

@Bernadette: If I would have same situation again, I think I would:

1 - Ctrl-Alt-F3/2 at login prompt
2 - sudo apt purge nvidia*
3 - sudo apt install nvidia-390
4 - sudo prime-select intel
5 - sudo nvidia-xconfig
6 - sudo nano /etc/X11/xorg.conf
7 - .. and replace with contents of #117
8 - sudo nano /etc/default/grub
9 - .. GRUB_CMDLINE_LINUX_DEFAULT="'quiet splash acpi_osi=Linux acpi_osi=! acpi_osi=Windows 2009' nouveau.runpm=0"
10- sudo update-grub
11 - sudo reboot
12 - login...
13 - and start praying...

@Tom - getting closer! I can now login...but icons are HUGE!!! Lol. Need to fix resolution

Thijs Kaper (thijs-kaper) wrote :

I'm using a Dell m4800, with "NVIDIA GK107GLM Quadro K1100M" (3840x2160 pixels). Symptom; gdm login screen shows normally, but after typing password and hitting enter, I end up on black screen. This is after upgrade from 17.10 to 18.04.

I found a silly workaround (after trying many many other suggestions / driver re-installs), now using nvidia-driver-396 or nvidia-driver-390; create (if not exists) a file /etc/rc.local, with this content:

#!/bin/bash

sleep 1

exit 0

And make it executable: chmod 755 /etc/rc.local

What also worked for me, is start laptop, wait for login screen, and use another machine to ssh into the laptop, and execute "sudo service gdm stop ; sleep 5 ; sudo service gdm start".
After that, I could normally log on.

For me this seems to indicate some sort of timing or initialization issue...

Cédric (cedricbonhomme) wrote :

@Thijs Kaper: I have the exact same problem.

My alternative workaround:
Like you I authenticate, black screen after typing the password and hitting enter. Then I go to tty2, authenticate in the terminal, and type 'startx' (and 4 times Ctrl+C). And finally KDE starts without problem on tty2. This is crazy.

Like @Bernadette Addison I had huge icons. It was impossible to set a higher resolution with the KDE display manager. So I used xrandr:
xrandr --output eDP-1-1 --mode 1920x1200 --scale 1x1
for example.
The resolution is fine even after a reboot.

I also want to add that I am actually using the nvidia driver 396.24. Because I had so much problems before... I tried to add the graphics-driver ppa as advised by @Chris McDonough. I do not know if finally this helped me a little. Maybe I should switch back to 390.

My graphical interface is really a mess since the upgrade to 18.04 :-(

Emiliano (retorquere) wrote :

I've just ran do-release-upgrade on a Lenovo P51, and the systems hangs just after "Starting Session c1 of user gdm". I get a little further by purging nvidia-* (I get the GDM greeter again) but after logging in there, the screen freezes and a little later I'm kicked back to the greeter.

Emiliano (retorquere) wrote :

I tried #116 by @minterior, and I now have a working desktop, but it feels substantially more sluggish than it was under 17.10.

Kirill Romanov (djaler1) wrote :

Why this have "Fix released" status? I cannot login after "prime-select intel", I see only a black screen

Jan Wester (j-vester) wrote :

I just tested the thing in #123 and I can only conclude: i am writing this note in 18.04 with nvidia-396 drivers on a Lenovo Y720. So I can only agree to what Thijs says. This sounds like a timing problem.....

Back to where I started with a non-bootable machine, after modifying xorg.conf listed in post #121. I will go aheada purge these nvidia drivers again, and try #123 to see if that works. This is a crazy mess!!

Is there any way possible to gain early access to the "FIX RELEASED" files???

Tom (tom-lorinthe) wrote :
Symin (symin) wrote :

In my case it was... complicated.

Turns out that after upgrade to 18.04 wayland was on by default for me.
prime-select intel worked fine
prime-select nvidia gdm would not show

Changing wayland to xorg in gdm (with intel) would not work - login screen just kept reapearing. Forcing xorg through /etc/gdm3/custom.conf only made it worse.

In the end I have decided to try and unplug my DP cable from the mainboard and plug it into the gfx card. This has worked. After the reboot GDM has showed up and only xorg was available (I have switched to xorg before I swapped the cable, though).

No reverse prime for me :( Hopefuly plymouth works with nvidia these days or this gets fixed soon.

Kyle Weber (kyew01) wrote :

I hear Pop!_OS 18.04 doesn't have this issue. I'm unfortunately about to give up on Ubuntu and give that a try. Some word of reassurance from the Ubuntu team here would be nice. Where they marked this as fixed, I'm not hopeful of a fix--at least anytime soon. If anyone has found a true and simple workaround, please let us know! Otherwise, I think my hardware will require me to look somewhere else...

hey

There i am using ubuntu bionic 18.04 kernel 04.15.21

cant login on gdm or lightdm freezes on entering password or access tty on install nvidia-390 , nvidia 396 from ppa:graphics-drivers/ppa and nvidia-driver-390 from bionic main repo

used to have black screen on boot suddenly rectified

nouveau driver ends up in cpu hard and soft lock

need help desperately. not able to access GPU

Tom (tom-lorinthe) wrote :

@Joseph: did you try #121 ?

@tom-lorinthe

I have no issues with accessing Intel I just blacklisted nouveau for that purpose. I wanted to use Nvidia but on evry install it seems to crash the OS

will try and fix nvidia-prime after getting nvidia driver working

there is also dkms seems not to install in the kernel 4.15.21

anyways as you suggested it will attempt it thank you

no #121 don't work for me

I can access my desktop because i have blacklisted nouveau and using my intel gpu system which I assume is functioning via mesa drivers nomodeset also works
only issue is if i try to run nvidia

iuuuuan (ivan-janes) wrote :

I have finally getting to work my ubuntu 18.04 with drivers installed from additional drivers.

After update from ubuntu 17.10 to 18.04 nvidia-390 drivers were installed, nvidia-340 package was metapackage for nvidia-390.

Today I was able to install nvidia-340.106 driver directly from additional drivers, but they unfortunately did not work.

I have described method how to compile nvidia-340.104 for kernel 4.15 in #114 and this worked without problems.

I did comparison of nvidia-340.104 and nvidia-340.106 and found out that in nvidia-340.106 driver has fix for issue between the NVIDIA kernel driver's Page Attribute Table (PAT) support and the KPTI page table isolation.
no

After few tries with different kernel settings I have noticed that I have nopat option enabled in grub kernel boot.

Simple fix for that was to remove nopat option in grub

1. Open grub configuration file /etc/default/grub
# sudo vi /etc/default/grub

or

# sudo nano /etc/default/grub

2. Remove nopat from GRUB_CMDLINE_LINUX_DEFAULT

My current options looks like this:
GRUB_CMDLINE_LINUX_DEFAULT="splash nomdmonddf nomdmonisw nomdmonddf nomdmonisw"

3. Save file and exit editor

4. Update grub configuration

# sudo update-grub2

5. Reboot
# sudo reboot

6. Install recommended drivers
# sudo ubuntu-drivers autoinstall

7. Reboot
# sudo reboot

Dedas (andreas-winkler) wrote :

Ivan Janes,

With those options NVidia card seems to be disabled properly but now the systems hang whenever I plug in the laptop power charger. Also, I can only use Wayland and not Xorg (freeze again). Maybe the last one is a bad xorg.conf?

iuuuuan (ivan-janes) wrote :

Andreas, nvidia on my notebook is enabled and working properly. It is not disabled.

Currently I only one option enabled for GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub :
GRUB_CMDLINE_LINUX_DEFAULT="splash"

I do not have /etc/X11/xorg.conf file.

If you backup file /etc/X11/xorg.conf, remove it and reboot laptop, does it help ?

I have disabled wayland in /etc/gdm3/custom.conf with option (uncomment option in file):
WaylandEnable=false

What is prime-select query output ? - on my notebook it returns nvidia
$ prime-select query
nvidia

Dedas (andreas-winkler) wrote :

Thank you for your answer. I solved the problem with nvidia prime not really disabling the nvidia card (still drawing power) when switching to Intel with:

sh -c 'echo auto > /sys/bus/pci/devices/0000\:01\:00.0/power/control'

Almost halved the power draw on my Dell XPS 15.

Tom (tom-lorinthe) wrote :

@Dedas can you elaborate a bit more what that does?
- Is it safe?
- Will it allow switching nvidia on with "sudo prime-select nvidia" ?
- Is this command needed only once?

Volodymyr Buell (vbuell) wrote :

Got back screen yesterday but for my case it was a disk space issue. Booted into recovery mode, freed up space in root partition and rebooted. Everything seems work ok after that... Apparently nvidia does need some free space to boot up (it wasn't an issue before i think. My system partition is really tiny so it's almost normal to have zero free space on it)

Milan Pultar (pultami1) wrote :

I am not sure whether it is ok to post here, but I have lately found this github repo dedicated to making Ubuntu run on XPS 9560. It works for Ubuntu 17.10 and 18.04 will be hopefully added as well. Many of us have this laptop and the repo partly adresses the issues mentioned here so I thought posting the link here might not be a bad idea. I have not tried this myself yet, but I guess installing U17.10 is the only option now because of the drivers problem...

https://github.com/stockmind/dell-xps-9560-ubuntu-respin

Dedas (andreas-winkler) wrote :

@Tom

"can you elaborate a bit more what that does?
- Is it safe?
- Will it allow switching nvidia on with "sudo prime-select nvidia" ?
- Is this command needed only once?"

Yes it should be safe. It it freezes just restart your machine, the setting will be gone.

It turns off the nvidia gpu så no.

It is needed every time you boot. So use rc.local or something similar.

Kyle Weber (kyew01) wrote :

I upgraded from 17.10 to 18.04. It wouldn't log in, but through ssh I purged the nvidia drivers, installed 396 through the PPA, rebooted, and it came up and worked. It is a tower with GTX 1060.

Tom (tom-lorinthe) wrote :

@Dedas: I cant see any difference; power consumption on Dell XPS 15 9560 stays the same...

Tom (tom-lorinthe) wrote :

It seems with the following two commands, I can get my power from ~15W to ~8W on Dell XPS 15 9560:

 # move from Nvidia to intel graphics (if not already done)
 prime-select intel
 # switch of power to Nvidia (repeat after each laptop start)
 sudo sh -c 'echo auto > /sys/bus/pci/devices/0000\:01\:00.0/power/control'
 sudo sh -c "echo "1" > remove"

Dedas (andreas-winkler) wrote :

If you want it to stay create a file /etc/rc.local and make it executable:

sudo chmod +x /etc/rc.local

In rc.local type:

#!/bin/sh -e
sh -c 'echo auto > /sys/bus/pci/devices/0000\:01\:00.0/power/control'
sh -c "echo "1" > remove" (I didn't need this)
exit 0

Tom (tom-lorinthe) wrote :

echo "1" > /sys/bus/pci/devices/0000\:01\:00.0/remove is required for me to powerdown nvidia, but it results in powerdown freeze

Still investigating ... ((

also, still investigating. every one of these fixes all lead to the same outcome for me - cannot boot with nvidia proprietary drivers installed, or else stuck in a boot-loop after entering password at gdm screen.

Gmgarciam (gmgarciam) wrote :

Hello. My situation was very complicated, and none of the fixes I found would work. I am running a Nvidia GTX970 with an Intel CPU and using a dual monitor setup. Ubuntu 17.04 was working very well. Later upgrading to Ubuntu 17.10, the Nvidia graphics became an issue because of Wayland, but I followed this guide and was able to set it working for 17.10, https://charlienewey.github.io/getting-nvidia-drivers-working-on-ubuntu-17-10/ . For 18.04, nothing I found online was working. I was able to setup Openbox and use that to investigate the matter. I suspected it was some sort of opengl problem since all applications requiring it would fail to run and cheking with the terminal, it would say that the libGLU1.1.so was not found, or one of those opengl libraries. Upon further investigating, it turned out that the xorg that comes stock with 18.04 does not have the latest Mesa patch that supports nvidia graphics cards. So I ended up getting the padoka ppa in order to get the latest xorg and mesa. Upon doing so, everything is working fine. I thought this fix was a little unorthodox being that I believed that Padoka was for Nouvou and AMD cards but, apparently it fixed the issue with the proprietary 396 drivers. I had the same issue with the 384, and 390. So I am not sure if this fix only pertains to the Nvidia 396 drivers, but I believe the problem stems from an Xorg that does not have the latest Mesa.

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/mesa

Tom (tom-lorinthe) wrote :

@bernadette, it baffels me. Today my Xps 15, 9560 works flawlessly fast and nimble. I also nailed the power drain and now have ~5W running on battery, see https://github.com/stockmind/dell-xps-9560-ubuntu-respin/issues/8

Makes me thinking... what BIOS version do you have ? I run 1.9.4

ulyses (jose-abrural) wrote :

The only working solution for me for the Nvidia graphic card problem in Ubuntu 18.04, was to follow the instructions from this page:

https://medium.com/@emtudo/ubuntu-18-04-travamento-com-placa-nvidia-3720dfe7410a

and then start the system through recovery mode.

So, if this bug is marked as "fixed released" and 500 comments further it's clear it doesn't fix anything, should we open a new bug report?

I have the same problem of power drains even when prime-select is on intel. I know for sure that the nvidia GPU is running because the external HDMI port is working and shouldn't since it's wired to the GPU.

 sudo sh -c 'echo auto > /sys/bus/pci/devices/0000\:01\:00.0/power/control'
 sudo sh -c "echo "1" > remove"

gives no result on my system (Nvidia Quadro M2000M/Thinkpad P51).

Tom (tom-lorinthe) wrote :

@aurelienpierre: are you sure your laptop uses the same device number as the Dell XPS 15 this script was for (0000:01:00.0)?

Displaying first 40 and last 40 comments. View all 157 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.