/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

Bug #1662860 reported by dino99 on 2017-02-08
962
This bug affects 207 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-375 (Ubuntu)
High
Unassigned

Bug Description

Error while upgrading the package:

Setting up nvidia-375 (375.26-0ubuntu1) ...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

dpkg: error: version '-' has bad syntax: version number is empty

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: nvidia-375 375.26-0ubuntu1
ProcVersionSignature: Ubuntu 4.9.0-16.17-generic 4.9.6
Uname: Linux 4.9.0-16-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia_drm nvidia_modeset nvidia
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Feb 8 12:43:11 2017
SourcePackage: nvidia-graphics-drivers-375
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
dino99 (9d9) wrote :

Tested a complete nvidia* removal, then a reinstall, but still get the same error.

oem@u64:~$ ldd /usr/lib/nvidia-375/libEGL.so.1
 linux-vdso.so.1 => (0x00007fffceaeb000)
 libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fb5c34f6000)
 libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fb5c31ed000)
 libGLdispatch.so.0 => /usr/lib/nvidia-375/libGLdispatch.so.0 (0x00007fb5c2f04000)
 libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fb5c2b3d000)
 /lib64/ld-linux-x86-64.so.2 (0x0000555975bf3000)

dino99 (9d9) wrote :

oem@u64:/usr/lib/nvidia-375$ ls -aiF | grep libEGL
292910 libEGL_nvidia.so.0@
269365 libEGL_nvidia.so.375.26
292908 libEGL.so@
269322 libEGL.so.1
269355 libEGL.so.375.26

dino99 (9d9) wrote :

Well, that driver generate too many crashes now & then : lp:1663524 lp:1663528

back with 375.26-0ubuntu0~gpu17.04.1 from the graphics-drivers ppa which has no install issue (libEGL) and makes not the session crashing.

The zesty-proposed version is unusable.

dino99 (9d9) wrote :

#4 feedback

the crash still happen, and journalctl show issue about gnome-session ( lp:1663839 )

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-375 (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

Moved to newest nvidia-378.13 from the graphics-drivers ppa : install & work well

Morgan (m-t-garcia1987) wrote :

This also affected me on 16.04.

As user dino99 pointed out, upgrading to nvidia-378.13 solved the issue.

dino99 (9d9) on 2017-02-17
tags: added: xenial
Changed in nvidia-graphics-drivers-375 (Ubuntu):
importance: Undecided → High
Stefano (stefano-d) wrote :

I get this on Ubuntu 17.04 when installing the NVIDIA BLOB:

"
...
Trigger für libc-bin (2.24-7ubuntu2) werden verarbeitet ...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link
"

But I don't get
"dpkg: error: version '-' has bad syntax: version number is empty"

I am using version 375.39

sajid iqbal (sajidiqbal) wrote :

Is there any solution of this ?

Changed in nvidia-graphics-drivers-375 (Ubuntu):
status: Confirmed → Invalid
ake sandgren (ake-sandgren) wrote :

Yes, please make a fix for this, or suggest a workaround.

It's a bit annoying to get a
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link
message once a day from ~40 systems.

(We run a nightly cronjob that sometimes need to refresh the ld.so.cache)

Lisio (lisio) wrote :

$ ldconfig
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link
/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

Libraries are present, they are just a regular files, not symlinks. Annoying.

smaeda (smaeda) wrote :

I got this, but cleared. The following was successful with my environment; latest CUDA Toolkit 8.0(including nvidia-375) in Ubuntu 16.10.

$ sudo mv /usr/lib/nvidia-375/libEGL.so.1 /usr/lib/nvidia-375/libEGL.so.1.org
$ sudo mv /usr/lib32/nvidia-375/libEGL.so.1 /usr/lib32/nvidia-375/libEGL.so.1.org
$ sudo ln -s /usr/lib/nvidia-375/libEGL.so.1 /usr/lib/nvidia-375/libEGL.so.375.39
$ sudo ln -s /usr/lib32/nvidia-375/libEGL.so.1 /usr/lib32/nvidia-375/libEGL.so.375.39

$ deviceQuery
deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

Detected 1 CUDA Capable device(s)

Device 0: "GeForce GTX 1060 6GB"
  CUDA Driver Version / Runtime Version 8.0 / 8.0
  CUDA Capability Major/Minor version number: 6.1
  Total amount of global memory: 6070 MBytes (6364463104 bytes)
  (10) Multiprocessors, (128) CUDA Cores/MP: 1280 CUDA Cores
  GPU Max Clock rate: 1709 MHz (1.71 GHz)
  Memory Clock rate: 4004 Mhz
  Memory Bus Width: 192-bit
  L2 Cache Size: 1572864 bytes
  Maximum Texture Dimension Size (x,y,z) 1D=(131072), 2D=(131072, 65536), 3D=(16384, 16384, 16384)
  Maximum Layered 1D Texture Size, (num) layers 1D=(32768), 2048 layers
  Maximum Layered 2D Texture Size, (num) layers 2D=(32768, 32768), 2048 layers
  Total amount of constant memory: 65536 bytes
  Total amount of shared memory per block: 49152 bytes
  Total number of registers available per block: 65536
  Warp size: 32
  Maximum number of threads per multiprocessor: 2048
  Maximum number of threads per block: 1024
  Max dimension size of a thread block (x,y,z): (1024, 1024, 64)
  Max dimension size of a grid size (x,y,z): (2147483647, 65535, 65535)
  Maximum memory pitch: 2147483647 bytes
  Texture alignment: 512 bytes
  Concurrent copy and kernel execution: Yes with 2 copy engine(s)
  Run time limit on kernels: Yes
  Integrated GPU sharing Host Memory: No
  Support host page-locked memory mapping: Yes
  Alignment requirement for Surfaces: Yes
  Device has ECC support: Disabled
  Device supports Unified Addressing (UVA): Yes
  Device PCI Domain ID / Bus ID / location ID: 0 / 1 / 0
  Compute Mode:
     < Default (multiple host threads can use ::cudaSetDevice() with device simultaneously) >

deviceQuery, CUDA Driver = CUDART, CUDA Driver Version = 8.0, CUDA Runtime Version = 8.0, NumDevs = 1, Device0 = GeForce GTX 1060 6GB
Result = PASS

Steffen Keiper (o-ubpntu-p) wrote :

smada's solution worked, but he confused the ln order. This should work:

sudo mv /usr/lib/nvidia-375/libEGL.so.1 /usr/lib/nvidia-375/libEGL.so.1.org
sudo mv /usr/lib32/nvidia-375/libEGL.so.1 /usr/lib32/nvidia-375/libEGL.so.1.org
sudo ln -s /usr/lib/nvidia-375/libEGL.so.375.39 /usr/lib/nvidia-375/libEGL.so.1
sudo ln -s /usr/lib32/nvidia-375/libEGL.so.375.39 /usr/lib32/nvidia-375/libEGL.so.1

Rebooted afterwards, then the problem was solved an Steam started again.

dino99 (9d9) on 2017-03-27
Changed in nvidia-graphics-drivers-375 (Ubuntu):
status: Invalid → Confirmed
Merlin (the.emrys) wrote :

 I will edit smaeda (smaeda) a little to make it properly run with remaining cuda installtion
after running these commands

$ sudo mv /usr/lib/nvidia-375/libEGL.so.1 /usr/lib/nvidia-375/libEGL.so.1.org
$ sudo mv /usr/lib32/nvidia-375/libEGL.so.1 /usr/lib32/nvidia-375/libEGL.so.1.org
$ sudo ln -s /usr/lib/nvidia-375/libEGL.so.1 /usr/lib/nvidia-375/libEGL.so.375.39
$ sudo ln -s /usr/lib32/nvidia-375/libEGL.so.1 /usr/lib32/nvidia-375/libEGL.so.375.39

Execute the following to apply changes:
sudo ldconfig

Build the NVIDIA samples so we can confirm CUDA is working
cd /root/NVIDIA_CUDA-7.0_Samples/ ( note it should point to the directory you installed samples in)
sudo make
NOTE: This step takes quite a bit of time to complete.

cd 1_Utilities/deviceQuery

Execute the following to test:
sudo ./deviceQuery

Dave English (sandersw) wrote :

the.emrys (for the benefit of others) as noted before the order for ln needs to be as for cp, i.e.:

$ sudo ln -s /usr/lib/nvidia-375/libEGL.so.375.39 /usr/lib/nvidia-375/libEGL.so.1
$ sudo ln -s /usr/lib32/nvidia-375/libEGL.so.375.39 /usr/lib32/nvidia-375/libEGL.so.1

regards

dino99 (9d9) wrote :

Tested again with xenial:

 nvidia-375 from the ubuntu archive (Alberto Milone job) is still crappy
but the same version from graphics-drivers ppa (mamarley) works great.

SeijiSensei (ubuntuforums-2) wrote :

Still get this today, April 6, 2017, when upgrading from nvidia-367 to nvidia-375 on Kubuntu 14.04.

It's been over two months since this bug was reported. Why hasn't it been fixed already? It's not part of the proprietary driver itself, just the code used for its installation.

Hakan Hekimgil (hakan-s) wrote :

Thanks to smaeda, Steffen, Merlin and Dave (thanks guys!), I have resolved my problem last week... But today the driver was upgrade from 375.39 to 375.51 and hey, it's back again!!! The same procedure may resolve the issue AGAIN but it seems that the solution is TEMPORARY until the next upgrade...

ITEAS (info-tux-pc) wrote :

Please fix it!
Thanks

unicorp99 (unicorp99) wrote :

/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

in LTS 16.04.2 from nvidia-367 to nvidia-375

David Wood (jbevren) wrote :

LibEGL.so.1 isn't a symbolic link but should be. I had an issue with a program that required EGL and could not find any capabilities with nvidia-375.

I repaired the issue and now have working EGL with these commands:
mv libEGL.so.1 libEGL.so.1.orig
ln -s libEGL.so.375.39 libEGL.so.1

This leads me to believe that libEGL.so.1 should be a link to libEGL.so.375.39.

Future updates to nvidia packages would do best to follow suit of course. :)

Additional information available on request.

Thomas Tanner (tomtanner) wrote :

The proper solution would be to not install libEGL.so.375.39, as it is the deprecated non-GLVND implementation. The workaround is therefore to delete

rm /usr/{lib,lib32}/nvidia-375/libEGL.so.375.39

Excerpt from the nvidia documentation:

"OpenGL applications do not work with driver version 364.xx and later, which worked with previous driver versions

Release 361 of the NVIDIA Linux driver introduced OpenGL libraries built upon the libglvnd (GL Vendor Neutral Dispatch) architecture, to allow for the coexistence of multiple OpenGL implementations on the same system. The .run installer package includes both GLVND and non-GLVND GLX client libraries, and beginning with release 364, the GLVND libraries are installed by default.

By design, GLVND conforms with the Linux OpenGL ABI version 1.0 as defined at https://www.opengl.org/registry/ABI/ and exposes all required entry points; however, applications which depend upon specifics of the NVIDIA OpenGL implementation which fall outside of the OpenGL ABI may be incompatible with a GLVND-based OpenGL implementation.

If you encounter an application which is incompatible with GLVND, you may install a legacy, non-GLVND GLX client library by adding the --no-glvnd-glx-client to the nvidia-installer command line at installation time. Please contact the application vendor to inform them that their application will need to be updated to ensure compatibility with GLVND."

ubuntuslave (ubuntuslave) wrote :

To get rid of this `ldconfig` message, I just tricked it by going into the respective /usr/lib/nvidia-375 and /usr/lib32/nvidia-375 folders and relinking it to itself (manually):

    $ sudo mv libEGL.so.1 libEGL.so.1.orig
    $ sudo ln -s libEGL.so.1.orig libEGL.so.1

This got rid of the annoying message for now.

Mark Foster (fostermarkd) wrote :

Impact here was an unbootable system (blank screen) not just an annoying error message.

Had to boot into rescue mode to fix the files/links and run ldconfig

Alik (kilaka) wrote :

Mark, regarding your comment (#25), `Impact here`, impact of what? Impact of doing `sudo mv...`?

Carlo Wood (carlo-alinoe) wrote :

I'm having the same issue here (xenial)... Quite annoying.
I hesitate to create a symbolic link to libEGL.so.375.39 as many people suggest because that is clearly a different file:

>ls -l /usr/lib/nvidia-375/libEGL.so*
lrwxrwxrwx 1 root root 11 Mar 17 11:31 /usr/lib/nvidia-375/libEGL.so -> libEGL.so.1
-rw-r--r-- 1 root root 77264 Feb 1 04:35 /usr/lib/nvidia-375/libEGL.so.1
-rw-r--r-- 1 root root 20608 Feb 1 04:35 /usr/lib/nvidia-375/libEGL.so.375.39

Note the difference in size. Closer inspection shows that libEGL.so.375.39 is missing
the following symbols:

-eglClientWaitSync
-eglCreateImage
-eglCreatePlatformPixmapSu
-eglCreatePlatformPixmapSu
-eglCreatePlatformWindowSu
-eglCreatePlatformWindowSu
-eglCreateSync
-eglDestroyImage
-eglDestroySync
-eglGetPlatformDisplay
-eglGetSyncAttrib
-eglWaitSync

as well as 21 undefined symbols (defined in glibc) that apparently are only used in these functions.

I tried to find out what these functions are for but failed (it's very hard to find
anything about them); but, since I could only find them back as being part of EGL15
(in some java document) from 2014, my best guess is that they are legacy and not important.

Jacky Wang (jacky-chao-wang) wrote :

Confirmed that this issue still happens for 2 LTS: Ubuntu 16.04.2 Server + Nvidia 375.39

Can also confirm that i get this error two separate machines running 16.04.2 with nvidia 375.39.

bamyasi (iadzhubey) wrote :

Still present here for Ubuntu 17.04 with nvidia drivers 375.39-0ubuntu5.

information type: Public → Public Security
information type: Public Security → Public
Samuel Penn (y-sam-7) wrote :

Just seen this after an upgrade on 14.04 LTS. I've also seen it previously on 16.04 machines.

/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link
/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

bamyasi (iadzhubey) wrote :

Bug still here with latest nvidia-375 (375.66-0ubuntu0.14.04.1)

zubin ghai (zubin-ghai) wrote :

Bug still here with nvidia-375.66 on Mint 18.1

Brian Park (xparks) wrote :

Same bug on Ubuntu 17.04.

Hi,
Bug still here in Ubuntu 17.04 nvidia-375.66 drivers (GTX 1050 laptop). Everything is updated to last version.

Thanks

Changed in nvidia-graphics-drivers-375 (Ubuntu):
assignee: nobody → AcidZer0 (bulik23rus-cool)
Doug McMahon (mc3man) wrote :

Seen in Ubuntu 17.04 nvidia-375.66 but has no affect on install or use..

Pavan Gupta (pavgup) wrote :

Still seeing this problem in 16.04, but no affect on install or use.

Careful is advised when trying to fix theses warnings manually creating links.

I run:
sudo mv /usr/lib/nvidia-375/libEGL.so.1 /usr/lib/nvidia-375/libEGL.so.1.org
sudo mv /usr/lib32/nvidia-375/libEGL.so.1 /usr/lib32/nvidia-375/libEGL.so.1.org
sudo ln -s /usr/lib/nvidia-375/libEGL.so.375.39 /usr/lib/nvidia-375/libEGL.so.1
sudo ln -s /usr/lib32/nvidia-375/libEGL.so.375.39 /usr/lib32/nvidia-375/libEGL.so.1

And ended up unable to boot into a graphical interface. I was able to recover by running:

dpkg-reconfigure nvidia-375

Vlad Orlov (monsta) on 2017-08-01
Changed in linuxmint:
status: New → Invalid
no longer affects: linuxmint
Eglefino (ruudino-k) wrote :

@clementlefebvre

It's a nice message "no longer affects:linuxmint" but is there a solution for us all about the 'nvidia-375'? nvidia-graphics-drivers-375 (Ubuntu 16.04)

pavel bursa (bursap) wrote :
Changed in nvidia-graphics-drivers-375 (Ubuntu):
assignee: AcidZer0 (bulik23rus-cool) → nobody

Bug is still present

/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

$ inxi -Fz
System: Host: stephan-MS-7A75 Kernel: 4.12.0-12-generic x86_64 bits: 64 Desktop: Xfce 4.12.3
           Distro: Ubuntu Artful Aardvark (development branch)
Machine: Device: desktop Mobo: MSI model: Z270 GAMING PLUS (MS-7A75) v: 1.0 UEFI: American Megatrends v: 1.20 date: 04/07/2017
CPU: Dual core Intel Pentium G4620 (-HT-MCP-) cache: 3072 KB
           clock speeds: max: 3700 MHz 1: 799 MHz 2: 799 MHz 3: 799 MHz 4: 802 MHz
Graphics: Card: NVIDIA GP107 [GeForce GTX 1050 Ti]
           Display Server: x11 (X.Org 1.19.3 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1200@59.95hz
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 version: 4.5.0 NVIDIA 375.82
Audio: Card-1 NVIDIA GP107GL High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel 200 Series PCH HD Audio driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.12.0-12-generic
Network: Card: Intel Ethernet Connection (2) I219-V driver: e1000e
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives: HDD Total Size: NA (-)
           ID-1: /dev/nvme0n1 model: N/A size: 250.1GB
Partition: ID-1: / size: 228G used: 66G (31%) fs: ext4 dev: /dev/nvme0n1p2
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 41C
           Fan Speeds (in rpm): cpu: N/A
Info: Processes: 187 Uptime: 26 min Memory: 629.2/7945.6MB Client: Shell (bash) inxi: 2.3.34

@clementlefebvre

The problem is still there with Mint 18.2:

...
Processing triggers for libc-bin (2.23-0ubuntu9) ...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link
/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link
...

Steven Harms (sharms) wrote :

Can confirm this happens on the daily Ubuntu 17.10 build:
Processing triggers for libc-bin (2.26-0ubuntu1) ...
/sbin/ldconfig.real: /usr/lib/nvidia-375/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-375/libEGL.so.1 is not a symbolic link

Leon (pablo-leonrodrigues) wrote :

Also, happens on Ubuntu 17.10 beta 2.
Dell Inspiron 15 Série 7000 - 7560
NNVIDIA(R) GeForce(R) 940MX 4GB GDDR5

Brian Ploetz (bploetz) wrote :

I'm now seeing this on Ubuntu 16.04 with the nvidia-384 drivers, which looks like they were released within the last day or so.

Processing triggers for libc-bin (2.23-0ubuntu9) ...
/sbin/ldconfig.real: /usr/lib/nvidia-384/libEGL.so.1 is not a symbolic link
/sbin/ldconfig.real: /usr/lib32/nvidia-384/libEGL.so.1 is not a symbolic link

Jackie LaRonde (msjackieelle) wrote :

Correction to #46, tried with correct folder names (-384) and get same response (sudo mv /usr/lib32/nvidia-384/libEGL.so.1 /usr/lib32/nvidia-384/libEGL.so.1.org)

Confirmed with Ubuntu 17.04 with upgrading to libcuda1-384 nvidia-384 nvidia-opencl-icd-384

Get the following errors:

/sbin/ldconfig.real: /usr/lib/nvidia-384/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-384/libEGL.so.1 is not a symbolic link

pavel bursa (bursap) wrote :

Ubuntu 16.10.3 LTS also confirmed for new Nvidia driver.
Ge force GT 640 PCIe SSE2, Intel core i3-4160, Asrock Z97 Extreme 6

Processing triggers for libc-bin (2.23-0ubuntu9) ...
/sbin/ldconfig.real: /usr/lib/nvidia-384/libEGL.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib32/nvidia-384/libEGL.so.1 is not a symbolic link

Olek Wojnar (olekw) wrote :

The ldconfig problem is fixed with nvidia-384 in Xubuntu 17.10. Unfortunately, the dpkg error is still present.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers