Boot fails: black screen after GRUB, no login

Bug #1447838 reported by Anders Feder on 2015-04-23
84
This bug affects 15 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers-346 (Ubuntu)
Critical
Unassigned
Nominated for Vivid by Alberto Salvia Novella

Bug Description

After upgrading from 14.10 to 15.04, I can no longer boot my machine normally. After the GRUB screen, some things load as they should, then the screen turns all black (no cursor, and no backlight), and though I hear the Ubuntu login "drum sound" played, the screen is just black and no login dialog is shown.

If I boot into recovery mode, then select "resume normal boot", I do not experience this issue, and the login screen is shown, and I can login and use the machine, although the resolution of the screen is not good, and I can't select others from the control center.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: plymouth 0.9.0-0ubuntu9
ProcVersionSignature: Ubuntu 3.19.0-15.15-generic 3.19.3
Uname: Linux 3.19.0-15-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME-Flashback:Unity
Date: Fri Apr 24 00:21:31 2015
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouth
EcryptfsInUse: Yes
InstallationDate: Installed on 2012-10-25 (910 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MachineType: ASUSTeK COMPUTER INC. K55VM
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-15-generic root=UUID=ae02b482-170e-439e-9b28-1eeab977ff19 ro recovery nomodeset intel_pstate=enable
ProcFB: 0 EFI VGA
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.19.0-15-generic root=UUID=ae02b482-170e-439e-9b28-1eeab977ff19 ro recovery nomodeset intel_pstate=enable
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
UpgradeStatus: Upgraded to vivid on 2015-04-23 (0 days ago)
dmi.bios.date: 05/23/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K55VM.206
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: K55VM
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK55VM.206:bd05/23/2012:svnASUSTeKCOMPUTERINC.:pnK55VM:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnK55VM:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.name: K55VM
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Anders Feder (afeder) wrote :
Steve Langasek (vorlon) on 2015-04-24
affects: plymouth (Ubuntu) → nvidia-graphics-drivers-346 (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers-346 (Ubuntu):
status: New → Confirmed
Ronan Jouchet (ronj) wrote :

Hi, a colleague and I are hitting the same symptoms.

1. We don't have any kernel oops in our syslog
2. Boot fails if I use the default grub entry, but succeeds if we use "recovery mode" then just resume booting. Ironically, recovery mode warns that graphical boot could fail, and advises to back off and use the regular boot entry (which fails ^^).
3. We are both using x86_64 machines, and GPU is nv using package nvidia-346-updates.
4.a. His machine is a fresh ubuntu-gnome 15.04 install
4.b. Mine is a ubuntu-gnome 14.10 that was `do-release-upgrade`d to 15.04. I do have the non-systemd " (upstart)" grub boot entries, but they lead to the same result.

Might be related to https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1447356

Changed in nvidia-graphics-drivers-346 (Ubuntu):
importance: Undecided → Critical
status: Confirmed → Triaged
Changed in nvidia-drivers-ubuntu:
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1447838

tags: added: iso-testing
i1abnrk (i1abnrk) wrote :

I've had a very similar experience with the upgrade to 15.04 with NVIDIA GTX 960. I've just completed nearly 24hours of troubleshooting. I got around my NVIDIA problems here after a fresh install of 14.10 and some steps I found here that helped. http://ubuntuforums.org/showthread.php?t=2263316 see also my additional steps at comment #7
I see there are problems with many NVIDIA cards and I don't want to keep posting this for each driver.

i1abnrk (i1abnrk) wrote :

comment #17, not comment #7, apologies

Pavel Lunin (plunin) on 2015-04-27
information type: Public → Public Security
Steve Beattie (sbeattie) on 2015-04-29
information type: Public Security → Public
Anders Feder (afeder) wrote :

Installing nvidia-current seems to have resolved the issue I had.

sudo apt-get install nvidia-current

Ronan Jouchet (ronj) wrote :

To add one data point to Anders Feder above, installing nvidia-current (currently 304.125-0ubuntu2) instead of nvidia-346 (currently 346.59-0ubuntu1) doesn't solve the issue for me. Ubuntu fails to start the login manager with both of them.

Anders Feder (afeder) wrote :

Ronan Jouchet (ronj):

I first installed: bumblebee bumblebee-nvidia primus linux-headers-generic. But since that did not fix the issue by its own, I assume that it was nvidia-current that made the actual difference in my case.

dhenry (tfc-duke) wrote :

I have very similar symptoms, but I don't have nvidia graphics in my computer. I have an i945GM gpu. Also, the issue occurs when booting kernel 3.19.0-17, but not with 3.19.0-15 or 3.19.0-16, neither with 4.0.2 from kernel ppa.

When booting in failsafe mode and resuming to normal boot, Xorg will start with the vesa driver (hence the wrong screen resolution).

I don't know if it's the same issue as the one reported here.

Ronan Jouchet (ronj) wrote :

dhenry (tfc-duke):

We must be having different issues. I tried upgrading to mainline builds (v4.0-vivid, v4.1-rc2-vivid), without success: Ubuntu still fails to boot except if I select "Advanced options" in GRUB, then the "recovery mode" of my chosen kernel.

Pierre (pierre-levy) wrote :

I have also a problem quite similar but with an ATI (radeon) graphic card.
Here is mine bug report :
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/1475914
Everything works with 3.19.0-15 but not with higher versions.
I hope it would help somebody to find where is the problem.

I experience the same problem, but with integrated graphics card - Intel HD 4600, ubuntu 15.04 64 bit

Brian Roberts (quillus) wrote :

If it helps with isolation any, having what I believe to be the same issue. Any of the available nvidia drivers result in receiving no signal to the monitor post-grub. (or at least nothing it interprets as signal)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers