SRU Request: nvidia-340 340.107-0ubuntu0.16.04.1: nvidia-340 kernel module failed to build (nvidia_uvm_lite.c:857:14: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types])

Bug #1819077 reported by Jarno Suni on 2019-03-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nvidia-graphics-drivers-340 (Ubuntu)
High
Unassigned
Xenial
High
Alberto Milone

Bug Description

SRU Request:

[Impact]
nvidia-340 (from xenial-proposed) breaks compatibility with linux-generic-hwe-16.04.

[Test Case]
1) Enable the -proposed repository, and install the new 340 NVIDIA driver (340.107-0ubuntu0.16.04.2).

2) Check that the kernel module can be built against the new kernel.

3) Restart your computer, and see if everything works correctly when accessing the desktop.

[Regression Potential]
Low. The update simply re-enables a patch that had been disabled in 340.107-0ubuntu0.16.04.1

_____________

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: nvidia-340 340.107-0ubuntu0.16.04.1
ProcVersionSignature: Ubuntu 4.4.0-142.168-generic 4.4.167
Uname: Linux 4.4.0-142-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
.proc.driver.nvidia.gpus.0000.01.00.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0000:01:00.0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 340.104 Thu Sep 14 17:13:13 PDT 2017
 GCC version: gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.11)
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
BootLog: root: clean, 221224/1281120 files, 2095043/5120000 blocks
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DKMSKernelVersion: 4.15.0-46-generic
Date: Fri Mar 8 01:23:53 2019
DistUpgraded: Fresh install
DistroCodename: xenial
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.8, 4.15.0-46-generic, x86_64: installed
 bbswitch, 0.8, 4.4.0-142-generic, x86_64: installed
 nvidia-340, 340.107, 4.4.0-142-generic, x86_64: installed
DuplicateSignature: dkms:nvidia-340:340.107-0ubuntu0.16.04.1:/var/lib/dkms/nvidia-340/340.107/build/uvm/nvidia_uvm_lite.c:857:14: error: initialization from incompatible pointer type [-Werror=incompatible-pointer-types]
GraphicsCard:
 NVIDIA Corporation G84GLM [Quadro FX 570M] [10de:040c] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company G84GLM [Quadro FX 570M] [103c:30c5]
InstallationDate: Installed on 2015-11-21 (1202 days ago)
InstallationMedia: Xubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
LightdmGreeterLogOld:
 ** Message: Starting lightdm-gtk-greeter 2.0.1 (Aug 7 2015, 01:24:18)
 ** Message: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf.d/01_ubuntu.conf
 ** Message: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf.d/30_xubuntu.conf
 ** Message: [Configuration] Reading file: /etc/lightdm/lightdm-gtk-greeter.conf
 upstart: indicator-application main process (970) killed by TERM signal
PackageVersion: 340.107-0ubuntu0.16.04.1
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.4.0-142-generic root=UUID=bdc3be24-dee9-4ead-bca0-c9b1e45a87e5 ro persistent quiet splash
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.5
 apt 1.2.29ubuntu0.1
SourcePackage: nvidia-graphics-drivers-340
Title: nvidia-340 340.107-0ubuntu0.16.04.1: nvidia-340 kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68MVD Ver. F.20
dmi.board.name: 30C5
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 71.36
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68MVDVer.F.20:bd12/01/2011:svnHewlett-Packard:pn:pvrF.20:rvnHewlett-Packard:rn30C5:rvrKBCVersion71.36:cvnHewlett-Packard:ct10:cvr:
dmi.product.version: F.20
dmi.sys.vendor: Hewlett-Packard
modified.conffile..etc.modprobe.d.nvidia-340_hybrid.conf: [deleted]
version.compiz: compiz N/A
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.91-2~16.04.1
version.libgl1-mesa-dri: libgl1-mesa-dri 18.0.5-0ubuntu0~16.04.1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 18.0.5-0ubuntu0~16.04.1
version.nvidia-graphics-drivers: nvidia-graphics-drivers-* N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.18.4-0ubuntu0.8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.10.1-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel N/A
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.12-1build2
xserver.bootTime: Thu Mar 7 23:28:16 2019
xserver.configfile: default
xserver.errors:
 Failed to load module "fbdev" (module does not exist, 0)
 Failed to load module "vesa" (module does not exist, 0)
 Failed to load module "fbdev" (module does not exist, 0)
 Failed to load module "vesa" (module does not exist, 0)
xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:

xserver.version: 2:1.18.4-0ubuntu0.8

Jarno Suni (jarnos) wrote :
tags: removed: need-duplicate-check

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 1718839, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

summary: nvidia-340 340.107-0ubuntu0.16.04.1: nvidia-340 kernel module failed to
- build
+ build (nvidia_uvm_lite.c:857:14: error: initialization from incompatible
+ pointer type [-Werror=incompatible-pointer-types])
Alberto Milone (albertomilone) wrote :

This is not a duplicate, since it was caused by a driver in xenial-proposed that was accepted yesterday.

Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Alberto Milone (albertomilone)
description: updated
summary: - nvidia-340 340.107-0ubuntu0.16.04.1: nvidia-340 kernel module failed to
- build (nvidia_uvm_lite.c:857:14: error: initialization from incompatible
- pointer type [-Werror=incompatible-pointer-types])
+ SRU Request: nvidia-340 340.107-0ubuntu0.16.04.1: nvidia-340 kernel
+ module failed to build (nvidia_uvm_lite.c:857:14: error: initialization
+ from incompatible pointer type [-Werror=incompatible-pointer-types])
Jarno Suni (jarnos) wrote :

Works fine with 340.107-0ubuntu0.16.04.2

Changed in nvidia-graphics-drivers-340 (Ubuntu):
status: New → Fix Released
importance: Undecided → High
Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: In Progress → Fix Released
tags: added: regression-proposed
Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: Fix Released → Fix Committed
tags: added: verification-done-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nvidia-graphics-drivers-340 - 340.107-0ubuntu0.16.04.2

---------------
nvidia-graphics-drivers-340 (340.107-0ubuntu0.16.04.2) xenial; urgency=medium

  * debian/templates/dkms_nvidia.conf.in:
    - Re-enable buildfix_kernel_4.11.patch (LP: #1819077).

nvidia-graphics-drivers-340 (340.107-0ubuntu0.16.04.1) xenial; urgency=medium

  * New upstream release:
    - Added support for X.Org xserver ABI 24 (xorg-server 1.20).
    - Improved nvidia-bug-report.sh to check for kern.log which is
      the default kernel log-file location for many Debian-based
      Linux distributions.
    - Fixed a bug which could cause X servers that export a Video
      Driver ABI earlier than 0.8 to crash when running X11
      applications which call XRenderAddTraps().
  * debian/templates/dkms_nvidia.conf.in,
    debian/dkms_nvidia/patches/buildfix_kernel_4.4_get_user_pages.patch:
   - Drop buildfix_kernel_4.11.patch.
   - Add support for new 7 argument get_user_pages() (LP: #1573508).
  * debian/substvars:
   - Add support for X ABI 24.

 -- Alberto Milone <email address hidden> Fri, 08 Mar 2019 12:04:12 +0100

Changed in nvidia-graphics-drivers-340 (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for nvidia-graphics-drivers-340 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.