Ubuntu

garbled Emacs display when running under compiz with nvidia drivers

Reported by Gro-Tsen on 2008-11-28
200
This bug affects 33 people
Affects Status Importance Assigned to Milestone
NVIDIA Drivers Ubuntu
Undecided
Unassigned
nvidia-graphics-drivers-177 (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by delbian
nvidia-graphics-drivers-180 (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by delbian
nvidia-graphics-drivers (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by delbian

Bug Description

Binary package hint: nvidia-glx-177

In a nutshell: garbled Emacs display when running under compiz with nvidia drivers.

More precisely: when Emacs (running in its own X11 window) attempts to refresh the window (e.g., when scrolling up or down a page, jumping to top, control-L or something), it often happens that only the upper portion of the window is refreshed. This also sometimes happens with gnome-terminal (typically when scrolling), but much less reproducibly. With Emacs, it occurs so frequently that it makes the editor almost unusable.

Software & hardware config summary:
        Ubuntu 8.10 Intrepid
        Kernel 2.6.27-9-generic
        x86-64 system (with 64-bit userland) on a Core 2 Duo
        nVidia driver version 177.80 OR 177.82 OR 180.08 (I tried all three)
        nVidia Quadro NVS 290 rev 161 graphics card
        compiz 1:0.7.8-0ubuntu4.1
        Pretty much any Emacs (emacs22-x, emacs22-gtk, emacs-snapshot-gtk)

To reproduce: launch Emacs, in its own window, on some text file (of more than one page), with the compiz window manager running; jump to the bottom of the file (M-<), and then then to the top (M->) or refresh the screen (C-l): quite often, only the upper portion of the window is refreshed, not the bottom, with the limit not necessarily along a line boundary. Only the display is affected: jumping to a different workspace and back will redraw the window correctly.

The bug does not occur with metacity, so it's probably composite-related.

Probably nVidia's fault, because I couldn't produce a similar effect with an Intel 945GME with the X.org/intel driver (and 32-bit but otherwise similar software config). I sent a bug report of similar content to the nVidia team (aka /dev/null).

I tried removing --lose-bindings from the compiz options, and disabling DamageEvents in the xorg.conf, neither seemed to have any effect.

Ubuntu bug #269904 (similar problem affecting Firefox &al) is possibly related to this, but _not identical_ (because the latter bug has a workaround which does not help for this one). Although it's hard to tell since the bug report has been much polluted.

On the other hand, Ubuntu bug #239917 is _not_ related (at least the main part of it is not; the bug I describe is perhaps alluded to).
[lspci]
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 290 (rev a1)
     Subsystem: nVidia Corporation Device 0492

Gro-Tsen (david-madore) wrote :
Greg Michalec (greg-primate) wrote :

I have the same problem using Vim, so I imagine the bug is related to gnome-terminal + compiz.

compiz 1:0.7.8-0ubuntu4.1
gnome-terminal 2.24.1.1-0ubuntu1
nvidia-glx 177.80-0ubuntu3
video card: nVidia Corporation GeForce 8400M GS (rev a1)

Gro-Tsen (david-madore) wrote :

@Greg Michalec → If you're running vim in a gnome-terminal (which by your comment I assume you are) then it falls under the gnome-terminal umbrella, yes, and indeed all programs running under gnome-terminal are affected to some extent. My bug report was mostly about Emacs running its own window (as opposed to within a terminal), because then I find the bug even more frequent.

vseguip (vseguip) wrote :

Just chiming in to confirm this bug. My hardware

Ubuntu Intrepid 2.6.27-11-generic
Intel Core 2 Duo CPU T7250
Nvidia 177.82 and 180
Compiz 0.7.8
Quadro NVS 135M 60.86.47.00.01

Bryce Harrington (bryce) wrote :

[This is an automated message]

Hi david-madore,

Please attach the output of `lspci -vvnn` too.

Changed in nvidia-graphics-drivers-177:
status: New → Incomplete
vseguip (vseguip) wrote :

Attaching results of lspci -vvnn

Bryce Harrington (bryce) on 2009-01-23
description: updated
Changed in nvidia-graphics-drivers-177:
status: Incomplete → Confirmed
TM (junkmail-media) wrote :

I'm experiencing this bug in gnome terminal, emacs, and xchat.

Some output from uname:
2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686 GNU/Linux

The results of lspci -vvnn are attached.

Running aptitude search nvidia shows the following packages are installed;

nvidia-173-modaliases
nvidia-177-kernel-source
nvidia-177-modaliases
nvidia-71-modaliases
nvidia-96-modaliases
nvidia-common
nvidia-glx-177
nvidia-settings

I'm running on a third generation (Santa Rosa) MacBook Pro with Ubuntu 8.10.

Bryce Harrington (bryce) wrote :

[This is an automated message]

In Jaunty (9.04), we are dropping the nvidia-graphics-drivers-177 package, which
is now superseded by then nvidia-graphics-drivers-180 package.

  http://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-180

To transition your bug into the new package, we need your help. Please do the following:

 a. Verify the bug occurs in Jaunty with the -180 driver
     (ISOs: http://cdimage.ubuntu.com/releases/jaunty/)
 b. If you haven't already, please include in the bug:
     * Your /var/log/Xorg.0.log
     * Your /etc/X11/xorg.conf
     * The output of `lspci -vvnn`
     * Steps to reproduce the issue
 c. Under Affects, click the down arrow to the left of 'nvidia-graphics-drivers-177'
 d. Edit the Package to change 'nvidia-graphics-drivers-177' to 'nvidia-graphics-drivers-180'
 e. Click Save Changes

Thank you!

[We'll expire the remaining -177 bugs in a month or so.]

lingrlongr (keberle) wrote :

I have the same problem, but so far, only noticed it with vi. What causes the behavior for me is what text below the cursor gets pushed down the screen, like when a line is inserted. I keep having to refresh the screen with Ctrl+L. I only started having this problem after upgrading to the nvidia 180 drivers. Previously, I was using 177 and didn't have this problem.

Installed:
compiz: 1:0.7.8-0ubuntu4.2~ppa2
gnome-terminal 2.24.1.1-0ubuntu1
nvidia-glx-180 180.11-0ubuntu1~intrepid1
nvidia-180-kernel-source 180.11-0ubuntu1~intrepid1

$ lspci | grep -i nvidia
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600M GT (rev a1)

$ uname -a
Linux xps 2.6.27-11-generic #1 SMP Thu Jan 29 19:24:39 UTC 2009 i686 GNU/Linux

$ cat /etc/issue
Ubuntu 8.10 \n \l

Laptop is a Dell XPS M1530.

[Files in attached files.tar.gz]
lspci -vvnn
Xorg.0.log
xorg.conf

indium (indium) wrote :

Similar story here:
I have a macbook pro 4.1 (core 2duo) with an uptodate ubuntu 8.10. the terminal urxvt give the most refresh problems. When it spits out long lists (like for 'locate e') the terminal screen gets scrambled). Even sometimes the update manager screen list (of to-be-updated ubuntu items) scrambles. I've not seen a difference between the 173 and 177 drivers.

I now switched from compiz to metacity, which resolved the problem, so I'd say that the problem is purely graphics card. (never a program crashed or complained about the scrambling).

Bryce Harrington (bryce) wrote :

[This is an automated message]

In Jaunty (9.04) we have dropped the nvidia-graphics-driver-177 package, as
it is superseded by nvidia-graphics-drivers-180.

Because of this, we are closing this bug as expired.

You are encouraged to file your -nvidia bug reports against the
nvidia-graphics-drivers-180 package.

Changed in nvidia-graphics-drivers-177:
status: New → Invalid
Bryce Harrington (bryce) wrote :

[This is an automated message]

In Jaunty (9.04), we have just updated to the latest
nvidia-graphics-drivers-180 package from nVidia, version 180.44.

This package provides fixes for a large number of bugs, and we need your
assistance in testing if it fixes the issue you reported.

To do this, please do the following:

 a. Update to the 180.44 version of -nvidia using your favorite update
     method

 b. Attempt to reproduce your bug

 c. If your bug still remains, please simply reply to this email
     indicating so.

 d. If your bug is now solved, you can help us by setting your bug
     report to Fix Released:
     * In launchpad, go to your bug report
     * Click on the downward pointing arrow under Status
     * Set the Status field to 'Fix Released'
     * Comment on the change, such as, 'Verified fixed in 180.44'
     * Click 'Save Changes'

 e. If the original problem is solved but there are now other problems,
     please close the original bug and open new ones for those issues.

Thank you!

For details on the changes in this version of -nvidia, please see:

   http://www.nvidia.com/object/linux_display_ia32_180.44.html

Rafael Sachetto (rsachetto) wrote :

I'm using 180.44 version of nvidia driver and Jaunty with all updates and I still have this problem, using either vim or gvim. If I disable compiz the problem does not happen.

lspci | grep -i nvidia
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8400M GS (rev a1)

uname -a
Linux kratos 2.6.28-11-generic #41-Ubuntu SMP Wed Apr 8 04:38:53 UTC 2009 i686 GNU/Linux

cat /etc/issue
Ubuntu jaunty (development branch) \n \l

Installed:
compiz-core 1:0.8.2-0ubuntu7
nvidia-glx-180 180.44-0ubuntu1
nvidia-180-kernel-source 180.44-0ubuntu1

vseguip (vseguip) wrote :

After upgrading to Jaunty and using the following compiz settings I can't seem to reproduce the bug:

* Texture filter: best
* Lighting: checked
* Detect refresh rate: unchecked
* Refresh rate 200
* Sync to vblank: unchecked

cat /etc/issue
Ubuntu jaunty (development branch) \n \l

Installed:
compiz-core 1:0.8.2-0ubuntu7
nvidia-glx-180 180.44-0ubuntu1
nvidia-180-kernel-source 180.44-0ubunt

Luke Hoersten (lukehoersten) wrote :

Still have this problem on Jaunty.

Same here, gvim, gnome-terminal, several qt apps

Same here, gvim, gnome-terminal, several qt apps, jaunty

I also have this problem, and it's really quite an annoyance since I'm an emacs user.

Grzegorz Śliwiński (fizyk) wrote :

I got this problem with variety of apps accross ubuntu.
I'm neither using emacs, nor have noticed the problem within gnome-terminal, but it often occurs within mine game, where I often have to move window around to see marked flags, within OpenOffice where certain graphical elements tend to disappear, or text just vanishes after typing few letters. happens to me with Opera decoration bar, which often get refreshed only after clickin on it.

I'm using Jaunty 64bit on my laptop with nVidia GeForce 9200GS graphic card.

Jaunty, nvidia 180.44

I have only scene this bug in Emacs, but it's EXTREMELY annoying -- a maximize and unmaximize is the quickest way I've found to trigger it. I also see garbled ness in OpenOffice Writer, but not nearly as bad as Emacs.

Setting "Visual Effects" under the Appearance control pane to "None" seems to make it go away, until it's set back.

64-bit Core2Duo, running 64-bit system.

Same behaviour over here.

steps to reproduce: after some scrolling and editing in Gnu Emacs and OpenOffice, display gets garbled and / or partly whited out.

workaround: disabling desktop effects to "None".

installed:
Jaunty, with all updates as of today
nvidia-glx-180 180.44-0ubuntu1
nvidia-180-kernel-source 180.44-0ubuntu1
compiz-core 1:0.8.2-0ubuntu8

Switching the Appearance->"Visual Effects" to None is also an annoying work around since it destroys ones workspaces, and re-parents all the windows to the new first workspace.

Does anyone have a better work-around? I just switched to "None," while at my office, where I do most of my Emacs and Open Office usage, and just lost my train of thought completely -- since I use workspaces to keep track of different projects that I'm working on.

Can an enlightened dev let us know if there is an nvidia module parameter than might fix this?

Bryce Harrington (bryce) wrote :

I've posted a new version of the -nvidia driver to our xorg-edgers PPA,
would you mind testing it either on Jaunty or Karmic and see if it
resolves this bug?

Get nvidia-graphics-drivers-180 - 185.18.14 here:

  https://edge.launchpad.net/~xorg-edgers/+archive/ppa

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Confirmed → New
status: New → Incomplete

I updated to nvidia-graphics-drivers-180 - 185.18.14 (and associated updates) from the PPA.

The problem still persists. One thing I've noticed is a difference in the brokenness.

Before in Emacs, quickly scrolling up and down would cause the breakage. Now, that seems to be gone. However, switching buffers (Ctrl-X RightArrow, for e.g.), almost immediate causes the issue to appear.

A cursory test of OpenOffice.org Word Processor seems AOK -- I definitely saw artifacts, but less grave/apparent than Emacs, before.

Other glitches, that may or may not be attributable to this issue in general include oddities like only half of window's title bar becoming solid from transparent when it gets focus.

I'll happily test any other changes -- I'd really like Emacs to not suck! ;-)

I've started using Emacs in a terminal with xterm-mouse-mode. (I even tried gedit for a while.)

Anyways, if anyone would like to start a bounty for this, I'll happily pitch in some cash.

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Confirmed
Rit Li (rit) wrote :

I also have the same problem with gvim.

Bryce Harrington (bryce) on 2009-08-13
tags: added: intrepid

I've got the same issue on a Thinkpad T61p with a Quadro FX 570 nvidia chip in it running 9.04. I rarely see it on gnome terminals, but I frequently encounter it when using the OpenOffice spreadsheet. Usually performing page up/down actions does not update all the cells, or the row numbers vanish.

Currently I'm running Jaunty. Usually I run the 173 driver as it is issue free (except being slow). Driver 180 has better performance but garbles. Today I used the nvidia vdpau PPA (https://launchpad.net/~nvidia-vdpau/+archive/ppa) to test out the 185 driver which also garbles my spreadsheets.

robinzoni (robinzoni) wrote :

The same here. 2.6.28-15-generic #52-Ubuntu. i686 GNU/Linux, nvidia-driver-180.
This issue can be seen under emacs-snaphot as well (the attachment shows a screenshot of the problem).

aot2002 (jasonbronson) wrote :

This happens also to me with open office, the browser sometimes and maybe other apps non related to the emacs

I am using a T61 lenovo laptop and this only happens with desktop effects to anything other then none. I get it to occur from scrolling mostly with the wheel on my external mouse.

aot2002 (jasonbronson) wrote :

I've found going back to Nvidia 173 works perfect so its broke in the latest 180 version

Since reinstalling my Thinkpad T61P with Karmic and the nVidia 185 driver I have not seen the garbled display issue at all. I've also bought a new computer with an integrated nVidia card and that also shows no problems. I'll be unsubscribing myself from this issue.

aot2002 (jasonbronson) wrote :

installing a new version of ubuntu does not appeal to me just to solve this video issue ?

Heikki Toivonen (hjtoi) wrote :

I just did a fresh install of Jaunty and I was seeing this (Dell Latitude D830 with nVidia Quadro NVS 135M card, nvidia driver version 185.18.36) in at least Firefox, Thunderbird, Pidgin and CompizConfig Settings Manager when scrolling. It seems like vseguip's advice of setting the following option in CompizConfig Settings Manager made the problem go away:

* Texture filter: best

The option used to have value "good". It is in General > Display Settings.

Other options I left as they were (my refresh rate is 50, sync to vblank not set, detect refresh rate checked).

asaijo (asaijo) wrote :

This is really annoying. Emacs buffer text is messed by random color and unreadable. ( NVIDIA-180 driver, Compiz enabled)
I don't want to disable Compiz visual effects because transparency and expose are very useful.

My workaround:

get old NVIDIA driver (version 173) and install it manually.

possible side effect:

I have to re-install the driver when linux kernel version changed. sigh...

The same issues here since 10.04, now with emacs-snaphshot, emacs23 and OOo. Furthermore, running one of the mentioned applications slows my machine down---it seems to be frozen (Dual core CPU @ 1,86 GHz, 4 GB RAM). Yes, this is annoying. But vseguip's work around fixed it indeed and gave my machine a performance boost. Thanks vseguip!

I have to cancel my statement in #35. vseguip's work around doesn't work anymore.

I do not use nvidia drivers but I have garbled display in emacs. I am running Ubuntu Maverick 10.10 and I already updated compiz.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nvidia-graphics-drivers (Ubuntu):
status: New → Confirmed
gene (eugenios) wrote :

It is also true for my X200M radeon card with the radeon driver.
I started noticing it quite a long time ago, maybe even since the 10.04 version (while I have no issues with the i915 machine LTS) . For the time being I am running 11.04 on the custom-built kernel, uname: Linux 3.0.17-nonrad+ #1 SMP Wed Jan 18 12:24:31 CST 2012 i686 i686 i386 GNU/Linux

John Fettig (john-fettig) wrote :

This also happens in Oneiric with nvidia drivers 280.13 (installed by package nvidia-current) and

 VGA compatible controller: nVidia Corporation GT218 [GeForce 210] (rev a2)

I applied the changes suggested by vseguip using the tool "ccsm" provided by the package compizconfig-settings-manager (you have to go into "advanced search" and search for the terms he provided). When I logged out and logged back in, the problem was gone.

I have discovered that enabling vsync in CCSM greatly reduces the problem. Altough performance is affected...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers