Jockey should support blacklisting drivers if certain CPU instructions are not available

Bug #272498 reported by alienexplorers on 2008-09-20
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
jockey (Ubuntu)
Wishlist
Alberto Milone
nvidia-graphics-drivers-173 (Ubuntu)
Undecided
Unassigned

Bug Description

Tried running the GeForce FX5200 with nvidia-173 driver and system would not boot into anything, but low graphic mode. Looked threw the logs and found that the error occured due to my old AMD K6-III 450 not being able to run the SSE instruction set. I hope once the 96.xx.xx drivers are released they will not need the SSE instruction set.

alienexplorers (dfsjr47) wrote :

There should be a info page somewhere with information on all drivers available and what they require to run. I can't even find something like this on the nvidia site.

Alberto Milone (albertomilone) wrote :

The 96xx legacy driver shouldn't need SSE.

NVIDIA confirmed that legacy drivers won't need SSE:
http://www.nvnews.net/vbulletin/showpost.php?p=1522622&postcount=8

I can make Jockey look for SSE and make it offer only the legacy driver if the CPU doesn't support it.

Changed in jockey:
assignee: nobody → albertomilone
importance: Undecided → Wishlist
status: New → Triaged
Changed in nvidia-graphics-drivers-173:
status: New → Invalid
alienexplorers (dfsjr47) wrote :

Thank You for taking of this problem. I thought I totally bombed my system. Any idea when Ubuntu will import the 96.43.07 drivers?

Alberto Milone (albertomilone) wrote :

It depends on NVIDIA. When such drivers are available we'll include them in Ubuntu.

Changed in jockey (Ubuntu):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers