compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from XOpenDisplay() from nux::WindowThread::ThreadCtor()

Bug #947844 reported by theevilbeast on 2012-03-06
242
This bug affects 31 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Critical
Jay Taoko
Unity
Fix Released
Critical
Brandon Schaefer
nux (Ubuntu)
Critical
Jay Taoko
Precise
Critical
Unassigned
unity (Ubuntu)
Critical
Unassigned
Precise
Critical
Unassigned

Bug Description

SRU testcase

1. install unity from precise-proposed
2. make sure unity does not crash while enabling/disabling a plugin in CCSM

I have problems with alt+tab. When I use it the bars where are (close,minimize and maximize) disappear. And compiz is not even installed. I installed it and try to make some changes but it almost always crashes and I can't even reboot with terminal. System freezes. I thing maybe is something to do with VGA drivers, because when I installed 12.10 when I move windows they appear to lag like I have low fps. My VGA is nvidia 450GTS and now I am with 295 .20 drivers which I install from app "additional drivers".

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: libnux-2.0-0 2.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
Date: Tue Mar 6 11:29:38 2012
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fd9446a56e0: cmp 0x18(%rax),%r14
 PC (0x7fd9446a56e0) ok
 source "0x18(%rax)" (0x1e000060002be1c) not located in a known VMA region (needed readable region)!
 destination "%r14" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libc.so.6
 calloc () from /lib/x86_64-linux-gnu/libc.so.6
 XOpenDisplay () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 nux::WindowThread::ThreadCtor(_XDisplay*, unsigned long, __GLXcontextRec*) () from /usr/lib/libnux-2.0.so.0
 nux::CreateFromForeignWindow(unsigned long, __GLXcontextRec*, void (*)(nux::NThread*, void*), void*) () from /usr/lib/libnux-2.0.so.0
Title: compiz crashed with SIGSEGV in calloc()
UpgradeStatus: Upgraded to precise on 2012-03-06 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

StacktraceTop:
 _int_malloc (av=0x7fd9449db720, bytes=16384) at malloc.c:3697
 __libc_calloc (n=<optimized out>, elem_size=<optimized out>) at malloc.c:3274
 XOpenDisplay (display=<optimized out>) at ../../src/OpenDis.c:256
 nux::WindowThread::ThreadCtor (this=0x1809a00, X11Display=0x0, X11Window=347, OpenGLContext=0x8ec6e8) at ./WindowThread.cpp:1104
 nux::CreateFromForeignWindow (X11Window=347, OpenGLContext=0x8ec6e8, user_init_func=0x7fd9307b6be0 <unity::UnityScreen::initUnity(nux::NThread*, void*)>, data=0xe91880) at ./Nux.cpp:210

affects: ubuntu → nux (Ubuntu)
Changed in nux (Ubuntu):
importance: Undecided → Medium
summary: - compiz crashed with SIGSEGV in calloc()
+ compiz crashed with SIGSEGV in _int_malloc()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nux (Ubuntu):
status: New → Confirmed
William Grant (wgrant) on 2012-03-30
visibility: private → public
summary: - compiz crashed with SIGSEGV in _int_malloc()
+ compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
+ XOpenDisplay() from nux::WindowThread::ThreadCtor()
Changed in nux:
status: New → Confirmed
tags: added: bugpattern-needed
Changed in unity:
importance: Undecided → High
status: New → Confirmed
Changed in nux:
importance: Undecided → High
Changed in unity:
milestone: none → 5.12.0
milestone: 5.12.0 → 5.10.0
Changed in nux:
importance: High → Critical
Changed in unity:
importance: High → Critical
Omer Akram (om26er) on 2012-04-02
Changed in nux (Ubuntu):
importance: Medium → Critical
Tim Penhey (thumper) on 2012-04-03
Changed in nux:
assignee: nobody → Jay Taoko (jaytaoko)

So I'm able to reproduce this, or at lease the call to nux::WindowThread::ThreadCtor() which then calls XOpenDisplay(NULL), which then fails.

To reproduce:
1) Open CCSM (CompizConfig Settings Manager)
2) Disable Unity Plugin
3) Enable Unity Plugin

Repeat steps 2 and 3 until a crash! There was also a different crash I was getting that I have to look into...

Didier Roche (didrocks) on 2012-04-12
Changed in unity:
milestone: 5.10.0 → 5.12.0

This error occurs when Compiz-Fusion "Desktop Wall" is enabled. After startup the destop "edge-flipping" does not work even when enabled. Using Compiz Config to disable the Desktop Wall and then re-enable the Desktop Wall causes the proper edge-flipping behavior to resume but also causes this error.

Changed in unity:
assignee: nobody → Brandon Schaefer (brandontschaefer)
Changed in nux:
status: Confirmed → Invalid
Changed in nux (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in nux (Ubuntu):
status: Fix Committed → Invalid
Changed in unity (Ubuntu):
status: New → Fix Committed
Omer Akram (om26er) on 2012-04-26
Changed in unity (Ubuntu Precise):
importance: Undecided → Critical
status: Fix Committed → Confirmed
description: updated
Didier Roche (didrocks) on 2012-04-27
Changed in nux:
status: Invalid → Fix Released
Changed in unity:
status: Fix Committed → Fix Released

Hello theevilbeast, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (6.0 KiB)

This bug was fixed in the package unity - 5.12-0ubuntu1

---------------
unity (5.12-0ubuntu1) precise-proposed; urgency=low

  * New upstream release.
    - Launcher, Alt-Tab - clicking on launcher item or selecting a app in Alt-
      Tab raises all app windows, not just most recently focused (LP: #959339)
    - [heap corruption?] compiz crashed with SIGSEGV in _int_malloc() from
      g_realloc() from ... from g_dbus_connection_send_message_with_reply()
      from g_object_unref() from unity::dash::HomeLens::Impl::~Impl() from
      unity::dash::HomeLens::~HomeLens() (LP: #931201)
    - compiz crashed with SIGSEGV in _int_malloc() from __libc_calloc() from
      XOpenDisplay() from nux::WindowThread::ThreadCtor() (LP: #947844)
    - Regression: Installing apps causes a terrible visual glitch-- have to
      restart X.org. (LP: #981168)
    - Window management - unity doesn't realise when applications bring their
      windows to the front (LP: #802816)
    - Dash - Clicking on the desktop dash border should do nothing, *NOT*
      close the dash (LP: #839472)
    - [FFe, UIFe] HUD - The HUD does not respect launcher icon size settings
      in autohide mode (LP: #921506)
    - compiz crashed with SIGSEGV in g_volume_get_mount() (LP: #918548)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - Panel is transparent when Dash is open; no blur no average BG color
      (LP: #965323)
    - Unity crashes with SIGSEGV when hitting debug DBus interface hard
      (LP: #979429)
    - compiz crashed with SIGSEGV in _int_malloc() from g_object_unref() from
      unity::dash::Model<unity::dash::FilterAdaptor>::~Model() (LP: #941750)
    - indicators menu are sometimes cut off at screen edge (LP: #883317)
    - the shortcut keys in workspace section of the shortcut overlay aren't
      translated (LP: #980828)
    - [regression] Dash keeps repainting unnecessarily (LP: #980924)
    - compiz crashed with SIGSEGV in nux::NTextureData::ClearData() from
      nux::NTextureData::~NTextureData() from nux::Texture2D::~Texture2D()
      (LP: #952378)
    - compiz crashed with SIGSEGV in g_object_unref() from
      unity::dash::Settings::~Settings() from
      unity::UnityScreen::~UnityScreen() (LP: #981764)
    - compiz crashed with SIGSEGV in unity::dash::ResultView::~ResultView()
      from unity::dash::ResultViewGrid::~ResultViewGrid() from
      nux::Object::Destroy() from nux::Object::UnReference() (LP: #942286)
    - compiz crashed with SIGSEGV in
      ends_with_iter_select<__gnu_cxx::__normal_iterator<char const*,
      std::basic_string<char> >, char const*, boost::algorithm::is_iequal>()
      from unity::ui::PointerBarrierWrapper::EmitCurrentData() (LP: #983268)
    - Chinese can't be shown completely in dash filter (LP: #984583)
    - [Unity 5.10] compiz crashed with SIGSEGV in
      unity::hud::HudIconTextureSource::ColorForIcon() from
      unity::hud::Icon::Icon() from emit from unity::IconTexture::IconLoaded
      (LP: #983646)
    - [regression] Close button does not close the dash/HUD (LP: #986264)
    - compiz crashed with SIGSEGV in g_volume_eject_with_operation_finish()
      fro...

Read more...

Changed in unity (Ubuntu):
status: Confirmed → Fix Released
Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in nux (Ubuntu):
status: Invalid → Fix Released
assignee: nobody → Jay Taoko (jaytaoko)
To post a comment you must log in.