can't type characters with accent (dead keys)

Bug #746761 reported by Marco Biscaro
324
This bug affects 52 people
Affects Status Importance Assigned to Milestone
Nux
Confirmed
Wishlist
Jay Taoko
Unity
Fix Released
High
Neil J. Patel
nux (Ubuntu)
Wishlist
Unassigned
unity (Ubuntu)
High
Unassigned

Bug Description

Problem:

On Latin-derived languages, accented characters (like á, à, é, í, ó, ú, ã, õ, ñ, ü) are very common. The problem is that accented characters cannot be typed on dash.

How to reproduce:

1. With Brazillian Portuguese translation installed, open dash
2. Type 'Apar'
3. The program 'Aparência' (Appearence) is listed
4. Try to type the letter 'ê'

What happens:

When you press the accent key, the graphic signal is drawn immediately (see screenshot)

What should happens:

The accent should not be drawn immediately. It should wait the next letter (e.g. press '^' and press 'e' should give 'ê')

Note:

If the next pressed key is a space, the accent should be draw alone, as in a normal text field (e.g. press '^' and press <space> should give '^')

Related branches

Revision history for this message
Marco Biscaro (marcobiscaro2112) wrote :
Neil J. Patel (njpatel)
Changed in unity:
assignee: nobody → Mirco Müller (macslow)
importance: Undecided → High
milestone: none → 3.8.4
status: New → Confirmed
Mirco Müller (macslow)
Changed in unity:
status: Confirmed → In Progress
ooze (zoe-gauthier)
Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Florian Boucault (fboucault) wrote :

Does not affect Unity 2D.

Didier Roche (didrocks)
Changed in unity (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Mirco Müller (macslow) wrote :

This is rather a nux than an unity-issue. nux needs to handle the input of the dead-key combination (e.g.

Revision history for this message
Mirco Müller (macslow) wrote :

~ + a)

Mirco Müller (macslow)
Changed in nux:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Mirco Müller (macslow)
Didier Roche (didrocks)
Changed in nux (Ubuntu):
status: New → In Progress
Mirco Müller (macslow)
Changed in unity:
milestone: 3.8.4 → 3.8.6
Mirco Müller (macslow)
Changed in unity:
milestone: 3.8.6 → 3.8.8
Mirco Müller (macslow)
Changed in unity:
milestone: 3.8.8 → 3.8.10
Revision history for this message
Mirco Müller (macslow) wrote :

Here is an example-screencast of unity compiled against the proposed nux-branch with dead-keys working...

Revision history for this message
Marco Biscaro (marcobiscaro2112) wrote :

@Mirco: looks nice!

But, looking at code, I think you forgot some dead-keys: 'ñ' and '¨' to all vowels (ä, ë, ï, ö, ü).

Maybe some other too, but I realise that this changes will already greatly improve the usability. Thanks!

Revision history for this message
Loris Zinsou (nepenthes) wrote :

I don't know if this is a related problem, but Unity lacks latin collations variants: when you type unaccented characters in place of their accented equivalent ones, Unity doesn't behave as expected.

In French, if you search for the video player : you start typing "lecteur vid" and Unity finds "Lecteur vidéo". If you continue typing "lecteur video", it does not show anymore "Lecteur vidéo" as a search result.

Unity should be more tolerent to accent errors : in latin languages, you often "forget" to use accented characters when quickly typing.

Revision history for this message
Marco Biscaro (marcobiscaro2112) wrote :

I agree with Loris. I think you should report this on another bug (that probably will be targeted to oneiric, because we're getting out of time to natty).

Didier Roche (didrocks)
Changed in unity:
milestone: 3.8.10 → 3.8.12
Revision history for this message
Alberto R Mitre (armitre) wrote :

I happen to have had the same problem in Skype for months - it's still there, and it's a bit annoying. It was a Ibus related issue, but it doesn't look like it's the case this time.

Furthermore, I have two computers with 11.04 beta, and in my laptop I didn't have this issue while searching using the Unity panel a week ago (I don't have it with me now, sorry, I can't check), while I did have the problem with Skype too.

I use Ubuntu 11.04 with the Spanish language and Spanish keyboard distribution. I can properly write the letter "Ñ" (we have a key for that one), but can't write properly á, é, í, ó, ú and other letters that are the result of pressing two keys in a row (right now, typing this message, I was able to write them, using Chrome navigator. Firefox and Libreoffice aren't affected either).

David Barth (dbarth)
Changed in unity:
milestone: 3.8.12 → 3.8.14
Revision history for this message
Simos Xenitellis  (simosx) wrote :

The issue here is that all gtk+ applications have their own knowledge of dead keys (accents), so if an application is a gtk+ application, accents work just fine.

If an application is not a gtk+ application, then the app has to use the dead keys that are configured from the X server. It's normally the file
/usr/share/X11/locale/en_US.UTF-8/Compose

The above refer to
1. dead key Compose sequences (such as dead_acute + a = á)
2. general Compose sequences (such as Compose + o + c = ©)

I did not try the specific app; if it's a gtk+ app, it should work just fine, perhaps some minor change
If it is not a gtk+ app, then you need to check the XOrg settings.

To figure out whether XOrg deadkeys work, start 'xterm' and try to type a compose sequence. If it does not work, then it's a XOrg problem. It it works on xterm, then it's a Unity app thing (so, it's easy to fix).

Last, if you have IBus activated and enabled, it may also mess up with all these.

Revision history for this message
Daniel Cordeiro (dcordeiro) wrote :

Simos, even if the X.org deadkeys work (that is my case), the problem still happens in Unity.

Anyway, Unity should respect the keyboard settings defined by the user with gnome-keyboard-properties (that is Ubuntu's official way to configure a keyboard).

Revision history for this message
Simos Xenitellis  (simosx) wrote :

@DanielCordeiro: You mention that XOrg dead keys work in your case. I suppose you mean that dead keys work in xterm. If that is the case, then the Unity bug is easily fixable, and it's a bug in Unity.

(do not have Unity installed yet)

Revision history for this message
Marco Biscaro (marcobiscaro2112) wrote :

@Loris: the feature you suggest on comment #7 is reported in bug #773197.

tags: added: i18n
summary: - can't type characters with accent
+ can't type characters with accent (dead keys)
David Barth (dbarth)
Changed in unity:
milestone: 3.8.14 → 3.8.16
Revision history for this message
David Barth (dbarth) wrote :

The proposed branch is not a candidate for an SRU: it creates regressions which are not acceptable.

Changed in unity:
assignee: Mirco Müller (macslow) → Jay Taoko (jaytaoko)
milestone: 3.8.16 → alpha2
status: In Progress → Confirmed
Changed in nux:
assignee: Mirco Müller (macslow) → Jay Taoko (jaytaoko)
status: In Progress → Confirmed
Changed in nux (Ubuntu):
status: In Progress → Confirmed
Changed in unity (Ubuntu):
status: In Progress → Confirmed
Didier Roche (didrocks)
Changed in unity:
milestone: 4.2.0 → 4.4.0
Didier Roche (didrocks)
Changed in unity:
milestone: 4.4.0 → 4.6.0
Revision history for this message
Marco Biscaro (marcobiscaro2112) wrote :

Any progress with this bug?

Didier Roche (didrocks)
Changed in unity:
milestone: 4.6.0 → 4.8.0
Revision history for this message
Joaquín Ignacio Aramendía (samsagax) wrote : Re: [Bug 746761] Re: can't type characters with accent (dead keys)

In the last Oneiric alpha I've tested this working as expected but I
wouldn't risk to say it's solved.
--
Joaquín Ignacio Aramendía <email address hidden>

El lun, 01-08-2011 a las 15:13 +0000, Marco Biscaro escribió:
> Any progress with this bug?
>

Neil J. Patel (njpatel)
Changed in unity:
assignee: Jay Taoko (jaytaoko) → Neil J. Patel (njpatel)
status: Confirmed → In Progress
Revision history for this message
David Barth (dbarth) wrote :

This is fixed since IM support has been merged in into Unity. Merging that back into nux is an item for next cycle.

Changed in nux:
importance: High → Wishlist
Changed in unity:
status: In Progress → Fix Released
Changed in unity (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
Changed in nux (Ubuntu):
importance: Undecided → Wishlist
Revision history for this message
Simos Xenitellis  (simosx) wrote :

In the latest Unity in Ubuntu 12.04 Beta1 (with all updates), I can see this bug reappearing.
In both the Dash and Lens text box, I am not able to type Greek or Latin with accents.

It's Unity 5.6.0.

Revision history for this message
Filippos Kolyvas (fkol-k4) wrote :

I can confirm the reappearance of the bug for the 12.04 version.
In detail, pressing the accent key shows the accent alone without waiting for the press of the accented letter key.
As result, instead of typing the accented character as one character, two consecutive characters are typed, the accent and the letter to be accented.
Unity version is Unity 5.6.0-0ubuntu4 in 12.04LTS (VirtualBox Guest in 11.10 Host)

Revision history for this message
Daniel Cordeiro (dcordeiro) wrote :

I just tested on Ubuntu 12.04 using a keybord configured as US international with AltGr key and locale set to pt_BR.UTF-8. I had two different behaviours (both unexpected):

First:
  ' + c gave me ć

Then, the most common behaviour:
  ' + c gave me 'c

When I was expecting " ' + c = ç "

Revision history for this message
Sonickydon (fiotakis) wrote :

I can not confirm that for el (Greek) on a 32bit 12.04 install I just upgraded (using the extended Greek keyboard layout).

Revision history for this message
Simos Xenitellis  (simosx) wrote :

Sonickydon: Can you check again with latest updates? If you use an Ubuntu mirror, you may not have the full packages updates.

I can confirm that with latest updates (today), the problem appeared again and it still exists.

I created a new bug report, at https://bugs.launchpad.net/unity/+bug/961741
about this regression.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers