compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()

Bug #744231 reported by Ofer Cohen on 2011-03-28
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Undecided
Unassigned
Unity
Fix Released
Critical
Neil J. Patel
nux (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

The steps I did:
1. remove kubuntu-desktop
2. reinstalling ubuntu-desktop
3. reboot
4. login
5. when desktop loading I get the error.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.36-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CheckboxSubmission: c66fb5627f9c3d7394f8fd63f104e1a5
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
CrashCounter: 1
Date: Mon Mar 28 13:59:54 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f9a5249ee40 <gdk_cairo_set_source_pixbuf+272>: movzbl 0x2(%rax),%r10d
 PC (0x7f9a5249ee40) ok
 source "0x2(%rax)" (0x00000002) not located in a known VMA region (needed readable region)!
 destination "%r10d" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nux
StacktraceTop:
 gdk_cairo_set_source_pixbuf () from /usr/lib/libgdk-x11-2.0.so.0
 PanelHomeButton::Refresh() () from /usr/lib/compiz/libunityshell.so
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
UpgradeStatus: Upgraded to natty on 2011-03-27 (1 days ago)
UserGroups: adm admin audio cdrom dialout disk fuse lpadmin netdev ofer plugdev sambashare video www-data
XsessionErrors:
 (nautilus:1772): Gtk-WARNING **: Change Desktop Background: missing action Change Desktop Background
 (nautilus:1772): Gtk-WARNING **: Ubuntu Documentation: missing action Ubuntu Documentation
 (nautilus:1772): Gtk-WARNING **: Change Desktop Background: missing action Change Desktop Background
 (nautilus:1772): Gtk-WARNING **: Ubuntu Documentation: missing action Ubuntu Documentation
 (nautilus:1772): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

Related branches

Ofer Cohen (oc666) wrote :

StacktraceTop:
 gdk_cairo_set_source_pixbuf () from /usr/lib/libgdk-x11-2.0.so.0
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
visibility: private → public
Omer Akram (om26er) wrote :

thanks for the bug report but unfortunately the logs collected by launchpad's automatic retracer don't have anything useful in them to be worked on. If you are still able to reproduce this crash can you please get a backtrace by following the instructions here https://wiki.ubuntu.com/Unity/FilingBugs#Getting a stack trace

Changed in nux:
status: New → Incomplete
Changed in nux (Ubuntu):
status: New → Incomplete
Changed in unity:
status: New → Incomplete
Neil J. Patel (njpatel) wrote :

Inspecting the unity source code I found two places where we use gdk_cairo_set_source_pixbuf and one of them was missing a NULL pointer check, so I've added that and I believe it should fix this bug (as I believe it's caused by a missing icon).

If you still get this after next week's release (3.8.2), please re-open.

Changed in unity:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Critical
milestone: none → 3.8.2
status: Incomplete → Fix Committed
Changed in nux (Ubuntu):
status: Incomplete → Invalid
Changed in nux:
status: Incomplete → Invalid
status: Invalid → Opinion
status: Opinion → Invalid
Didier Roche (didrocks) on 2011-04-01
Changed in nux:
status: Invalid → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (5.9 KiB)

This bug was fixed in the package unity - 3.8.2-0ubuntu1

---------------
unity (3.8.2-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - New window tracking system breaks in the case where windows try to
      restack relative to destroyed windows that were never mapped
      (LP: #723014)
    - does not display icons until hovered (LP: #726033)
    - Unity Launcher has black spaces where icons should be (LP: #729353)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in SimpleLauncherIcon::OnIconThemeChanged()
      (LP: #741652)
    - compiz crashed with SIGSEGV in free() (LP: #738864)
    - compiz crashed with SIGSEGV in g_closure_invoke() (LP: #741674)
    - compiz crashed with SIGSEGV in free() (LP: #742300)
    - Unity can't get touch the touch initialization signals from GEIS
      (LP: #742555)
    - Windows that reparent away from the root before they are mapped can
      cause other windows to become invisible (and compiz to crash)
      (LP: #743011)
    - compiz crashed with SIGSEGV in gdk_cairo_set_source_pixbuf()
      (LP: #744231)
    - [dash] Keyboard navigation not implemented as specified (LP: #608132)
    - xterms broken in unity (LP: #692463)
    - Unity opens application menu on Alt+F10 shortcut (LP: #722674)
    - First four items in Dash begin "Find" "Find" "Find" "Find" (LP: #729002)
    - Increase the size of the top left Launcher reveal area from 1px to a
      slightly larger triangle that comes out of the top left corner
      (LP: #736034)
    - Add a test case for invisible windows regressions (LP: #736876)
    - Re-sync with xquerytree to avoid stacking order issues (LP: #740465)
    - Keyboard navigation: quicklist not opening for Trash launcher item
      (LP: #741793)
    - Wrong window moves (LP: #741656)
    - compiz crashed with SIGSEGV in
      SimpleLauncherIcon::ActivateLauncherIcon() (LP: #742110)
    - Combo in the search bar did not disappear after the places was closed
      (LP: #742712)
    - Expo doesn't quit reliably when using keynav or shortcut (LP: #744196)
    - Make the BFB icon turn blue when an application goes urgent
      (LP: #744973)
    - Launcher - increase "launcher reveal %" for 'Fade and slide' launcher
      reveal transition to 65% (LP: #745602)
    - Arrows do not fade out with rest of launcher durring DND (LP: #746811)
    - Don't create windows over the launcher (LP: #688816)
    - Launcher - Indicate which application is currently focused with a
      glowing Launcher icon (LP: #676604)
    - Unity Grid is broken for multi-monitor setups (LP: #709221)
    - dynamic quicklists are not working (LP: #729074)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - it is still possible to quit unity from the panel (LP: #733725)
    - Selection does not fit small icons in Unity Dash (LP: #735746)
    - Unmounting media gives no error when failed (LP: #737633)
    - ATI/fglrx workaround patch (LP: #740298)
    - "Files & Folders" tooltip say...

Read more...

Changed in unity (Ubuntu):
status: New → Fix Released
Changed in nux (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers