compiz crashed with SIGABRT in raise()

Bug #741942 reported by Jamie Strandboge on 2011-03-24
388
This bug affects 88 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Jay Taoko
Unity
Fix Released
High
Jay Taoko
nux (Ubuntu)
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

After updating my natty install today, the desktop is completely unusable with compiz crashing all over the place when changing focus and notify-osd events.

Steps to reproduce:
1. login
2. ctrl-t to open a gnome-terminal
3. move the terminal to the center of the desktop
4. click the desktop
5. click inside the terminal
6. repeat alternating 4 and 5 until compiz crashes.

I tried moving aside ~/.compiz and ~/.compiz-1 before logging in with no effect. This happens with many windows, not just gnome-terminal. Also, the Ubuntu logo is not displayed in the upper left anymore (ie, the one next to the global menu).

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: libnux-0.9-0 0.9.36-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Thu Mar 24 12:58:41 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: nux
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: compiz crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to natty on 2011-02-24 (27 days ago)
UserGroups: adm admin cdrom dialout kvm libvirtd lpadmin plugdev sambashare sbuild

Related branches

Jamie Strandboge (jdstrand) wrote :
visibility: private → public

StacktraceTop:
 raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 abort () at abort.c:92
 g_assertion_message (domain=<value optimized out>, file=<value optimized out>, line=<value optimized out>, func=0x7ff2dd324730 "g_variant_type_info_check", message=0x2ac0140 "assertion failed: (0 <= index && index < 24)") at /build/buildd/glib2.0-2.28.4/./glib/gtestutils.c:1358
 g_assertion_message_expr (domain=0x7ff2dd2da646 "GLib", file=0x7ff2dd3243b0 "/build/buildd/glib2.0-2.28.4/./glib/gvarianttypeinfo.c", line=186, func=0x7ff2dd324730 "g_variant_type_info_check", expr=<value optimized out>) at /build/buildd/glib2.0-2.28.4/./glib/gtestutils.c:1369
 g_variant_type_info_check (info=<value optimized out>, container_class=<value optimized out>) at /build/buildd/glib2.0-2.28.4/./glib/gvarianttypeinfo.c:186

Changed in nux (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Didier Roche (didrocks) on 2011-03-25
Changed in nux (Ubuntu):
status: New → Triaged
importance: Medium → High
Changed in nux:
status: New → Triaged
importance: Undecided → High
Changed in unity:
status: New → Triaged
importance: Undecided → High
Didier Roche (didrocks) on 2011-03-25
Changed in unity:
milestone: none → 3.8.2
Thiago Belem (thiago.belem) wrote :

A work around is:

1. When the screen freeze and you can't do anything (just move your mouse)
2. Hit CTRL+ALT+F2
3. $ pkill compiz
3. Hit CTRL+ALT+F7
4. Wait compiz reload :)

kyleabaker (kyleabaker) wrote :

Occurs for me on login before opening any windows at all.

Jamie Strandboge (jdstrand) wrote :

The suggested work around does not work here. After a few seconds it starts happening again. I've done both
compiz --replace' and 'unity --reset' and while both can 'fix' it for a few moments, the buggy behavior returns quickly. compiz and therefore unity are completely unusable atm. unity-2d works ok as a workaround.

#5 is a valid workaround if compiz is working (for the most part) and just happened to have a one-off crash that took away unity and all window decorations. Coming up with a solution to get your desktop back without restarting the computer or even GDM isn't that obvious.

Unfortunately, SIGABRT in raise() is a very general bug. We (the end users) aren't seeing why (0 <= index && index < 24). There could be multiple fronts causing index to go out of range, leaving compiz in varying states for different people.

An example I just noticed is that there isn't a line about the nvidia kernel module in the submitter's report. All bug reports I file mention the nvidia kernel module. With that very limited information, I would assume that Jamie and the bug submitter are using one of the built-in open-source 3D drivers (nv, r[nnn]g, intel) while Thiago and I are using nvidia (or fglrx). But that's going off very limited information so I very well could be wrong. Then again, I just used that as an example of what I meant by multiple fronts.

Thiago Belem (thiago.belem) wrote :

Is there anything I can do and/or provide to help with more information about this bug?

Jamie Strandboge (jdstrand) wrote :

bug #741908 (a duplicate of this one) has the information on my hardware, which is intel.

Jay Taoko (jaytaoko) wrote :

I cannot reproduce this bug. I am using Unity from trunk. Is someone constantly reproducing this bug?

Jay Taoko (jaytaoko) on 2011-03-31
Changed in nux:
status: Triaged → Incomplete
Changed in unity:
status: Triaged → Incomplete
Changed in nux:
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity:
assignee: nobody → Jay Taoko (jaytaoko)
Jamie Strandboge (jdstrand) wrote :

Jay, I am the reporter, I see this constantly and Unity is now completely unusable for me (I have to use unity-2d). All I have to do is login and start opening applications and very quickly this bug occurs. I gave a reduced reproducer for my hardware in my initial report (as previously mentioned, apport-collected hardware info is in duplicate bug #741908). I have:
nux 0.9.36-0ubuntu1
compiz 1:0.9.4git20110322-0ubuntu5
unity 3.6.8-0ubuntu3

I am not sure why the bug is now marked Incomplete....

Didier Roche (didrocks) wrote :

@Jay: you can't reproduce every crashers, however please don't set them incomplete when it has been reported against latest version in Natty with all the stacktrace info beeing there.

Changed in unity:
status: Incomplete → Triaged
Changed in nux:
status: Incomplete → Triaged
Jay Taoko (jaytaoko) on 2011-03-31
Changed in nux:
status: Triaged → Fix Committed
Changed in unity:
status: Triaged → Fix Committed
Changed in nux (Ubuntu):
status: Triaged → Fix Committed
Jamie Strandboge (jdstrand) wrote :

Thanks for the fixes! Not sure when these fixes will hit natty, but I'd be happy to test patches against what is (or will be) in natty if that would be helpful. I'm also fine with waiting for them to hit the archive. Thanks again, it'll be great to have my desktop back. :)

They should land tomorrow, Jamie, look forward to hearing back from you
then!

Didier Roche (didrocks) on 2011-04-01
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.38-0ubuntu1

---------------
nux (0.9.38-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in std::_List_node_base::_M_hook()
      (LP: #711916)
    - compiz crashed with SIGSEGV in nux::View::PostProcessEvent2()
      (LP: #712498)
    - compiz crashed with SIGSEGV in sigc::internal::signal_emit0<void,
      sigc::nil>::emit() (LP: #729715)
    - compiz crashed with SIGSEGV in brw_validate_state() (LP: #730707)
    - Finish Nux detection tool support (LP: #722089)
    - compiz crashed with SIGABRT in raise() (LP: #741942)
    - compiz crashed with SIGSEGV in PanelMenuView::ProcessEvent()
      (LP: #742139)
    - compiz crashed with SIGSEGV in operator->() (LP: #741961)
    - Graphics hardware capability detection (LP: #685208)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabPointer()
      (LP: #740784)
    - compiz crashed with SIGSEGV in nux::Area::InitiateResizeLayout()
      (LP: #741977)
    - compiz crashed with SIGSEGV in nux::GraphicsDisplay::GrabKeyboard()
      (LP: #742233)
    - Missing child addition signals on nux::Layout and nux::View
      (LP: #734803)
    - compiz crashed with SIGSEGV in
      nux::GpuRenderStates::SubmitChangeStates() (LP: #735908)
    - unity_support_test crashed with SIGSEGV (LP: #743848)
  * debian/control:
    - adding libpci-dev build-dep for the new lighter unity_support_tool
 -- Didier Roche <email address hidden> Fri, 01 Apr 2011 11:15:39 +0200

Changed in nux (Ubuntu):
status: Fix Committed → Fix Released
Jamie Strandboge (jdstrand) wrote :

FYI-- this seems to be fixed now with the latest updates. Thanks again! :)

Mark Shuttleworth (sabdfl) wrote :

On 05/04/11 18:42, Jamie Strandboge wrote:
> FYI-- this seems to be fixed now with the latest updates. Thanks again!
> :)

Good man, thanks for circling back :-) New updates tomorrow, test for a
regression ;-)

Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers