compiz crashed with SIGSEGV in nux::BaseTexture::GetDeviceTexture()

Bug #692823 reported by Anthony Hook on 2010-12-21
62
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
High
Jay Taoko
Unity
Fix Released
High
Jay Taoko
nux (Ubuntu)
High
Jay Taoko
Natty
High
Jay Taoko
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: compiz

This happens after I log in. I see unity load for about 2 seconds, and then it crashes.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: compiz-core 1:0.9.2.1+glibmainloop3-0ubuntu5
ProcVersionSignature: Ubuntu 2.6.37-10.24-generic 2.6.37-rc6
Uname: Linux 2.6.37-10-generic i686
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/allscreens/options/active_plugins'
Date: Mon Dec 20 19:50:58 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
MachineType: ASUSTeK Computer INC. 1000
PciDisplay: 00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.37-10-generic root=UUID=7b5dbba8-a114-4302-99ca-941972f55fc5 ro vt.handoff=7 quiet splash
RelatedPackageVersions:
 xserver-xorg 1:7.5+6ubuntu3b1
 libgl1-mesa-glx 7.9+repack-1ubuntu3
 libdrm2 2.4.22-2ubuntu1
 xserver-xorg-video-intel 2:2.13.901-2ubuntu2
 xserver-xorg-video-ati 1:6.13.2-1ubuntu2
SegvAnalysis:
 Segfault happened at: 0x2ab1f9f <_ZN3nux11BaseTexture16GetDeviceTextureEv+239>: mov 0x48(%edi),%eax
 PC (0x02ab1f9f) ok
 source "0x48(%edi)" (0x00000048) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 nux::BaseTexture::GetDeviceTexture() () from /usr/lib/libnux-graphics-0.9.so.0
 Launcher::DrawRenderArg(nux::GraphicsEngine&, Launcher::RenderArg const&, nux::Rect) () from /usr/lib/compiz/libunityshell.so
 Launcher::DrawContent(nux::GraphicsEngine&, bool) () from /usr/lib/compiz/libunityshell.so
 nux::View::ProcessDraw(nux::GraphicsEngine&, bool) () from /usr/lib/libnux-0.9.so.0
 nux::Layout::ProcessDraw(nux::GraphicsEngine&, bool) () from /usr/lib/libnux-0.9.so.0
Title: compiz crashed with SIGSEGV in nux::BaseTexture::GetDeviceTexture()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
XsessionErrors:
 (nm-applet:1354): Gtk-CRITICAL **: IA__gtk_widget_is_toplevel: assertion `GTK_IS_WIDGET (widget)' failed
 (nm-applet:1354): Gtk-CRITICAL **: IA__gtk_widget_is_toplevel: assertion `GTK_IS_WIDGET (widget)' failed
 (nautilus:1350): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed
dmi.bios.date: 06/11/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1003
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 1000
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1003:bd06/11/2009:svnASUSTeKComputerINC.:pn1000:pvrx.x:rvnASUSTeKComputerINC.:rn1000:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 1000
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
glxinfo: Error: [Errno 2] No such file or directory
system: distro = Ubuntu, architecture = i686, kernel = 2.6.37-10-generic

Anthony Hook (anthonyhook) wrote :

StacktraceTop:
 nux::BaseTexture::GetDeviceTexture (this=0x0)
 Launcher::DrawRenderArg (this=0x9b32128,
 Launcher::DrawContent (this=0x9b32128,
 nux::View::ProcessDraw (this=0x9b32134,
 nux::Layout::ProcessDraw (this=0x9b05588,

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Anthony Hook (anthonyhook) wrote :

Also, this can be reproduced every time I log in, if there's anything else I can do to help track this down.

visibility: private → public
Didier Roche (didrocks) on 2011-01-10
affects: compiz (Ubuntu) → nux (Ubuntu)
Changed in nux (Ubuntu):
importance: Medium → High
status: New → Triaged
David Barth (dbarth) on 2011-01-21
Changed in nux:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Jay Taoko (jaytaoko)
Changed in nux (Ubuntu Natty):
assignee: nobody → Jay Taoko (jaytaoko)
Changed in unity:
importance: Undecided → High
assignee: nobody → Jay Taoko (jaytaoko)
milestone: none → 3.4
Changed in nux (Ubuntu Natty):
milestone: none → natty-alpha-2
Jay Taoko (jaytaoko) wrote :

I cannot reproduce this on my Intel laptop with the my intel core i3. This could be a missing texture. Is this bug still hapening? A fix for missing application icon was submitted 2 weeks ago in unity.

David Barth (dbarth) wrote :

This looks like a classic case of objects not being created properly and then using a broken reference throughout the rest of the code. If icon files are not installed properly or something goes wrong while loading icons at starteup. then the launcher will crash.

Look into Launcher.cpp in the constructor when you do a bunch of nux::CreateTextureFromFile: where are you making sure all of them are created properly?

The fix should be quite obvious after that...

Changed in unity:
status: New → Confirmed
Changed in nux (Ubuntu Natty):
status: Triaged → Confirmed
David Barth (dbarth) wrote :

To reproduce the crash, and confirm the fix, just move an icon file and see how Unity starts

Martin Pitt (pitti) on 2011-01-25
Changed in nux (Ubuntu Natty):
milestone: natty-alpha-2 → natty-alpha-3
David Barth (dbarth) on 2011-02-04
Changed in unity:
milestone: 3.4 → 3.6
Jay Taoko (jaytaoko) wrote :

So far, I cannot reproduce this bug. Please, provide more info about how to reproduce if this issue is still happening.

Changed in nux:
status: Triaged → Incomplete
Jay Taoko (jaytaoko) wrote :

Cannot reproduce. Provide more info if this is still happening.

Changed in unity:
status: Confirmed → Incomplete
Changed in nux (Ubuntu Natty):
status: Confirmed → Incomplete
Alex Launi (alexlauni) wrote :

David, can you give a very specific set of steps to reproduce this?

Didier Roche (didrocks) on 2011-02-21
Changed in unity (Ubuntu Natty):
status: New → Incomplete
David Barth (dbarth) wrote :

I provided guildeines on how to potentially reproduce the issue: did anyone tried my instructions?

Martin Pitt (pitti) wrote :

This is a bug fix, can happen after FF, and isn't a release blocker.

Changed in nux (Ubuntu Natty):
milestone: natty-alpha-3 → none
Didier Roche (didrocks) on 2011-03-01
Changed in unity:
milestone: 3.6 → 3.6.2
Didier Roche (didrocks) on 2011-03-07
Changed in unity:
milestone: 3.6.2 → 3.6.4
Didier Roche (didrocks) on 2011-03-10
Changed in unity:
milestone: 3.6.4 → 3.6.6
Didier Roche (didrocks) on 2011-03-17
Changed in unity:
milestone: 3.6.6 → 3.6.8
Jay Taoko (jaytaoko) wrote :

Caused by missing application icon texture.

Changed in nux:
status: Incomplete → Fix Committed
Changed in unity:
status: Incomplete → Fix Committed
Changed in unity (Ubuntu Natty):
status: Incomplete → Fix Committed
Changed in nux (Ubuntu Natty):
status: Incomplete → Fix Committed
Didier Roche (didrocks) on 2011-03-24
Changed in nux:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nux - 0.9.36-0ubuntu1

---------------
nux (0.9.36-0ubuntu1) natty; urgency=low

  * New upstream release.
    - compiz crashed with SIGSEGV in nux::BaseTexture::GetDeviceTexture()
      (LP: #692823)
    - compiz crashed with SIGSEGV in nux::Focusable::SetFocused()
      (LP: #737716)
    - compiz crashed with SIGSEGV in nux::Memcpy() (LP: #738225)
  * debian/rules:
    - bump shlibs
 -- Didier Roche <email address hidden> Thu, 24 Mar 2011 04:54:54 +0100

Changed in nux (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package unity - 3.6.8-0ubuntu1

---------------
unity (3.6.8-0ubuntu1) natty; urgency=low

  * New upstream release.
    - crash at the second drag and drop from an unity place (LP: #736704)
    - Compiz crashes with SIGSEGV in nux::GraphicsDisplay::GrabPointer when
      opening the Dash (LP: #737287)
    - Visual Tearing/Rendering Issues with Unity Launcher (LP: #737476)
    - unity-window-decorator crash on unity panel dragout (LP: #740480)
    - unity-panel-service crashed with SIGSEGV in g_type_check_instance_is_a()
      (LP: #694699)
    - compiz crashed with SIGSEGV in nux::BaseTexture::GetDeviceTexture()
      (LP: #692823)
    - the "no result" and "search the web" items need icons (LP: #711199)
    - Resizing with external padding/grab area prevents reaching edge of
      screen (LP: #710356)
    - drag and drop of launcher icons uses microscopic drag icon (LP: #727647)
    - text in places look squeezed (LP: #727799)
    - at-spi-registry consumes most of the CPU and make the system unusable on
      Natty (LP: #729827)
    - migrate_favorites.py crashed with GError in __main__: Bad key or
      directory name: "/desktop/unity/launcher/favorites/app-
      dc++.desktop/type": `+' is an invalid character in key/directory names
      (LP: #737016)
    - Launcher hide state is confusing (LP: #739850)
    - Polish new launcher hide state (part 2) (LP: #740020)
    - launcher icons should expan on super or when entering keynav
      (LP: #741319)
    - Launcher - Dragging a Launcher icon to the Trash should remove the icon
      (LP: #676466)
    - Launcher - Enable dragging and dropping of files & folders to Launcher
      icons (LP: #676549)
    - Dash - Add Dash group header mouseover effect (LP: #689640)
    - unity aborts when you plug in an external monitor (LP: #700757)
    - Keyboard-navigation: focus on launcher remembered (LP: #713340)
    - Launcher Quicklists should always contain the application title
      (LP: #723877)
    - When a maximized window has window on top of it in 'restored state' (not
      maximised) , it is not possible to un-maximized the window by dragging
      the title bar downwards (LP: #723882)
    - When windows open for the first time they should not hide the launcher
      (LP: #723878)
    - UI blocked when expanding a section with more than 2000 items
      (LP: #736059)
    - Change ALT-Tab to bring the target window to the front (LP: #736938)
    - compiz crashed with SIGABRT in __kernel_vsyscall() (LP: #737814)
    - Launcher does not respond to changes in icon theme (LP: #605475)
    - Implement new style scrollbars in Dash (LP: #608124)
    - Closing launcher menu raises window under mouse (LP: #728787)
    - adding url launcher support from the search (LP: #739038)
    - Launcher - Set Launcher 'Hide Animation' to 'Slide only' by default.
      Also introduce subtle fade in effect. (LP: #739567)
    - "Time & Date" settings appears in launcher with empty tooltip
      (LP: #740907)
    - ZeitgeistLog missing implementation of get_property for "connected"
      (LP: #734080)
    - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
    - The Unity P...

Read more...

Changed in unity (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers