blurred dash distorted in ubuntu 13.04 with ATI Radeon Xpress X1250 RS690

Bug #1167018 reported by matheus
120
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Nux
Fix Released
Critical
Unassigned
nux (Ubuntu)
Critical
Unassigned
Nominated for Raring by Stephen M. Webb

Bug Description

http://askubuntu.com/questions/285525/dash-background-blur-problem

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: linux-image-3.8.0-17-generic 3.8.0-17.27
ProcVersionSignature: Ubuntu 3.8.0-17.27-generic 3.8.6
Uname: Linux 3.8.0-17-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: matheus 1867 F.... pulseaudio
Date: Tue Apr 9 18:19:36 2013
HibernationDevice: RESUME=UUID=6829f5b9-1e0c-42a2-a8c4-8eb21ed733e1
InstallationDate: Installed on 2013-04-01 (8 days ago)
InstallationMedia: This
MachineType: LG Electronics R405-A.B2MDP1
MarkForUpload: True
ProcFB:
 0 EFI VGA
 1 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-17-generic root=UUID=8f00944f-965d-4c43-b822-09c881f130e6 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.8.0-17-generic N/A
 linux-backports-modules-3.8.0-17-generic N/A
 linux-firmware 1.104
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/15/2008
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: LHORSF0D
dmi.board.name: Lhotse-II
dmi.board.vendor: LG Electronics Inc.
dmi.board.version: Rev0.4b
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: LG Electronics Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrLHORSF0D:bd01/15/2008:svnLGElectronics:pnR405-A.B2MDP1:pvr0100:rvnLGElectronicsInc.:rnLhotse-II:rvrRev0.4b:cvnLGElectronicsInc.:ct1:cvrN/A:
dmi.product.name: R405-A.B2MDP1
dmi.product.version: 0100
dmi.sys.vendor: LG Electronics

Related branches

Revision history for this message
matheus (matheusm-miranda) wrote :
Revision history for this message
Brad Figg (brad-figg) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
affects: linux (Ubuntu) → dash (Ubuntu)
Changed in dash (Ubuntu):
status: Confirmed → New
Revision history for this message
Adolfo Jayme (fitojb) wrote : Re: dash ubuntu 13.04

Can you attach an screenshot?

affects: dash (Ubuntu) → unity (Ubuntu)
Changed in unity (Ubuntu):
status: New → Incomplete
Revision history for this message
matheus (matheusm-miranda) wrote :

I fix the dash distorted in dash blur I put the command (no blur) and the dash was fixed

Changed in unity (Ubuntu):
status: Incomplete → Fix Committed
Adolfo Jayme (fitojb)
Changed in unity (Ubuntu):
status: Fix Committed → Invalid
Revision history for this message
John S. Gruber (jsjgruber) wrote :

Adolfo--

I'm having the same trouble as the original problem reporter, as are others. Turning blur off is only a small improvement to readability.

Please see http://askubuntu.com/questions/285525/dash-background-blur-problem for confirmation and for a picture of the problem.

Changed in unity (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Phonteus Nevolius (phontanka) wrote :

Let me add a screenshot directly here.

summary: - dash ubuntu 13.04
+ dash distorted in ubuntu 13.04 with ATI Radeon Xpress X1250 RS690
summary: - dash distorted in ubuntu 13.04 with ATI Radeon Xpress X1250 RS690
+ blurred dash distorted in ubuntu 13.04 with ATI Radeon Xpress X1250
+ RS690
Revision history for this message
rrich1974 (richardsdma) wrote :

still, the good side is that the radeon driver works better. i get better hw acceleration than in 12.04.

Adolfo Jayme (fitojb)
Changed in unity (Ubuntu):
importance: Undecided → Critical
Revision history for this message
kai (kkrapu) wrote :

Also happens with Radeon X 800 (RV480). The blur used in the launcher icon tooltips works fine though.

Revision history for this message
rrich1974 (richardsdma) wrote :

come on....is anyone working to fix this bug?

Revision history for this message
Justin McGuffin (stereotypebe) wrote :

I had this same issue on my wifes laptop when I installed Ubuntu 13.04 on it. This fixed the problem for me!
http://askubuntu.com/questions/286796/ubuntu-13-04-suffers-graphics-corruption

Revision history for this message
rrich1974 (richardsdma) wrote :

okay, thanx....
i installed unity tweak tools and click "search" and deactivate "background blur".
that solved the issue....but the bug remains and "unity tweak tools" is not installed by default nor supported by canonical.

Adolfo Jayme (fitojb)
affects: unity (Ubuntu) → nux (Ubuntu)
Revision history for this message
Paul Gittings (taffydownunder) wrote :

Also seeing this with the Nouveau driver and Nvidia 8600 video card. However, the pixalation over time gets worse and affects non-dash icons then elements of displayed windows (corners, icons within windows) to the point that the whole UI becomes unusable.

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Since this bug:

- Is valid.
- Is well described.
- Is reported in the upstream project.
- Is ready to be worked on by a developer.

It's already triaged.

description: updated
Changed in nux (Ubuntu):
status: Confirmed → Triaged
Changed in nux (Ubuntu):
assignee: nobody → John S. Gruber (jsjgruber)
Revision history for this message
John S. Gruber (jsjgruber) wrote :

Builds seem to be originating from lp:nux rather than lp:ubuntu/nux so I've proposed a merge there. The merge proposal contains an Ubuntu patch fo debian/patches:

In the Linear Sampling Blur routines:

  1. Clamp the sampling in the shader to the texture. This removes
     the strange and ugly pattern.

  2. To produce the blur, reduce the number of shader passes to those
     possible by using the linear sampling to sample each texel just
     once.

Changed in nux (Ubuntu):
assignee: John S. Gruber (jsjgruber) → nobody
Revision history for this message
John S. Gruber (jsjgruber) wrote :
Revision history for this message
kai (kkrapu) wrote :

Both static and active blur seem to work ok now on Radeon X800 GTO (R480 chip) with the fixed packages.

I had some problems with it though, first, the PPA has no packages for 13.04, only for Saucy so I had to manually download the packages and install them with dpkg. Second is some broken dependencies, libnux depends on libpango-1.0-0 and libpangocairo-1.0-0. Libpango is installed, don't know why the broken dependency for that, but there's no libpangocairo in the repos. Also after installing, the package unity has two broken dependencies, compiz-core-abiversion-20130125 and libnux-abiversion-20130411.0.

I'll leave things as it is for a while and see if any problems come up with blurring or anything related, but for now all seems good on that front. Performance isn't all that stellar, though perfectly usable, but I think that's just a general unity issue. I realize my GPU is quite old, but even so I think the experience could be a lot more snappy. Hopefully performance is something that will be focused on with future releases. I understand unity in 13.04 should already be performing better than past versions, but I haven't used those so can't compare.

Anyway I'm getting off topic, thanks for fixing the bug, hopefully the fix gets merged upstream soon. As it is, the graphic bug makes the whole system feel broken on a fresh install and many people will just opt for something that works right out, rather than spend time googling on how to fix the issue.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

kai: Thanks for the feedback. Fixing problems starts with the current development release, so that's where I've started. Raring is running older code and the package in my ppatwo repository isn't compatible. It's probably not a good idea to force install like that (not that I'v never done the same--but it's risky). The interface between unity and nux is different between the two versions in a way that's significant to the code involved, by the way.

The process is for the saucy fix to be reviewed and possibly iterate to a fix that's acceptible to a core developer. Once a fix is accepted, in general use in saucy, and works OK for everyone (those with the affected hardware and those using different hardware), it may be possible to consider an SRU (Stable Release Update) for raring.

In the meantime I'd suggest that you restore your raring system to the stock nux raring binary packages.

Thanks for trying the fix and letting us know what happened (and for mentioning your hardware, too).

All: It would be useful for those running saucy to give the fix a try and leave some feedback.

Changed in nux (Ubuntu):
assignee: nobody → John S. Gruber (jsjgruber)
Changed in nux:
importance: Undecided → Critical
status: New → Triaged
milestone: none → 4.0.3
Changed in nux (Ubuntu):
assignee: John S. Gruber (jsjgruber) → nobody
Stephen M. Webb (bregma)
Changed in nux:
milestone: 4.0.3 → 4.0.4
Revision history for this message
John S. Gruber (jsjgruber) wrote :

I've posted a blog containing suggestions on how to fix this bug, numerous gotcha's, some suggestions, and a couple of other potential bugs I've noticed in related code at https://sites.google.com/site/johnsjgruber/updates/thenuxgaussianblur .

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

John, thanks for your report and your work... However it would be nice if you could fix your patches so that we could include in Ubuntu as distro patches the biggest ones, and in nux the small ones (without any need to sign the CLA).

Thanks.

Revision history for this message
John S. Gruber (jsjgruber) wrote :

Marco--I'm told making the biggest patch a distro patch doesn't eliminate the need for a CLA and further isn't acceptable in that form. Also I think my uploaded array hack is too messy and hard to read and should be done as a vector of structures in order to be clear. I describe that method in the linked article but haven't uploaded that code.

I think you can see what loops to increase by one iteration from the two smallest patches. They aren't needed to fix this problem and are extremely simple. Maybe you can double check me that they are off by one and can change the for loops by one if you agree with me.

The other, more important problem IMHO is that shaders are stored by the num_pass and that's confused with sigma in NuxGraphics/GraphicsEngine.h I wasn't able to really fix this but it may be more important to fix as it seems to me to create an out of bounds condition on the saved shader program arrays. The variable num_pass currently should be (sigma*3)+1 if memory serves. I worry that out of bounds conditions can show up in very difficult problems that can arise anytime and can be hard to find.Therefore I'm eager to fix them. I don't know of any filed bug arising from this, however.

Revision history for this message
rrich1974 (richardsdma) wrote :

it seens that the problem is fixed in ubuntu 13.10

Anders (eddiedog988)
Changed in nux:
status: Triaged → Confirmed
Changed in nux (Ubuntu):
status: Triaged → Confirmed
Changed in nux (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
John S. Gruber (jsjgruber) wrote :

Like rrich1974, fixed on my system as of 13.10.

Changed in nux (Ubuntu):
status: Triaged → Fix Released
Changed in nux:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers