Comment 3 for bug 1801183

Hi Andrew,
Sorry I can't help you from the logs I see, but I wanted to let you know that NTP had accrued way too many issues over the time.
Therefore from Ubuntu 18.04 and onwards the recommended and primarily supported ntp components are:
- systemd-timesyncd (if you need NTP client only, default installed)
- chrony (for more advanced NTP client logic)
- chrony (NTP serving)