[FFe] netplan with forward-definition support

Bug #1670495 reported by Mathieu Trudel-Lapierre on 2017-03-06
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nplan (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]
Any complex configuration requiring layering of devices currently requires that "lower" layers are defined above "upper" layers. Ordering of configuration should not matter in netplan.

[Test case]
- Run nplan integration tests on the release
- Validate that netplan generate && netplan apply alone, without config, behave as expected (no result)
- Validate that netplan generate && netplan apply with minimal config writes /run/NetworkManager/conf.d/10-globally-managed-devices.conf
- Validate that netplan generate && netplan apply works with any existing configuation.

[Regression potential]
Any failure to work with existing configuration should be considered a regression. Any new failure of the test suite would be a regression.

---

I'd like to upload a new release of netplan; notable changes include:

 - forward-definition support (the underlying ethernet devices of bridges and bonds no longer need to be defined before the bridge or bond they are a member of)
 - add missing configuration knob for toggling STP for a bridge.

nplan is seeded on most flavors, but not used my default. It provides an alternate way for people to configure their network devices.

netplan builds successfully and all tests pass.

(this build is without MTU support, which might not be included depending on whether I get the fixes from Ryan quickly enough)

Will upload without the extra "mtu support " feature.

description: updated
Steve Langasek (vorlon) wrote :

Incremental feature enhancements with isolated impact and upstream test suite; FFe granted.

Changed in nplan (Ubuntu):
status: New → Triaged
Iain Lane (laney) wrote :

any chance you could look into the i386 test failures? and ideally amd64, since that apparently took 3 tries to pass.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nplan - 0.19

---------------
nplan (0.19) zesty; urgency=medium

  * Add support for unordered definition of network devices: you can now
    specify a virtual devices before their member devices. (LP: #1670495)
  * Allow setting up the STP state for a bridge. (LP: #1665088)
  * Document bond/bridge parameters support. (LP: #1664702)

 -- Mathieu Trudel-Lapierre <email address hidden> Thu, 09 Mar 2017 11:04:50 -0500

Changed in nplan (Ubuntu):
status: Triaged → Fix Released
description: updated

Hello Mathieu, or anyone else affected,

Accepted nplan into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/nplan/0.21~16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nplan (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers