Two notification bubbles at the same time

Bug #559109 reported by Michael Bienia
104
This bug affects 17 people
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
Fix Released
Medium
Mirco Müller

Bug Description

Binary package hint: notify-osd

This is on an up-to-date lucid with a dual-screen setup and metacity as window manager (no compiz).

Since a short time I notice that an notification bubble appears for a fraction of a second in the left upper corner (on the left monitor) before it jumps to the right upper corner (on the right monitor) where it gets display till the timeout.
But when there are several events in queue waiting to get displayed, I see the last notification bubble in the left corner till it's time for it to get display in the right location.

See the attached screenshot. I see the notification bubbles for 1 to 5 appear fast in the left upper corner and "5" stays there till it gets display in the other corner.

Some more testing shows that this flickering of the notification bubble only happen when I've a window in the left upper corner (which is the case the most time as I've place there the window with my IRC client)

Revision history for this message
Michael Bienia (geser) wrote :
David Barth (dbarth)
Changed in notify-osd (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
Changed in notify-osd:
milestone: none → ubuntu-10.04
Revision history for this message
wilsonliam (wilsonliam) wrote :

This also affects me - notifications are queued on the the left of the screen, and then appear on the right when the previous one has disappeared. They also don't disappear when my mouse cursor is above them. I running Ubuntu Netbook Edition, and it can be annoying especially when you have gwibber-service running with notifications.

Revision history for this message
wilsonliam (wilsonliam) wrote :

1st screenshot. Note the contact coming online on the right, and another being queued on the left.

Revision history for this message
wilsonliam (wilsonliam) wrote :

2nd screenshot, the second contact who was on the left has now shown on the right.

Revision history for this message
Micah Gersten (micahg) wrote :

https://bugs.edge.launchpad.net/ubuntu/+source/notify-osd/+bug/559279/comments/4 is interesting as it seems to note that installing compiz helps

Revision history for this message
Virgil Brummond (uraharakisuke153) wrote :

This happens to me as well, when there is only one notification it flickers from the top left to the proper position on the top right. However if there is two notifications, one appears on the top left, and does not disappear when the mouse moves over it. I can click through it though. After the first notification times out the second one moves back to the proper position and functions like normal.

See screenshot here:
https://bugs.launchpad.net/ubuntu/+source/notify-osd/+bug/559794

Mirco Müller (macslow)
Changed in notify-osd:
assignee: nobody → Mirco Müller (macslow)
Revision history for this message
Mirco Müller (macslow) wrote :

Sofar I can say that it seems to be a bug in metacity (without compositor enabled). If you try compiz, mutter or metacity (with compositor) this bug doesn't occur. I'm still looking deeper into this issue, to find the real cause of it. But for the moment you can work-around it by using either switching on metacity's compositing or use compiz or mutter.

Changed in notify-osd:
importance: Undecided → Medium
Changed in notify-osd (Ubuntu):
importance: Undecided → Medium
milestone: none → ubuntu-10.04
status: New → In Progress
Changed in notify-osd:
status: New → In Progress
Revision history for this message
robket (robket) wrote :

I have had the same issue since last week when I upgraded notify-osd to version 0.9.29-0ubuntu1. I'm not able to test it with compiz (compiz not working at the moment).

Running "for i in 1 2 3; do notify-send $i; done" I also have each notification appear for its allotted time on the right after waiting for the previous one to dissappear with the last queued notification always visible in the top left, not dissapearing on mouseover but only once it has its turn on the right.

I'm going to try installing the previous version of notify-osd to make sure that the problem is there and not in metacity.

Revision history for this message
Mirco Müller (macslow) wrote :

I've found the issue. It's in notify-osd. Working on a fix now.

Revision history for this message
Mirco Müller (macslow) wrote :

Branch lp:~macslow/notify-osd/fix-559109 holds the fix to this bug. It's up for review and will either make its way into Lucid as a distro-patch or new release. I'll leave that to the desktop-folks to decide.

Changed in notify-osd:
status: In Progress → Fix Committed
Changed in notify-osd (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9.29-0ubuntu2

---------------
notify-osd (0.9.29-0ubuntu2) lucid; urgency=low

  * Backport change from Mirco Müller to fix double bubbles issue (lp: #559109)
 -- Sebastien Bacher <email address hidden> Wed, 14 Apr 2010 12:50:49 +0200

Changed in notify-osd (Ubuntu):
status: Fix Committed → Fix Released
David Barth (dbarth)
Changed in notify-osd:
status: Fix Committed → Fix Released
Revision history for this message
robket (robket) wrote :

Yes, I can confirm that this bug fix worked successfully. Yay! Now I can turn pidgin notifications back on :)

no longer affects: notify-osd
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers