New notification does not work if icon theme is changed from Human

Bug #338837 reported by Mike Basinger on 2009-03-06
76
This bug affects 8 people
Affects Status Importance Assigned to Milestone
notify-osd (Ubuntu)
High
Mirco Müller

Bug Description

If I change the icon theme away from Human, the new notification system in Jaunty (updated 6-Mar-2009) no longer works.

Chris Coulson (chrisccoulson) wrote :

I can confirm this. I'm attaching a screenshot, which if you look hard enough in the top right hand corner of the screen, you will see a black line underneath the panel (which appears when I press my volume buttons and seems to be the notification window).

I'm also not using Human icon theme. If I switch back to Human, then it works.

Changed in notify-osd:
importance: Undecided → High
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :
Download full text (6.1 KiB)

Isn't this a duplicate of the #331383 bug?

Otherwise try this to solve it, it makes symlinks in your icon set to the human icons used for the notifications.

cd /home/USERNAME/.icons/ICONTHEME/scalable/status
ln -s /usr/share/icons/Human/scalable/status/notification-audio-next.svg notification-audio-next.svg
ln -s /usr/share/icons/Human/scalable/status/notification-audio-play.svg notification-audio-play.svg
ln -s /usr/share/icons/Human/scalable/status/notification-audio-previous.svg notification-audio-previous.svg
ln -s /usr/share/icons/Human/scalable/status/notification-audio-volume-high.svg notification-audio-volume-high.svg
ln -s /usr/share/icons/Human/scalable/status/notification-audio-volume-low.svg notification-audio-volume-low.svg
ln -s /usr/share/icons/Human/scalable/status/notification-audio-volume-medium.svg notification-audio-volume-medium.svg
ln -s /usr/share/icons/Human/scalable/status/notification-audio-volume-muted.svg notification-audio-volume-muted.svg
ln -s /usr/share/icons/Human/scalable/status/notification-audio-volume-off.svg notification-audio-volume-off.svg
ln -s /usr/share/icons/Human/scalable/status/notification-battery-low.svg notification-battery-low.svg
ln -s /usr/share/icons/Human/scalable/status/notification-device-eject.svg notification-device-eject.svg
ln -s /usr/share/icons/Human/scalable/status/notification-device-firewire.svg notification-device-firewire.svg
ln -s /usr/share/icons/Human/scalable/status/notification-display-brightness-full.svg notification-display-brightness-full.svg
ln -s /usr/share/icons/Human/scalable/status/notification-display-brightness-high.svg notification-display-brightness-high.svg
ln -s /usr/share/icons/Human/scalable/status/notification-display-brightness-low.svg notification-display-brightness-low.svg
ln -s /usr/share/icons/Human/scalable/status/notification-display-brightness-medium.svg notification-display-brightness-medium.svg
ln -s /usr/share/icons/Human/scalable/status/notification-display-brightness-off.svg notification-display-brightness-off.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-3G-full.svg notification-GSM-3G-full.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-3G-high.svg notification-GSM-3G-high.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-3G-low.svg notification-GSM-3G-low.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-3G-medium.svg notification-GSM-3G-medium.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-3G-none.svg notification-GSM-3G-none.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-disconnected.svg notification-GSM-disconnected.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-EDGE-full.svg notification-GSM-EDGE-full.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-EDGE-high.svg notification-GSM-EDGE-high.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-EDGE-low.svg notification-GSM-EDGE-low.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-EDGE-medium.svg notification-GSM-EDGE-medium.svg
ln -s /usr/share/icons/Human/scalable/status/notification-GSM-EDGE-none.svg notification...

Read more...

Chris Coulson (chrisccoulson) wrote :

Bug 331383 is "fixed".

The problem here is that the icons get installed to /usr/share/notify_osd as opposed to /usr/share/notify-osd. A change was recently committed to change the PACKAGE_NAME from notify_osd to notify-osd, by modifying the name passed to AC_INIT in configure.in. However, PACKAGE_NAME in the actual configure script used to build the package still says notify_osd, which is why the icons get installed in the wrong place. So the configure script used to build the package was generated from the old configure.in file (when the package name was notify_osd).

Chris Coulson (chrisccoulson) wrote :

Just to point out, renaming /usr/share/notify_osd to /usr/share/notify-osd makes it work.

Changed in notify-osd:
status: Confirmed → Triaged
Botond Szász (boteeka) wrote :

I confirm Chris Coulson's solution works.

David Barth (dbarth) wrote :

That's a regression. 0.9 had that right. Mirco, just fix the 1st line in configure.in. Thanks

Changed in notify-osd:
assignee: nobody → macslow
importance: Undecided → High
status: New → In Progress
manzur (sl-solaris) wrote :

i can confirm this too

Nicolas (nicolas-espina) wrote :

renaming /usr/share/notify_osd to /usr/share/notify-osd makes the notification of soud works, but the brightness notification steel broke

Chris Coulson (chrisccoulson) wrote :

The brightness notification is because you havent got the latest gnome-power-manager yet

Nicolas (nicolas-espina) wrote :

I update my system half hour ago and the problem steels there... But if you says that... I believe you :D... Thanks for answer!

Claudio Moretti (flyingstar16) wrote :

I can confirm Nicolas problem:
on my Dell Vostro 1500, i did a
ln -s /usr/share/notify_osd /usr/share/notify-osd
and now the volume notification shows up, but I still can't see the brightness one :(
Also, I could see some of the notifications (such as the "Connected to MyWirelessNetwork" one) before doing it =S

Claudio Moretti (flyingstar16) wrote :

BTW,
$: dpkg -l | grep gnome-power-manager
ii gnome-power-manager 2.24.2-2ubuntu6 power management tool for the GNOME desktop

$: uname -a
Linux Mycroft 2.6.28-9-generic #31-Ubuntu SMP Wed Mar 11 15:43:58 UTC 2009 i686 GNU/Linux

Nicolas (nicolas-espina) wrote :

Exactly configuration of Claudio here on my HP laptop...

Martin Pitt (pitti) wrote :

Fixed upstream in 0.9.5.

Changed in notify-osd:
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package notify-osd - 0.9.5-0ubuntu1

---------------
notify-osd (0.9.5-0ubuntu1) jaunty; urgency=low

  * New upstream bug fix release:
    - Fix typo in project name in AC_INIT (LP: #338837)
  * Add debian/watch.
  * Add bzr-builddeb configuration.
  * debian/copyright: Update download location.

 -- Martin Pitt <email address hidden> Tue, 17 Mar 2009 13:31:07 +0100

Changed in notify-osd:
status: Triaged → Fix Released

I installed the fix, and the problem was indeed fixed for all volume related
notifications. However, I still do not see the notifications when I change
the brightness on my laptop (Dell Inspiron 1420). The icon set I'm using is
Mashup.

Mike Basinger (mike.basinger) wrote :

I can confirmed that brightness still does not work.

Changed in notify-osd:
status: Fix Released → New
Changed in notify-osd (Ubuntu):
status: Fix Released → New
Chris Coulson (chrisccoulson) wrote :

Please open a new bug report for that, as that's a separate issue

Changed in notify-osd (Ubuntu):
status: New → Fix Released
Changed in notify-osd:
status: New → Fix Released
manzur (sl-solaris) wrote :

i say the same as crashsystems

Michael Rooney (mrooney) wrote :

Chris, can we just open a new task against gnome-power-manager for the
brightness issue? I understand that is the issue from reading above
comments.

Chris Coulson (chrisccoulson) wrote :

No, because it is a separate issue. The problem in this bug report was all the icons being installed in to the wrong location, due to a typo in the package name passed to AC_INIT. That is fixed now, so any remaining issues are unrelated to this bug and should be opened separately

Michael Rooney (mrooney) wrote :

I see, Mike B. has filed it as https://bugs.launchpad.net/bugs/344385 .

Changed in notify-osd (Ubuntu):
assignee: nobody → Mirco Müller (macslow)
no longer affects: notify-osd
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments