Please merge Debian changes into Zesty 1.10.3 packaging

Bug #1664652 reported by Thomas Ward on 2017-02-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Status tracked in Zesty
Zesty
Wishlist
Thomas Ward

Bug Description

We currently are not tracking Debian directly, due to speed-of-release issues or other issues.

We need to merge Debian's packaging changes into the existing Ubuntu packaging.

This will necessitate sort of a half-and-half merge. Changelog data will come from merges.ubuntu.com, and then be manually merged with existing changelog data for 1.10.3. The rest of the packaging with one or two exceptions will be left alone, started over from "Debian fresh" packaging, and the Ubuntu delta re-added.

The evil of going from static module compilation to dynamic module compilation necessitates radical packaging changes; to accommodate for this, we need to reintroduce the delta.

Note that this will necessitate adding some additional packages to Main, and the rest to Universe, that package list will be made available 'soon' once the delta is completely reintroduced to the Debian packaging.

Thomas Ward (teward) wrote :

Some notes:

Dynamic module packages have been added. Some need to go to main, the rest to universe.

These should go to Main:
libnginx-mod-http-geoip
libnginx-mod-http-image-filter
libnginx-mod-http-xslt-filter
libnginx-mod-mail
libnginx-mod-stream

Changed in nginx (Ubuntu Zesty):
status: In Progress → Fix Committed
Thomas Ward (teward) wrote :

A second merge is being uploaded now, to get the last changes to the packaging from Debian. With the exception of our delta, we are now 'in sync' with Debian packaging.

Thomas Ward (teward) wrote :

(The only packaging change was the Debian VCS string in debian/control; otherwise the packaging only has the Ubuntu delta)

Thomas Ward (teward) wrote :

The last merge I just uploaded has this debdiff in comparison to Debian, anyways.

tags: added: patch
Thomas Ward (teward) wrote :

Archive Admins:

There will be some overriding changes here that'll need to be done. We have a bunch of things that need to move to Universe, but some needs to be kept in Main. We also need to acknowledge the dropping of nginx-core-dbg; this was replaced by nginx-core-dbgsym as detailed below.

I was told to poke you guys, and rbasak said to subscribe you. Note of course that Perl is still holding up the migration from zesty-proposed to zesty, not sure if that's been looked at at all.

------

This is what should be in main and universe, as well as some things that're dropped due to the merge.

MAIN:
 nginx
 nginx-common
 nginx-core
 nginx-core-dbgsym
 libnginx-mod-http-geoip
 libnginx-mod-http-geoip-dbgsym
 libnginx-mod-http-image-filter
 libnginx-mod-http-image-filter-dbgsym
 libnginx-mod-http-xslt-filter
 libnginx-mod-http-xslt-filter-dbgsym
 libnginx-mod-mail
 libnginx-mod-mail-dbgsym
 libnginx-mod-stream
 libnginx-mod-stream-dbgsym

UNIVERSE:
 nginx-doc
 nginx-extras
 nginx-extras-dbgsym
 nginx-full
 nginx-full-dbgsym
 nginx-light
 nginx-light-dbgsym
 libnginx-mod-http-auth-pam
 libnginx-mod-http-auth-pam-dbgsym
 libnginx-mod-http-cache-purge
 libnginx-mod-http-cache-purge-dbgsym
 libnginx-mod-http-dav-ext
 libnginx-mod-http-dav-ext-dbgsym
 libnginx-mod-http-echo
 libnginx-mod-http-echo-dbgsym
 libnginx-mod-http-fancyindex
 libnginx-mod-http-fancyindex-dbgsym
 libnginx-mod-http-headers-more-filter
 libnginx-mod-http-headers-more-filter-dbgsym
 libnginx-mod-http-lua
 libnginx-mod-http-lua-dbgsym
 libnginx-mod-http-ndk
 libnginx-mod-http-ndk-dbgsym
 libnginx-mod-http-perl
 libnginx-mod-http-perl-dbgsym
 libnginx-mod-http-subs-filter
 libnginx-mod-http-subs-filter-dbgsym
 libnginx-mod-http-uploadprogress
 libnginx-mod-http-uploadprogress-dbgsym
 libnginx-mod-http-upstream-fair
 libnginx-mod-http-upstream-fair-dbgsym
 libnginx-mod-nchan
 libnginx-mod-nchan-dbgsym

NO LONGER PRESENT PACKAGES:
 nginx-{light,core,full,extras}-dbg
   * Replaced by -dbgsym packages in Debian, which was only recently merged in.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nginx - 1.10.3-1ubuntu3

---------------
nginx (1.10.3-1ubuntu3) zesty; urgency=medium

  * debian/tests/control: Remove the 'ec-x25519' test stanzas from the
    declarations of tests to run. This test requires OpenSSL >= 1.1.0
    to support the X25519 ECDH curve, and we do not have OpenSSL 1.1.0.
    This delta can be ***dropped*** when we do have OpenSSL >= 1.1.0.
    - This fixes the autopkgtests, of which the Debian merge introduced
      a regression due to the ec-x25519 test.

 -- Thomas Ward <email address hidden> Mon, 27 Feb 2017 19:51:57 -0500

Changed in nginx (Ubuntu Zesty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers