NGINX 1.10.x Fail to Build in OpenSSL 1.1.0, switch to Mainline for Yakkety and future non-LTS (until next LTS)

Bug #1604434 reported by Thomas Ward on 2016-07-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Wishlist
Thomas Ward

Bug Description

This is a bug filed long before we need to worry about it, but we'll keep it in the list for now.

NGINX 1.10.x does not build against OpenSSL 1.1.0. There is a fix in NGINX 1.11.x mainline, but it will not be backported to NGINX 1.10.x.

Ahead of the need of this issue in Ubuntu (we don't have 1.1.0 yet), we should prepare to include NGINX 1.11.x on top of the existing packaging instead. Nipping this now so it doesn't have a problem later wouldn't hurt.

As well, we also get some fixes for HTTP/2 things by switching to 1.11.x ahead of the next LTS (and track Stable/Mainline depending on when the release happens each year until next LTS, which we should target Stable releases.)

------

PREREQUISITE:

* Merge from Debian 1.10.1-1, see Bug #1580252

Thomas Ward (teward) on 2016-07-19
summary: - NGINX Fail to Build in OpenSSL 1.1.0.
+ NGINX 1.10.x Fail to Build in OpenSSL 1.1.0, switch to Mainline for
+ Yakkety and future non-LTS (until next LTS)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers