nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)

Bug #1132678 reported by Rowan Wookey on 2013-02-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
High
Unassigned

Bug Description

Nginx doesn't start in Ubuntu 13.04 due to the error nginx: [emerg] bind() to [::]:80 failed (98: Address already in use) it's caused by having these lines in /etc/nginx/sites-available/default

 listen 80;
 listen [::]:80 default_server;

In previous releases both are commented out.

This also effects https://launchpad.net/~nginx/+archive/stable

Rowan Wookey (rwky) on 2013-03-09
Changed in nginx (Ubuntu):
status: New → Invalid
Thomas Ward (teward) wrote :

I checked with the poster. They marked this as 'Invalid' because of non-response, and thougth that it was mis-filed.

Jst because a bug has no responses does not mean it is not looked at. I have reset the bug's status to 'new' accordingly after discussing the nature of this bug with the poster via email.

------
Thomas
BugSquad Member

Changed in nginx (Ubuntu):
status: Invalid → New
Daniel Hahler (blueyed) wrote :

See also https://github.com/gplessis/dotdeb-nginx/issues/18 (the nginx package in dotdeb.org).

Changed in nginx (Ubuntu):
status: New → Triaged
importance: Undecided → High

We've now fixed this in Debian.

In debian/conf/sites-available/default:

    listen 80 default_server;
    listen [::]:80 default_server ipv6_only=on;

I'm marking this Fix Committed since the fix has been committed to the upstream for this package. I'm going to leave it up to Thomas to decide whether or not a patch needs to be built for Ubuntu specifically. That should depend entirely on which Ubuntu releases are affected.

Thomas: If you need to discuss this with me, I'll be in the lounge.

Changed in nginx (Ubuntu):
status: Triaged → Fix Committed
Thomas Ward (teward) wrote :

I've got a fixed version of this prepared for Raring, but just in case I broke something accidentally, I'm running build-tests and testing on this.

Rowan, does this bug only occur on Raring, or does it happen on any other versions of Ubuntu?

Thomas Ward (teward) wrote :

Raring debdiff attached. Adding ubuntu-sponsors to this.

Dimitri John Ledkov (xnox) wrote :

@michaellustfield
Fix committed is wrong status for the Ubuntu package task, instead triaged is correct which means that "a fix for this has been identified but needs to be packaged/uploaded"
If there is an equivalent bug report in Debian for this issue, one can open an extra task pointing to the debian bug ("also affects distribution" button) that way there would be two tasks, with debian one - fix released, and ubuntu one - trianged.
Also see: https://wiki.ubuntu.com/Bugs/Status

Changed in nginx (Ubuntu):
status: Fix Committed → Triaged
Dimitri John Ledkov (xnox) wrote :

@Michael Lustfield
Are you planning to make an upload into experimental or sid? There is no other delta in nginx package and on ubuntu side we can just sync it from debian.

Rowan Wookey (rwky) wrote :

Thomas it only applies to raring and the ppa here https://launchpad.net/~nginx/+archive/stable

Marc Deslauriers (mdeslaur) wrote :

Since I still don't see a fixed version in Debian we can sync, I've applied the debdiff to Raring (albeit with a slightly modified version number).

Thanks for the debdiff!

Changed in nginx (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nginx - 1.2.6-1ubuntu1

---------------
nginx (1.2.6-1ubuntu1) raring; urgency=low

  * debian/conf/sites-available/default:
    * Modify default site default configuration file to bind to IPv6
      only for IPv6 default listen statement (LP: #1132678)
 -- Thomas Ward <email address hidden> Tue, 12 Mar 2013 00:23:02 +0000

Changed in nginx (Ubuntu):
status: Fix Committed → Fix Released
Mehdi Abaakouk (sileht) wrote :

The patch have a misspelling: "ipv6_only=on" must be replaced by "ipv6only=on"

See: https://bugs.launchpad.net/ubuntu/+source/nginx/+bug/1162177

Anthony Fok (foka) on 2013-05-10
no longer affects: nginx (Debian)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.