nginx-light: invalid parameter "ipv6_only=on"

Bug #1162177 reported by Leon on 2013-03-30
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
nginx (Debian)
Fix Released
Unknown
nginx (Ubuntu)
High
Unassigned

Bug Description

I'm running Raring and when I install nginx-light and try to start it I get this error:

  invalid parameter "ipv6_only=on" in /etc/nginx/sites-enabled/default

I believe it's because the `nginx-light` package doesn't contain the IPv6 module.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nginx (Ubuntu):
status: New → Confirmed
David Niergarth (jdnier) wrote :

Actually, I see this error even with nginx-full installed or with nginx-extras installed.

Thomas Ward (teward) wrote :

The changes which prompted this bug were caused by Bug 1132678.

The workaround for this is to modify the sites-available/default file to remove the ipv6 listen statement.

I will set an importance on this bug later, I am not able to do so effectively from my phone.

------
Thomas

Mehdi Abaakouk (sileht) wrote :

"ipv6_only=on" must be replaced by "ipv6only=on"

Thomas Ward (teward) wrote :

I'll try and get a patch pushed through quickly for this.

------
Thomas

Changed in nginx (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Thomas Ward (teward)
Thomas Ward (teward) wrote :

Importance set to high because this prevents usability of the package.

Changed in nginx (Ubuntu):
importance: Undecided → High
Thomas Ward (teward) wrote :

Debdiff for Raring. This debdiff contains a fix for the bug which was introduced in Bug 1132678 which prevented out-of-the-box functionality.

Thomas Ward (teward) on 2013-04-06
Changed in nginx (Ubuntu):
assignee: Thomas Ward (teward) → nobody
Marc Deslauriers (mdeslaur) wrote :

ACK on the debdiff. I'll upload it in a few minutes (albeit with -1ubuntu2 instead of -1ubuntu1.1).
Thanks!

Changed in nginx (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nginx - 1.2.6-1ubuntu2

---------------
nginx (1.2.6-1ubuntu2) raring; urgency=low

  * debian/conf/sites-available/default:
    * Modify default site configuration file to correct a typo
      that prevented out-of-the-box usability (LP: #1162177)
 -- Thomas Ward <email address hidden> Fri, 05 Apr 2013 20:22:38 +0100

Changed in nginx (Ubuntu):
status: Fix Committed → Fix Released
Changed in nginx (Debian):
status: Unknown → New
no longer affects: nginx
Changed in nginx (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.