Ubuntu

cannot connect to hidden ssid

Reported by Felix on 2009-08-31
540
This bug affects 56 people
Affects Status Importance Assigned to Milestone
Plasma-widget-networkmanagement
Fix Released
Medium
networkmanagement (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Lothar
Nominated for Lucid by EowynCarter
Nominated for Maverick by EowynCarter

Bug Description

Binary package hint: plasma-widget-networkmanagement

Kubuntu karmic alpha 4 x64 won't connect (try to connect) to a WPA2 network with hidden SSID.

plasma-widget-networkmanagement 0.1~svn1013816-0ubuntu1

I added a new connection, entered the SSID and the encryption method + passphrase and enabled auto connect.

Unfortunately i am not able to click "conenct to this network" or something similar. Autoconnect doesn't work either. As far as I can see nothing happens. daemon.log and syslog don't contain anything.

Jonathan Thomas (echidnaman) wrote :

Is this still an issue with the most recent snapshot? There has been work on hidden connections since svn 1013816.

Changed in plasma-widget-networkmanagement (Ubuntu):
status: New → Incomplete

There are still issues about hidden WPA networks (with karmic alpha 6). See Bug #432856.
Try clicking the icon, when it's "connecting" to the hidden network, it should be crashing.
If it crashes, this is a duplicate of #432856.

Jonathan Thomas (echidnaman) wrote :

The crash is a totally separate issue affecting the GNOME applet.

Jonathan Thomas (echidnaman) wrote :

...which is not to say that there couldn't be a WPA bug with NetworkManager itself, it's just that a crash wouldn't be indicative of a duplicate.

Maybe you could try http://cdimage.ubuntu.com/daily-live/20090927/, for me it has resolved the problem described in Bug #432856 (also related to connecting to hidden WPA network).

Felix (apoapo) wrote :

Are you able to connect to hidden ssid networks? Cause the bug is set to incomplete. What info do you need?

Lothar (lothar-tradescape) wrote :

I tried the Kubuntu live CD Karmic RC today and I could not access an AP that has a hidden SSID. I can create a new connection and enter the connection information with the SSID and passphrase, but when I try to activate the connection nothing happens and in the list the applet shows always "never" as the last connection date.
I did not see any entries in the system log, so I assume it never even tried to establish the connection.
I created an apport file for offline use that I will attach.

EowynCarter (tsunade30) wrote :

using kubuntu rc, i can't connect to my network with wpa and hidden ssid. Wicd won't go either.
Works a charm with ubuntu, or switching the network to non-hidden ssid.

Lothar (lothar-tradescape) wrote :

Is there any chance to get that fixed for the release? There's not much time left.

jpmccarthy (jeff-mccarthy) wrote :

I exposed my SSID and it works now - didn't try it hidden though when I had updated the initial install.

Changed in plasma-widget-networkmanagement (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
Marco (bulletxt) wrote :

Importance medium? Wow. This is an old bug that kubuntu 9.04 had! Great. Wonderful. After 6 months still this? I can't connect to a hidden connection? I can't believe it. I thought, oh well kubuntu 9.04 had this bug but 9.10 wouldn't. Instead............... just wonderful.

Hey canonical, please stop supporting that antique DE called gnome and be smart. Switch to kde4 and support it, but for real.

Lothar (lothar-tradescape) wrote :

Marco, your comment is a bit harsh. I am disappointed as well that wireless does not work out of the box. One would assume that it would be tested thoroughly and that any found issues would be worked on with highest priority, as a non working wireless makes kubuntu look stupid. But then kubuntu may still be a second class citizen within the ubuntu family :-(

EowynCarter (tsunade30) wrote :

Well, i tried gnome network manager, no dice.
Any hope to get this fixed ?

No WiFi connexion ? That a shame, for the reason Lothar pointed out. It's among the expected-to-work-out-of-the-box things.
Please, please ! Get this fixed, I really wanted to switch to kde, and that's a show-stopper for me.
Or maybe someone around there would have the required knowledge to do this ?

jpmccarthy (jeff-mccarthy) wrote :

I would note that KDE works wirelessly - its hidden networks causing the problem - I broadcasted my SSID (still WPA protected) and it works fine. Not perfect but feasible.

Anton Piatek (anton-piatek) wrote :

Is this a duplicate of Bug #330811 ?
I am also not able to connect to hidden networks on karmic - would be very happy to try installing (or even building) a test package if there is one

EowynCarter (tsunade30) wrote :

jpmccarthy, my network uses a hidden ssid, and it WILL stay that way.
I'll sooner switch to vista....

Don't know what to do. Stay with gnome ? Go to an other distri ?
"sighs".

Anyone know of a distri that have kde 4.3, Xi-fi drivers , and working wi-fi ?

Eric Biven (ebiven) wrote :

In 9.04 I was able to get the Network Manager applet to see my hidden network by running the following command once:

sudo iwlist eth1 scan essid MYHIDDENSSID

After running that command I rebooted, and after that I could at least manually select my network after logging in. Can anyone confirm or deny if that method still works in 9.10?

Please note that the release notes for kubuntu describe this problem and suggest the a workaround, which works for me. Here are the detailed steps:

1. Install the gnome-network manage with the following:
 sudo apt-get install network-manager-gnome

2. stop the KDE network manager applet
 pkill knetworkmanager

3. start the GNOME network manager applet
 nm-applet &

then use the configuration provided by the GNOME applet to configure the hidden wireless network.

Sir_Brizz (bj-cardon) wrote :

That's not much of a workaround.

This is just disappointing. This is two releases in a row that have had exactly the same bug, reported two months early, and still no fix. I don't want to install the gnome network manager. It has a bunch of dependencies.

EowynCarter (tsunade30) wrote :

The problem i see there there is is that we're told "here is a workaroud", rather than "we're working on a fix for for that, in the meantime, you can use this as a workaround."
And that workaround don't work for me..

Eric, that did the trick for me. Tanks :) Well, i guess that's a decent workaround. Still, that one NEEDS a fix.

I confirm this bug on Kubuntu 9.10 final release.

Eric Biven (ebiven) wrote :

On the plus side once you use the iwlist fix in post #17 Karmic will attach to the hidden SSID network automatically at login. Jaunty would require you to manually select it from the list.

Dolax (dominik-klein) wrote :

The fix from post #17 does not work for me. After the scan via iwlist the nm applet shows my hidden network, but I cannot connect. Clicking on the network name has no effect. I ran wireshark to check if anything happened. After reboot I cannot see my network anymore, so auto connect does not work either.

I'm also very annoyed about this long term bug!

The importance is clearly underestimated with medium. There are a lot of university or company wlans that wont change their network configuration to observable SSID only because Kubuntu has a bug...

EowynCarter (tsunade30) wrote :

""" The importance is clearly underestimated with medium."""
seconded !

Dolax, make sure you don't have any leftover of old, and buggy, config. And in my case, what i did was iwlist yada yada yada, reboot, noting on network list, iwlist yada yada again, deactivate wifi, reactivate wifi (that cause the applet to refresh the list). And my network finally showed.

Felix (apoapo) wrote :

i can confirm that "sudo iwlist wlan0 scan essid hiddenwlanssid" results in a working connection. i had set up the connection details before. fixing this would be very great, cause *only* "experienced" users switch to kubuntu and they have hidden ssids more often than the usual user. one of the first things they are going to see on "linux" is a not working wlan.. frustrating!

cki (charles-kirsch) wrote :

Hello,
I could connect to a hidden network using kubuntu9.10 and knetworkmanager after changing the file /usr/share/dbus-1/system-services/fi.epitest.hostap.WPASupplicant.service:
Exec=/sbin/wpa_supplicant -u -s -D nl80211
My computer uses driver iwl3945. I don't know if this works for other wireless drivers.

Tony Mancill (tmancill) wrote :

The fix in Post #26 didn't work for me (and my system uses iwl3945 as well); this was on a fresh install of kubuntu 9.10.

I agree that the importance is underestimated, particularly in the light of #284596. Essentially, Ubuntu (any flavor) isn't going to work out of the box if you use wi-fi and have multiple users.

cki (charles-kirsch) wrote :

Hi Tony,
did you reboot after application of the option? Maybe you also need to drop and recreate the wireless profile after the modification and boot.

Felix (apoapo) on 2009-11-12
summary: - cannot connect to hidden ssid/wpa2
+ cannot connect to hidden ssid
kiloxxx (kiloxxx) wrote :

I confirm that the fix in post #17 (sudo iwlist wlan0 scan essid hiddenwlanssid) works; the fix also solved another problem related to the fact that the wi-fi connection was previously unable to resume after a suspension.

The strange thing is that my hidden connection previously needed a web authentication, while I could now connect directly to the Internet without any authentication...

kiloxxx (kiloxxx) wrote :

Ok, everything returned to normality. May be someone was working at the wlan network.

WildSioux (mtanner79) wrote :

I confirm that the fix in post #17 (sudo iwlist wlan0 scan essid hiddenwlanssid) works. Kind of...

I had installed the gnome network manager because wicd would not connect. So after successfully connecting to my hidden ssid with gnome network manager. I decided to give the kde network manager another try. I removed the gnome one and installed the kde one. Rebooted and issued this command. Much to my surprise it connected!

However, I screwed it up when I deleted the gnome keyring stuff when I added my wpa2 info. So the problem is with me anyways is the kde network manager needs the info saved in the keyring-gnome one. The kde keyring is not working for some reason. I hope there is a fix for this.

WildSioux (mtanner79) wrote :

After doing some trial and error with network-manager-gnome working. I completely removed all of the gnome network manager and keyring stuff. And re-installed the kde plasma-widget-networkmanagement - 0.9~svn1029786+ag1-0ubuntu1...

I couldn't get it to work at first. But I deleted all old saved kwallets, and all of the saved networks related to my hidden ssid. I then tried to connect with kwallet disabled. It would not see my network. But (sudo iwlist wlan1 scan essid hiddenwlanssid) would make it see it but no connection. Clicking on it opened up a secret dialog to re-enter the wpa2 key (even though I had entered it in the "Connect to Other Network."

It would still not work, so I enabled kwallet and clicked on it again. This time it connected!

I then deleted the kwallet and the network again to start fresh. This time, kwallet disabled. Left click on the wireless icon in taskbar >> Manage Networks >> Other >> Connection Secrets >> In File (unencrypted).

Right click wireless icon >> Connect to Other Network >> It shows my network ssid but without a little wireless signal next to it (hidden). Double clicking on it brings up the dialog to enter the security info. I entered it all and saved it. It didn't connect, but (sudo iwlist wlan1 scan essid hiddenwlanssid) worked. It connected and this time WITHOUT USING KWALLET.

So, it seems the problem is plasma-widget-networkmanager doesn't remember to connect even though the ssid and key is saved (regardless of kwallet or not).

One thing I have noticed that it doesn't always reconnect after startup. sudo iwlist wlan1 scan essid hiddenwlanssid will make it connect though.

Abhinay Mukunthan (lexxonnet) wrote :

I can confirm this bug on the stable release of Karmic, with KDE 4.3.4 updates applied. Furthermore, the iwlist wlan0 scan essid hiddenap workaround doesn't work for me. Knetworkmanager simply refuses to acknowledge the existence of the hidden AP even though iwlist sees it.

I can't believe this bug is listed as Medium. In my opinion, it is absolutely critical that this be fixed. I can't connect to my hidden University Network because of this bug, and its extremely frustrating.

Dread Knight (dread.knight) wrote :

This is fucking stupid. Not even my gnome network manager connects to wireless for me now, not even under gnome. Good thing we have 2 major desktop environments, so that none of them works properly, while Windows 7 is pretty much flawless for me.

Im a linux advocate and I help out as much as possible, but releasing a major distro with such a show stopper bug is simply lame and depressing. I'm aware I'm trolling, but feedback is feedback, I respect all the devs out there, but Linux can't be taken seriously if I can't do basic stuff as connecting to internet, so things must change.

Is there some PPA with a working network manager?

Felix (apoapo) wrote :

Is this upstream KDE related? Do we have to report somewhere else? How to get this damn bug to attention finally? A fix till lucid is definitely necessary. It's so sad to have to mention such bugs when trying to convince friends to use Linux.

Batiste (batiste-bieler) wrote :

Yep this bug is pretty embarassing. The new wiifi manager as a nice UI but if doesn't work what's the point? Does it work for somebody at least?

Zee (zsalloum) on 2010-03-12
Changed in plasma-widget-networkmanagement (Ubuntu):
assignee: nobody → Zee (zsalloum)
assignee: Zee (zsalloum) → nobody

I just upgraded to the lucid beta, and still cannot connect to a hidden network: I'm still seeing the behavior noted originally.

Jens Bremmekamp (nem75) wrote :

As mentioned before: the problem persists. And "Importance: Medium"? Give me a break.

hector (mailbox-deandreis) wrote :

I,ve the same problem (and others, special on netbook edition) on different netbooks, with kubuntu beta 2 version, daily version (06 apr), desktop edition and netbook edition.
1 The system don't connect to a hidden network
2 I've changed the router to a visble network (non oter changes)
3 I've made a new connection to work (old connections don't work)
4 The system is connected
5 Change the router to hiden network
6 Restarted the netbook, the network connection remain ok.

Chris Galindo (chris-galindo) wrote :

I'm having the same issue. I just downloaded Kubuntu at the suggestion of my College Instructor. I run a hidden wireless network, and can't login. I pkill'd knetworkmanager, and enabled nm-applet. nm-applet sees the hidden network with no issue. I have went back and forth to try and get knetworkmanager to work using iwlist scan wlan0 ssid to no avail.
I'm a Windows user as its what I started with... I have gone back and forth to Linux and always seem to find myself stepping back towards MS. I guess what I'm saying... is that the learning curve is tough enough, you would think something as basic as this issue is... would be resolved quickly. I hope to stick it out and experience the magic of "Linux" that everyone keeps assuring me of.

Thanks!

Changed in plasma-widget-networkmanagement:
status: Unknown → Confirmed
Changed in plasma-widget-networkmanagement:
importance: Unknown → Medium
61 comments hidden view all 141 comments

There are currently different bugs mixed up here. The original bug was about KDE NM not being able to connect to hidden networks because the GUI was lacking. This should be fixed in most recent versions according to comment 36. I saw this menu entry myself but didn't have a chance to try it yet.

Comment 38 is not about hidden ESSIDs anymore. It might be a limitation introduced by a recent kernel or an updated crda (cf. <http://wireless.kernel.org/en/developers/Regulatory/CRDA>).

Anyway, I'm tempted to close this bug as FIXED once I was able to try it out, unless somebody still has trouble connecting to a hidden ESSID with a recent KDE NM.

NO this is not fixed. I just upgraded to suse 11.4 and had the exact same problem with it as with all the other versions. Do not close.

Confirm that I can't connect to the hidden network using plasma networkmanager applet. When I type network name and press Enter, nothing happens. Condemned to use gnome nm-applet.

Confirmed. Installed Fedora 15 (with KDE 4.6.3) on a new laptop and couldn't connect to a network with hidden ESSID using KDE networkmanager. After killing it and starting nm-applet, I can connect just fine.

The basic problem of this bug has resurfaced with Fedora 15, kde-plasma-networkmanagement-0.9-0.47.20110323.fc15.1

Also, F15 now has Gnome 3 and I am not interested in testing from that - I trust that it works anyway, as F14 did with kde-plasma-networkmanagement-0.9-0.40.20110323.fc14.

When I try to type in my ESSID in "Enter network name and press <enter>", this shows in .xsession-errors:

Usage: networkmanagement_configshell [Qt-options] [KDE-options] [options] mode

Create network connections standalone

Generic options:
  --help Show help about options
  --help-qt Show Qt specific options
  --help-kde Show KDE specific options
  --help-all Show all options
  --author Show author information
  -v, --version Show version information
  --license Show license information
  -- End of options

Options:
  --connection <connection-id> Connection ID to edit
  --hiddennetwork <ssid> Connect to a hidden wireless network
  --type <type> Connection type to create, must be one of '802-3-ethernet', '802-11-wireless', 'pppoe', 'vpn', 'cellular'
  --specific-args <args> Space-separated connection type-specific arguments, may be either 'gsm' or 'cdma' for cellular, or 'openvpn' or 'vpnc' for vpn connections, and interface and AP identifiers for wireless connections

Arguments:
  mode Operation mode, may be either 'create' or 'edit'

(In reply to comment #47)
> The basic problem of this bug has resurfaced with Fedora 15,
> kde-plasma-networkmanagement-0.9-0.47.20110323.fc15.1
>
> Also, F15 now has Gnome 3 and I am not interested in testing from that - I
> trust that it works anyway, as F14 did with
> kde-plasma-networkmanagement-0.9-0.40.20110323.fc14.

Easier than I thought - "yum install NetworkManager-gnome", and as I expected nm-applet connected to my wireless just fine. It even saw the Connection Information that was in place from the last time KDE networking was broken and I used nm-applet instead.

I am trying to debug this problem but with NetworkManager-0.9 Plasma NM always shows my hidden AP. Can someone here confirm that this problem does not happen with NM-0.9?

Retested with up-to-date Fedora 15:

kde-plasma-networkmanagement-0.9-0.53.20110616git.nm09.fc15.x86_64
NetworkManager-0.8.9997-5.git20110702.fc15.x86_64
kernel-2.6.38.8-32.fc15.x86_64

On my system it now finds and connects to hidden networks. I'll keep nm-applet off to monitor the situation with other networks.

Some notes for other testers:

 - make sure to delete all existing network connections first. Old connections created by nm-applet seem to confuse kde-plasma-networkmanagement.

 - make sure to delete the folder "Network Management" in your KDE wallet. Old passwords seem to confuse kde-plasma-networkmanagement.

 - (double-)clicking on a new network connection in kde-plasma-networkmanagement doesn't seem to start the connection setup editor. I had to use "Add..." in the Network Management Settings (BUG?)

 - After creating a network connection and entering the password, make sure to toggle the "System Connection" switch in the connection editor ON and then OFF. This makes sure that the password is transferred to your KDE wallet (This seems to be a problem/bug with NetworkManager. Also with nm-applet the passwords are first stored to /etc/system-config/network-scripts and after disabling the "available to all users" switch they are transferred to the GNOME keyring)

(In reply to comment #48)

I'm having the same problem as comment #48. I'm using Kubuntu 11.04 with the KDE Backports PPA - KDE SC 4.6.5. I'm using the package 0.9~svngit20110408-0ubuntu2. I've been having the same issue for a few versions back (KDE's network manager has never been able to connect to a hidden network for me). Gnome's nm-applet is able to connect fine.

Currently, when I click the network manager's icon I have a "<hidden network>" entry. I click on that and it turns into a textbox, where I type in the name of my hidden network and press enter. When I hit enter, nothing happens. The textbox just stays there. I can click away from the popup, and when I open the popup again it is still a textbox. After reading comment 48 I found that I'm getting the same message in my .xsession-errors file at the precise moment that I hit enter (and each subsequent time I try to hit enter).

Another note, I feel it would be very useful if I there were a checkbox in the config for manually adding a hidden network, in which checking the box would make it always available in the connection list.

Thanks for your work!

I was having the same issue reported in this bug and using the iwlist trick worked to allow me to connect using plasma network manager however I had to do this after every reboot which was annoying. I discovered that the reason was it required the BSSID (obtained once connected by clicking on "Copy current AP's MAC to BSSID). I use "System Connection" and noticed this was written to the config file at /etc/NetworkManager/system-connections/hiddenssid. Perhaps this should be a mandatory step that the applet does when connecting?

Further to my last comment. I was playing around with configs and found that it automatically added band=a to the config file mentioned in my last comment, which then broke it again. At one point just after I had deleted and re-added the config it set this to band=bg which did work. I changed a setting on the connection and it set it back to band=a which failed again??? I deleted the band option all together after looking at a config gnome nm-applet wrote and it works fine (it doesn't use band) - is this config option even necessary considering it seems to get it wrong and not having it works fine anyway?

James Robertson, do you use NM-0.8 or 0.9?

"Copy current AP's MAC to BSSID", which in current code is called only "Select" binds the connection to that MAC address. If the MAC address changes for any reason (for instance your current AP router broke and you bought a new one) you must manually change that setting again or NetworkManager will refuse to connect. That setting must be used only in special cases, such as in crowed wifi environments with WDS. WDS is a configuration where several AP routers uses the same essid, in that case you may want to fix the connection to a specified AP (the one with strongest signal) instead of roaming between all the access points in the WDS network.

In hidden essid case it seems NetworkManager needs to bind to a specified BSSID to connect.

My NM-0.9's configuration files do not contain the "band" setting. I think that setting is not necessary anymore.

Git commit d119e72811b25d167ee646d831b0aa4bb48f2a15 by Lamarque V. Souza.
Committed on 07/09/2011 at 10:33.
Pushed by lvsouza into branch 'nm09'.

Make hidden wifi networks work.

BUG: 209464
FIXED-IN: nm09

M +1 -1 applet/CMakeLists.txt
M +36 -6 applet/activatablelistwidget.cpp
M +5 -4 applet/hiddenwirelessnetworkitem.cpp
M +2 -0 libs/ui/wirelesspreferences.cpp
M +1 -1 plasma_nm_version.h
M +3 -8 settings/configshell/main.cpp
M +25 -1 settings/configshell/manageconnection.cpp
M +4 -0 settings/configshell/manageconnection.h

http://commits.kde.org/networkmanagement/d119e72811b25d167ee646d831b0aa4bb48f2a15

Changed in plasma-widget-networkmanagement:
status: Confirmed → Fix Released

this solution may work for Fedora however it does not for suse.

You have to recreate the connection by clicking on the <hidden network> item in the connection list.

Git commit 75ed3fbb062a03fa7acaee37ce7d1ccc4745aa2a by Lamarque V. Souza.
Committed on 09/09/2011 at 05:32.
Pushed by lvsouza into branch 'nm09'.

Fix <hidden network> not responding when entering the ssid.

CCBUG: 209464
CCBUG: 281659

M +3 -3 applet/hiddenwirelessnetworkitem.cpp
M +1 -1 plasma_nm_version.h

http://commits.kde.org/networkmanagement/75ed3fbb062a03fa7acaee37ce7d1ccc4745aa2a

I confirm that I have the same problem. Let's see if the update will arrive and work.

This issue is still present on Kubuntu 11.10, please fix it....

Regards,
Jorge

Git commit 39726abaaf3e78390149bedb560fd452fbc74161 by Lamarque V. Souza.
Committed on 04/02/2012 at 04:40.
Pushed by lvsouza into branch 'nm09'.

Fix wifi hidden network support.

M +1 -1 plasma_nm_version.h
M +3 -5 settings/configshell/manageconnection.cpp
M +2 -2 settings/configshell/manageconnection.h

http://commits.kde.org/networkmanagement/39726abaaf3e78390149bedb560fd452fbc74161

Git commit 8fa2cf50cd9cf9c3a4818c9845660bb5c66a610c by Lamarque V. Souza.
Committed on 04/02/2012 at 04:35.
Pushed by lvsouza into branch 'master'.

Fix wifi hidden network support. A new QtNetworkManager/libnm-qt snapshot
is also required.

M +1 -1 plasma_nm_version.h
M +1 -0 settings/configshell/main.cpp
M +4 -6 settings/configshell/manageconnection.cpp
M +2 -2 settings/configshell/manageconnection.h

http://commits.kde.org/networkmanagement/8fa2cf50cd9cf9c3a4818c9845660bb5c66a610c

Maarten Bezemer (veger) on 2012-03-18
affects: plasma-widget-networkmanagement (Ubuntu) → networkmanagement (Ubuntu)
Maarten Bezemer (veger) on 2012-03-18
Changed in networkmanagement (Ubuntu):
status: Confirmed → Incomplete

Many of the mentioned commits here (that claims to fix this issue), in particular d119e72811b25d167ee646d831b0aa4bb48f2a15 can only be found in the nm09 branch of
the networkmanagement repository.

To put an end to this I think the commits (maybe the whole nm09 branch) needs to be merge to master for the fix to reach the distributions (such as kubuntu)

d119e72811b25d167ee646d831b0aa4bb48f2a15 is incorporated into master already, it is just not in the git history. master and nm09 branches work the same way reggarding hidden wifi networks. Anway, master is in development and not for general mainly because libnm-qt and libmm-qt do *not* keep binary compatibility. I am also about to bump the mininal KDE SC version to 4.9.0 in master branch (it is 4.6.0 in nm09 branch).

Doesn't look so to me:

$ git remote -v
origin git://anongit.kde.org/networkmanagement (fetch)
origin git://anongit.kde.org/networkmanagement (push)
$ git remote update
Fetching origin
$ git branch -ra --contains d119e72811b25d167ee646d831b0aa4bb48f2a15
  remotes/origin/nm09

If d119e72811b25d167ee646d831b0aa4bb48f2a15 is in master, why is it then not listed then?

Seems like 405c1563 and cdd98456 are the commits that fixes this bug...

I made a fresh Quantal Quetzal installation today in the laptop with this problem, and I can confirm that the problem is gone. Now I can login and immediately it connects to the hidden SSID with WPA Personal password.

If you are still experiencing this problem and upgraded from an prior version, I suggest a fresh install to check it out.

Thank you so much to the people who works to solve this problem. You are really awesome.

Best regards,

-Andrey

Maarten Bezemer (veger) on 2012-10-29
Changed in networkmanagement (Ubuntu):
status: Incomplete → Fix Released

opensuse 12.2 kde 4.9.5 nm 0.9.0.7

i create a connection to a hidden wifi network
then
i activate wifi network
then
the hidden wifi network does not appear in the list of the wifi networks

if i set to "automa

if i set to "automaticaly connection"
then
i reboot
then the wifi connection is activated and i can use it

i can't switch from an ethernet or a visible wifi network to a hidden wifi network

the hidden wifi network is well registered

i must be clear.

creating a connection to a hidden wifi network works well.
but
after this connection does not appear in the list of the wifi networks in nm plasmoid.

then you can't switch to it because you can't select it.

I have this problem with Linux Mint 16 KDE Live DVD, using KDE 4.11.2. Is it expected? I had to do "sudo iwlist wlan0 scan essid <my ssid>" to make the system connect to the hidden network once added to the "Connection editor" window, otherwise I could not find any way to do it (there's no "connect" command in the "Connection editor" window and the just added hidden network was not shown in the tray panel for wireless connections).

(In reply to comment #72)
> I have this problem with Linux Mint 16 KDE Live DVD, using KDE 4.11.2. Is it
> expected? I had to do "sudo iwlist wlan0 scan essid <my ssid>" to make the
> system connect to the hidden network once added to the "Connection editor"
> window, otherwise I could not find any way to do it (there's no "connect"
> command in the "Connection editor" window and the just added hidden network
> was not shown in the tray panel for wireless connections).

by "Connectino editor" I am assuming you are using Plasma NM 0.9.8.x. If so then you should check the "hidden" checkbox in the edit connection dialog.

(In reply to comment #73)
> by "Connectino editor" I am assuming you are using Plasma NM 0.9.8.x. If so

Yes, it is NM 0.9.8.0. The window title is "Connectino editor".

> then you should check the "hidden" checkbox in the edit connection dialog.

That did the trick (after some seconds, the new network appeared in the available network list in the tray icon and connection was estabilished), thank you! However, IMHO it's not very intuitive. In fact, I thought that the "Hidden" checkbox were referring to some sort of visibility constraint to the network configuration I was editing, rather than to the SSID of the network itself. After all:
1) if I'm there to configure a new wireless network it's because I need a hidden network which is not listed in the network tray icon (otherwise I would have simply clicked on it from there)
2) isn't the system smart enough to determine whether that network SSID is hidden or not?

Maybe the original intent was to mimic the checkbox "connect even if the SSID is not broadcast" that is in Windows?

I tried to set the "hidden"-checkbox. But although NM said the connection was updated, it always reverted back to unset. Connecting to a hidden network didn't succeed. Also restarting NM didn't help.

Git commit 2abb222f201d481c007e032b4266e6ca4db4249c by Lamarque V. Souza.
Committed on 04/04/2014 at 21:36.
Pushed by lvsouza into branch '0.9.3'.

Be more informative about what option 'Hidden' do in create wifi connection
dialog.

M +7 -1 libs/editor/settings/ui/wificonnectionwidget.ui

http://commits.kde.org/plasma-nm/2abb222f201d481c007e032b4266e6ca4db4249c

Git commit d8ea094e60a4fc80fb828b5ca80e5f8b3d97130c by Lamarque V. Souza.
Committed on 04/04/2014 at 21:36.
Pushed by lvsouza into branch 'master'.

Be more informative about what option 'Hidden' do in create wifi connection
dialog.

M +7 -1 libs/editor/settings/ui/wificonnectionwidget.ui

http://commits.kde.org/plasma-nm/d8ea094e60a4fc80fb828b5ca80e5f8b3d97130c

(In reply to comment #74)
> (In reply to comment #73)
> > by "Connectino editor" I am assuming you are using Plasma NM 0.9.8.x. If so
>
> Yes, it is NM 0.9.8.0. The window title is "Connectino editor".
>
> > then you should check the "hidden" checkbox in the edit connection dialog.
>
> That did the trick (after some seconds, the new network appeared in the
> available network list in the tray icon and connection was estabilished),
> thank you! However, IMHO it's not very intuitive. In fact, I thought that
> the "Hidden" checkbox were referring to some sort of visibility constraint
> to the network configuration I was editing, rather than to the SSID of the
> network itself. After all:
> 1) if I'm there to configure a new wireless network it's because I need a
> hidden network which is not listed in the network tray icon (otherwise I
> would have simply clicked on it from there)

It is not listed because those kind of network does not broadcast their presence (they are "hidden"). It is not easy to figure out they are in the neighborhood and doing so is slow and requires more power to the wifi card, which can harm battery time for notebook users.

> 2) isn't the system smart enough to determine whether that network SSID is
> hidden or not?

kind of yes (the algorithm is not reliable). However, as I wrote above enabling the special scan type used to search for them requires more time and power to scan, therefor it is enabled only on demand.

> Maybe the original intent was to mimic the checkbox "connect even if the
> SSID is not broadcast" that is in Windows?

I do not know. I, for one, did not add the "Hidden" option to the create wifi dialo. I have just pushed a commit to make it clearer what that option does. I hope that helps.

(In reply to comment #75)
> I tried to set the "hidden"-checkbox. But although NM said the connection
> was updated, it always reverted back to unset. Connecting to a hidden
> network didn't succeed. Also restarting NM didn't help.

Denpending on the wifi card scanning for hidden networks can be tricky. What is your wifi card? Anyway, a NetworkManager log would also be helpfull to figure out what is wrong.

(In reply to comment #78)
> It is not listed because those kind of network does not broadcast their
> presence (they are "hidden"). It is not easy to figure out they are in the
> neighborhood and doing so is slow and requires more power to the wifi card,
> which can harm battery time for notebook users.

I did not mean that the tray icon should scan for hidden networks, but that I would have expected a behaviour like the one is in Windows or Android (or even in iOS, if I remember well): once I manually add a new network, by specifying its SSID and protection parameters, it is always visible in that tray icon, with just an indication whether it is in range or out of range. If it is in range, I can choose to connect to it (unless auto-connection is enabled for it, in this case it's automatic), otherwise of course I cannot, but the network is still visible for future reference.

> > 2) isn't the system smart enough to determine whether that network SSID is
> > hidden or not?
>
> kind of yes (the algorithm is not reliable). However, as I wrote above
> enabling the special scan type used to search for them requires more time
> and power to scan, therefor it is enabled only on demand.

Here I meant this: once I add a new network by manually configure it, why does the system need to know whether its SSID is hidden or not? I mean, if the specified SSID is among the ones that are currently broadcast, it means it's visible and in range, otherwise if it's in range it means that it is in range but hidden, otherwise it is simply out of range (in this case it's not so interesting to know whether it's hidden or not).

> I do not know. I, for one, did not add the "Hidden" option to the creater
> wifi dialo. I have just pushed a commit to make it clearer what that option
> does. I hope that helps.

I don't have seen the details of your commit yet, but I think it surely helps. Thank you!

Git commit fba7187a6280738f6e2608d9620c2ff24e7f7109 by Jan Grulich, on behalf of Lamarque V. Souza.
Committed on 04/04/2014 at 21:36.
Pushed by grulich into branch 'frameworks'.

Be more informative about what option 'Hidden' do in create wifi connection
dialog.

M +7 -1 libs/editor/settings/ui/wificonnectionwidget.ui

http://commits.kde.org/plasma-nm/fba7187a6280738f6e2608d9620c2ff24e7f7109

David (davidrob) on 2014-04-10
information type: Public → Public Security
Displaying first 40 and last 40 comments. View all 141 comments or add a comment.
This report contains Public Security information  Edit
Everyone can see this security related information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.