[apport] NetworkManager crashed with signal 5 in main()

Bug #85113 reported by JK on 2007-02-14
312
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Nominated for Gutsy by Jan Kunder
network-manager (Ubuntu)
High
Alexander Sack
Nominated for Gutsy by Jan Kunder

Bug Description

Binary package hint: network-manager

Crashed during login which may be linked to nm-applet. I can't provide much more information.

ProblemType: Crash
Date: Wed Feb 14 07:59:14 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/sbin/NetworkManager
Package: network-manager 0.6.4-6ubuntu2
ProcCmdline: NetworkManager
ProcCwd: /
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=fr_FR.UTF-8
 LANGUAGE=fr_FR:fr:en_GB:en
Signal: 5
SourcePackage: network-manager
Stacktrace:
 Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
 Core was generated by `NetworkManager'.
 Program terminated with signal 5, Trace/breakpoint trap.
 #0 0x080691d9 in main ()
 #0 0x080691d9 in main ()
StacktraceTop: main ()
ThreadStacktrace:
 .
 Thread 1 (process 5456):
 #0 0x080691d9 in main ()
Uname: Linux kws3 2.6.20-8-generic #2 SMP Tue Feb 13 05:18:42 UTC 2007 i686 GNU/Linux
UserGroups:

JK (jk4-deactivatedaccount) wrote :
Emilio Pozuelo Monfort (pochu) wrote :

Same here (see duplicate for crash report)

Changed in network-manager:
status: Unconfirmed → Confirmed
waldschm (waldschm) wrote :

Same error. I had just upgraded from Edgy and this error came up after the restart.

Changed in network-manager:
importance: Undecided → High
Andrew Frank (frank-geoinfo) wrote :

i did an distro-upgrade from an earlier 7.04 and got this error

StacktraceTop:

Giuliastro (gyesspam) wrote :

Upgraded to Feisty, NetworkManager doesn't seem to work. Crashes on launch.

Miguel Duarte (malduarte) wrote :

same here

Nikolaus Filus (nfilus) wrote :

One more affected upgrade from 6.10 to feisty (rc).
Although nm crashes while first login to the updated gnome, it seems to restart immediately and works as expected (I didn't loose my wireless connection). Will see if this happens after every new bootup or login ...

Martin Pitt (pitti) wrote :

So it gets a SIGTRAP in

        if (!nm_data->dbus_connection)
        {
                nm_error ("nm_dbus_init() failed, exiting. "
                          "Either dbus is not running, or the "
                          "NetworkManager dbus security policy "
                          "was not loaded.");
                exit (EXIT_FAILURE); <== RIGHT HERE
        }

n-m's nm_error() function attaches gdb onto the process to get a backtrace for the log, that's where the SIGTRAP comes from. So the real cause of this is that dbus is not running properly.

Can you guys please upgrade to the latest Feisty? Is this only an apport inconvenience, or does n-m really not work for you?

2007/4/13, Martin Pitt <email address hidden>:

> Can you guys please upgrade to the latest Feisty? Is this only an apport
> inconvenience, or does n-m really not work for you?

I've got that bug just after daily upgrade this morning.

--
Pavel Parkhomenko

mr.ses (blacksun) wrote :

I also got this bug appear this morning after an apt-get update.
The only file updated was update-manager-core_1:0.59.20_i386.deb

One thing I have noticed though is that networking seems unaffected and the NetworkManager still seems to be running

me@here:~$ ps awwux | grep NetworkManager
root 5118 0.0 0.2 29736 2112 ? Ssl 10:28 0:00 /usr/sbin/NetworkManager --pid-file /var/run/NetworkManager/NetworkManager.pid
root 5152 0.0 0.1 3052 1260 ? Ss 10:28 0:00 /usr/sbin/NetworkManagerDispatcher --pid-file /var/run/NetworkManager/NetworkManagerDispatcher.pid

same here! I do have all updates installed!!
I also crashes sometimes when I want to set it to standby...

Gregor Rosenauer (grexe) wrote :

this is the first time I got this crash, using a fresh Feisty x86 Beta for ~2 weeks now.
Also Amarok crashed on login.
Maybe on a related note, gs-eps tends to crash when used for producing some PDFs in a row.
Using kernel 2.6.20.3 and latest updates (KDE 3.5.6 etc.)

I just booted into the lowlatency kernel (2.6.20-15), and it crashed. It has never crashed before.

Martin Pitt (pitti) wrote :

Well, guys, yes, I *know* that it crashes. My question was whether it actually stops network-manager from working for you (i. e. you don't have the notification tray applet and it does not connect). Can you please confirm/deny that? Thank you

saserr (saserr) wrote :

Knetworkmanager is showing that I am connected, and also NetworkManager and NetworgManagerD are running.
Apport just registered this crash after normal log in (10 days after upgrade to 7.04), and everything seams to be running normal.

I do also have some problems with shutting down and suspend sometimes. According to the log file, NetworkManager can't be shut down :(
Could it have to do with the ndiswrapper?

In some cases my NetworkManager can not connect to my router... I don't know if it is the same problem. It usually stops at 57% connection. and most of the time a restart of the dhclient3 is solving the trouble!

This happened to me just now as I upgraded to the latest gutsy. It also results in my eth0 interface being de-configured.

Boyd Stephen Smith Jr. (bss03) wrote :

I'm at latest gusty as well.
KNetworkManager (the tray applet) doesn't seem to have any problems, and I'm still connected to the office wlan.
In fact, NetworkManager(Dispatcher)? are still running as well.

Christian Meyer (chrisime) wrote :

I was running into the same problem...CONFIRMED.
--> Ubuntu Gutsy

Same bug, under Gutsy Gibbon.

Confirm under Gutsy. Still appear to be online somehow.

Current gutsy still has this problem. Just upgraded and NM was one of the upgrades and boomo -- apport report.

Alexander Sack (asac) wrote :

i just merged in code that might fix this issue. We now properly unref dbus connections on exit, so hopefully getting a dbus_connection when restarting will fail less frequently now. Next gutsy upload should ship this fix.

Thanks,

 - Alexander

Changed in network-manager:
assignee: nobody → asac
status: Confirmed → Fix Committed
Alexander Sack (asac) wrote :

network-manager (0.6.5-0ubuntu8) gutsy; urgency=low

  * debian/patches/41n_graceful_supplicant_shutdown.patch: move
    supplicant_cleanup into stage1_prepare; remove test timeouts in
    _stage2_config and add 1 second sleep to the end of xx_stage1_prepare
  * debian/patches/series: add new patch 41n_graceful_supplicant_shutdown.patch
    to series
  * debian/patches/41l_enable_ipw3945_reset_essid.patch: enable
    ipw3945_reset_essid, by setting up function in class constructor
  * update debian/patches/41l_enable_ipw3945_reset_essid.patch:
    completely deactivate device in stage1 now
  * debian/patches/series: add new patch 41l_enable_ipw3945_reset_essid.patch
  * debian/patches/41m_unref_dbus_connection_on_shutdown.patch,
    unref shared dbus_connection on shutdown (LP: #85113)
  * debian/patches/series: add new patch 41m_unref_dbus_connection_on_shutdown.patch
  * debian/patches/41k_20_sec_wireless_link_timeout.patch: increase
    timeout for link setup ... taken from upstream ml
  * debian/patches/series: add new patch 41k_20_sec_wireless_link_timeout.patch
  * debian/patches/41e_fix_vpn_ftbfs_dont_disable_gnome_deprecated.patch: Fix
    ftbfs because of recently deprecated gnome druid - this patch enables gnome
    deprecated in Makefiles
  * debian/patches/series: add new patch
    41e_fix_vpn_ftbfs_dont_disable_gnome_deprecated.patch
  * debian/patches/41d_ipw3945_turn_off_essid_in_stage1.patch:
    implement stage1_prepare implementation in nm-device-802-11-wireless.c
  * debian/patches/series: add new patch 41d_ipw3945_turn_off_essid_in_stage1.patch
  * debian/rules, debian/control, debian/patches/series: Switch patchsystem to quilt
  * debian/patches/41c_ubuntu-fixup--get_mode_always_fails_typo_fix.patch: fix
    programming bug in wireless code
  * debian/patches/24pp_svn2591_Ensure-the-device-is-up-stage3.patch: ensure
    device is up in stage3 - cherry-picked from svn
  * debian/patches/24pp_svn2618_set-hardware-RF-to-enabled-if-no-killswitches.patch:
    enable hardware rf by default - cherry-picked from svn
  * debian/patches/24pp_svn2604_Add-HAL-based-rfkill-support.patch: hal based rfkill
    - cherry-picked from svn
  * debian/patches/24pp_svn2579-sleep-1-second-to-stabilize-if.patch: sleep to
    stabilize link status - cherry-picked from svn
  * debian/patches/41o_completely_deactivate_stage1.patch: use nm_device_deactivate
    instead of just real_deactivate to deactivate device more cleanly

 -- Alexander Sack <email address hidden> Tue, 7 Aug 2007 09:51:02 +0200

Changed in network-manager:
status: Fix Committed → Fix Released

This just happened again during upgrade. Perhaps it was upgrading to the fixed release noted above that it happened and this is the last time it should happen.

We can hope.

Yannick (splitsch) wrote :

I just upgraded from feisty to gutsy, and apport came and told me network-manager had crashed...

NetworkManager crash after upgrade from network-manager 0.6.5-0ubuntu7 to 0.6.5-0ubuntu9 in Gutsy.

SourcePackage: network-manager
Stacktrace: #0 0x0806a56b in main ()
StacktraceTop: main ()
ThreadStacktrace:
 .
 Thread 1 (process 10425):
 #0 0x0806a56b in main ()
Title: NetworkManager crashed with signal 5 in main()

James D (james-d1) wrote :

Getting the same sort of thing in Kubuntu Gutsy, both on log-in and on waking the computer up from power wasting. The network itself works fine though...

Happened to me in Kubuntu Gutsy, apparently randomly, BUT at the same time GParted also crashed [while fiddling with my partitions :O]. Might be random coincidence, but it might be related. I don't really know.

Scott Beamer (angrykeyboarder) wrote :

It happened to me as well, but I have no idea why. It was random (although I had been installing other packages - but don't ask me which ones. :) :).

Scott Beamer (angrykeyboarder) wrote :

Whoa! I just noticed this bug is rather *old*.

My previous comment applied to da "Gutsy Gibbon". :)

Kalrog (nathan-deckinga) wrote :

I just got this error for the first time as well. Setup is an AMD x86-64 installation of Kubuntu Gutsy (up to date as of last night, but more updates available today 2 for restricted modules and one for nvidia video).

Zupop (zupop) wrote :

The only thing I can add is that I reported a problem concerning network-manager. After my upgrade to gutsy tribe 5, changing kernel from day to day it often had problems with wireless connections . Now this problem seems to be solved.

Brian Mathis (bcmathis) wrote :

Got the error after a update on 9/24/07. Im using Gutsy

I also just got the error after updating Gutsy on September 24.

Ryan McClure (mcc-mcc3d) wrote :

Affirming error, just did an update.

turox (tuxturox) wrote :

Got the error after a update on 9/25/07. Im using Gutsy

Kansei (clauretano) wrote :

confirmed, 9/24/2007 update cause this. When I resumed from suspend, nm-applet was missing and I was sad. It worked fine after re-launching it :)

Emilio Pozuelo Monfort (pochu) wrote :

Reopening.

Changed in network-manager:
status: Fix Released → Confirmed
Nizar Kerkeni (nizarus) wrote :

I got the same problem after 9/25/07 update

John Vivirito (gnomefreak) wrote :

Can you please attach the output of lspci -v and attach the file /var/log/syslog

Matthias Klose (doko) wrote :

seen after an update on 20070825 as well

Jim Bailey (jim-freesolutions) wrote :

Similar problem following Gutsy update this was the first but I have maybe a dozen other Hal and gnome realted failure. shame since things were pretty smooth before latest update.

Christopher Denter (dennda) wrote :

Same as Jim Bailey here.
(Trying apports sending-methods.)

regards.

Son (son.caokim) wrote :

In response to Martin Pitt (wrote on 2007-04-25):
Networking stops functioning after crash. I had to reboot, and it seems to rework normally.
The crash happens after/during today's update of latest package from Gutsy repo.

I got this crash on suspend resume in Gutsy Tribe 5 with updates on a Core2 MacBook.

Here are my log files. NetworkManager came up normally today when I booted.

I had been on train (no wifi) and then suspended. Got to the office and resumed (no cable, wifi available but doesn't like bcm43xx driver so it doesn't work). When I say "doesn't work" it does appear to be working for the first time ever so that's an unexpected bonus!

Alexander Sack (asac) wrote :

Chris, your log doesn't even contain a crash from what i see. Can you get one that captures _this_ signal 5 crash?

Alexander, I don't see anything related at first glance in /var/log/syslog. I also have some archived syslog.0 files that I can take a look at. What should I be looking for? I was directed to this bug by apport and still have the /var/crash/_usr_sbin_NetworkManager.0.crash file if that would be helpful.

akapteijn (akapteijn) wrote :

same crash here

RobPower (robpwr) wrote :

Confirmed on Gutsy Gibbon Latest Beta
Here is my lspci -v and my syslog file.

I can confirm the bug.
It happend "now" = 01.10.07 15:18 GMT.
1Gbit onboard Intel
i965G+E6600+2GBRAM (only HEAVY tested & used pieces)
After aptitude upgrade after 10? days.

*****
I also had and have problems from installing till now. After starting PC from OFF state, there is (always?) 90%+ NOT working networking. After console /etc/init.d/networking restart it works fine within few secs!
It sometimes (AFAIR!) corrected "yourself" within 10 minutes after start.
If this is/not regarding this bug - pls tell me.
NOT problems if booted to/on XP/Etch on the same network the same machine.

*****
I hate NO option to attach 5 files at once (not using tar workaround).
If there is any - pls email me!

Pauldb (polichinel8) wrote :

I had the same error, while I was upgrading from 7.04 (Feisty) to 7.10 (Gutsy), my computer didn't answer i had to
shutdown by pushing 5 sec on the button
After restar i got that problem

PS : sorry, you certaintly saw that i don't write english very well, i'm french speaker sry again...

Alexander Sack (asac) wrote :
Changed in network-manager:
status: Confirmed → Fix Committed
mabovo (mabovo) wrote :

Not only network is unstable in Gutsy Beta but last kernel update kill also sound and avahi daemon returned with bug.
It seems that all applets (Tomboy, NM-applet and others) appearing on top panel has problems with gnome. There was one instance that Gutsy disabled all applets installed on superior panel in order to start Gnome.

Alexander Sack (asac) wrote :

mabovo, your comment doesn't match the topic of this bug. Please open new bugs for the issues you mention ... at least if you can reproduce them.

Alexander Sack (asac) wrote :

network-manager (0.6.5-0ubuntu15) gutsy; urgency=low

  * debian/patches/41z_lp138217_use_timeout_to_schedule_activation.patch,series:
    don't use idle_source to schedule activation, but rest a bit by using a
    timeout_source with 250ms delay (LP: #138217).
  * debian/network-manager.postinst: sleep 2 seconds after ifblacklist_migrate.sh
    (LP: #146757).
  * debian/patches/41w_lp145683_cancel_scan_in_supplicant_cleanup.patch,series: first part
    for lp145683 - cancel pending scans on terminate (LP: #145683).
  * debian/patches/41wa_lp145683_wpa_ctrl_check_select_result_for_error.patch,series:
    second part to fix lp145683; test select result for errors (in case of
    TERMINATE) (LP: #145683).
  * debian/patches/41y_queue_if_dbus_name_is_taken_on_startup.patch,series: make
    restart of network manager more failsafe and even allow to take over name
    ownership. When ownership is taken over (dbus signal |NameLost| received), we
    shutdown cleanly by sending |X| through |nm_shutdown_pipe| (LP: #85113).
  * debian/patches/41x_lp145653_reraise_fatal_signals.patch: re-raise fatal
    signals (LP: #145653).

 -- Alexander Sack <email address hidden> Tue, 02 Oct 2007 13:32:50 +0200

Changed in network-manager:
status: Fix Committed → Fix Released
®om (rom1v) wrote :

I just updated to 2.6.22-13-generic, but my bug is not resolved:
https://bugs.launchpad.net/ubuntu/+source/gthumb/+bug/144882

(marked as a duplicate of this one, I don't know why)

This bug is not related to gthumb. It is a NetworkManager bug.

Changed in gthumb:
status: New → Invalid
LEVIS Cyril (atlas95) wrote :

I have this at boot on hardy :/ sometimes

raanan (raanan-opcat) wrote :

I also have this on boot. usually after a suspend and a failed resume.

raanan (raanan-opcat) wrote :

the previous post is in hardy

LEVIS Cyril (atlas95) wrote :

Networkmanager work very but sometimes crash when I do nothing...I use transmission, evolution, liferea, program which check if networkmanager is connect, i don't know if the problem comes here...
- nm 0.6.6 in hardy

Florian Zeitz (florian-zeitz) wrote :

Same here. Since upgrading to nm 0.6.6-0ubuntu3 I get a apport crash report on every boot that points me to this bug.
But nm works without any problems, this is just a apport inconvenience for me as of now.

Just reproduced this with network-manager version "0.7~~svn20080818t061112+eni0-0ubuntu1" on x86-64, Intrepid.

Steps were:
 - plug in modern Sony Ericsson phone
 - reboot phone while USB connected, putting it in a particular mode
  -> we see two cdc_acm interfaces visible, followed by networkmanager crash:
$ dmesg
[snip]
usb 6-1: new full speed USB device using uhci_hcd and address 4
usb 6-1: configuration #3 chosen from 1 choice
cdc_acm 6-1:3.1: ttyACM0: USB ACM device
cdc_acm 6-1:3.3: ttyACM1: USB ACM device
usb0: register 'cdc_ether' at usb-0000:00:1d.0-1, CDC Ethernet Device, 01:08:0a:35:03:00
nm-system-setti[6493] trap int3 ip:7f5e6ced5c54 sp:7fff77cc9d80 error:0

On Tue, Sep 02, 2008 at 04:56:08PM -0000, Daniel J Blueman wrote:
> Just reproduced this with network-manager version
> "0.7~~svn20080818t061112+eni0-0ubuntu1" on x86-64, Intrepid.
>
> Steps were:
> - plug in modern Sony Ericsson phone
> - reboot phone while USB connected, putting it in a particular mode
> -> we see two cdc_acm interfaces visible, followed by networkmanager crash:
> $ dmesg
> [snip]
> usb 6-1: new full speed USB device using uhci_hcd and address 4
> usb 6-1: configuration #3 chosen from 1 choice
> cdc_acm 6-1:3.1: ttyACM0: USB ACM device
> cdc_acm 6-1:3.3: ttyACM1: USB ACM device
> usb0: register 'cdc_ether' at usb-0000:00:1d.0-1, CDC Ethernet Device, 01:08:0a:35:03:00
> nm-system-setti[6493] trap int3 ip:7f5e6ced5c54 sp:7fff77cc9d80 error:0
>

you should get a network-manager crash file in /var/crash/ ... please
submit that by double clicking so we can see how it crashed and for
what reason.

 - Alexander

Download full text (4.1 KiB)

No problem. I was directed to add into this bug-report by apport; presumably it had matched the stacktrace top with that in this bug report. Further info available on request.

Title: nm-system-settings crashed with signal 5 in dbus_g_proxy_call_with_timeout()

Stacktrace:
 #0 IA__g_logv (log_domain=0x0, log_level=G_LOG_LEVEL_ERROR,
     format=0x7f5e6da0334a "Out of memory", args1=0x7fff77cca220)
     at /build/buildd/glib2.0-2.17.7/glib/gmessages.c:503
  depth = <value optimized out>
  domain = (GLogDomain *) 0x195b560
  data = (gpointer) 0x0
  log_func = (GLogFunc) 0x406460
  domain_fatal_mask = 6
  test_level = G_LOG_FLAG_FATAL
  was_recursion = 0
  i = <value optimized out>
 #1 0x00007f5e6ced5fc3 in IA__g_log (log_domain=0x7f5e6ce8da00 "",
     log_level=1824902704, format=0x21 <Address 0x21 out of bounds>)
     at /build/buildd/glib2.0-2.17.7/glib/gmessages.c:517
  args = {{gp_offset = 24, fp_offset = 48,
     overflow_arg_area = 0x7fff77cca300, reg_save_area = 0x7fff77cca240}}
 #2 0x00007f5e6d9f8d25 in ?? () from /usr/lib/libdbus-glib-1.so.2
 #3 0x00007f5e6d9f96d5 in dbus_g_proxy_call_with_timeout ()
    from /usr/lib/libdbus-glib-1.so.2
 #4 0x00000000004072e7 in ?? ()
 #5 0x00007f5e6cecc63b in g_timeout_dispatch (source=0x195d020,
     callback=0x7f5e6cc5ce30, user_data=0x21)
     at /build/buildd/glib2.0-2.17.7/glib/gmain.c:3532
 No locals.
 #6 0x00007f5e6cecbea2 in IA__g_main_context_dispatch (context=0x1936b10)
     at /build/buildd/glib2.0-2.17.7/glib/gmain.c:2073
 No locals.
 #7 0x00007f5e6cecf63d in g_main_context_iterate (context=0x1936b10, block=1,
     dispatch=1, self=<value optimized out>)
     at /build/buildd/glib2.0-2.17.7/glib/gmain.c:2706
  max_priority = 2147483647
  timeout = 2822
  some_ready = 1
  nfds = 3
  allocated_nfds = <value optimized out>
  fds = (GPollFD *) 0x192fc80
  __PRETTY_FUNCTION__ = "g_main_context_iterate"
 #8 0x00007f5e6cecfb6d in IA__g_main_loop_run (loop=0x192c6f0)
     at /build/buildd/glib2.0-2.17.7/glib/gmain.c:2929
  self = (GThread *) 0x192d460
  __PRETTY_FUNCTION__ = "IA__g_main_loop_run"
 #9 0x0000000000406bcb in main ()
StacktraceTop:
 ?? () from /usr/lib/libdbus-glib-1.so.2
 dbus_g_proxy_call_with_timeout ()
 ?? ()
 g_timeout_dispatch (source=0x195d020,
 IA__g_main_context_dispatch (context=0x1936b10)
ThreadStacktrace:
 .
 Thread 1 (process 6493):
 #0 IA__g_logv (log_domain=0x0, log_level=G_LOG_LEVEL_ERROR,
     format=0x7f5e6da0334a "Out of memory", args1=0x7fff77cca220)
     at /build/buildd/glib2.0-2.17.7/glib/gmessages.c:503
  depth = <value optimized out>
  domain = (GLogDomain *) 0x195b560
  data = (gpointer) 0x0
  log_func = (GLogFunc) 0x406460
  domain_fatal_mask = 6
  test_level = G_LOG_FLAG_FATAL
  was_recursion = 0
  i = <value optimized out>
 #1 0x00007f5e6ced5fc3 in IA__g_log (log_domain=0x7f5e6ce8da00 "",
     log_level=1824902704, format=0x21 <Address 0x21 out of bounds>)
     at /build/buildd/glib2.0-2.17.7/glib/gmessages.c:517
  args = {{gp_offset = 24, fp_offset = 48,
     overflow_arg_area = 0x7fff77cca300, reg_save_area = 0x7fff77cca240}}
 #2 0x00007f5e6d9f8d25 in ?? () from /usr/lib/libdbus-glib-1.so.2
 #3 0x00007f5e6d9f96d5 in dbus_g_proxy_c...

Read more...

Alexander Sack (asac) wrote :

On Tue, Sep 02, 2008 at 05:29:31PM -0000, Daniel J Blueman wrote:
> No problem. I was directed to add into this bug-report by apport;
> presumably it had matched the stacktrace top with that in this bug
> report. Further info available on request.
>

your backtrace appears not to have all symbols. please submit the
crash like a said and post the bug id.

 - Alexander

To post a comment you must log in.