Network Manager asks for the PIN even if it is memorized

Bug #704123 reported by Uqbar on 2011-01-17
260
This bug affects 65 people
Affects Status Importance Assigned to Milestone
NetworkManager
New
Medium
One Hundred Papercuts
Medium
Unassigned
network-manager (Debian)
New
Unknown
network-manager (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Alberto Salvia Novella
Nominated for Precise by Alberto Salvia Novella
Nominated for Trusty by Alberto Salvia Novella
Nominated for Utopic by Alberto Salvia Novella

Bug Description

****************
HOW TO REPRODUCE
****************

1. Plug the USB modem into a port.

2. When you are asked to enter the modem's PIN, do along with the "automatically unlock this device" option.

3. Unplug the modem, and plug it again.

******************
EXPECTED BEHAVIOUR
******************

- The modem to be automatically unlocked.

**************
REAL BEHAVIOUR
**************

- You are asked to enter the PIN again.

************
WORK-AROUNDS
************

- Changing the SIM's PIN to empty.

- Renaming the "/usr/share/nm-applet/gsm-unlock.ui" file.

****************
RELEVANT DETAILS
****************

- The same behaviour when configuring the PIN from the "Network Connections" menu.

- Even if the PIN is stored in "/etc/NetworkManager/system-connections/", Network Manager cannot retrieve it.

- The bug makes the device to become locked as soon as network connectivity is lost for a while.

- This bug forces administrators to tell the PIN to other users, while they will rather want to keep it in secret and just allow themselves to be able to configure the connectivity in specific devices.

Uqbar (uqbar) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in network-manager (Ubuntu):
status: New → Incomplete
Bigfoot (me-eckschi) on 2011-02-02
Changed in network-manager (Ubuntu):
status: Incomplete → Confirmed

Can you please check if the resulting file in /etc/NetworkManager/system-connections/ contains the PIN in a "PIN", "password" or "secret" field?

Thanks.

Changed in network-manager (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Medium
Uqbar (uqbar) wrote :

Yes, it does.
I get the broadband connection even if I dismiss the dialog.

Bigfoot (me-eckschi) wrote :

for me the directory /etc/NetworkManager/system-connections/ is completely empty

Uqbar (uqbar) wrote :

Have you define the connections as "available to all users"?
If not, the connection will be local to the user defining it.

Changed in network-manager (Ubuntu):
status: Incomplete → Triaged
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Peter Schüller (schueller-p) wrote :

I have the same issue, connection is stored in /etc/NetworkManager/systems-connections/ the connection is available to all users, pin is set.

If the device is recognized at bootup time the connection is established without asking the pin.

If I disconnect the device and connect it again, the device is always recognized, then the pin is asked, but if I cancel the dialog the connection is established anyways.

Anders Feder (afeder) wrote :

I've fixed this: lp:~anders-feder/network-manager-applet/bug-704123

Someone else has to figure out how to get it into Ubuntu.

Anders Feder (afeder) on 2011-09-13
Changed in network-manager (Ubuntu):
status: Triaged → In Progress
Changed in network-manager (Ubuntu):
assignee: Mathieu Trudel-Lapierre (mathieu-tl) → nobody

Unassigning myself from the bug since Anders appears to be working on it.

Anders, if this is the case, please assign yourself: this shows you're working on the bug.

I'm adding my comments on your fix in the merge request. It looks nice (haven't tested yet), but will need a little more work (I've added the details).

Please, don't hesitate to ask for more information if you need, or ping me on IRC (though I will be out for a little while tonight, but will look at this bug and the related merge again as soon as I can).

Anders Feder (afeder) on 2011-09-14
Changed in network-manager (Ubuntu):
assignee: nobody → Anders Feder (anders-feder)

The attachment "Fix for bug #704123" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

I haven't been able to find a way to determine if a PIN code is configured, so I am unassigning myself. Anyone is welcome to continue work on the patch I submitted here:
https://code.launchpad.net/~anders-feder/network-manager-applet/fix-704123/+merge/75722

For details about the issue that stopped me from proceeding, see this posting:
http://mail.gnome.org/archives/networkmanager-list/2011-September/msg00170.html

Changed in network-manager (Ubuntu):
status: In Progress → Confirmed
assignee: Anders Feder (anders-feder) → nobody
Anders Feder (afeder) wrote :
Changed in network-manager (Ubuntu):
assignee: nobody → Anders Feder (anders-feder)
status: Confirmed → In Progress
Anders Feder (afeder) on 2011-10-12
Changed in network-manager (Ubuntu):
status: In Progress → Fix Committed
Anders Feder (afeder) wrote :

Patch for this issue committed upstream. Fix should show up in network-manager 0.9.2.

almursi (haqqshahid) wrote :

Hi, I have a similar problem (useless request of pin), but together with other related to the console device, because my ZTE MF190 successfully connect only on ttyUSB4, but usually when I did not cancel the request for pin, it tries to connect to ttyUSB2 (fortunately seems to be alternating between one and another ttyUSB when I unplug and try again, but it also means that if I did restart session again encounter the problem of failed connection attempt to ttyUSB2). The truth is that I am not clear what process handles the assignment of ttyUSB, so I'm not sure where to explain this bug :). Best regards.

Menno (1aunthpad-0ut) wrote :

This seems a duplicate of https://bugs.launchpad.net/bugs/675039

Narcis Garcia (narcisgarcia) wrote :

I still have the same problem with Ubuntu 11.04 (Natty) and the USB modem "Huawei K3770".

$ aptitude show network-manager | grep -ie "version"
Version: 0.8.4~git.20110319t175609.d14809b-0ubuntu3

Narcis Garcia (narcisgarcia) wrote :

How can I fix this problem on Ubuntu 11.04 (gnome desktop) without upgrading to 12.04 ?
The version 0.9.2 of network-manager is only available from Ubuntu 12.04

Rada (ldrada) wrote :

Hi, this bug is still present in Ubuntu 12.04. How do I apply the fix?

Gregor Riepl (onitake) wrote :

The network-manager package is bumped to version 0.9.4.0-0ubuntu3 in precise, but the bug still occurs.

Is it necessary to purge certain old files before it will disappear? Did the fix that was committed previously actually address the problem?

H.i.M (hir-i-mogul-gmail) wrote :

Bug still present in precise.

Gary M (garym) on 2012-05-18
tags: added: natty precise
tags: added: oneiric
Anders Feder (afeder) on 2012-05-23
Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
Peter Silva (peter-bsqt) wrote :

This bug still occurs on precise, using 0.9.4. I can connect (without using the PIN), the PIN is entered in the configuration, but while connected it prompts to enter the pin, then states that the PIN cannot be applied while connected. I disconnect, then apply unlock, and can connect again.

Please reopen the bug.
I can also affirm that the problem is still existing on ubuntu 12.04 (network-manager 0.9.4.0-0ubuntu4.1)

Anders Feder (afeder) wrote :

Sorry, I don't have SIM card to test with. I unassign myself so someone else hopefuly will pick it up.

Changed in network-manager (Ubuntu):
assignee: Anders Feder (anders-feder) → nobody
Stephan Henningsen (zta77) wrote :

I too can confirm that the bug still exists on Ubuntu 12.04 with network-manager 0.9.4.0-0ubuntu4.1.

> I too can confirm that the bug still exists on Ubuntu 12.04 with network-manager 0.9.4.0-0ubuntu4.1.

So I guess this report should be re-opened.

summary: - PIN is asked despite it's configured into the system connection
+ NM asks non-administrative user for the PIN even though it's in the
+ system-connections file

If you get this bug on Precise, please attach debug logs: see http://wiki.ubuntu.com/DebuggingNetworkManager

Changed in network-manager (Ubuntu):
status: Fix Released → Incomplete
Thomas Hood (jdthood) wrote :

@Uqbar and any one else affected: Can you reproduce this in Ubuntu 12.04?

Gregor Riepl (onitake) wrote :

Thomas, I can't say if the bug is completely reproduceable in Precise. I tend to restrict stored PINs to the current user for security reasons. In this case, the PIN dialog appears whenever I log in. It's an annoyance, albeit a minor one.

My take on the issue is that nm should not ask for a PIN at all. Only when a connection is made should the user be presented with a PIN dialog - and in this case nm will know if a PIN is stored or not, no matter if system wide or user specific. YMMV, but I think this approach would kill all birds with a single stone.

Darren Dalv (001dalv) wrote :

Like onitake, I also think nm(-applet?) should not ask for a PIN at all.

I have a SIM-card plugged into my laptop which I only need occasionally. Annoyingly, nm asks me on every log-in to enter the PIN, whether I use it or not. Also, it is not clear what will happen if one enters the PIN (instead of pressing just escape on the dialog). Will nm make a connection? Even if it's not the users intention? What does it need the PIN for then?

At least make it configurable, so that I can disable this (at least for me) useless behavior.

Ganton (ganton) wrote :

This bug still exists in Kubuntu 13.04, at least. If I boot the computer with the modem plugged in -> I can connect to internet (because the computer remembers the PIN that I gave it). However, if I plug off the modem and I plug it in again -> the computers asks for the PIN... like if it didn't know it!

Gregor Riepl (onitake) wrote :

I can confirm that the same applies for Ubuntu 13.04.

While browsing the source code, I learned that the dialog will not be presented if the environment variable INDICATOR_GREETER_MODE is set (the value seems to be irrelevant). However, I haven't found a good way to pass this variable to nm-applet yet.

Additionally, I'm using the WWAN modem with multiple SIM cards, and having a single PIN for all of them is not an acceptable solution. However, I would like to have a configuration for each network operator/SIM card with the respective PINs stored for each connection. This is possible with nm-applet - but getting rid of the dialog is not.

f92ja (f92ja) wrote :

Same problem here on Debian Wheezy 7.1 with network-manager 0.9.4.0-10, but I eventually found a dirty workaround:

The layout of the PIN dialog is defined in /usr/share/nm-applet/gsm-unlock.ui. If this file is renamed, whatever program spawns the dialog silently fails. Hence the bugging dialog will not appear, but the connection works nevertheless.

Alexander Heuer (evilphish) wrote :

After having this problem for years now, it is still there with 13.10.
Hardware used:
ID 0bdb:1911 Ericsson Business Mobile Networks BV
All I want is for the network manager to save the SIM pin and use it from then on without bothering me with every login...

Jan Prieser (jan-prieser) wrote :

this bug is still annoying in ubuntu trusty 14.04.
I have only one user (the first created) and have to enter the pin on every login. i don't use auto-connect and do not want to.
I just want to save the pin or change it to be asked when enabling wwan in nm-applet.

Jan Prieser (jan-prieser) wrote :

some more information:
- the pin is saved in gnome keyring. "PIN Code for SIM card '<number>' on '<hexstring>'"
- the pin is also stored in /etc/NetworkManager/systems-connections/connectionname

built-in lenovo modem "0bdb:193e Ericsson Business Mobile Networks BV"

Stefan Hammer (j-4) wrote :

Which information is missing? Why is this bug incomplete?
Package: network-manager
Version: 0.9.8.10-3
Package: modemmanager
Version: 0.5.2.0-2

Bus 001 Device 003: ID 0bdb:193e Ericsson Business Mobile Networks BV

Changed in network-manager (Ubuntu):
status: Incomplete → Confirmed
Uqbar (uqbar) wrote :

2.5 years ago a fix has been committed (Comment #12).
Then waht?

Daniel A. (alive-dienub) wrote :

I've had this bug since 10.10 and now I'm on 14.04. It's still bugging me, and actually with the release of 14.04 it has gotten worse. Now, when I power up my laptop, my Password login prompt gets interrupted by the SIM PIN popup. Once I log in, another SIM PIN Unlock Required popup interrupts me. No amount of "Never require PIN again" clicking ever stops the distro from asking me to unlock my SIM.

tags: added: trusty

When wireless broadband connectivity goes off, the device gets automatically locked. So every time you are forced to disconnect it, type the PIN again and reconnect to the network.

summary: - NM asks non-administrative user for the PIN even though it's in the
- system-connections file
+ NetworkManager asks non-administrative user for the PIN even though it's
+ in the system-connections file
summary: - NetworkManager asks non-administrative user for the PIN even though it's
- in the system-connections file
+ Network Manager asks non-administrative user for the PIN even though
+ it's in the system-connections file
summary: - Network Manager asks non-administrative user for the PIN even though
- it's in the system-connections file
+ Network Manager asks for the PIN even though it's in the system-
+ connections file
summary: - Network Manager asks for the PIN even though it's in the system-
- connections file
+ Network Manager asks for the PIN even it is memorized
summary: - Network Manager asks for the PIN even it is memorized
+ Network Manager asks for the PIN even if it is memorized
description: updated
Changed in network-manager (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
tags: added: amd64 lucid utopic
removed: maverick natty oneiric patch
Changed in hundredpapercuts:
status: New → Triaged
importance: Undecided → Medium
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → New
Changed in network-manager (Debian):
status: Unknown → New
description: updated

I confirm that the PIN prompt does appear over again. It even pops up at the login screen, as Daniel described in comment #40.

themroc (rauchweihe) wrote :

You can solve the problem if you uncheck the option "All users can connect with this network" in connection settings.

Uqbar (uqbar) wrote :

@themroc, your workaround has no general applicability.
The GSM/3G modem PIN is a sensitive information and would get different security level whether stored under /etc or in $HOME.
In the former case only root would know it and be bale to change or disable it. In the latter case all users should know.

Uqbar (uqbar) wrote :

It's 4 years old now!

Anders Feder (afeder) wrote :

Uqbar (uqbar): Unfortunately, nothing is ever accomplished by sitting around and complaining. I personally don't have the PC where I experienced this issue anymore, so I can't attempt to reproduce the reports that it is still occuring. Someone who is experiencing the issue will need to pinpoint the bug in the code before anyone can attempt to address it.

Felix (grisu42) wrote :

Also affected by the bug. It's annoying, especially since I'm using the GSM modem only from time to time.

lsusb
Bus 003 Device 015: ID 0bdb:193e Ericsson Business Mobile Networks BV

I'm on Ubuntu 14.04

udippel (udippel) wrote :

Same here (as #47): 14.04

The bug here pops up slightly different: "SIM PIN2 Unlock Required". The PIN2 is the difference. I dunno what PIN2 is, but never mind, if I type PIN1 it goes away, or if just close the window, it connects perfectly well. So I'm annoyed mostly with the pop-up of the Network Manager.
Plus, as additional observations:
1. Whatever I do (see further up), it *does* connect. It read PIN1 perfectly okay, I never had to enter it. It set up the link perfectly okay *without* me ever entering this PIN.
2. It never displays 'Connected'; it always gets stuck at 'Connecting'., contrary to the other network interfaces. This obviously is very buggy code. It has an IP address, I can ping 8.8.8.8, and yet it still talks about 'Connecting'.
3. And the broadband icon in the network manager (at least in Kubuntu) never shows the link (box ticked).
4. And yet, despite 3., the notification says 'FONIC connected', while applet talks about 'used last'.

Machine: lenovo Thinkpad, Qualcomm Gobi 2000.

$ dmesg | grep ualcom
[ 1.267272] tun: (C) 1999-2004 Max Krasnyansky <email address hidden>
[ 2.646269] usb 2-1.4: Product: Qualcomm Gobi 2000
[ 2.646271] usb 2-1.4: Manufacturer: Qualcomm Incorporated
[ 3.943987] usbserial: USB Serial support registered for Qualcomm USB modem
[ 3.944028] qcserial 2-1.4:1.1: Qualcomm USB modem converter detected
[ 3.944136] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB0
[ 8.204086] qcserial ttyUSB0: Qualcomm USB modem converter now disconnected from ttyUSB0
[ 8.561286] usb 2-1.4: Product: Qualcomm Gobi 2000
[ 8.561290] usb 2-1.4: Manufacturer: Qualcomm Incorporated
[ 8.564658] qcserial 2-1.4:1.1: Qualcomm USB modem converter detected
[ 8.564842] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB0
[ 8.565818] qcserial 2-1.4:1.2: Qualcomm USB modem converter detected
[ 8.565996] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB1
[ 8.566646] qcserial 2-1.4:1.3: Qualcomm USB modem converter detected
[ 8.566738] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB2
$ dmesg | grep wwan
[ 3.743945] thinkpad_acpi: rfkill switch tpacpi_wwan_sw: radio is unblocked
[ 8.593799] qmi_wwan 2-1.4:1.0: cdc-wdm0: USB WDM device
[ 8.593986] qmi_wwan 2-1.4:1.0 wwan0: register 'qmi_wwan' at usb-0000:00:1d.0-1.4, WWAN/QMI device, aa:4f:5a:69:94:c2
[ 8.594022] usbcore: registered new interface driver qmi_wwan
$ dmesg | grep ttyUSB
[ 3.944136] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB0
[ 8.204086] qcserial ttyUSB0: Qualcomm USB modem converter now disconnected from ttyUSB0
[ 8.564842] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB0
[ 8.565996] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB1
[ 8.566738] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.