upstart randomly stalls boot on network-manager?

Bug #499361 reported by Marc MERLIN on 2009-12-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: upstart

In karmic with updates as of today, my system randomly hangs during boot and works on other boots.

It looks like it's due to networkmanager. I do have:
cat /etc/network/interfaces
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto usb0
iface usb0 inet dhcp

#auto eth1
#iface eth1 inet dhcp

and
gandalfthegrey:/var/local/space/nobck$ cat /etc/NetworkManager/nm-system-settings.conf
[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=true

network manager otherwise works totally fine for ethernet and wireless.

See attached pictures of hung boot with --debug given on the lilo prompt

Marc MERLIN (marc-soft) wrote :

Upstart is an init daemon, any problems (including hangs) caused by configuration are bugs in the packages that ship configuration (usually :p)

affects: upstart (Ubuntu) → network-manager (Ubuntu)
Tony Espy (awe) wrote :

A couple of comments, in the future, please follow the guidelines at:

https://help.ubuntu.com/community/ReportingBugs

Following these instructions will result in a bug with a lot more debug information.

For now, could you please run the command "apport-collect -p linux 499361" from an xterm or via Alt-F2 ( Run Application )?

Also, in general boot hangs in most cases are kernel related, especially if they occur before X starts. Also, I'm going to change change the package once more to "linux".

I see no evidence from you screenshots that the hang is related to NetworkManager. The second attachment shows what look to be normal NM startup messages. At this early in the game, if it was caused by network-manager, you could try removing your nm-system-settings.conf to see if that alleviates the hang.

affects: network-manager (Ubuntu) → linux (Ubuntu)

Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse: Error: command ['fuser', '-v', '/dev/dsp', '/dev/snd/by-path', '/dev/snd/hwC0D1', '/dev/snd/controlC0', '/dev/snd/pcmC0D1p', '/dev/snd/hwC0D0', '/dev/snd/pcmC0D0c', '/dev/snd/pcmC0D0p', '/dev/snd/seq', '/dev/snd/timer', '/dev/sequencer', '/dev/sequencer2'] failed with exit code 1:
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xfc020000 irq 17'
   Mixer name : 'Conexant CX20561 (Hermosa)'
   Components : 'HDA:14f15051,17aa2100,00100000 HDA:14f12c06,17aa2122,00100000'
   Controls : 13
   Simple ctrls : 6
DistroRelease: Ubuntu 9.10
HibernationDevice: RESUME=/dev/sda7
MachineType: LENOVO 4063FM6
Package: linux (not installed)
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: auto BOOT_IMAGE=linux ro root=fd00 panic=20 resume=/dev/sda7 usbcore.autosuspend=1 pwd=cryptItIs1pc
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.ISO-8859-1
Uname: Linux 2.6.31.6-core2smp-1khznohz-preempt-notcks-noide-hm64-20091206 i686
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin mailman mythtv netdev nvram plugdev powerdev pulse scanner video
XsessionErrors: (firefox:4966): GLib-WARNING **: g_set_prgname() called multiple times
dmi.bios.date: 10/02/2009
dmi.bios.vendor: LENOVO
dmi.bios.version: 6FET79WW (3.09 )
dmi.board.name: 4063FM6
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6FET79WW(3.09):bd10/02/2009:svnLENOVO:pn4063FM6:pvrThinkPadW500:rvnLENOVO:rn4063FM6:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4063FM6
dmi.product.version: ThinkPad W500
dmi.sys.vendor: LENOVO

tags: added: apport-collected
Marc MERLIN (marc-soft) on 2009-12-22
summary: - upstart randomly hangs boot on network-manager?
+ upstart randomly stalls boot on network-manager?
Marc MERLIN (marc-soft) wrote :
Marc MERLIN (marc-soft) wrote :
affects: linux (Ubuntu) → network-manager (Ubuntu)

Hi Marc,

I'm having a little bit of a hard time figuring out where your boot process stalls. Is at starting NTP? Is it at another process? If so, please specify which one, it's not immediately obvious for me from the screen shot :)

Thanks!

Changed in network-manager (Ubuntu):
status: New → Incomplete
Marc MERLIN (marc-soft) wrote :

Mathieu, you are correct, upstart makes it hard to know what's hanging since it's happening in parrallel in a non deterministic fashion, and it's not like I can run ps at that time.

I originally filed this against upstart, because quite franlky upstart does not make it easy to see what the problem is.
I however think the problem is with the network-manager init script. I think when I had
auto eth0
iface eth0 inet dhcp

It would sometimes bring try to bring up eth0 when it wasn't plugged in, and hang.
Note that there are 5 pictures:

boot with --debug
http://launchpadlibrarian.net/37077999/100_upstart_picts.jpg
http://launchpadlibrarian.net/37078016/101_upstart_picts.jpg

boot without --debug
http://launchpadlibrarian.net/37095414/StallPict1a.jpg
http://launchpadlibrarian.net/37095417/StallPict1b.jpg

boot that happened not to hang:
http://launchpadlibrarian.net/37095427/NonStall.jpg

I very seldom boot my laptop, especially now that it randomly does not complete booting, and honestly I can't tell for sure which process hangs upstart but it looks like it's network-manager

Marc MERLIN (marc-soft) wrote :

somehow this bug was marked as incomplete despite me giving all the information requested within days. I just hand fixed the status but if it means the bug was mostly ignored until today as a result, that's a pretty poor experience for the user :(

Changed in network-manager (Ubuntu):
status: Incomplete → New
Marc MERLIN (marc-soft) wrote :

For what it's worth the problem has gone away for me in maverick.

Thomas Hood (jdthood) on 2012-07-01
Changed in network-manager (Ubuntu):
status: New → Fix Released
To post a comment you must log in.